Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 01 Sep 2014, 10:43
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Audio
SOLVED: Sound on Compaq Armada 1750- ALSA snd-es18xx driver
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
bullterrier


Joined: 16 May 2011
Posts: 23

PostPosted: Thu 29 Dec 2011, 13:40    Post subject:  SOLVED: Sound on Compaq Armada 1750- ALSA snd-es18xx driver
Subject description: No sound
 

I have an old laptop A Compaq 1750 and installed the latest Puppy lucid 5.2.8. After making the below manual configurations Alsamixer detects the Es audiodrive 1869. I have unmuted all the available options. All I get from the speakers is a hissing static type sound when I play a sound file.

The Bios sound settings are as follows:

ESS Audio drive, ESS1869, IR number 5, DMA channel 1, DMA channel 5, IO Range 0x220 - 0x022f, IO Range 0x0388 - 0x038b, IO Range 0x0330 - 0x0331

Sound works on Winxp / and over the years I successfully configured sound on ubuntu 7.04/7.10 and tinycore linux

After browsing the forums and trying out suggestions I have the following setup:

Content of /etc/modprobe.d/alsa.conf

alias snd-card-0 snd-es18xx
alias snd-slot-0 snd-es18xx
options snd-es18xx isapnp=0 port=0x0220 dma1=1 dma2=5 irq=5 mpu_port=0x330

I have also the following kernel entry in /boot/grub/menu.lst

pnpbios=off acpi=off

These are turned off as in
http://www.murga-linux.com/puppy/viewtopic.php?t=22365&search_id=1865191538

Thanks

Last edited by bullterrier on Sat 31 Dec 2011, 17:40; edited 1 time in total
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 5103
Location: Charleston S.C. USA

PostPosted: Thu 29 Dec 2011, 14:02    Post subject:  

From menu->help->LupuNews Help

Quote:
If no sound, open Menu -> Multimedia Tools -> Alsamixer (alsamixer, not alsawizard). Press F6 and that will show you what sound devices have been detected and configured. If yours is not the top one then arrow down and click it, then make sure everything plausible is turned up. I have to do this with my “second” sound card (an M-Audio). Then to play through the M-Audio I use Audacious but one can also use Pmusic and any other audio player that allows you to choose which device to play through. I have to this also with my M-Audio and I use Audacious -> File -> Preferences -> Output Plugin Preferences to choose the card I want.

If none of this works, then try alsawizard. The thing about alsawizard is that after it runs there is only one device configured--if that is the device you want then good, otherwise .....


Also, try right click on speaker icon in tray.
Choose Full Window
Make sure everything needed is active and turned up.

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
bullterrier


Joined: 16 May 2011
Posts: 23

PostPosted: Thu 29 Dec 2011, 16:57    Post subject:  

Thanks for reply.

1. Ran Alsamixer - pressed F6 - there are 2 entries - on the top it says "default" and the entry below - "0 - ESS Audiodrive ES1869" I selected the ESS Audiodrive entry. I have rebooted and the Sound icon in the taskbar has now disappeared. However Alsamixer still picks up the soundcard

2. Alsa config has been tried and it dosn't work for these non plug and play legacy sound cards built into the motherboard - they have to be manually configured.

Still no sound - just a static type of sound when mp3 or wav files are played.

Thanks any help is appreciated.
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5245
Location: Australia

PostPosted: Fri 30 Dec 2011, 04:14    Post subject:  

bullterrier wrote:
I have also the following kernel entry in /boot/grub/menu.lst

pnpbios=off acpi=off

These are turned off as in
http://www.murga-linux.com/puppy/viewtopic.php?t=22365&search_id=1865191538

Yes, those boot options are an important start.
But you missed a critical point in that earlier forum thread - the audio (ALSA) settings in /etc/modprobe.d/ often fail to "take" with older ISA-based audio devices.

I suggest you completely delete (or move) /etc/modprobe.d/alsa.conf
Then reboot.
Now run these 3 commands -
Code:
rmmod snd-es18xx
modprobe snd-es18xx isapnp=0 irq=5 dma1=1
modprobe snd-es18xx isapnp=0 irq=5 dma1=1 dma2=5


Now try to play an audio file, preferably with a simple commandline application like aplay. If you hear no sound, but aplay does its thing without reporting any errors, the sound system is half-working.
Launch alsamixer -
Code:
alsamixer

And check that the master volume is not muted, indicated by "M". If it is, press the "m" key to unmute, then raise the volume level.
Now try aplay again.

If this all works, you can automate the process from /etc/rc.d/rc.local
Back to top
View user's profile Send private message 
bullterrier


Joined: 16 May 2011
Posts: 23

PostPosted: Fri 30 Dec 2011, 07:37    Post subject:  

Great - some sound.

Did what you said, unloaded module, and reloaded it gradually.

played sound files found in /root/puppy-reference/audio/ in aplay

all the wav files played perfectly

the mp3 and ogg files sounded awful (like an old 56k modem dailing up)

went into alsamixer.

Turned up all the sliders I could - there are a few duplicated entries (ie. "3d contr" & "Hardware") with no sliders just an "00" in a box above them.

Thanks - what is the next step.
Back to top
View user's profile Send private message 
bullterrier


Joined: 16 May 2011
Posts: 23

PostPosted: Fri 30 Dec 2011, 07:43    Post subject:  

added the following lines to /etc/rc.d/rc.local

rmmod snd-es18xx
sleep 1
modprobe snd-es18xx isapnp=0 irq=5 dma1=1
sleep 1
modprobe snd-es18xx isapnp=0 irq=5 dma1=1 dma2=5

Am about to reboot and test.
Back to top
View user's profile Send private message 
bullterrier


Joined: 16 May 2011
Posts: 23

PostPosted: Fri 30 Dec 2011, 07:51    Post subject:    

rebooted and . .

The wav files are playing with aplay.

It dosn't play the mp3 or ogg files. (Are these being encoded correctly?)

What is the next step?
Back to top
View user's profile Send private message 
bullterrier


Joined: 16 May 2011
Posts: 23

PostPosted: Fri 30 Dec 2011, 08:03    Post subject:  

WOW!!! Thanks for your help.

Just fired up VLC media palyer, loaded an mp3 and it played perfectly.

Well done puppy! > This 10 year + old laptop now has sound, uses my usb 3g/HSDP modem via usb-modeswitch to connect to the internet. The old wireless card works perfectly. And it has an up to date world class os. It is as fast than it was when it had Windows 95 installed.

Last Question: The sound wigit on the task bar has disappeared. I moved a few files in init.d (10alsa and alsa-restore.conf) when manually configuring my sound over the last few days - Would this have made the sound wigit disappear?
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Audio
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0617s ][ Queries: 12 (0.0049s) ][ GZIP on ]