Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 30 Jul 2014, 05:04
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
ffmpeg AND libraries for Puppy528-003 Lupu ?
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
sunburnt


Joined: 08 Jun 2005
Posts: 5010
Location: Arizona, U.S.A.

PostPosted: Thu 22 Dec 2011, 03:34    Post subject:  ffmpeg AND libraries for Puppy528-003 Lupu ?  

I keep saying how SFS files are so great, but folks just keep making Pets...
But I`d be glad to get any ffmpeg setup that`ll work on 528.

I downloaded Debian ffmpeg_0.8.6-0.1_i386 and missing libraries.
ldd says all is good, but running it reports an error about: libavformat.so.53
I`ve never seen this problem before, so I can`t fix it easily.

I need ffmpeg, and it`s dependencies for Puppy528-003 Lupu.
"ldd" listed ffmpeg`s missing dependencies in 528 as:
    /root/apps/lib/libavcodec.so.53.5.0
    /root/apps/lib/libavdevice.so.53.0.0
    /root/apps/lib/libavfilter.so.2.4.0
    /root/apps/lib/libavformat.so.53.2.0
    /root/apps/lib/libavutil.so.51.7.0
    /root/apps/lib/libswscale.so.2.0.0
    /root/apps/lib/libx264.so.118
Back to top
View user's profile Send private message 
Master_wrong

Joined: 19 Mar 2008
Posts: 456

PostPosted: Thu 22 Dec 2011, 05:06    Post subject:  

You should search /usr/lib

i remember the version in puppy is libavcodec.so.54 or 55, and you just need to link it into what you need.
other files please try

http://debian-multimedia.org/pool/main/f/ffmpeg-dmo/ffmpeg-dmo.php

http://debian-multimedia.org/pool/main/x/x264/x264.php

_________________
Cluster-Pup v.2-Puppy Beowulf Cluster
http://www.murga-linux.com/puppy/viewtopic.php?p=499199#499199
Back to top
View user's profile Send private message 
sunburnt


Joined: 08 Jun 2005
Posts: 5010
Location: Arizona, U.S.A.

PostPosted: Thu 22 Dec 2011, 16:10    Post subject:  

Hi Master_wrong; I did look in /usr/lib. I found they`re all 52 in Puppy528 Lupu.

I have the all the library`s I listed for ffmpeg, but something`s not right.
Maybe a kernel compatibility problem, I have no way of knowing.
Back to top
View user's profile Send private message 
Master_wrong

Joined: 19 Mar 2008
Posts: 456

PostPosted: Fri 23 Dec 2011, 05:10    Post subject:  

ah yes 52, btw i try booting 528 and its already has ffmpeg installed. its ffmpeg 0.6-4:06-2 ubuntu4

so you need to upgrade them?

http://www.murga-linux.com/puppy/viewtopic.php?t=73975

_________________
Cluster-Pup v.2-Puppy Beowulf Cluster
http://www.murga-linux.com/puppy/viewtopic.php?p=499199#499199
Back to top
View user's profile Send private message 
sunburnt


Joined: 08 Jun 2005
Posts: 5010
Location: Arizona, U.S.A.

PostPosted: Fri 23 Dec 2011, 16:02    Post subject:  

Master_wrong; I`ve never had any ffmpeg that came with Puppy work.
I can`t remember what the ffmpeg in Puppy528 did.

I tried the old static build of ffmpeg for dPup and it will still works for 528 !
Static builds ( ffmpeg file is 2MB ) will work in more Puppy versions I think.

Last edited by sunburnt on Thu 29 Dec 2011, 15:13; edited 1 time in total
Back to top
View user's profile Send private message 
darkcity


Joined: 23 May 2010
Posts: 2435
Location: near here

PostPosted: Thu 29 Dec 2011, 13:28    Post subject:  

Did you solve the ffmpeg in puppy528 problem?

What where you trying to do? Twisted Evil

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0610s ][ Queries: 12 (0.0058s) ][ GZIP on ]