Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 02 Oct 2014, 12:51
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Slacko Puppy 5.3.1
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 29 of 37 Posts_count   Goto page: Previous 1, 2, 3, ..., 27, 28, 29, 30, 31, ..., 35, 36, 37 Next
Author Message
Jasper


Joined: 25 Apr 2010
Posts: 1135
Location: England

PostPosted: Tue 20 Dec 2011, 10:59    Post_subject:  

Hi,

What about Menu>Desktop>Desksetup Templates for Desk Icons>Traditional.

It may not be exactly what you want or need and it may not work, but if you click on the Floppy disk style icon, in that same window, first you should be able to restore your current mess - or you could backup your current mess first. then click that icon.

My regards

PS you're a decade out in your reply above.
Back to top
View user's profile Send_private_message 
Sylvander

Joined: 15 Dec 2008
Posts: 3447
Location: West Lothian, Scotland, UK

PostPosted: Tue 20 Dec 2011, 11:50    Post_subject:  

1. SUCCESS! Very Happy

That did the trick! Cool
Now all partition icons are displayed...
Just as I like them.

2. I'm being offered the option "Save the session = Yes/No?" at shut-down; haven't yet tested if it's working OK.
Will do so as I reboot to backup the slackosave.

3. The "Save" icon on the desktop still isn't working.

4. Will make a backup of the present slackosave, then try the other stuff you suggested.
Back to top
View user's profile Send_private_message 
Jasper


Joined: 25 Apr 2010
Posts: 1135
Location: England

PostPosted: Tue 20 Dec 2011, 12:15    Post_subject:  

Hi again Sylvander,

I'm pleased you've had a partial result. I never use my desktop save icon so as to avoid an error message on rebooting. I seem to recall you found a fix for that. A restatement below or a link to your fix would be appreciated.

My regards
Back to top
View user's profile Send_private_message 
Sylvander

Joined: 15 Dec 2008
Posts: 3447
Location: West Lothian, Scotland, UK

PostPosted: Tue 20 Dec 2011, 12:37    Post_subject:  

1. I have lots of handy stuff found here at the Puppy forums, and listed in my Puppy Linux thread at the PC-Guide forums.

Here's page 14 of my thread, which is at page 17 right now, and has had 59,836 views at this moment.

Here's the post that includes the link to the post with the info you want [plus links to other related and useful stuff].

--------------------------------------------------------------------------------------------
And here's the post by Dougal that gives the needed info.
---------------------------------------------------------------------------------------------

When I'm setting up a new Puppy I go through that thread finding useful stuff [configurations/tweaks/packages] to add.
The above is only one of them.
I've often thought it would be a good idea to make a new post or thread listing all the really pertinent stuff in one go, and leave out all the dross.
Any thoughts?

2. The save at shutdown of Slacko is working/functional.
Back to top
View user's profile Send_private_message 
Aitch


Joined: 04 Apr 2007
Posts: 6825
Location: Chatham, Kent, UK

PostPosted: Tue 20 Dec 2011, 15:02    Post_subject:  

Sylvander

Your thread over there is a one man masterpiece....thanks

Aitch Smile
Back to top
View user's profile Send_private_message 
don570


Joined: 10 Mar 2010
Posts: 3307
Location: Ontario

PostPosted: Tue 20 Dec 2011, 17:21    Post_subject: audacity package  

I made the audacity package a bit
smaller by removing similar libraries

The libsamplerate that I used was 0.1.2
that I found on the forum

When I compiled the latest version 0.1.8
it was just too big and stripping didn't make
any difference. So I kept the old libsamplerate
in the pet package.

Here's the revised package with the similar
libraries removed

http://www.datafilehost.com/download-f8c606c8.html

_________________________________________
Back to top
View user's profile Send_private_message 
Sylvander

Joined: 15 Dec 2008
Posts: 3447
Location: West Lothian, Scotland, UK

PostPosted: Tue 20 Dec 2011, 17:23    Post_subject:  

Aitch wrote:
one man masterpiece....

Wow! It sure is nice to have my efforts so appreciated. Very Happy

Thank you. Cool
Back to top
View user's profile Send_private_message 
Jasper


Joined: 25 Apr 2010
Posts: 1135
Location: England

PostPosted: Wed 21 Dec 2011, 10:13    Post_subject:  

Hi Sylvander,

Thanks to your help the minor spurious reboot error message I had when using my desktop save icon is now fixed.

Although I don't have problems saving on exit to power off or reboot it seems the better option to use the desktop save icon - because if anything goes seriously wrong with any save - there is the opportunity to recover (which seems impossible [except for "puppy pfix=1" as a partial solution] if a save on exit fails).

My regards
Back to top
View user's profile Send_private_message 
coldbeer

Joined: 22 Dec 2011
Posts: 1

PostPosted: Thu 22 Dec 2011, 08:58    Post_subject: Kernel Panic Slacko 5.3.1  

FYI: Kernel Panic Slacko 5.3.1
--------------------------------------------------------------------
Loading drivers neede to access disk drives.
Searching for Puppy files....
Loading the 'puppy_slacko_5.3.1.sfs' main file... copying to ram
Setting up the layered filesystem...
Performing a 'switch_root' to the layered filesystem ...Kernel panic not sync'd.
g:Attempted to kill init!
Pid: 1, com: switch_root Not tainted 2.6.37.6 #1
Call Trace:
[<c12a2988>] ? panic+0x4d/0x130
[<c1029179>] ? dn+exit+0x5a/0x59d
[<c1029868>] ? dn_group_exit+0x0/0x7b
[<c12a48a5>] ? syscall_call+0x7/0xb
-----------------------------------------------------------------------

I have an older P4 machine with pata drives and Nvidia GeForce 6200 card.

Clues:
1) I have used puppy 4.3.1 on this same machine lots of times. Then I got the NVidia card and puppy 4.3.1 now also gives a kernel panic on the live cd - ALONG with this Slacko 5.3.1. Problem due to video card?

2) I have Slackware 13.37 also and it boots fine.
Back to top
View user's profile Send_private_message 
mave

Joined: 02 Apr 2009
Posts: 130
Location: Germany

PostPosted: Fri 23 Dec 2011, 13:39    Post_subject:  Swap-Partition shown on desktop  

Hi,

did on a blank Thinkpad T41: ext3-partition and 1024MB-partition and installing Slacko 5.3.1 (and GRUB4DOS).

Now the swap-tartition is shown in Desktop as sda2. On other installs, no swap is shown...

And: clicking on it, Puppy wants to open a floppy drive. (disabling floppy inside BIOS gives no change).

Uuups! Why this?
puppy-swap-icon.jpg
 Description   
 Filesize   10.08 KB
 Viewed   1482 Time(s)

puppy-swap-icon.jpg

Back to top
View user's profile Send_private_message 
bigpup


Joined: 11 Oct 2009
Posts: 5170
Location: Charleston S.C. USA

PostPosted: Fri 23 Dec 2011, 17:29    Post_subject: Re: Swap-Partition shown on desktop  

mave wrote:
Hi,

did on a blank Thinkpad T41: ext3-partition and 1024MB-partition and installing Slacko 5.3.1 (and GRUB4DOS).

Now the swap-tartition is shown in Desktop as sda2. On other installs, no swap is shown...

And: clicking on it, Puppy wants to open a floppy drive. (disabling floppy inside BIOS gives no change).

Uuups! Why this?

What does Gparted say the partition is?

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7805
Location: qld

PostPosted: Fri 23 Dec 2011, 18:27    Post_subject: Re: Swap-Partition shown on desktop  

mave wrote:
Hi,

did on a blank Thinkpad T41: ext3-partition and 1024MB-partition and installing Slacko 5.3.1 (and GRUB4DOS).

Now the swap-tartition is shown in Desktop as sda2. On other installs, no swap is shown...

And: clicking on it, Puppy wants to open a floppy drive. (disabling floppy inside BIOS gives no change).

Uuups! Why this?


Ok, this has to be the most unusual thing I have ever seen!

Of course maybe you can do some debugging yourself, fdisk -l, probepart and others.

What happens when you boot a live session pfix=ram? (just edit the menu.lst at boot). Does the same show up?

Can you try booting live pfix=ram with racy/wary 522 ?(either one). These will probably exhibit the same as a Slacko pfix=ram boot as the woof version is very close. This will also narrow down to a Slacko or woof issue.

How did you format the drive? Was the drive formatted with Slacko?

More info is definitely needed. Smile

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
01micko


Joined: 11 Oct 2008
Posts: 7805
Location: qld

PostPosted: Fri 23 Dec 2011, 18:31    Post_subject: Re: Kernel Panic Slacko 5.3.1  

coldbeer wrote:
FYI: Kernel Panic Slacko 5.3.1
--------------------------------------------------------------------
Loading drivers neede to access disk drives.
Searching for Puppy files....
Loading the 'puppy_slacko_5.3.1.sfs' main file... copying to ram
Setting up the layered filesystem...
Performing a 'switch_root' to the layered filesystem ...Kernel panic not sync'd.
g:Attempted to kill init!
Pid: 1, com: switch_root Not tainted 2.6.37.6 #1
Call Trace:
[<c12a2988>] ? panic+0x4d/0x130
[<c1029179>] ? dn+exit+0x5a/0x59d
[<c1029868>] ? dn_group_exit+0x0/0x7b
[<c12a48a5>] ? syscall_call+0x7/0xb
-----------------------------------------------------------------------

I have an older P4 machine with pata drives and Nvidia GeForce 6200 card.

Clues:
1) I have used puppy 4.3.1 on this same machine lots of times. Then I got the NVidia card and puppy 4.3.1 now also gives a kernel panic on the live cd - ALONG with this Slacko 5.3.1. Problem due to video card?

2) I have Slackware 13.37 also and it boots fine.


Hmmm.. something tells me there is a hardware issue with your optical reader if you booted from CD/DVD. If not, more is needed, like how you installed.

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
mave

Joined: 02 Apr 2009
Posts: 130
Location: Germany

PostPosted: Sat 24 Dec 2011, 06:27    Post_subject:  

Hi,

the partition is real swap and the harddisk was formatted under Slacko with GParted...

But, sorry, now it's at parent's desk about 300km away. Will look closer with Teamviewer on it Wink

It's running without problems. Maybe I can reproduce this on another Thinkpad. Thanks to all, great thanks for Slacko!
Back to top
View user's profile Send_private_message 
charlie6


Joined: 30 Jun 2008
Posts: 1010
Location: South of Belgium

PostPosted: Sat 24 Dec 2011, 06:43    Post_subject: Re: Kernel Panic Slacko 5.3.1  

Hi,
coldbeer wrote:
FYI: Kernel Panic Slacko 5.3.1
--------------------------------------------------------------------
Loading drivers neede to access disk drives.
Searching for Puppy files....
Pid: 1, com:
Code:
switch_root Not tainted 2.6.37.6 #1

...
2) I have Slackware 13.37 also and it boots fine.


As far as I could remember, I got once such a
Code:
switch_root Not tainted 2.6.37.6 #1

message while trying to boot slacko using a fresh slacko-frugall install and using the «2.6.37.6-smp» version of vmlinuz (i.e. vmlinuz-2.6.37.6-huge-smp) after installed
- kernel-modules-smp-2.6.37.6_smp.txz and
- kernel-huge-smp-2.6.37.6_smp.txz files
downloaded from the slackware repo. (context: install of the 2.6.37.6-smp kernel for compiling a kernel module - details herehttp://karellen.blogspot.com/2011/11/pctel-inc-hsp-micromodem-56-with-linux.html )
In my case, the puppy-slacko's vmlinuz was trying to boot using modules in /lib/modules/2.6.37.6-smp/kernel/XYZ/.../*.ko modules. So I experienced that the puppy_slacko's vmlinuz (is not -smp) would not match with /lib/modules/2.6.37.6-smp/kernel/XYZ/.../*.ko modules)
Here, changing to a full install and symlinking vmlinuz to vmlinuz-2.6.37.6-huge-smp (and deleting the previous vmlinuz) got it solved.

In your case, would the puppy-slacko-save files be «too close» to the slackware files inside the same directory/or/partition, would'nt they?
Or a mismatch upon the name «vmlinuz», Slacko using the vmlinuz of Slackware, or something like that?

Doing
Code:
# uname -r

Slacko anwers
Code:
# uname -r
2.6.37.6

whereas the slackware 13.37-smp answers
Code:
# uname -r
2.6.37.6-smp


Also, all this is given as cut-and-try-results-for-information-only as my informatic knowledges are limited.

Hope this could help anyway, <| ;~)> !

Cheers ...
and...
Merry Xtmas to the whole Puppy goodwilling community !

Charlie
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 29 of 37 Posts_count   Goto page: Previous 1, 2, 3, ..., 27, 28, 29, 30, 31, ..., 35, 36, 37 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1183s ][ Queries: 13 (0.0206s) ][ GZIP on ]