Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 23 Oct 2014, 04:56
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
How to install official NVIDIA drivers
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [12 Posts]  
Author Message
vtpup


Joined: 15 Oct 2008
Posts: 1149
Location: Republic of Vermont

PostPosted: Thu 26 Nov 2009, 00:20    Post subject:  How to install official NVIDIA drivers  

Why
Because there has been much confusion about loading and using Nvidia graphics cards drivers, I've written this How-To for installing them into Puppy directly from Nvidia's own official installer.

To test your present system, please open a terminal type in the command:

Code:
glxgears


then <ENTER>

1.) If you see a graphic display of a pair of gears turning, please wait a few moments and you will soon see a frame rate posted in the terminal window. If the frame rate is up above 1000 FPS or so, it is likely that your card is working properly with an already-present NVIDIA driver.

2.) If your frame rate is much lower (say 300 fps), and/or the movement seems jerky then it's likely you have an older non-OEM Nvidia native Linux driver (like nv) or your computer is using graphics hardware emulation.

3.) If you don't get the graphic gears display at all and the terminal doesn't understand the glxgears command, then you don't have OpenGL aboard. True Nvidia OEM installed drivers include OpenGl support, but not necessarily a full OpenGL installation. You can try the command glxinfo in a terminal to see if you have OpenGl aboard. If you don't, you can load the xorg DRI .pet via the Puppy Package Manager to install OpenGL. Then you should be able to run glxgears.

In cases 2 and 3 above you may want to install Nvidia proprietary drivers. Some of these are available as .pets, however there seems to be a high rate of failure reported for these on the Puppy forum. The likely reason is that there are many different kernel versions of Puppy, many different Nvidia cards, and some choices that have to be made when compiling a driver to a particular system. A pet doesn't allow you any options and isn't custom compiled for your system. When you install nvidia drivers using Nvidia's own installer, it asks you a few questions and then creates a driver compiled specifically for your kernel, graphics board, and system.

If you would like to install drivers for your board using Nvidia's own installer that's what this How-to is for.

(Note: sorry to say, this how-to applies to frugal install, and removable media based systems with a personal savefile, not "full" HD installs. I use a frugal install, so maybe someone else who uses full installs can translate this how-to for others using that method. The main differences will be in loading the devx and and kernel source -- frugal installs use .sfs files for those).

Okay, ready to go? Here it is, with as much detail as I can come up with. Print these instructions out, because you won't be able to see them onscreen once you start working in the Nvidia installer.

Preliminary preparations

Before starting, please:

1.) Go to the Nvidia website and download the appropriate Linux driver for your card here:
www.nvidia.com/Download/index.aspx?
Be sure to specify Linux32bit (or Linux 64bit, depending on your system) and your exact card type.

2.) After downloading the Nvidia Installer be sure to put it in the /root directory -- if it isn't there already. This will make it easy to find when you are working in the terminal. It will be named something like:

NVIDIA-Linux-x86-96.43.13-pkg1.run

The numbers will probably be different, but it will look like that in general. Make a note of this filename on paper, with exact capitals lowercase and spelling for use later when you are using the terminal.

3.) You should know what version of Puppy Linux you are using, and also what kernel version you are using for the next step. You will need to download two files. They are the devx file, and the kernel source file for your version. Devx files are located here:

ftp://distro.ibiblio.org/pub/linux/distributions/puppylinux/

Kernel source files are located here:

http://puppylinux.com/sources/

As an example, let's say I have a Puppy 4.3.1 with the new Linux kernel (also known as the standard or 2.6.30.5 kernel)

From Ibiblio I go to the 431 directory and find:

devx_431.sfs.

From puppylinux.com I go to the kernel 2.6.30.5 directory and find:

kernel_src-2.6.30.5-patched.sfs4.sfs

I download both of these into /mnt/home. That's where .sfs files always go if I want to use them.

4.) Go to Menu>System>Bootmanager and click on the button to load sfs files. The two files you just downloaded should be there, so select them for loading next time you boot. Close out of Boot Manager.

5.)Now remove any Nvidia driver .pets you may have installed. Do this using the Menu>Setup> Puppy Package Manager.

6.) Reboot, and open Boot Manager to make sure the two files you specified are still listed in the right pane -- that means they were loaded properly. If not, have someone help you on the forum to make sure they get loaded. Sometimes it takes changing a checkbox setting to get them loaded, or you may be trying to load too many sfs files for your version of Puppy. You may have to temporarily remove something else.

Okay, let's do it

1.) Go to menu>shutdown>exit to prompt. You will be in terminal mode now

2.) Type
Code:
ls
and <enter>. You should see a listing of files, including the name of the Nvidia driver file that you downloaded to /root earlier. If it scrolls off the screen you still have a copy of the exact name on paper, which you wrote down earlier.

3.) Type the exact name of the NVIDIA installer file, preceeded by a ./ (a dot and forward slash) into the terminal. You can use the left and right arrow keys to move around and edit the letters if you need to. Don't use the mouse, it doesn't work with terminal editing.

My file example above would look like this:

Code:
./NVIDIA-Linux-x86-96.43.13-pkg1.run


4.) If yours looks right, hit <enter>. The nvidia installer should start up.

If it doesn't, you probably don't have the spelling exactly right. To see the proper spelling you can enter ls again. Then, to edit what you wrote last time, just hit an up arrow, and it will appear again. Then you can edit it to correct the spelling, and try <enter> again..

5.) Once the installer starts up, follow all of the instructions and suggestions it makes. It will at some point give a message that it can't find a suitable driver pre-made for your kernel, and will ask to compile a new one. Yes, that's what you want. It will also ask to rewrite your xorg.conf file. That's fine, too. Basically do what it asks.

6.) When done, type reboot, and start up Puppy again. Run the glxgears program in the terminal, and hopefully it will now run faster for you.

Note: if you still don't have OpenGL aboard (no glxgears), and you decide to now load the xorg DRI .pet to install it, you will unfortunately overwrite some of the Nvidia OpenGL driver files you just created. You would then need to reinstall the Nvidia driver again. So the order of installation must be xorg DRI first, then Nvidia driver over that, not the other way around

7.) If everything is okay, you can open Boot Manager and remove the devx and kernel source files. They aren't needed anymore -- the installer just uses them to compile your custom driver. If you want, you can also delete or move the NVIDIA installer file out of /root. I like to keep a copy, however, in case I ever have to reinstall the Nvidia driver.

Hope this helps..
Back to top
View user's profile Send private message 
p3m4la5

Joined: 15 Apr 2011
Posts: 16

PostPosted: Thu 23 Jun 2011, 03:58    Post subject:  

vtpup, it's work for me.....
http://murga-linux.com/puppy/viewtopic.php?p=537071 with RIVA TNT.
I'll keep this page in my HD
Back to top
View user's profile Send private message 
DukeDomo

Joined: 16 Dec 2011
Posts: 7
Location: Croatia

PostPosted: Sun 18 Dec 2011, 14:39    Post subject:  

Hello there. Did everything exactly like you wrote and got 'sh- Permission denied.'

Running Wary 5.2.2 frugal on SCSI Disk with RivaTNT2 M64 Pro

Any help?
Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 7835
Location: qld

PostPosted: Sun 18 Dec 2011, 16:50    Post subject:  

Code:
chmod 755 NVIDIA-Linux{your-version-here}.run


Permissions are not set to executable on the downloaded files from nvidia.

vt-pup, you should add it to your nice "howto" Wink

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
DukeDomo

Joined: 16 Dec 2011
Posts: 7
Location: Croatia

PostPosted: Sun 18 Dec 2011, 18:28    Post subject:  

yep figured it out from searching around Forum.
BTW next build was success but X kept on reverting to vesa driver.

Then i made completely new frugal install without upgrading Xorg to 7.6 redone the steps up and finally running X on the driver after 4h of trial and error.

I just hope my future steps into Puppy do not consume this much time Rolling Eyes

Thank you very much for this How To Smile
Back to top
View user's profile Send private message Visit poster's website 
banger0250


Joined: 12 Aug 2010
Posts: 44
Location: Rothwell,Brisbane,Qld,AU

PostPosted: Tue 03 Jan 2012, 03:47    Post subject:  

Good tutorial man, add the chmod command to the nvidia driver section and it will be perfect.
I got 11400FPS on glxgears with racy5.2.2. Very Happy

_________________
Taking pup for a walk
Back to top
View user's profile Send private message MSN Messenger 
pabloA

Joined: 12 Feb 2009
Posts: 29

PostPosted: Tue 03 Jan 2012, 11:47    Post subject:  

additional to the fine info above:

If after installing the driver of your choice, and returning to GUI, you find the screen needs adjusting to fit;
-open a console.
-type nvidia-settings

If your video settings needed to be ajusted for over-compenstaion, you may miss a save option within nvidia-settings -> nvidia-settings Configuration. To see the 'Save cureent configuration' button you may need to resize the window by grabing the title bar.

Hth
Back to top
View user's profile Send private message 
PenguinPupLin

Joined: 23 Dec 2011
Posts: 126
Location: The Little Red Dot

PostPosted: Tue 17 Jan 2012, 11:43    Post subject:  

Hello, I tried the above method and got the error:unable to build the nvidia kernel module. Before that it said something about gcc version check not matching (4.4 vs 4.3) with option to continue with the installation, I went ahead.

The Lighthouse puppy 5.0.3 devx and source files are checked for md5sum to be matching and the NVIDIA-Linux-x86-96.43.20-pkg1.run driver is correct as it has been used successfully to compile for at least 4 other puppies. I've also removed the previous Nvidia96.pet before rebooting and exiting to prompt to start the compilation.

What did I do wrong?
Back to top
View user's profile Send private message 
PenguinPupLin

Joined: 23 Dec 2011
Posts: 126
Location: The Little Red Dot

PostPosted: Mon 23 Jan 2012, 11:14    Post subject:  

Because my wary511 pupsave file was corrupted and I forgot to back it up, so had to use an earlier savefile without nvidia driver and recompile it again. Using the same devx and source files and the nividia installer that worked fine previously,this time after nvidia-xconfig, it informed:

Warning: Unable to parse X-org version string.
sh. line 1: 9254 Broken pipe...

Any advice appreciated. Thanks in advance.
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 3341
Location: Ontario

PostPosted: Mon 23 Jan 2012, 13:13    Post subject:  

I have the same problems trying to compile on Lighthouse 503 Crying or Very sad

Did you ever try Lighthouse 502 and Tazoc's nvidia driver package??

It's available here along with nvidia drivers. Near top of page.
http://www.lhpup.org/download500.htm#mar-iso

__________________________________________-
Back to top
View user's profile Send private message 
PenguinPupLin

Joined: 23 Dec 2011
Posts: 126
Location: The Little Red Dot

PostPosted: Tue 24 Jan 2012, 03:38    Post subject:  

Yes,I did and it worked OK using Tarzoc's Nvidia96 driver which is stated for LHP 5.00c and later, so I don't see why it didn't work for your LHP502.

After that I attempted to compile one using the latest Nvidia96.43.20 installer driver following the method you and jim1911 pointed out to me, and it worked beautifully. I did the same for my other puppies,eg Wary511, puppy 431 and lupu525, but ran into an unusual problem with Classic Pup 214X which I've posted elsewhere and won't delve into it here.

Now I want to do it again for Wary 511 and encounter this issue - it worked the first time,why not now?.

Thanks for your response.
Back to top
View user's profile Send private message 
PenguinPupLin

Joined: 23 Dec 2011
Posts: 126
Location: The Little Red Dot

PostPosted: Thu 26 Jan 2012, 13:37    Post subject:  

PenguinPupLin wrote:
Because my wary511 pupsave file was corrupted and I forgot to back it up, so had to use an earlier savefile without nvidia driver and recompile it again. Using the same devx and source files and the nividia installer that worked fine previously,this time after nvidia-xconfig, it informed:

Warning: Unable to parse X-org version string.
sh. line 1: 9254 Broken pipe...

Any advice appreciated. Thanks in advance.

Done (rather than solved,in the stirct sense of the word,as I didn't go into the root of the problem):- I started from scratch. Booted into RAM mode (i.e.pfix=ram), chose vesa, and created a new pupsave 1GB size (as I've read somewhere the process of creating the driver may require a free space of about 768MB in pupsave for frugal install - perhaps this was the reason why it failed previously but I couldn't remember how much free space I had then). Rebooted into the savefile and installed the nvidia driver again. Also to make sure, I ran the following code as suggested by someone:
# depmod-FULL
# modprobe nvidia
# nvidia-xconfig
# xwin
(Just running the code without doing the above didn't help).
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [12 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1324s ][ Queries: 12 (0.0276s) ][ GZIP on ]