Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 03:46
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Nvidia drivers for Puppy 3.0
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 4 [50 Posts]   Goto page: Previous 1, 2, 3, 4 Next
Author Message
sketchman


Joined: 01 Jun 2006
Posts: 251
Location: West Virginia, USA

PostPosted: Mon 19 May 2008, 23:25    Post subject:  

Paul-B wrote:
And what of new drivers for Dingo, any news on that?

Paul-B


I'm by no means an expert, but don't 3.x and 4.x puppies use the same kernel? I think that means they can use the same driver package.

I have this current .pet running my 4.0 puppy and it DOES work for me. No more refresh lines in my movies anymore.

_________________
"In a world that exists without walls and fences, who needs Windows and Gates?"
Back to top
View user's profile Send private message 
lawrencelkl

Joined: 04 Jun 2008
Posts: 2

PostPosted: Wed 04 Jun 2008, 09:25    Post subject: where to download a driver for puppy 4.0  

Hi people,

I am completely new to linux so please bear with me.
I just recently installed puppy 4 and then installed openFOAM, the open source cfd program.
when i launch the paraFoam (paraview) , a viewing postprocessing tool to view the results, i get msg in the console window

Xlib:mixing "GLX" extension in display "0.0"

is this the problem with display driver? honestly i dont know what display card i have but it is a acer travelmate 270.

please kindly help me with a instruction on wher to download and how to install the or perhaps before al lthis, how to determine my display card type.

your help is very very much appreciated.

thanks

Lawrence
Back to top
View user's profile Send private message 
ricesteam

Joined: 04 Jun 2008
Posts: 13

PostPosted: Wed 04 Jun 2008, 16:41    Post subject:  

Hi,

I'm new to puppy. I have a GeForce 6600 and downloaded the nvidia-100-xx files. I installed it using the pup installer.

I tried following further instructions, but I can't find "install_nvidia"

When I restarted xwin, I noticed Nvidia X Server Settings installed, but when I checked my Display settings, I noticed my OpenGL config is still unknown.

What am I missing?

Thanks
Back to top
View user's profile Send private message 
stevenbinion


Joined: 24 Aug 2007
Posts: 180
Location: Pittsburgh, PA - United States

PostPosted: Wed 04 Jun 2008, 17:17    Post subject:  

ricesteam wrote:
Hi,

I'm new to puppy. I have a GeForce 6600 and downloaded the nvidia-100-xx files. I installed it using the pup installer.

I tried following further instructions, but I can't find "install_nvidia"

When I restarted xwin, I noticed Nvidia X Server Settings installed, but when I checked my Display settings, I noticed my OpenGL config is still unknown.

What am I missing?

Thanks


Xorg DRI drivers. which version of Puppy are you using?

_________________
[Home of Wolf Pup Linux]
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger MSN Messenger 
ICQ Number 
ricesteam

Joined: 04 Jun 2008
Posts: 13

PostPosted: Wed 04 Jun 2008, 17:34    Post subject:  

I think I got it working. I installed the xorg-dri packages from the package installer. I'm using Puppy 4.00.
Back to top
View user's profile Send private message 
lawrencelkl

Joined: 04 Jun 2008
Posts: 2

PostPosted: Thu 05 Jun 2008, 13:47    Post subject: puppy 4 with sis  

hi, i think i have a Sis M650 on my laptop and i have puppy 4.0. i cannot launch paraview and it keep saying the Xlib: extension "GLX" is missing. any helps please?

Thanks

Lawrence
Back to top
View user's profile Send private message 
cb88


Joined: 28 Jan 2007
Posts: 1169
Location: USA

PostPosted: Tue 10 Jun 2008, 21:08    Post subject:  

well this is kinda old news but I didn't make any nvidia dotpup or pet ... it was most likely gray wow mu or tempestuous
_________________
Taking Puppy Linux to the limit of perfection. meanwhile try "puppy pfix=duct_tape" kernel parem eater.
X86: Sager NP6110 3630QM 16GB ram, Tyan Thunder 2 2x 300Mhz
Sun: SS2 , LX , SS5 , SS10 , SS20 ,Ultra 1, Ultra 10 , T2000
Mac: Platinum Plus, SE/30
Back to top
View user's profile Send private message Visit poster's website 
arfon


Joined: 17 Aug 2008
Posts: 22
Location: North Wales, UK

PostPosted: Sat 30 Aug 2008, 17:44    Post subject:  Perfect for GeForce 8400M GS  

@ gray

Brilliant nvidia drivers. I was struggling to get xorg working with anything other than a generic driver on the HurtMePlenty puppy. Then I discovered your pet which worked perfectly, and now I can use the external monitor as well.

My Laptop is a Sony VAIO VGN-SZ71MN/B with NVIDIA GeForce 8400M GS in case anyone else has similar model. The pet I used was: NVIDIA-100.14.19-k2.6.21.7.pet

Thanks very much, I'm off to game land now. Very Happy

Arfon
(North Wales)

PS: I found it useful to start with Xvesa then
install pet - Exit X - run xorgwizard - restart X
Back to top
View user's profile Send private message Visit poster's website 
reggiesbutchershop

Joined: 09 Jul 2009
Posts: 1

PostPosted: Thu 09 Jul 2009, 07:46    Post subject: nvidia on puppy 4.2.1
Subject description: x will not accept nvidia changes to xorg.conf
 

Hi, I am new to puppy. I have puppy linux on a dell latitude d520. So far everything has worked very well and I am very happy with it. However, dual monitors are necessary for my work. When I start xorg the monitors are mirrored. I have looked at what other people's suggestions and tried to install nvidia and enable the "twin view" option. When I install nvidia, i exit out of x and go into xorgwizard. The xorgwizard recognizes two different screens (it asks for the resolution for each) but when x starts (i type xwin) it goes back to the original xorg.conf file.

At the moment, I run puppy from a USB, which may be the problem. I have tried all the different versions of nvidia.pet that are available and none seem to work. Does anyone know how I can install nvidia? Any help is greatly appreciated.
Back to top
View user's profile Send private message 
qinchuan12345

Joined: 30 Jul 2009
Posts: 2

PostPosted: Fri 31 Jul 2009, 01:41    Post subject: I can not install nvidia driver(Geforce 6100)
Subject description: I can not install nvidia driver(Geforce 6100)
 

Hi,any one pleas:
I can not let nvidia Geforce 6100 work with any of the driver list above.
My computer:
cpu: AMD 2800+
mainboard:T6100 with on board nvidia Geforce 6100(c51 GPU)
memry:ddr 1G+512M
os:puppy 4.2(k2.6.21.7)

I have test all the driver above,and test other nvidia driver for puppy,after install,I reboot the computer,the sys can not start the xorg,but the Xseg is ok.I check the err file log,It show me "can not load the nvidia dirver kernel".So,is the version of puppy(k2.6.21.7) can not use these driver?The other version I hav'nt test.
plese help me.Forgive my bad English.

thank a lot!!
Back to top
View user's profile Send private message 
qinchuan12345

Joined: 30 Jul 2009
Posts: 2

PostPosted: Wed 05 Aug 2009, 01:59    Post subject: It's OK
Subject description: Now It is Ok
 

I download the version of puppy match to the nvidia driver's version,and It is work very good.If your puppy can not driver with nvidia driver,check the version.
Back to top
View user's profile Send private message 
runtt21


Joined: 07 Jun 2008
Posts: 1650
Location: BigD Texas

PostPosted: Wed 05 Aug 2009, 19:25    Post subject:  

Nivida drivers for Puppy 4.1 & 4.2

http://www.murga-linux.com/puppy/viewtopic.php?t=34001

_________________

www.macpup.org http://macpup.org/runtt21
Back to top
View user's profile Send private message Visit poster's website 
mandrivauser50

Joined: 13 Feb 2010
Posts: 9
Location: Europe

PostPosted: Sat 13 Feb 2010, 11:56    Post subject:  

Is there any chances to get drivers for Puppy Linux 4.2.1. My graphic card is Nvidia Geforce 9500 GT.

Hope it's a Pet package - automatically installed. Puppy didn't look very good by editing xorg.conf. Fonts are tiny and blurry.
Back to top
View user's profile Send private message 
Luposian

Joined: 04 Dec 2011
Posts: 5

PostPosted: Mon 05 Dec 2011, 15:28    Post subject: Re: Nvidia drivers for Puppy 3.0  

gray wrote:
For the new kernel (2.6.21.7) of Puppy 3.0 I have put together the set of three driver packages for nvidia cards.

nvidia-7186.pet for ancient nvidia graphics cards (riva TNT to Geforce 1).

nvidia-9643.pet for most nvidia cards (officially Gf2 to Gf4 but have tested on Gf7 OK).

nvidia-100.14.19.pet for latest cards (Gf5 to Gf8).

All available at http://download.tuxfamily.org/nop/

The pet packages install modified nvidia pkg1.run files to /tmp.
After this is complete drop out of X [ ctrl alt backspace ] and at the prompt enter install_nvidia and accept the defaults.
Then run xorgwizard and test the required resolution and finally run xwin.


I am running the very latest Puppy Linux (Lucid; kernel 2.6.33.2). Will your drivers work on my Creative 3D Blaster Annihilator Ultra (GeForce 2 Ultra chipset) or must I go to an older version of Puppy?

I am trying to get some remaining useful life out of an old Pentium II 266Mhz system I have, with 384Mb of RAM. Trying to find an OS that I can run from CD and then do builds of Haiku from... and various versions of Linux seem to be the best path for that.
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Wed 07 Dec 2011, 04:40    Post subject: Re: Nvidia drivers for Puppy 3.0  

Luposian wrote:
I am running the very latest Puppy Linux (Lucid; kernel 2.6.33.2). Will your drivers work on my Creative 3D Blaster Annihilator Ultra (GeForce 2 Ultra chipset)

nvidia-glx-sdl-285.05.09-2.sfs may support GeForce2 Ultra.
http://www.murga-linux.com/puppy/viewtopic.php?t=72405

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 3 of 4 [50 Posts]   Goto page: Previous 1, 2, 3, 4 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0929s ][ Queries: 12 (0.0116s) ][ GZIP on ]