Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 21 Nov 2014, 20:28
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Midori 0.4.3
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 3 Posts_count   Goto page: 1, 2, 3 Next
Author Message
jemimah


Joined: 26 Aug 2009
Posts: 4309
Location: Tampa, FL

PostPosted: Tue 29 Nov 2011, 11:29    Post_subject:  Midori 0.4.3
Sub_title: for wary, racy, and slacko
 

I've compiled Midori 0.4.3, this time against webkitgtk-1.4.3, which seems to have fewer issues, and it's a little smaller.

I didn't build gnutls statically this time so you should install that first.

http://www.smokey01.com/jemimah/saluki/pets/gnutls-2.8.5-i486.pet
http://www.smokey01.com/jemimah/saluki/pets/midori-0.4.3-i486.pet


You'll probably need this updated glib as well:

http://www.smokey01.com/jemimah/saluki/pets/glib-2.31.6-saluki-i486.pet


------------
This is Midori 0.4.2 compiled on Racy 5.2.2 against webkit-1.6.1. This has static webkit, libsoup, and glib-networking with static gnutls. I've included ssl support, all midori plugins, and the inspector. The download is 4.7MB.

For slacko you'll need to run the following command to make it work.
Code:
cd  /lib; ln -sf libssl.so.0.9.8 libssl.so.1.0.0


http://www.smokey01.com/jemimah/saluki/pets/midori-0.4.2-i486.pet

The patch I used to stop webkit from segfaulting is here:
http://www.smokey01.com/jemimah/saluki/source/webkit-161.patch

Edited_times_total
Back to top
View user's profile Send_private_message Visit_website 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Tue 29 Nov 2011, 11:39    Post_subject:  

Just downloaded. Looking forward to trying this... I like Midori, somehow it just sits right with me Smile
_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send_private_message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Tue 29 Nov 2011, 12:30    Post_subject:  

Damn... so fast. Little unstable, crashed trying to log on to forum first time round Smile
Peacekeeper hangs, but hey, so what!

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send_private_message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Tue 29 Nov 2011, 14:08    Post_subject:  

(Racy) Oh dear.. crashed and died forever Sad
_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send_private_message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Thu 01 Dec 2011, 00:32    Post_subject:  

Barry was not enamoured either
http://murga-linux.com/puppy/viewtopic.php?p=585651#585651
I have not tested as I never find a small browser sufficient for more than an hour. Which is all some people need.
What hardware is Midori not working on? I think Jemimah is compiling on and for quite recent hardware?
Was it Midori that was/is used successfully in Lucid (in my case to download a 'real' browser)? Smile

_________________
Puppy WIKI
Back to top
View user's profile Send_private_message Visit_website 
aarf

Joined: 30 Aug 2007
Posts: 3620
Location: around the bend

PostPosted: Thu 01 Dec 2011, 04:12    Post_subject:  

racy522 with lupufy-slacko openbox midori
had to reinstall and refresh fbpanel after installing midori then midori again possibly because my savefile was too small. now reported at "47M personal storage, free space= 19M" and everything seems to work on short testing. this post from midori.
PS your guess is as good as mine as to how that "Posted by ttuuxxx" got to be in that screenshot Question i am definitely not ttuuxxx Exclamation
edit: mouse was over the left menu and "Posted by ttuuxxx" is a mouse over popup.
image-3.jpg
 Description   
 Filesize   33.52 KB
 Viewed   4255 Time(s)

image-3.jpg

image-2.jpg
 Description   
 Filesize   36.71 KB
 Viewed   3803 Time(s)

image-2.jpg


Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Thu 01 Dec 2011, 04:28    Post_subject:  

The fatal crash I had came from clicking the icon far left on the icon bar aarf. Should display side pane?
_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send_private_message 
aarf

Joined: 30 Aug 2007
Posts: 3620
Location: around the bend

PostPosted: Thu 01 Dec 2011, 04:35    Post_subject:  

DaveS wrote:
The fatal crash I had came from clicking the icon far left on the icon bar aarf. Should display side pane?
you mean like so <attached> works for me. still on my first run of midori. no crashes.
image-5.jpg
 Description   
 Filesize   54.04 KB
 Viewed   4068 Time(s)

image-5.jpg


_________________

ASUS EeePC Flare series 1025C 4x Intel Atom N2800 @ 1.86GHz RAM 2063MB 800x600p ATA 320G
_-¤-_

<º))))><.¸¸.•´¯`•.#.•´¯`•.¸¸. ><((((º>

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
mavrothal


Joined: 24 Aug 2009
Posts: 1788

PostPosted: Thu 01 Dec 2011, 04:36    Post_subject:  

aarf wrote:

had to reinstall and refresh fbpanel after installing midori then midori again possibly because my savefile was too small.


Not sure about that.
I had it install in XOpup-2.2 (lupu525) with plenty of space and lost JWM menu and fbpanel (in openbox), and "fixmenus" did not fix it. Removing it, everyhing went back to normal. Confused

_________________
Kids all over the world go around with an XO laptop. They deserve one puppy (or many) too Very Happy
Back to top
View user's profile Send_private_message 
Sage

Joined: 04 Oct 2005
Posts: 4813
Location: GB

PostPosted: Thu 01 Dec 2011, 04:43    Post_subject:  

Quote:
The fatal crash I had came from clicking the icon far left on the icon bar

All very interesting. I've had that happen with (the latest) FF running in MintXfce when accessing top-far-left (by accident). Also saw similar with another recent distro & FF. Never seen it with Opera!
Back to top
View user's profile Send_private_message 
aarf

Joined: 30 Aug 2007
Posts: 3620
Location: around the bend

PostPosted: Thu 01 Dec 2011, 04:48    Post_subject:  

mavrothal wrote:
aarf wrote:

had to reinstall and refresh fbpanel after installing midori then midori again possibly because my savefile was too small.


Not sure about that.
I had it install in XOpup-2.2 (lupu525) with plenty of space and lost JWM menu and fbpanel (in openbox), and "fixmenus" did not fix it. Removing it, everyhing went back to normal. Confused
this is where i had to get fbpanel to restart from <attached>. console restart failed.
edit: to get to that menu when there is no fbtray, right click on the desktop wallpaper.
image-7.jpg
 Description   
 Filesize   56.45 KB
 Viewed   4124 Time(s)

image-7.jpg


_________________

ASUS EeePC Flare series 1025C 4x Intel Atom N2800 @ 1.86GHz RAM 2063MB 800x600p ATA 320G
_-¤-_

<º))))><.¸¸.•´¯`•.#.•´¯`•.¸¸. ><((((º>

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
aarf

Joined: 30 Aug 2007
Posts: 3620
Location: around the bend

PostPosted: Thu 01 Dec 2011, 05:13    Post_subject:  

was running from console
Code:
# midori
** Message: console message: file:///usr/share/webkitgtk-1.0/webinspector/inspector.js @1425: Localized string "No Watch Expressions" not found.

** Message: console message: file:///usr/share/webkitgtk-1.0/webinspector/inspector.js @1425: Localized string "Timeline Panel" not found.

** Message: console message: file:///usr/share/webkitgtk-1.0/webinspector/inspector.js @1425: Localized string "Start/stop recording" not found.

#

now running from menu>internet>midori
my flashplayer.so is on my opera partition so midori has been and still is running without flashplayer

_________________

ASUS EeePC Flare series 1025C 4x Intel Atom N2800 @ 1.86GHz RAM 2063MB 800x600p ATA 320G
_-¤-_

<º))))><.¸¸.•´¯`•.#.•´¯`•.¸¸. ><((((º>
Back to top
View user's profile Send_private_message Visit_website 
aarf

Joined: 30 Aug 2007
Posts: 3620
Location: around the bend

PostPosted: Thu 01 Dec 2011, 07:56    Post_subject:  

my "t"s have turned into strange "i"s. but not when i type a "t" into this input box for example. they look like normal "t's until they are in the post and viewed in the forum then they look like strange "i"s.
edit: not everywhere is affected. forum front page is ok. but inside post are affected. viewing with midori.
opera11.6 is not affected anywhere.

edit: temporary glitch,on reboot all is normal Arrow
image-7.jpg
 Description   
 Filesize   52.79 KB
 Viewed   3946 Time(s)

image-7.jpg


_________________

ASUS EeePC Flare series 1025C 4x Intel Atom N2800 @ 1.86GHz RAM 2063MB 800x600p ATA 320G
_-¤-_

<º))))><.¸¸.•´¯`•.#.•´¯`•.¸¸. ><((((º>

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
sc0ttman


Joined: 16 Sep 2009
Posts: 2386
Location: UK

PostPosted: Thu 01 Dec 2011, 08:45    Post_subject:  

I thought my system (Akita) would be too old, seems that it is:

Code:
# midori
midori: symbol lookup error: /usr/lib/midori/libcookie-manager.so: undefined symbol: g_tls_certificate_get_type


Although the vast majority of libs and stuff in Akita is now from Wary512... So I expect it will not work in Wary 5.1.x as well....?

If I can to the bottom of this Midori error, I might find that I missed something when updating to a Wary 'core'...

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send_private_message 
jemimah


Joined: 26 Aug 2009
Posts: 4309
Location: Tampa, FL

PostPosted: Thu 01 Dec 2011, 12:49    Post_subject:  

sc0ttman wrote:
I thought my system (Akita) would be too old, seems that it is:

Code:
# midori
midori: symbol lookup error: /usr/lib/midori/libcookie-manager.so: undefined symbol: g_tls_certificate_get_type


Although the vast majority of libs and stuff in Akita is now from Wary512... So I expect it will not work in Wary 5.1.x as well....?

If I can to the bottom of this Midori error, I might find that I missed something when updating to a Wary 'core'...


That's odd. Do you have your own version of glib-networking? Maybe it's using yours rather than the included one.
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 3 Posts_count   Goto page: 1, 2, 3 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0891s ][ Queries: 13 (0.0057s) ][ GZIP on ]