(OLD) (ARCHIVED) Puppy Linux Discussion Forum Forum Index (OLD) (ARCHIVED) Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info

This forum can also be accessed as http://oldforum.puppylinux.com
It is now read-only and serves only as archives.

Please register over the NEW forum
https://forum.puppylinux.com
and continue your work there. Thank you.

 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups    
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 27 Sep 2020, 00:58
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
wine 0.9.15 sfs for Puppy2
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
Page 1 of 1 [15 Posts]  
Author Message
violetdream

Joined: 15 Apr 2006
Posts: 109

PostPosted: Sat 17 Jun 2006, 03:58    Post subject:  wine 0.9.15 sfs for Puppy2  

Using the file that I just posted earlier, I made an sfs using the instructions on the forum here (http://www.puppyos.com/nfphpbb/) that's down now. It fixed all the problems I was having installing wine on a computer with a very small amount of ram and no extra space to install large programs like wine. Here you go, enjoy! It's based on wine 0.9.15

http://www.mooload.com/new/file.php?file=files/170606/1150530983/wine_200.sfs

If it could be hosted somewhere else that would be good. Thanks. It could probably be used for pup1 too but I'm not sure.
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13647
Location: Karlsruhe, Germany

PostPosted: Sat 17 Jun 2006, 10:39    Post subject:  

very nice, thanks Smile

Mirror:
http://dotpups.de/files/wine0915_200.sfs

Mark
Back to top
View user's profile Send private message Visit poster's website 
New Puppy Fan


Joined: 14 Aug 2005
Posts: 77
Location: Minnesota, USA

PostPosted: Sun 16 Jul 2006, 02:52    Post subject: Re: wine 0.9.15 sfs for Puppy2  

violetdream wrote:
Using the file that I just posted earlier, I made an sfs using the instructions on the forum here (http://www.puppyos.com/nfphpbb/) that's down now. It fixed all the problems I was having installing wine on a computer with a very small amount of ram and no extra space to install large programs like wine. Here you go, enjoy! It's based on wine 0.9.15

I renamed wine0.9.15_200.sfs to wine0.9.15_201.sfs to run in Puppy 201, put it in the same place with pup_save.3fs, rebooted and trying to run wine, but getting message "command not found".
What's wrong?
Thanks for advice.
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13647
Location: Karlsruhe, Germany

PostPosted: Sun 16 Jul 2006, 04:52    Post subject:  

For some people the mounting seems not to work depending on their setup.
You alternatively could use the unleashed package:
http://www.murga.org/~puppy/viewtopic.php?t=8717&highlight=wine

Mark
Back to top
View user's profile Send private message Visit poster's website 
gw

Joined: 22 Apr 2006
Posts: 89
Location: Suisse

PostPosted: Sun 16 Jul 2006, 08:04    Post subject:  

Hello,

I can install and run wine with Puppy 2.01r2-seamonkey, but it doesn't run with Puppy barebones 2.01r2. I observed the same with versions 2.0 and 2.01. Does somebody know why and what to do to be able to run wine with the barebones versions?

Thank you
--
gw
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13647
Location: Karlsruhe, Germany

PostPosted: Sun 16 Jul 2006, 08:07    Post subject:  

type "wine" in a console, and post here the errors you get.
Mark
Back to top
View user's profile Send private message Visit poster's website 
gw

Joined: 22 Apr 2006
Posts: 89
Location: Suisse

PostPosted: Sun 16 Jul 2006, 09:51    Post subject:  

Hello Mark,

Soft : dicoverb (runs perfectly under wine) http://perso.orange.fr/herve.echelard/

Error *only with the barebones* version :

sh-3.00# wine /root/dicoverb/Conjug.exe
err:module:load_builtin_dll failed to load .so lib for builtin L"winex11.drv": libXxf86vm.so.1: cannot open shared object file: No such file or directory
err:imagelist:ImageList_ReplaceIcon no color!
err:imagelist:ImageList_ReplaceIcon no color!
err:imagelist:ImageList_ReplaceIcon no color!
err:imagelist:ImageList_ReplaceIcon no color!
err:module:load_builtin_dll failed to load .so lib for builtin L"winex11.drv": libXxf86vm.so.1: cannot open shared object file: No such file or directory
err:module:load_builtin_dll failed to load .so lib for builtin L"winex11.drv": libXxf86vm.so.1: cannot open shared object file: No such file or directory
err:module:load_builtin_dll failed to load .so lib for builtin L"winex11.drv": libXxf86vm.so.1: cannot open shared object file: No such file or directory
Application tried to create a window, but no driver could be loaded.
Unknown error (127).
Application tried to create a window, but no driver could be loaded.
Unknown error (127).
sh-3.00#

Thank you
--
gw
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13647
Location: Karlsruhe, Germany

PostPosted: Sun 16 Jul 2006, 13:35    Post subject:  

Try this one, it includes these files:

usr/X11R6/lib/libXxf86dga.so
usr/X11R6/lib/libXxf86dga.so.1
usr/X11R6/lib/libXxf86dga.so.1.0
usr/X11R6/lib/libXv.so
usr/X11R6/lib/libXv.so.1
usr/X11R6/lib/libXv.so.1.0
usr/X11R6/lib/libXxf86vm.so
usr/X11R6/lib/libXxf86vm.so.1
usr/X11R6/lib/libXxf86vm.so.1.0

http://noforum.de/dotpups/mplayer-1.0-pre7-try2/X.org-version/mplayer-xorg-libs-for-normal-puppy.pup

Mark
Back to top
View user's profile Send private message Visit poster's website 
gw

Joined: 22 Apr 2006
Posts: 89
Location: Suisse

PostPosted: Sun 16 Jul 2006, 15:10    Post subject:  

Hello Mark,

Problem solved thanks to your assistance.
After installing the dotpup, wine runs now without problem on the barebones version.

Thank you
--
gw
Back to top
View user's profile Send private message Visit poster's website 
New Puppy Fan


Joined: 14 Aug 2005
Posts: 77
Location: Minnesota, USA

PostPosted: Mon 17 Jul 2006, 00:58    Post subject:  

MU wrote:
For some people the mounting seems not to work depending on their setup.
You alternatively could use the unleashed package:
http://www.murga.org/~puppy/viewtopic.php?t=8717&highlight=wine
Mark

Hi, Mark!
Later I tried to install Wine-0.9.15.tar.gz, but I got message about missing files or broken dependencies. So I desided to use wine_xxxxxx.sfs, but no luck either.
Where can I get missing files for wine?
Thanks again.
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13647
Location: Karlsruhe, Germany

PostPosted: Mon 17 Jul 2006, 07:08    Post subject:  

you must tell us, what files it needs, then I can give you links to the dotpups.
Mark
Back to top
View user's profile Send private message Visit poster's website 
New Puppy Fan


Joined: 14 Aug 2005
Posts: 77
Location: Minnesota, USA

PostPosted: Tue 18 Jul 2006, 02:54    Post subject:  

Hi, Mark.
Here is the message I got.
Back to top
View user's profile Send private message 
violetdream

Joined: 15 Apr 2006
Posts: 109

PostPosted: Tue 18 Jul 2006, 04:24    Post subject:  

When you're installing extra libs, watch out for libgl.so, I ran into problems with it. You can read about the solution in this thread: http://www.murga.org/~puppy/viewtopic.php?t=8812
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13647
Location: Karlsruhe, Germany

PostPosted: Tue 18 Jul 2006, 04:57    Post subject:  

http://dotpups.de/puppy-releases/Megapuppy002/Dotpups/liblcms.pup
libldap is not required for normal usage, we can search it in case you run very special software that requires it.
Concerning libGL see the message before mine.
Mark
Back to top
View user's profile Send private message Visit poster's website 
New Puppy Fan


Joined: 14 Aug 2005
Posts: 77
Location: Minnesota, USA

PostPosted: Sat 22 Jul 2006, 00:19    Post subject:  

Thanks violetdream and Mark. Now it seems wine to be running. There is no sound though. Maybe I'll try new wine 0.9.17.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [15 Posts]  
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0539s ][ Queries: 12 (0.0100s) ][ GZIP on ]