Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 30 Sep 2014, 14:36
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Racy NOP 5.2.2
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 6 [90 Posts]   Goto page: 1, 2, 3, 4, 5, 6 Next
Author Message
gray


Joined: 23 Feb 2007
Posts: 313
Location: Adelaide - South Australia

PostPosted: Mon 28 Nov 2011, 06:59    Post subject:  Racy NOP 5.2.2
Subject description: Nearly Office Pup based on Racy 5.2.2
 

Nearly Office Pup is an XFCE based puplet, so called because it is a no frills pup without office apps. The idea being that you install to USB pendrive and add an SFS file of the office package.

Racy NOP 5.2.2 is based on the recently released Puppy Racy 5.2.2 with JWM and Rox removed and replaced with XFCE4.6.2 and Thunar.

Note I tried XFCE4.8.3 but had lots of issues - especially with the new Thunar and gvfs dependency hell. Still not mature enough for any real use.

Also

Seamonkey suite replaced with Opera 11.52
Added modified Pwidgets
Removed Geany, Notecase, Homebank, Planner, Ayttm, Osmo, Inkscapelite, Games and of course Abiword & Gnumeric.

get racyNOP-5.2.2.iso (122Mb) from http://download.tuxfamily.org/nop

Also at same site is LibreOffice3.4.4.sfs and NVIDIA-290.10-k3.0.7.pet

update to revision 1 Jan 16 2012:

racyNOP-5.2.2r1 is a small update, upgrading Opera to V11.60 and adding lmsensors, and xarchive unrar and 7z capability.
Screenshot.png
 Description   
 Filesize   369.21 KB
 Viewed   9730 Time(s)

Screenshot.png


Last edited by gray on Mon 16 Jan 2012, 03:53; edited 1 time in total
Back to top
View user's profile Send private message 
Ray MK


Joined: 05 Feb 2008
Posts: 765
Location: UK

PostPosted: Mon 28 Nov 2011, 08:00    Post subject:  

Hi gray

Many thanks for this - absolutely fantastic.

Flies on my old Acer TravelMate 243LC laptop. Manual frugal to ext4 and a 800mb swap partition.
256mb ram, 2.5Ghz Celeron Proc. Wifi via pcmcia Belkin card.

Nice to see Opera and xfce/thunar - outstanding combination.

Initial setup to desktop etc, is so easy and intuitive - superb.

Greatly appreciate all you do for us with NOP.

Very best regards - Ray
Back to top
View user's profile Send private message 
kros54

Joined: 17 May 2009
Posts: 103
Location: member of Hungarian Puppy Linux Community

PostPosted: Mon 28 Nov 2011, 09:54    Post subject: Congratulations  

The NOP is one of my favorite!
Some of the packages was the compilation error. The Lupu 5.2X version of localization is very simple: package manager - system - Langpack - mouse clicks and you're done. (Of course, refinements remain, but it did so almost automatically the Rexbang the Macpup etc. puplet case. Too bad it was just a Geany out of it, but I did return. I like that the latest kernel in it.
The RAM is very low.
Congratulations, this will be the Hungarian edition.
Back to top
View user's profile Send private message Visit poster's website 
oligin10

Joined: 17 Jul 2010
Posts: 189
Location: Buckeye State, USA

PostPosted: Mon 28 Nov 2011, 10:19    Post subject: Thanks Gray  

As others have said, thank you for all you have done. Can't wait to try this out. Rob
Back to top
View user's profile Send private message 
Sage

Joined: 04 Oct 2005
Posts: 4790
Location: GB

PostPosted: Tue 29 Nov 2011, 08:08    Post subject:  

Sheer genius! Boy! are you competent, gray. All the old familiar polish. No Flash or Opera to load - you've already done it for us. Xfce already implemented - my favourite. Absolutely no excuse for neophytes, now.
Welcome back and long may you reign.
Are we lucky to benefit from all this talent?!
Back to top
View user's profile Send private message 
stifiling

Joined: 29 Dec 2007
Posts: 388

PostPosted: Tue 29 Nov 2011, 10:02    Post subject:  

this is nice. using it on my thinkpad. finally retired nop 431 for now.

would be nice to have a 64 bit nop...how bout slapping one of those together for us??...
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 2114
Location: Ontario Canada

PostPosted: Tue 29 Nov 2011, 10:24    Post subject: Racy NOP 5.2.2  

I did a manual frugal install to a gateway desktop pc.
I added xineplus-racy-i686.sfs,vlc-1.1.12-racy-i686.sfs,
and seamonkey-2.5-racy-i686.pet.
Everything is working well.
Thanks.
Screenshot-1.jpg
 Description   
 Filesize   165.85 KB
 Viewed   8328 Time(s)

Screenshot-1.jpg

Back to top
View user's profile Send private message 
Tuxified

Joined: 21 Sep 2011
Posts: 9

PostPosted: Wed 30 Nov 2011, 03:19    Post subject:  Racy NOP 5.2.2  

Downloading now, Thanks Gray!
Back to top
View user's profile Send private message 
arj_pup

Joined: 04 Nov 2011
Posts: 16
Location: india

PostPosted: Wed 30 Nov 2011, 13:13    Post subject: Re: Racy NOP 5.2.2
Subject description: Nearly Office Pup based on Racy 5.2.2
 

gray: can u help be on replacing rox with thunar in lucid puppy with xfce compiled form source
Back to top
View user's profile Send private message 
Max Headroom


Joined: 28 Jun 2006
Posts: 187
Location: GodZone Kiwi

PostPosted: Sat 03 Dec 2011, 16:17    Post subject: Please can AnyBody Help w/ Getting Compiz Working w this Tha
Subject description: I've got the NVidia Driver installed & libwnck & compiz-0.8.4 Packages installed...
 

& I've Done a Dependency Check on these Packages. No Problems there. Also the NVidia Splash Screen Displays

Here is the Output from Terminal
# compiz
compiz (core) - Error: Screen 0 on display ":0.0" already has a window manager; try using the --replace option to replace the current window manager.
compiz (core) - Fatal: No manageable screens found on display :0.0

Or Might Newer Updated Packages be Required 4 the New 3.07 Ke*nel?

Thanx in Advance!

SmileK

Last edited by Max Headroom on Sun 04 Dec 2011, 02:19; edited 2 times in total
Back to top
View user's profile Send private message Yahoo Messenger 
Max Headroom


Joined: 28 Jun 2006
Posts: 187
Location: GodZone Kiwi

PostPosted: Sat 03 Dec 2011, 17:22    Post subject: G'day Gray, Welcome back from Another Galaxy :)
Subject description: Any Chance of a New V'Box SFS Package & / or Pet 4 the New 3.0.7 Ke*nel, Thanx...?
 

Stop Press, I Found an All Ke*nel Versions Pet Package, But it Won't Run...

Here is the Terminal Output
# VirtualBox
WARNING: The vboxdrv kernel module is not loaded. Either there is no module
available for the current kernel (3.0.7) or it failed to
load. Please recompile the kernel module and install it by

sudo /etc/init.d/vboxdrv setup

You will not be able to start VMs until this problem is fixed.
VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/opt/VirtualBox/VirtualBox.so",) failed: libSDL-1.2.so.0: cannot open shared object file: No such file or directory
# ^C
# sudo /etc/init.d/vboxdrv setup
Stopping VirtualBox kernel modules ...done.
Uninstalling old VirtualBox DKMS kernel modules ...done.
Trying to register the VirtualBox kernel modules using DKMS ...failed!
(Failed, trying without DKMS)
Recompiling VirtualBox kernel modules ...failed!
(Look at /var/log/vbox-install.log to find out what went wrong)

And the Log Message Contents in Question
/opt/VirtualBox/src/vboxhost/vboxdrv/build_in_tmp: line 55: make: command not found

Any Help Will be Greatly Appreciated...

SmileK
Back to top
View user's profile Send private message Yahoo Messenger 
Geoffrey


Joined: 30 May 2010
Posts: 1396
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Wed 07 Dec 2011, 00:48    Post subject:  

I noticed that restartx doesn't work, /usr/bin/restartwm kills the panel where in Quirky it kills the session, the scripts are identical accept for one difference
Code:
if [ "`pidof xfce4-panel`" != "" ];then
 #killall xfce4-panel
 kill `pidof xfce4-panel`

and this is the quirky one
Code:
if [ "`pidof xfce4-session`" != "" ];then
 #killall xfce4-panel
 kill `pidof xfce4-session`

Just edit restartwm with the Quirky code and it will work, with this now working it is possible to add a entry to the menu to restart the window manager, /etc/xdg/menus/xfce-applications.menu needs to be edited add this line
Code:
 
      <Filename>restartwm.desktop</Filename>
   

so that the menu script looks like this, you will find it listed at line 29
Code:
 <Separator/>
      <Filename>xfce4-help.desktop</Filename>
      <Filename>logout.desktop</Filename>
      <Filename>restartwm.desktop</Filename>
    </Layout>

Next a desktop menu file needs to be created in /usr/share/applications, open that directory and create a new file and name it restartwm.desktop and paste this code and save it.
Code:
[Desktop Entry]
Version=1.0
Type=Application
Encoding=UTF-8
Exec=restartwm
Icon=restartwm.png
StartupNotify=false
Terminal=false
Categories=X-XFCE;X-Xfce-Toplevel;
OnlyShowIn=XFCE;
Name=RestartWM
Comment=Restart Xfce Desktop

Now a icon is needed for the menu, I couldn't find one in the icon theme, so I made one, it needs to be placed in /usr/share/icons, just right-click and save the image below.
let me know if it don't work, though it should

Geoffrey
restartwm.png
 Description   
 Filesize   5.1 KB
 Viewed   7531 Time(s)

restartwm.png

Back to top
View user's profile Send private message 
TheBlackSheep


Joined: 23 Nov 2008
Posts: 20
Location: Lancashire, UK

PostPosted: Wed 07 Dec 2011, 08:22    Post subject:  

Having always been a fan of gray and the NOP releases I now find myself disappointed Crying or Very sad - not a criticism of the release but the fact that I can't run this version on my laptop - as it is based on Racy it requires a processor with pae support but that means the centrino family (or at least the one this Dell Latitude 600 uses) is a no-go.

Is there a way of recompiling the kernel to not require pae and still using the rest of the system? Is this easy to do? ... and then I just replace the initrd.gz/vmlinuz with the non-pae version and keep the puppy_racy.5.2.2.sfs as it is?

TheBlackSheep
Back to top
View user's profile Send private message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2376
Location: UK

PostPosted: Wed 07 Dec 2011, 13:00    Post subject:  

TheBlackSheep wrote:
Having always been a fan of gray and the NOP releases I now find myself disappointed Crying or Very sad - not a criticism of the release but the fact that I can't run this version on my laptop - as it is based on Racy it requires a processor with pae support but that means the centrino family (or at least the one this Dell Latitude 600 uses) is a no-go.

Is there a way of recompiling the kernel to not require pae and still using the rest of the system? Is this easy to do? ... and then I just replace the initrd.gz/vmlinuz with the non-pae version and keep the puppy_racy.5.2.2.sfs as it is?

TheBlackSheep

How to 'switch' kernels:
http://www.murga-linux.com/puppy/viewtopic.php?t=60180

Follow the guide in the link above and you can replace the kernle you're using with one from another Puppy ISO... Very Happy

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send private message 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Wed 07 Dec 2011, 13:37    Post subject:  

TheBlackSheep wrote:
Having always been a fan of gray and the NOP releases I now find myself disappointed Crying or Very sad - not a criticism of the release but the fact that I can't run this version on my laptop - as it is based on Racy it requires a processor with pae support but that means the centrino family (or at least the one this Dell Latitude 600 uses) is a no-go.

Is there a way of recompiling the kernel to not require pae and still using the rest of the system? Is this easy to do? ... and then I just replace the initrd.gz/vmlinuz with the non-pae version and keep the puppy_racy.5.2.2.sfs as it is?

TheBlackSheep


Like your D600, my 700M also uses a Pentium M cpu.
These have a 400MHz FSB which doesn't work with PAE.
Think I'll try that kernel switch on Racy and Saluki when I
get some time.
Good luck.

_________________

Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 6 [90 Posts]   Goto page: 1, 2, 3, 4, 5, 6 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1148s ][ Queries: 13 (0.0209s) ][ GZIP on ]