Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 19:27
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Slacko Puppy 5.3.1
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 15 of 37 Posts_count   Goto page: Previous 1, 2, 3, ..., 13, 14, 15, 16, 17, ..., 35, 36, 37 Next
Author Message
01micko


Joined: 11 Oct 2008
Posts: 7835
Location: qld

PostPosted: Sun 13 Nov 2011, 18:31    Post_subject: Re: Xsane issue Threshold not available.  

Béèm wrote:
01micko wrote:
Béèm wrote:
Xsane issue Threshold not available.
Having been done some testing for Peasyscan, I discovered an issue in Xsane lineart (binary) mode.

When selecting the scan mode panel, I don't have the threshold bar.
My device is epson2

I have it in Icepuppy 012 and when discussing with rsrcn51 he advised to use the libsane-epson2.so.xxx library files in /usr/lib/sane from Ice to slacko 5.3

I did so and I could use the threshold bar.

Code:
# ls -l libsane-epson2*
lrwxrwxrwx 1 root root     24 2011-11-10 08:17 libsane-epson2.so -> libsane-epson2.so.1.0.20
lrwxrwxrwx 1 root root     24 2011-11-10 08:17 libsane-epson2.so.1 -> libsane-epson2.so.1.0.20
-rw-r--r-- 1 root root 162780 2011-05-26 17:18 libsane-epson2.so.1.0.20
-rwxr-xr-x 1 root root 160800 2011-10-24 13:39 libsane-epson2.so.1.0.21org
lrwxrwxrwx 1 root root     24 2011-10-24 13:32 libsane-epson2.so.1org -> libsane-epson2.so.1.0.21
#
The library files ending in xxxxorg are the slacko 5.3 ones.
The others (which work) the ICE puppy 012 ones

I thought I just mention this for those who are using a epson2 backend.
Béèm

To save me downloading ice puppy can you do me the favour of tarballing the libsane-epson2.so.1.0.20 file please? I can pet it up as a z_sane_hack and it will overwrite the slacko libs in woof.

TIA.
Micko,
I have been away a lot the WE.
I added a fake .gz extension to the file, just remove it after the download.


Thank you Smile

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
Gyle

Joined: 23 Dec 2007
Posts: 97
Location: Fr

PostPosted: Mon 14 Nov 2011, 07:40    Post_subject:  

Hi, Slacko is great on DVD!
- Slacko on DVD-RW Multisession
- 2 Go slackosave.2fs file written on the DVD
- nvidia-285.05.09-k2.6.37.6-s.pet (from slickpet) managing two screens configured the TwinView way,
the laptop screen (native 1024 x 768) running 1280 x 800 mode, and LCD screen 1920 x 1080 via VGA.
- SFS-Load on-the-fly, all at once:
---devx_slacko_5.3.sfs
--- OpenOfc-3.3.0_en-US_sfs4.sfs,
--- lazarus-0.9.28.2-complete.sfs
OpenOffice and Lazarus run very fast and smoothly in ram (4 Go)
Very amazed to see lazarus compiling at first run with just a little config error message.
- Persistence of the integrity of the desktop after multiple reboots
- Persistence of the integrity of the desktop after multiple SFS files loaded
- BootFlash Puppy to USB and savesession-dvd scripts have run in a breeze
- wine-1.3.28-i486_v2.pet (from slickpet) is rock solid for my old and very trusted messagerie PocoMail, fax via PDF, Moffsoft FreeCalc a pretty calculator, and NoteTab Pro a programmable editor,
- Opera 11.52, FireFox 8.0 with FireBugs and Developper add-ons
HD just mounted and unmounted when needed for archiving.
So many thanks to 01micko and the staff,
to BK who "ads" Slacko in his blog,
and to Flash who argumented many times in the forum about running Puppy on DVD.

#report-video-glx
lun. 14 nov. 2011 Operating System: Slacko Puppy-5.3 Linux 2.6.37.6
0.0 VGA compatible controller: nVidia Corporation G96 [GeForce 9650M GT] (rev a1)
oem: NVIDIA product: G96 Board - 0566648a Chip Rev

X Server: Xorg Driver: vesa
X.Org version: 1.9.5
dimensions: 3200x1080 pixels (856x292 millimeters)
depth of root window: 24 planes


Intel(R) Core(TM)2 Duo CPU T5850
Core 0: 2167 1: 1000 MHz

...the above also recorded at '/tmp/root/report-video-glx'.

Edited_times_total
Back to top
View user's profile Send_private_message 
scruffy

Joined: 09 Apr 2010
Posts: 42
Location: UK

PostPosted: Mon 14 Nov 2011, 14:58    Post_subject: Opera 11.52 fullscreen
Sub_title: F11 does not exit fullscreen
 

Slacko 5.3 fresh frugal install.

Looks very impressive so far.....1 point to note.

Opera 11.52 full screen does not toggle correctly with F11. F11 gives fullscreen but there is no way to leave fullscreen.

This only occurs in JWM , with Openbox and Icewm it works perfectly.



scruffy

_________________
AMD Athlon 1100MHz 512MB -Soundcard C-media CMI8738 -Graphics Nvidia geforce 4 MX440 - Netgear wired DSL
Back to top
View user's profile Send_private_message 
valer

Joined: 07 Nov 2011
Posts: 7
Location: Southern Finland

PostPosted: Mon 14 Nov 2011, 17:09    Post_subject:  

@Scruffy: The same thing happened to me once in Chromium. JWM is overall unimpressive and I'd like to see something better as the default, although I've heard that it has gotten much more bug-free than it used to be a while ago.

@Developers and tony: See this thread for an aufs-related bug report.
Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7835
Location: qld

PostPosted: Mon 14 Nov 2011, 17:32    Post_subject:  

valer wrote:
@Scruffy: The same thing happened to me once in Chromium. JWM is overall unimpressive and I'd like to see something better as the default, although I've heard that it has gotten much more bug-free than it used to be a while ago.

@Developers and tony: See this thread for an aufs-related bug report.


For the next release I am sticking with JWM. Joe Wing has updated a lot recently and in the next testing verion I will release with the latest to see if those bugs are fixed.

Is this aufs bug apparent in Slacko? We use a later aufs than Lucid. To check your filesystem on pupmode=7 (using the whole stick) you would have to boot to another install somehow (either another stick or live cd) OR... if you add "pfix=fsck" to the kernel line in the sysconfig file at the root of the drive (or extlinux if you use ext2,3,4) you should be able to at least check the save filesytem every boot. (or add pfix=ram and check manually whenever you want). Note though, you wont be able to check the integrity of the drive itself using either of those methods.

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
valer

Joined: 07 Nov 2011
Posts: 7
Location: Southern Finland

PostPosted: Mon 14 Nov 2011, 18:13    Post_subject:  

01micko wrote:
Is this aufs bug apparent in Slacko? We use a later aufs than Lucid. To check your filesystem on pupmode=7 (using the whole stick) you would have to boot to another install somehow (either another stick or live cd) OR... if you add "pfix=fsck" to the kernel line in the sysconfig file at the root of the drive (or extlinux if you use ext2,3,4) you should be able to at least check the save filesytem every boot. (or add pfix=ram and check manually whenever you want). Note though, you wont be able to check the integrity of the drive itself using either of those methods.


Yes, I think I forgot to stress that I'm using Slacko 5.3. I don't know how often the corruption happens "spontaneously", i.e. not after a crash, and in which versions. Thanks for the pointers, I'll try it if I get in the situation again. By the way, I tried a google search with the error message that appears in /var/log/messages and every help request hit was about Puppy.
Back to top
View user's profile Send_private_message 
Billtoo


Joined: 07 Apr 2009
Posts: 2128
Location: Ontario Canada

PostPosted: Wed 16 Nov 2011, 16:00    Post_subject: Slacko Puppy 5.3
Sub_title: Aurora
 

I made a firefox 8.0 pet (Aurora) in spup and it's working well.
The download link is:

http://www.datafilehost.com/download-24fe0abb.html
aurora.jpg
 Description   
 Filesize   111.48 KB
 Viewed   3773 Time(s)

aurora.jpg

Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7835
Location: qld

PostPosted: Wed 16 Nov 2011, 23:48    Post_subject:  

This is to announce a testing bugfix release only available in delta form (see link if you don't know what is or how to use delta files)

You will have to download either the slacko-MAIN or HIGHMEM-ALT iso if you don't already have it to use the delta files.

This is testing in anticipation of 5.3.1 (and perhaps for the PAE version I will name 5.3.1.1, that way you can have both without conflicts, however the later version num implies a later version, maybe not Confused Question) .. so... this is not an official release.. more or less an RC.

There are some major changes for a bugfix release. I really was in a dilemma as to whether to go with latest woof or the original 5.3 woof with bugfixes backported.. I took the easy route, at a bigger risk.

Download folder ...(includes deltas for MAIN and ALT, plus checksums)

Changes:
Quote:
update pmusic -zigbert
update psync -tasmod
bugfix touchpads -xorg -woof
bugfix light and heavy encryption -woof
new firstrun "quicksetup" -woof
(shinobars first-run is more elegant/mature however the new quicksetup is
firmly entrenched in woof, bugfixes are applied -shinobar -hostname-set)
bugfix too many deps showing in PPM -me -woof
boot to desktop -woof
(this is because Barry has improved this, works on 6
out of 7 on my machines, 7th was easy to fix with xorgwizard)
improvements in flash download in /usr/sbin/delayedrun
bugfix -getflash -me, Barry
added firmware -woof
(accounts for bigger size iso)
expanded firmware -woof
bugfix complete removal of video-upgrade-wizard.desktop -me
shutdown improvements -woof
(please report if you still have usb shutdown issues, or ext4)
roll back bootmanager
bold rox pinboard labels -option in woof
bugfix sane epsom libs -Béèm

latest woof November 10


There are NO devx files posted. As NO binaries were altered the old 5.3 devx will be fine if you rename it to 5.3.0.1 or 5.3.0.2 depending on which you get, MAIN or ALT.

Have fun Smile

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
jim3630


Joined: 13 Feb 2011
Posts: 792
Location: Northern Nevada

PostPosted: Thu 17 Nov 2011, 02:25    Post_subject:  

Delta patch for PAE 5.3.0.2 2.6.39.4 kernel applied. This now makes slacko the 3rd puppy to boot to correct screen
1600x900 on laptop and 1920x1080 on external monitor when have HDMI connected. Racy and 528 both do same.

frugal install to hdd ext4 pfix=ram. touchpad remains off after reboot as did prior. that is not my issue so it still does as before.
broadcom 4313 driver auto-deteced on wlan0.

Micko thanks!
hardinfo report has phony gz.

---------
installed mesa from slickpet. gears shows smooth seady movement ~60fps all way up to 1920x1080 on large external monitor.
hardinfo_report.html.gz
Description 
gz

 Download 
Filename  hardinfo_report.html.gz 
Filesize  44.12 KB 
Downloaded  263 Time(s) 

Edited_time_total
Back to top
View user's profile Send_private_message 
jim3630


Joined: 13 Feb 2011
Posts: 792
Location: Northern Nevada

PostPosted: Thu 17 Nov 2011, 02:35    Post_subject:  

found a project management software program that is light weight and works in 5.3.02 during my brief testing.
http://murga-linux.com/puppy/viewtopic.php?t=73371
planner-0.14.5-hacked.pet
Description 
pet

 Download 
Filename  planner-0.14.5-hacked.pet 
Filesize  423.84 KB 
Downloaded  269 Time(s) 
Back to top
View user's profile Send_private_message 
Billtoo


Joined: 07 Apr 2009
Posts: 2128
Location: Ontario Canada

PostPosted: Thu 17 Nov 2011, 08:47    Post_subject: Slacko Puppy 5.3
Sub_title: 5.3.0.2
 

I made the new 5.3.0.2 iso and did a manual frugal install with it.
I copied my 5.3 save file into the directory and it was updated on
first bootup.
I ran bootmanager and had it remove the 5.3 devx and added the renamed 5.3.0.2
devx and rebooted.

Thu 17 Nov 2011 Operating System: Slacko Puppy-5.3.0.2 Linux 2.6.39.4
5.0 VGA compatible controller: ATI Technologies Inc RS690M [Radeon X1200 Series]
oem: ATI ATOMBIOS product: RS690 01.00

X Server: Xorg Driver: radeon
X.Org version: 1.9.5
dimensions: 1280x800 pixels (338x211 millimeters)
depth of root window: 24 planes

direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
OpenGL vendor string: Mesa Project
OpenGL renderer string: Software Rasterizer
OpenGL version string: 2.1 Mesa 7.10.2

AMD Athlon(tm) Processor 2650e
Core 0: 1596 MHz

My desksetup template settings were lost when the save file was
updated I guess but I reran it and the settings were correct on the
next bootup.
Back to top
View user's profile Send_private_message 
8-bit


Joined: 03 Apr 2007
Posts: 3382
Location: Oregon

PostPosted: Thu 17 Nov 2011, 12:09    Post_subject:  

01micko,
Thank you for making delta files for this update!
It saves a lot of download time and bandwidth for those with a slower internet connection as well as updating their previously downloaded ISO files.

Just as a matter of opinion, I think all updates to Puppy versions should be offered as delta files as an update offered as a pet file or a tar.gz file tends to be lost down the line and makes it hard to remember what updates one has to reinstall when installing on another computer.

There was one other update Barry had made that was to /usr/sbin/filemnt that allowed one to mount and encrypted save file directly.
Was that perchance included?
Back to top
View user's profile Send_private_message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Thu 17 Nov 2011, 14:22    Post_subject:  

When I use Slacko 5.3 on Asus EeePC 900 then the CPU temperature
goes up the whole time.

I will make similar test using Snow Pup Lupu 513 and Puppeee 44

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send_private_message 
8-bit


Joined: 03 Apr 2007
Posts: 3382
Location: Oregon

PostPosted: Thu 17 Nov 2011, 15:18    Post_subject:  

Have you installed the menu-system-CPU frequency scaling on it?
I have no experience with that PC and am curious if it is supported.
I now that I have an older Toshiba Satellite that gives me a message of the CPU frequency being fixed.
In other words, the CPU frequency cannot be changed with the scaling tool.
Back to top
View user's profile Send_private_message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Thu 17 Nov 2011, 15:56    Post_subject:  

Good comment there 8-bit now that you remind me
was it pemasu or somebody telling one should write
something in terminal to activate it. What command
was it one should write then and should one restart
xwin and xorg after that change then maybe?
But how does that scaling works then. Is it automatically
sensing and readjusting itself or should learn about scaling
and test different values something?
My computer Asus 900 has a Celeron CPU as I get it.

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 15 of 37 Posts_count   Goto page: Previous 1, 2, 3, ..., 13, 14, 15, 16, 17, ..., 35, 36, 37 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1072s ][ Queries: 13 (0.0107s) ][ GZIP on ]