Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 19:06
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
upgrade older puppies to glibc 2.11 easy as pie
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Author Message
sickgut


Joined: 23 Mar 2010
Posts: 1157
Location: Tasmania, Australia in the mountains.

PostPosted: Tue 27 Jul 2010, 10:33    Post_subject:  upgrade older puppies to glibc 2.11 easy as pie
Sub_title: needed for new software compatibility
 

Hi,

I love my puppy 4.2 installation but I found that some more modern software I like required a newer glibc version.

Nexuiz, alien arena and Xaos are my favourite programs that fit this catagory. I have broken my puppy more than a few times attempting to upgrade my glibc but I have tried the following solution a few times now with great success. Note I have tried this with Puppy 4.2 and Puppeee RC7 (based on 431) and it worked flawlessly.

Only need 2 files. One is dpkg .pet (most of you probably already have this) and the libc6 2.11.deb ubuntu package. You can get them here:
http://distro.ibiblio.org/puppylinux/pet_packages-4/dpkg-deb-1.14.20.pet
http://64.12.96.232/pool/main/e/eglibc/libc6_2.11.1-0ubuntu7.1_i386.deb
[Links updated by Flash 9-28-11]
Simply install the dpkg pet by clicking on it, then in the directory you have download the libc6 .deb file, open a terminal and type the following:
Code:

dpkg-deb -x libc6_2.11.1-0ubuntu7.1_i386 /

Now you should have a sweetly updated older puppy that works with newer apps.

I have been using Lupu Puppy 5 for a while now simply because older puppies didn't have the glibc version i needed to run my programs, now with this solution i can use my 4.2 for everything, yay!

sickgut
Back to top
View user's profile Send_private_message Visit_website 
Fractal

Joined: 08 Dec 2010
Posts: 8

PostPosted: Wed 25 May 2011, 08:55    Post_subject:  

Thank you for this useful post - it dug me out of a programming hole!
Shocked
Back to top
View user's profile Send_private_message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2385
Location: UK

PostPosted: Wed 25 May 2011, 13:14    Post_subject:  

Gonna try.. this might be my lazy shortcut to get a few things done (in a much simpler way) before I get too busy or go off the idea! cheers Very Happy

i was gonna do a longer way... i used another package to do something similar, which apparently breaks locales or something... Does this way have any issues you know of?

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send_private_message 
nancy reagan

Joined: 22 Jan 2009
Posts: 513

PostPosted: Wed 25 May 2011, 15:04    Post_subject: Re: upgrade older puppies to glibc 2.11 easy as pie
Sub_title: links don't work
 

Hi sickgut


Links don't work

Nancy
Back to top
View user's profile Send_private_message 
muggins

Joined: 20 Jan 2006
Posts: 6689
Location: lisbon

PostPosted: Wed 25 May 2011, 19:02    Post_subject:  

Nancy,

sickgut no longer hosts any puppy stuff. For dpkg-deb-1.14.20.pet, it's in the pup4 ibiblio repository here.

For libc, you can use ubuntu repository:

http://mirror.anl.gov/pub/ubuntu//pool/main/e/eglibc/libc6_2.11.1-0ubuntu7.8_i386.deb

Edited_time_total
Back to top
View user's profile Send_private_message 
nancy reagan

Joined: 22 Jan 2009
Posts: 513

PostPosted: Thu 26 May 2011, 14:32    Post_subject: Thanks  

muggins wrote:
Nancy,

sickgut no longer hosts any puppy stuff. For dpkg-deb-1.14.20.pet, it's in the pup4 ibiblio repository here.

For libc, you can use ubuntu repository:

http://ubuntu.secsup.org//pool/main/e/eglibc/libc6_2.11.1-0ubuntu7.8_i386.deb


Thanks muggins

Howwever link does not work
Back to top
View user's profile Send_private_message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2385
Location: UK

PostPosted: Fri 03 Jun 2011, 07:53    Post_subject:  

sickgut

After upgrading gblic, on puppy 4, to any other more recent version, I always come across the same error message, with GTK... I would like to know if you get the same, or if you have fixed it..

I created a thread to try solve the problem here: http://www.murga-linux.com/puppy/viewtopic.php?p=530253

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send_private_message 
muggins

Joined: 20 Jan 2006
Posts: 6689
Location: lisbon

PostPosted: Fri 03 Jun 2011, 18:02    Post_subject:  

Nancy,

try the changed link above.
Back to top
View user's profile Send_private_message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Fri 03 Jun 2011, 18:09    Post_subject:  

Would it work for puppy 412 too? Or on such puppies like pupngo?
_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send_private_message 
Dewbie

Joined: 15 Apr 2010
Posts: 1783

PostPosted: Wed 28 Sep 2011, 03:26    Post_subject:  

Before downloading Ubuntu .deb that Flash updated above, go to this thread and read second post for new information from sickgut: http://murga-linux.com/puppy/viewtopic.php?t=66373

If you prefer using sickgut's commandline .deb installation method, note that dpkg-deb-1.14.20.pet is strictly for 4.2.x Puppies.

For 4.1.x, use this one:
http://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-4/dpkg-deb-1.10.18.pet

Neither dpkg-deb .pet is needed for 4.3.x; it installs Debian packages as-is.

Easier .deb installation method is outlined in next post.

Edited_times_total
Back to top
View user's profile Send_private_message 
Dewbie

Joined: 15 Apr 2010
Posts: 1783

PostPosted: Thu 29 Sep 2011, 06:57    Post_subject:  

EASIER WAY:
(for 4.1.x and 4.2.x)
Convert .deb to .pet using this method:
http://murga-linux.com/puppy/viewtopic.php?search_id=1923251336&t=39756
Back to top
View user's profile Send_private_message 
sickgut


Joined: 23 Mar 2010
Posts: 1157
Location: Tasmania, Australia in the mountains.

PostPosted: Mon 03 Oct 2011, 03:43    Post_subject:  

hello people

i started this thread quite a while ago and i thank flash for updating the links etc and i apologize for the fact i have posted stuff every where with links to my site and they are no longer valid.

this is because of an accident on the server on my part, i accidently chmod'ed the whole OS rather than just a folder and before i realised there was an easy way around it i had already logged out and it wouldnt let me back in, and it didnt restart with the changed permissions and so i had to reztore from backup and because i only use budget providers, i didnt have a backup.

when this happend i was already committed to my current pussy linux project and needed to continue with it and havent had the time to find all the files i had hosted for puppy stuff and remake my repo again and there where also packages i had made myself like the apt-get stuff and the 4000 lines of code i put in there for one of the config files but i didnt have a backup, the only one i had was on the site. ive created this situation myself by not keeping backups so there is no one to blame but me.

in the future i am looking at starting a repo again but not only puppy specific. there are alot of usefull packages that arnt in the ubuntu or debian repos and i will be making small .sfs files of these and offering 2 versions, one with all known dependencies and one with just the program itself. The version that includes all the known deps will work on puppy and probably most other minidistros.
Back to top
View user's profile Send_private_message Visit_website 
Colonel Panic


Joined: 16 Sep 2006
Posts: 1522

PostPosted: Mon 03 Oct 2011, 15:29    Post_subject:  

Thanks for this idea, it looks very promising. The main problem I have with keeping the 4.2 series running is that the older Firefoxes (i.e. pre-4.0) won't be allowed onto some of the newer and more security-conscious websites and you can't run the latest Seamonkeys on them either. So any fixes that solve this problem are well worth knowing about.

Thanks again!

CP .

_________________
Stone Pentium IV (2.4 GHz), 2 GB of RAM, 160 GB hard drive running PuppEX 14.1, New Year's Pup 02, Puppy 4.31 Workhorse, Puppy X-Precise 2.4, Puppy Carolina 1.2, Puppy Legacy OS2 LTS, Puppy Diamond 528_512 (full) and Puppy Upup Raring 3.9.9.2.
Back to top
View user's profile Send_private_message 
Dewbie

Joined: 15 Apr 2010
Posts: 1783

PostPosted: Tue 04 Oct 2011, 04:31    Post_subject:  

CP, try this:
http://www.murga-linux.com/puppy/viewtopic.php?t=71099
You'll need a user-agent I.D. from 4.0+ Firefox.

Or try ttuuxxx's Opera-11.51
I'm running it right now with Puppy Linux 4.1.2., no problem.
Back to top
View user's profile Send_private_message 
drblock2

Joined: 19 Jan 2009
Posts: 141

PostPosted: Fri 10 May 2013, 14:27    Post_subject: The gift that keeps giving  

Sickgut,

Many thanks. I used your solution to install djview3 in Wary 5.3.90!
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0935s ][ Queries: 12 (0.0193s) ][ GZIP on ]