Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 23:06
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Dpup Exprimo 5.X.15
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 69 of 148 Posts_count   Goto page: Previous 1, 2, 3, ..., 67, 68, 69, 70, 71, ..., 146, 147, 148 Next
Author Message
MoebusNet

Joined: 04 Jun 2011
Posts: 89

PostPosted: Mon 26 Sep 2011, 16:21    Post_subject:  

pemasu wrote:
Nope. My advice was meant for troublesome cf card readers. For SD ene card reader I have keucr module surely compiled. If your SD card reader is not recognized, I dont know straight what to do. Have you checked from the net, what kernel driver module is needed, is it keucr or something else.


Thank you. I just rechecked 5.X.7 uniprocessor and it's not recognizing the ENE card reader. For Lucid 5.25 & 5.28 I used keucr_2.6.33.2-lupu525.pet compiled by Dawnboy (I believe) and it works in 5.25 & 5.28.

If you're going to move on to a new kernel with this as just a development version it may not be worthwhile to worry about the ENE card reader until a release version. I was under the impression that the newer kernels were compiled to enable it (at least in Ubuntu) without doing anything special, but I've been known to be wrong (frequently). Thanks again for your work.

P.S. I've read with envy about your bicycling around the Finland lakes. I did something for the first time today you may not have experienced: I went to a buffalo (American bison) roundup in the Black Hills of South Dakota. Just like the Westerns on TV. Enjoy life!

_________________
Acer Aspire One D255-2301 (N450 Atom @ 1.6 Ghz, 1 Gb RAM, 160 Gb HDD w/WinXP, ENE SD card reader, Alps touchpad) 5.28/5.3.1 via manual-frugal ext4 USB flash drive (4Gb) using GRUB4DOS
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 26 Sep 2011, 16:43    Post_subject:  

MoebusNet. Yes, I know about keucr module and compiling it. I was the first to compile it for Puppies. I did it for Snow Puppy and 2.6.35.7 kernel, asked by myke, if I remember right. Latest Snow Puppy-020 has it preinstalled.
I gave some directions in that dawnsboy thread also. Thats why I am so amazed that your ene card reader is not recognized. I have enabled keucr module long time in my kernels.
When you boot to the X. As first thing, could you post the result of dmesg.
In console dmesg > dmesg.txt. Rename it as dmesg.gz and upload it here.
I would like to see what happens when your modules are loaded during boot time.

Yeah. Last summer was wonderful. I rollerskated, cycled and spent time in the lakes with my kids. I took a lot great pics from the countryside around the lakes. I was really happy in our summer house. There are great cycling routes around several lakes and rivers.
But your adventure is something I cant encounter in Finland. Very Happy
Back to top
View user's profile Send_private_message 
MoebusNet

Joined: 04 Jun 2011
Posts: 89

PostPosted: Tue 27 Sep 2011, 10:04    Post_subject:  

As requested.

BTW, local news crew got video of Buffalo roundup. Better than my pics (they were closer):

http://www.keloland.com/NewsDetail6162.cfm?Id=0,121344

They'll probably keep video up a couple of days.
dmesg.gz
Description  first time doing with console; hope I got it right.
gz

 Download 
Filename  dmesg.gz 
Filesize  44.82 KB 
Downloaded  128 Time(s) 

_________________
Acer Aspire One D255-2301 (N450 Atom @ 1.6 Ghz, 1 Gb RAM, 160 Gb HDD w/WinXP, ENE SD card reader, Alps touchpad) 5.28/5.3.1 via manual-frugal ext4 USB flash drive (4Gb) using GRUB4DOS
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Tue 27 Sep 2011, 10:55    Post_subject:  

MoebusNet. You dont have any ene card reader even detected.

In my dmesg:
Code:
[   30.798681] keucr: module is from the staging directory, the quality is unknown, you have been warned.
[   30.802159] usb --- usb_stor_init start
[   30.802182] usbcore: registered new interface driver eucr
[   30.802184] ENE USB Mass Storage support registered
.

Somehow your ene card is not detected. I wonder what happens if you load keucr manually in console: modprobe keucr
Would it lead to the appropriate keucr loading and is your ene card reader detected after that. Probably not.
Back to top
View user's profile Send_private_message 
MoebusNet

Joined: 04 Jun 2011
Posts: 89

PostPosted: Tue 27 Sep 2011, 17:27    Post_subject:  

pemasu wrote:
MoebusNet. You dont have any ene card reader even detected.

In my dmesg:
Code:
[   30.798681] keucr: module is from the staging directory, the quality is unknown, you have been warned.
[   30.802159] usb --- usb_stor_init start
[   30.802182] usbcore: registered new interface driver eucr
[   30.802184] ENE USB Mass Storage support registered
.

Somehow your ene card is not detected. I wonder what happens if you load keucr manually in console: modprobe keucr
Would it lead to the appropriate keucr loading and is your ene card reader detected after that. Probably not.


You're quite right; not detected after "modprobe keucr".

_________________
Acer Aspire One D255-2301 (N450 Atom @ 1.6 Ghz, 1 Gb RAM, 160 Gb HDD w/WinXP, ENE SD card reader, Alps touchpad) 5.28/5.3.1 via manual-frugal ext4 USB flash drive (4Gb) using GRUB4DOS
Back to top
View user's profile Send_private_message 
stu90


Joined: 25 Feb 2010
Posts: 1401
Location: England. Dell Inspiron 1501. Dpup

PostPosted: Fri 30 Sep 2011, 11:08    Post_subject:  

Here is a little application for testing that creates a mount point for phones when connected via bluetooth.

Follow the guide here:
http://www.murga-linux.com/puppy/viewtopic.php?p=566411#566411

After setup with the phone still in a visible state run autoblue to create mount points.



Dependencies:
Bluetooth.pet - download here:
http://www.smokey01.com/stu90/dpup.squeeze.pets/bluetooth-0.4.pet
autoblue-0.2.pet
Description  For setting up phone / bluetooth mount point
pet

 Download 
Filename  autoblue-0.2.pet 
Filesize  1.9 KB 
Downloaded  372 Time(s) 
Back to top
View user's profile Send_private_message 
MoebusNet

Joined: 04 Jun 2011
Posts: 89

PostPosted: Sat 01 Oct 2011, 12:20    Post_subject:  

@Pemasu: I was wrong, completely wrong (beats head on floor): Not being used to urxvt, I didn't realize I wasn't seeing the bottom 6 lines of dmesg.txt after "modprobe keucr" in console:

[ 2510.460637] keucr: module is from the staging directory, the quality is unknown, you have been warned.
[ 2510.466231] usb --- usb_stor_init start
[ 2510.466302] usbcore: registered new interface driver eucr
[ 2510.466323] ENE USB Mass Storage support registered.

It appears that keucr loads, but I still can't mount my SD card. Is this progress?

_________________
Acer Aspire One D255-2301 (N450 Atom @ 1.6 Ghz, 1 Gb RAM, 160 Gb HDD w/WinXP, ENE SD card reader, Alps touchpad) 5.28/5.3.1 via manual-frugal ext4 USB flash drive (4Gb) using GRUB4DOS
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 01 Oct 2011, 13:13    Post_subject:  

MoebusNet. Yes, it is progress. Your card is detected and keucr has been loaded and the loading of the module has been successful. Now it remains unknown, why the mounting does not work. Do you have different SD cards to the test if they make the difference.
Back to top
View user's profile Send_private_message 
MoebusNet

Joined: 04 Jun 2011
Posts: 89

PostPosted: Sat 01 Oct 2011, 14:36    Post_subject:  

pemasu wrote:
When you boot to the X. As first thing, could you post the result of dmesg.
In console dmesg > dmesg.txt. Rename it as dmesg.gz and upload it here.
I would like to see what happens when your modules are loaded during boot time.


The dmesg I originally sent was booting without an SD card in the reader. As an experiment, I copied the dmesg booting without the SD in the reader, then copied the dmesg after inserting the SD card. Looks like keucr is self-starting, recognizes the ENE card reader but not recognizing the SD card. I tried a different SD card, but not recognized either. Both recognized in 5.28.
dmesg1.gz
Description  insert SD card
gz

 Download 
Filename  dmesg1.gz 
Filesize  61.21 KB 
Downloaded  136 Time(s) 
dmesg.gz
Description  boot without SD card
gz

 Download 
Filename  dmesg.gz 
Filesize  44.26 KB 
Downloaded  135 Time(s) 

_________________
Acer Aspire One D255-2301 (N450 Atom @ 1.6 Ghz, 1 Gb RAM, 160 Gb HDD w/WinXP, ENE SD card reader, Alps touchpad) 5.28/5.3.1 via manual-frugal ext4 USB flash drive (4Gb) using GRUB4DOS
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 01 Oct 2011, 14:43    Post_subject:  

Your ene card reader is addressed as sdc. There is a lot errror messages. Main thing is that the SD card detection fails, with redundant failure messages.

The keucr module cant be totally non working, since I use it with my ene card reader successfully. I think about the problem, but I dont have any solution atm.
Back to top
View user's profile Send_private_message 
MoebusNet

Joined: 04 Jun 2011
Posts: 89

PostPosted: Sat 01 Oct 2011, 14:57    Post_subject:  

Thank you.

BTW, SeaMonkey upgraded to 2.4.1. Working great so far!
Smile

_________________
Acer Aspire One D255-2301 (N450 Atom @ 1.6 Ghz, 1 Gb RAM, 160 Gb HDD w/WinXP, ENE SD card reader, Alps touchpad) 5.28/5.3.1 via manual-frugal ext4 USB flash drive (4Gb) using GRUB4DOS
Back to top
View user's profile Send_private_message 
Tman


Joined: 22 Jan 2011
Posts: 814
Location: Toronto

PostPosted: Sat 01 Oct 2011, 15:46    Post_subject: ISO file won't mount when clicked on  

I found this problem in various modern puplets, including Xprimo, as well as in my own builds. Please see the attached link.

http://www.murga-linux.com/puppy/viewtopic.php?t=70855&start=335
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 01 Oct 2011, 15:53    Post_subject:  

Tman. It works for me. Believe me, I have mounted my own isos many...many....times. But...if you have 6 mounted drives, partitions whatever already, then you need to unmount at least one, so that the iso mounting works.

Check your /mnt how many mounts you have there active.
Back to top
View user's profile Send_private_message 
Tman


Joined: 22 Jan 2011
Posts: 814
Location: Toronto

PostPosted: Sat 01 Oct 2011, 16:26    Post_subject:  

Hmmm, interesting.

I am not home at the moment and using another computer with a few frugal pups installed. I know it worked for me on my home computer, I just can't remember which pup I used it on last.

This computer has only 1 windows partition and a linux swap partition, while my home desktop has 3 partitions (1 drive) and a linux swap.

I will check my home computer tonight and try to get the bottom of this.

EDIT: Nevermind; runtt21 gave me the solution in his Macpup thread. One needs to have the ISO outside of the main home drive for the mounting to work.
I copied and ISO file to a USB stick and it mounted fine. Guess I have to make another post in the Lucid 5.2.8 thread.

Edited_time_total
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 01 Oct 2011, 16:47    Post_subject:  

Yes. /mnt/home is already mounted. Maybe...if you just make a subfolder to the /mnt/home like /mnt/home/isos it could work.....
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 69 of 148 Posts_count   Goto page: Previous 1, 2, 3, ..., 67, 68, 69, 70, 71, ..., 146, 147, 148 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1082s ][ Queries: 13 (0.0296s) ][ GZIP on ]