Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 16 Sep 2014, 00:59
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Security/Privacy
nwipe-0.05
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [10 Posts]  
Author Message
DPUP5520

Joined: 16 Feb 2011
Posts: 801

PostPosted: Wed 27 Apr 2011, 19:42    Post subject:  nwipe-0.05
Subject description: A fork of dban
 

Basically runs dwipe command outside of dban itself allowing you to use this great program/wiper on any distro which will compile it. It is essentially the same as dwipe, with a few changes:

* pthreads is used instead of fork
* The parted library is used to detect drives
* The code is designed to be compiled with gcc

It isn't quite refined yet but still seems to run just fine.
nwipe-0.5.pet
Description  For Puppy 4.2
pet

 Download 
Filename  nwipe-0.5.pet 
Filesize  53.84 KB 
Downloaded  986 Time(s) 
Nwipe.png
Description 
png

 Download 
Filename  Nwipe.png 
Filesize  62.23 KB 
Downloaded  1125 Time(s) 
nwipe-0.05.pet
Description  For Lupu Series
pet

 Download 
Filename  nwipe-0.05.pet 
Filesize  27.1 KB 
Downloaded  1181 Time(s) 

_________________
PupRescue 2.5
Puppy Crypt 528

Last edited by DPUP5520 on Sat 01 Oct 2011, 02:38; edited 2 times in total
Back to top
View user's profile Send private message 
TwoPuppies


Joined: 29 Dec 2010
Posts: 25
Location: Melbourne, Australia

PostPosted: Tue 20 Sep 2011, 23:29    Post subject: nwipe-0.05  

Any chance of providing a version of this that will work in Puppy 4.2 ?
_________________
What you really need is to have two puppies:
Puppy Linux, and the sort with four legs and a tail.
Back to top
View user's profile Send private message 
DPUP5520

Joined: 16 Feb 2011
Posts: 801

PostPosted: Wed 21 Sep 2011, 01:32    Post subject:  

sorry I only compile for lupu series, I tried compiling programs for some older puppies as well as quirky and wary before and was just running into too many issues. Did you try to see if it would work for 4.2?
_________________
PupRescue 2.5
Puppy Crypt 528
Back to top
View user's profile Send private message 
TwoPuppies


Joined: 29 Dec 2010
Posts: 25
Location: Melbourne, Australia

PostPosted: Tue 27 Sep 2011, 00:43    Post subject:  

Yes, I did try it in 4.2

As far as I can tell, the issue seems to be one of missing library files (or links to these). I had a go at providing the required links and files, but eventually came up against a problem that I could not solve. There seemed to be a conflict between the newer versions of certain library files that were required by your application, and the older versions of the same files that were required by Puppy 4.2 . Whichever files are used, there is always something that does not work. Part of the problem is that I am certainly no Linux expert, and I don't really know what I am doing.

_________________
What you really need is to have two puppies:
Puppy Linux, and the sort with four legs and a tail.
Back to top
View user's profile Send private message 
DPUP5520

Joined: 16 Feb 2011
Posts: 801

PostPosted: Tue 27 Sep 2011, 01:52    Post subject:  

I'm planning on giving Puplite a try this weekend (it's based on 4.2) and when I do i'll add in the devx and see if I can get it compiled for you. it'll be a few days though.
_________________
PupRescue 2.5
Puppy Crypt 528
Back to top
View user's profile Send private message 
DPUP5520

Joined: 16 Feb 2011
Posts: 801

PostPosted: Sat 01 Oct 2011, 02:39    Post subject:  

Added a pet of nwipe-0.5 for Puppy 4.2
_________________
PupRescue 2.5
Puppy Crypt 528
Back to top
View user's profile Send private message 
TwoPuppies


Joined: 29 Dec 2010
Posts: 25
Location: Melbourne, Australia

PostPosted: Thu 06 Oct 2011, 06:53    Post subject:  

The new pet works just great.
As well as Puppy 4.2, it now also works in Puppy 4.3 and Quirky 1.2
Thanks a lot.

_________________
What you really need is to have two puppies:
Puppy Linux, and the sort with four legs and a tail.
Back to top
View user's profile Send private message 
ashes

Joined: 22 Aug 2011
Posts: 46

PostPosted: Sun 22 Apr 2012, 04:57    Post subject:  

Thank you for nwipe, being able to run dban out of the OS (lupu-528) is of great advantage.

Unfortunately, I have problems running it:

when I open nwipe I get the blue interface, same as dban
I select the drive to wipe either with <space> or <enter>
I select wiping options <p><r><v><m>

but how do I start the wiping process then?



I have tried wiping a specific drive via console with "nwipe /sdx" but that is not supported.
What works is "nwipe --autonuke" but I would like to use it more selectively Wink
Back to top
View user's profile Send private message 
DPUP5520

Joined: 16 Feb 2011
Posts: 801

PostPosted: Fri 27 Apr 2012, 21:53    Post subject:  

F5
_________________
PupRescue 2.5
Puppy Crypt 528
Back to top
View user's profile Send private message 
Atle

Joined: 19 Nov 2008
Posts: 283
Location: Oslo, Norway

PostPosted: Wed 21 Nov 2012, 09:59    Post subject:  

Brilliant... could not get the F5 to work, but loaded Puppy 5.2.8, by using live CD, inserted a USB with your neat little program, installed it..

Ejected the CD and the USB and opened terminal and wrote the magic words

nwipe --autonuke

And it worked like a charm...

Great program that will become important to me...

Atle
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
Display posts from previous:   Sort by:   
Page 1 of 1 [10 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Security/Privacy
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0637s ][ Queries: 13 (0.0044s) ][ GZIP on ]