Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 19 Apr 2015, 20:46
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
How to save to Savefile only on demand in Puppy 5.2
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 3 [33 Posts]   Goto page: Previous 1, 2, 3
Author Message

Joined: 24 Jul 2011
Posts: 9
Location: Kharkov, Ukraine

PostPosted: Thu 04 Aug 2011, 19:17    Post subject:  

2 Sylvander:
1. I think it's not a good idea to hardcoded deleting the .XLOADED file. If everything is ok with X - maybe. But if something going wrong, then this prompt helps to bypass X starting. I know that there is ability to use pfix=nox, but standard prompt seems to be more finger-saving technology (less typing required) Smile

2. It really does. It thinks that it's still on flash in some mystic way. But it's not my own fault [or glory]. Yes, I really edited a little some configuration files on CD, but there was nothing about savefile location. I have just add a key to forcing ACPI usage - it's necessary to powerdown correctly on my board, and add a notification about ACPI is forced to boot.msg file ("Just wait 5 seconds for normal startup (note that acpi is forced)").
Now the "isolinux.cfg" file contents such settings:
label puppy
kernel vmlinuz
append initrd=initrd.gz pmedia=cd acpi=force

There is no flash references in boot config files on CD. The reference is still maybe somewhere inside pupsave file itself. Maybe the cause is last saving of pupsave file under alive X. So, pupmode=13 is still active (it's exactly correct, because the prompt on shutdown inserted to case 13 only, and it appears anyway).
Btw, while trying to save pupsave file from command line (/usr/sbin/snapmergepuppy /initrd/pup_ro1 /initrd/pup_rw) with X inactive I've got some "file is locked" conditions. So it does not work while some processes are still running. And I really have no idea neither which ones exactly nor how to stop them.
So, next step is trying to burn onto CD pupsave file after correct shutdown with session saved on exit. Awaiting for save completion (now it still saves. about 30 minutes were already passed).

Thanks for remastering ISO file manual too. I did not know how to do it under linux, and used UltraISO under windows.

SimpleWater wrote:
I used this method, and works nice, but not guaranteed. It does save on certain situations. I think restarting X is one of them.

I have a bit strange situation with the file laying on CD (read-only CD-ROM), but with saving abilities also activated. So if any saving would be tried to perform then the system must raise some writing error message [or simply hang-up]. But nothing like that was detected even when restarting X many times. So, it seems that the X restarting is not an accidental save cause.

Let's digitize the world to re-compile it to better suit our own needs!
Back to top
View user's profile Send private message 

Joined: 27 Feb 2011
Posts: 503
Location: GERMANY

PostPosted: Fri 09 Sep 2011, 06:44    Post subject:  

Hi folks !
Tried several options .(mochi mopel--)
Somehow after installing a pet file then shutdown without saving (with mochimopels script) previous installed pet file still saved ,despite shutdown
without saving.(this occurs alwasy after installing programms either pet or deb files)
Other changes (for example a text file) where not saved.
what is that ?
Same effect- result with sylvanders change of the rc.shutdown.

then tried reversed action ,deleting the program(previous installed pet or deb files) manually (during session) then -shutdown without save.but now the " no save" option did work. These files still where there despite deleting during session.
Strange behaviour.
My saveintervalls are set to =0.
Does anybody know a simple way to choose save or not to save at shutdown .
I also used pupsavecinfig pet similar results.
I am using macpup 525- lucid- puppy 529- and dpupexprimo on USB stick.
Back to top
View user's profile Send private message 

Joined: 15 Dec 2008
Posts: 3634
Location: West Lothian, Scotland, UK

PostPosted: Fri 09 Sep 2011, 07:17    Post subject:  

1. All of my Puppies are each loaded using a "live" CD-RW, with the pupsave+SFS filepair...
Either on an ext3 partition on a Flash Drive, or else on an ext3 partition on an internal HDD...

2. And a file included in the ISO has had a configuration setting changed...
So that the pupsave on the HDD is treated as though a pupsave on a Flash Drive->[GREAT feature].

3. Not all of my Puppies [at least 1 doesn't] have feature 2 working, even when the necessary change has been made. Sad
Don't know why.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 3 [33 Posts]   Goto page: Previous 1, 2, 3
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0612s ][ Queries: 13 (0.0131s) ][ GZIP on ]