Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 23 Jun 2018, 12:41
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
faire un sfs avec mysql opérationnel fichier .sock
Moderators: Béèm, darkerror05
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [10 Posts]  
Author Message
alaindu22

Joined: 29 Jul 2009
Posts: 177

PostPosted: Sat 27 Aug 2011, 05:38    Post subject:  faire un sfs avec mysql opérationnel fichier .sock  

Bonjour

Je voudrais réaliser un sfs avec serveur lampp et j'ai toujours un problème :
erreur 202 sans doute du à mysql sock non présent dans /opt/lampp/var/mysql/
pourtant le serveur fonctionne car les pages php sont correctement interprétées.

Au départ j'ai installé xampp-linux-1.7.tar.gz et xampp-linuxdevel-1.7.tar.gz

Pas de problème pour lancer phpmyadmin
pas de problème non plus pour installer des appli serveur type dotclear

Si je remastérise toutou avec cette config, pas de problème non plus le cd remastérisé a le serveur php mysql qui fonctionne et les acces à phpmyadmin et à dotclear se font dès le premier boot.

Par contre si j'essaye de faire un sfs pour l'installer sur des toutous existants, cela ne fonctionne jamais ... erreur mysql.

Je suis obligé de passer par l'extraction des 2 tar.gz, de copier tous les répertoires de dotclear, de creer la base dotclear, et d'importer le fichier sql lié à cette base

Que faut-il faire pour que cela marche sans passer par toutes ces démarches ?

Alain
Back to top
View user's profile Send private message 
vezuve


Joined: 24 Jan 2008
Posts: 1289

PostPosted: Mon 29 Aug 2011, 11:48    Post subject:  

Hello,
Cet réponse est basée sur les infos fournies, si elle ne devait pas correspondre ou être inexacte, le demandeur en est seul responsable, a lui de bien fournir tout les infos nécessaire (nom de la distribution, etc, etc).

alaindu22 wrote:
j'ai installé xampp-linux-1.7.tar.gz et xampp-linuxdevel-1.7.tar.gz
a ouais et la suite Question Exclamation Evil or Very Mad
alaindu22 wrote:
si j'essaye de faire un sfs pour l'installer sur des toutous existants, cela ne fonctionne jamais
a ouais et la suite Question Exclamation Evil or Very Mad
Et en en PET serait pas mieux Question

@+

_________________
Recherche
sur PUPPY anglai + souven
PUPPY wikka tou sur tou anglai
Back to top
View user's profile Send private message 
alaindu22

Joined: 29 Jul 2009
Posts: 177

PostPosted: Tue 30 Aug 2011, 13:57    Post subject:  

bonjour
A vezuve : tes vacances n'ont pas du être terribles, vu tous les smiley que tu mets...

que cela soit avec toutou 4.12 4.31 5.20 ou asri 300 c'est la même chose
ce que tu demandes comme suite est expliqué dans le premier post
il s'agit d'une erreur 202 qui fait référence à mysql.sock

quand je remastérise un toutou après avoir installlé les 2 tar gz, ma version remastérisée fonctionne avec mysql et php myadmin

quand je veux faire un sfs cela ne fonctionne pas...
le fait de recopier tous les fichiers extraits des tar gz au bon endroit ne suffit pas et d'ailleurs il y a toujours le fichier mysql.sock qui ne passe pas à la copie.
Le but de cette opération est de faire un sfs (ou à la limite un fichier pet ) avec un serveur php et base sql totalement portable n'exigeant aucune manipulation des utilisateurs

J'ai essayé avec une version anglaise (puppyserveur)
voir http://www.weberp.org/PuppyLinux

cela montre que c'et possible d'y arriver mais je tiens à utiliser lampp et un phpmyadmin français avec une version de php inférieure à 5.3 car sinon j'ai d'autres applications web avec du code en php3 qui est vu comme obsolète

Alain
Back to top
View user's profile Send private message 
esmourguit


Joined: 17 Nov 2006
Posts: 1393
Location: Entre l'ile aux oiseaux.et l'ile de sainte Lucie

PostPosted: Tue 30 Aug 2011, 21:33    Post subject:  

Bonjour à tous,
Essaies de tout faire à la main.
Décompresses le fichier .sfs que tu veux modifier, puis copies les fichiers que tu veux ajouter, dans les différents répertoires et reconstitues le fichier sfs, toujours à la main.
unsquashfs nom_du_fichier_sfs_que_tu_veux_décompresser
Cela va créer un fichier squashfs-root, que tu ouvres et dans lequel tu copies les fichiers que tu veux rajouter.
puis tu refais le fichier .sfs :
mksquashfs squashfs-root nom_du_fichier_sfs_que_tu_veux_recompresser, en principe, et c'est conseillé dans ton cas, le même que l'original.
Cordialement Wink

_________________
Toutou Linux - Pets francisés
Back to top
View user's profile Send private message 
vezuve


Joined: 24 Jan 2008
Posts: 1289

PostPosted: Wed 31 Aug 2011, 17:14    Post subject:  

Hello,
Vous êtes incroyable, si si, voir indéboulonnable, vous ne pouvez admettre que votre demande est parfaite et que tout absolument tout y est, alors plutôt que de passer vos nerfs sur celui qui essaye de vous aider n'est pas finaux....
alaindu22 wrote:
j'ai installé xampp-linux-1.7.tar.gz
je le réécrit c'est bien, mais ou est le pas a pas, la marche a suivre, la procédure d’installation, merci a mon super chercheur:
PHP install with XAMPP wrote:

We try so many time to make php code work well with puppylinux, which we had got assistance from puppylinux chat room, so we found XAMPP, which make puppylinux work well.
Where download XAMPP

http://www.apachefriends.org/en/xampp-linux.html

http://www.apachefriends.org/en/xampp-linux.html#372

install

cd /folder/where/I/have/xampp

copy xampp-linux-1.7.tar.gz to opt

extract it using this line code: tar xvfz xampp-linux-1.7.tar.gz -C /opt

open an other terminal

and go to /opt/lampp

go to the lampp directory

and type: ./lampp start

for try your php scripts, you must save all it at the htdocs folder inside lampp directory

test:

http://localhost if finish start lampp

(how to create short cut to start xampp)

create script to make a shortcut

#!/bin/sh

cd /

cd opt/lampp

./lampp start
car un fichier compressé "tar.gz peut être désarchiver avec un clic,en console comme ci-dessus et différents termes de cde, voir en compilant, ce qui fait bien des infos si précieuse pour essayer de savoir ce qui cloche Exclamation
Pour le sfs il est important de connaitre la version, car sur les nouvelle versions de puppy il y a une nouvelle versions du sfs, donc voir si les cde d'esmourguit son aussi valable su la nouvelle version Question
Ce qui amène de nouvelle question, qui est de savoir sous quelle versions faut-il le créer et sera il compatible pour toutes les versions, voir créer un pour l'ancienne version et un pour la nouvelle, etc, etc Exclamation Question
Donc avant de le fustiger celui qui te vient en aide, demande toi ce qui pourrait manquer ou a compléter, pour avoir plus de personne qui te réponde et ainsi augmenter la chance a ce que ton problème soit résolu.

@+

_________________
Recherche
sur PUPPY anglai + souven
PUPPY wikka tou sur tou anglai
Back to top
View user's profile Send private message 
alaindu22

Joined: 29 Jul 2009
Posts: 177

PostPosted: Thu 01 Sep 2011, 09:21    Post subject:  

Back to top
View user's profile Send private message 
alaindu22

Joined: 29 Jul 2009
Posts: 177

PostPosted: Thu 01 Sep 2011, 09:28    Post subject:  

Bonjour
je reviens d'une partie de pêche fructueuse et j'ai le sourire...
je ne vais donc fustiger personne , (je ne crois pas l'avoir fait précédemment )
Merci à Esmourguit pour sa réponse mais même en suivant ses conseils je n'ai pas réussi à accéder à mysql aprés avoir installé le sfs.

Pour ce qui est de lampp, je sais l'installer et expliquer comment l'installer...
je sais aussi le faire fonctionner...

voir http://asri.edu.free.fr/thread.php?lng=fr&pg=1671&id=2&cat=2#14

voir aussi la version d'asri 300 avec serveur web intégré
http://www.neufgiga.com/n/50-17/share/LNK82874e565f0d5160c/
serveur web pour établissement scolaire et exemples de fonctionnement ( avec appli générateur d'album dont vous êtes le héros) fonctionne en local mais peut fonctionner avec tout l'internet sous réserve de mettre un mot de passe sur le serveur mysql.

Le problème est donc bien ciblé dans le titre et pas ailleurs...

Pour vézuve c'est sur mysql qu'il y a un problème
Quand on ne met que du php sans faire appel à une base de données le sfs fonctionne. Ainsi l'appli web générateur d'étiquettes pour tbi ou tnwii visible aussi sur
http://alain.botrel.free.fr/mots_image7/IMG/motimage.php fonctionne car elle ne fait pas appel à mysql
(je l'avais indiqué dans mon premier post (pourtant le serveur fonctionne car les pages php sont correctement interprétées. )
Par contre tout ce qui fait appel à mysql est en erreur

je pense que la personne qui arrivera à construire un sfs reprenant les 2 fichiers tar-gz mentionnés plus haut avec un phpmyadmin qui fonctionne aura la réponse à ma question, et cela quelque soit la version de toutou utilisée.
Alain
Back to top
View user's profile Send private message 
goupil

Joined: 07 Sep 2011
Posts: 25

PostPosted: Wed 07 Sep 2011, 04:45    Post subject:  

Bonjour,

je me suis confronté au même problème de transport d'XAMPP.

Je me suis cassé la tête sur la solution du sfs et finalement, j'ai choisi de créer un targz de l'ensemble complet /opt/lampp installé avec sa base sql.

Ca fonctionne bien et ce n'est pas plus compliqué qu'un sfs.
La décompression du fichier par script sh est ultra rapide. Ca peux même se faire sans que l'utilisateur s'en aperçoive.

C'est sûr, c'est moins élégant qu'un sfs.... et si quelqu'un a la solution, je suis aussi preneur.

Bonne journée,
Marc
Back to top
View user's profile Send private message 
goupil

Joined: 07 Sep 2011
Posts: 25

PostPosted: Wed 07 Sep 2011, 05:44    Post subject:  

(re) bonjour,

j'ai oublié, il y a aussi les fichiers libmysql à recopier (ou linker) dans /lib

Mais cela peux se faire avec la compression targz
Back to top
View user's profile Send private message 
alaindu22

Joined: 29 Jul 2009
Posts: 177

PostPosted: Thu 08 Sep 2011, 14:21    Post subject:  

Bonjour

Merci pour ces infos, je vais essayer ta méthode.

Mais avant je vais essayer aussi de convertir mes codes php3 et php4 avec ereg, split, session register, session unregister mysql db query au standard php5 pour pouvoir utiliser http://www.logicworks.co.nz/puppy/LHMP-7.3-5.1.47-5.3.3.pet qui lui fonctionne bien sans erreur mysql.

Je ne sais pas quand je pourrai mettre résolu sur ce thème...

Alain
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [10 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0720s ][ Queries: 12 (0.0127s) ][ GZIP on ]