Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 23 Jul 2014, 04:14
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Polarpup-005 with Qt4-4.8.0 and Gstreamer libs inbuild
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 17 of 34 [498 Posts]   Goto page: Previous 1, 2, 3, ..., 15, 16, 17, 18, 19, ..., 32, 33, 34 Next
Author Message
Billtoo


Joined: 07 Apr 2009
Posts: 2055
Location: Ontario Canada

PostPosted: Sat 16 Jul 2011, 09:18    Post subject:  

pemasu wrote:
Jim1911. From your posted log, it looks like my kernel sources sfs really had problems.
Quote:
nvidia: disagrees about version of symbol module_layout
ERROR: Installation has failed.

I have recompiled the kernel and reuploaded kernel source sfs for lupe28.
Download lupe28 version and try again.

http://www.smokey01.com/pemasu/Kernel_sources/kernel_src-2.6.39-3-patched-lupe28.sfs



I tried your new kernel source and installed the proprietary nvidia
driver.
Sat 16 Jul 2011 Operating System: Polarpup-003 Linux 2.6.39
0.0 VGA compatible controller: nVidia Corporation G84 [GeForce 8600 GT] (rev a1)
oem: NVIDIA product: G84 Board - p402h00 Chip Rev

X Server: Xorg Driver: nvidia
X.Org version: 1.7.6
dimensions: 1280x1024 pixels (382x302 millimeters)
depth of root window: 24 planes

direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 8600 GT/PCI/SSE2
OpenGL version string: 3.3.0 NVIDIA 275.19

Intel(R) Core(TM)2 Quad CPU Q6600
Core 0: 1603 1: 1603 2: 1603 3: 1603 MHz

...the above also recorded at '/tmp/root/report-video-glx'.
sh-4.1# glxgears
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
44654 frames in 5.0 seconds
50124 frames in 5.0 seconds
50119 frames in 5.0 seconds

Good work Smile
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 16 Jul 2011, 10:22    Post subject:  

Billtoo. Wonderful news. It was the source then. I thought so, since I was able to compile nvidia.ko without problem.
Now we just would need to make a pet of nvidia. Unfortunately I havent found a way to compile it and install it to the dedicated folder. My lack of nvidia graphics cause the installer to fail.

ATI Catalyst 11.6 has dual intel/ATI graphics switcher which needs one lib more before it works. I have to play with it more before I update the full ATI package.
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2445
Location: Texas, USA

PostPosted: Sat 16 Jul 2011, 14:23    Post subject:  

Hi pemasu,

I had the same good experience compiling the NVIDIA driver that Billtoo reported. Thanks for recompiling the kernel.

Regards,
Jim
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 18 Jul 2011, 15:40    Post subject:  

Feff-1.7. Front end for Ffmpeg to convert file formats. For example m4a to ogg.

Simplistic but seems to work.
Feff-1.7.pet
Description 
pet

 Download 
Filename  Feff-1.7.pet 
Filesize  96.88 KB 
Downloaded  182 Time(s) 
Feff-1.7.jpg
Description 
jpg

 Download 
Filename  Feff-1.7.jpg 
Filesize  465.99 KB 
Downloaded  201 Time(s) 
Back to top
View user's profile Send private message 
jim3630


Joined: 13 Feb 2011
Posts: 792
Location: Northern Nevada

PostPosted: Thu 21 Jul 2011, 09:40    Post subject:  

pemasu wrote:

Then I made two pets, the whole one with ati catalyst command center 31 Mb and stripped down version with only essential 21 mb.

And it works !!! Glxgears seqfaults but there was quite a lot updated and the code is hacked.

Download link for full ATI Catalyst 11.6:http://www.smokey01.com/pemasu/Drivers/ati-11-6-k2.6.39.3-lupe28.pet
Download link for stripped ATI Catalyst 11.6:http://www.smokey01.com/pemasu/Drivers/ati-11-6-k2.6.39.3-lupe28-stripped.pet


installed stripped version pet and glxgears does show seqfaults

Thu 21 Jul 2011 Operating System: Polarpup-003 Linux 2.6.39
2.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
oem: Intel(R)Ironlake Mobile Graphics Chipset Accelerated VGA BIOS product: Intel(R)Ironlake Mobile Graphics Controller Hardware Version 0.0

X Server: Xorg Driver: (II) glx: vendor=FireGL - ATI Technologies Inc.
X.Org version: 1.7.6
dimensions: 1024x768 pixels (270x203 millimeters)
depth of root window: 24 planes


pemasu, so how tell it works other than the hardinfo data? video games?
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 21 Jul 2011, 09:56    Post subject:  

Jim3630. I know that fglrx driver works when I have loaded it and for example lhp sys info shows that fglrx graphics driver is loaded. As I have written, my version is hacked because ATI Catalyst does not yet support officially 2.6.39.3 kernel. So....for me it works as graphics driver. I cant say anything more. I can even change driver from intel to fglrx but not back anymore. Well....my kernel does not have vgaswithcheroo enabled, it might affect also.
Back to top
View user's profile Send private message 
jim3630


Joined: 13 Feb 2011
Posts: 792
Location: Northern Nevada

PostPosted: Thu 21 Jul 2011, 10:05    Post subject:  

pemasu wrote:
Jim3630. I know that fglrx driver works when I have loaded it and for example lhp sys info shows that fglrx graphics driver is loaded. As I have written, my version is hacked because ATI Catalyst does not yet support officially 2.6.39.3 kernel. So....for me it works as graphics driver. I cant say anything more. I can even change driver from intel to fglrx but not back anymore. Well....my kernel does not have vgaswithcheroo enabled, it might affect also.


pmesu, just don't know what to expect from it? shows
X Server: Xorg Driver: (II) glx: vendor=FireGL - ATI Technologies Inc.
so it is there. maybe I could run xorg again and change to fglrx.

is fglrx better than glx?
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 21 Jul 2011, 13:31    Post subject:  

Jim3630. Fglrx is the kernel module driver which is in that Ati Catalyst package. When you are in console state aka exited to the prompt, you need to run in console there:
aticonfig --initial. That command makes the needed changes to the xorg.conf. After that in xorgwizard you can change to use xorg flgrx driver. After that when you go back to the x by xwin, you should have both fglrx drivers loaded, kernel module and xorg driver.
You can check also by lsmod do you see fglrx loaded.

Above is little complicated, fglrx drivers are the essential stuff that ATI Catalyst produces. All the other are framework libraries, scripts and so on.
Back to top
View user's profile Send private message 
jim3630


Joined: 13 Feb 2011
Posts: 792
Location: Northern Nevada

PostPosted: Thu 21 Jul 2011, 13:57    Post subject:  

pemasu wrote:
Jim3630. Fglrx is the kernel module driver which is in that Ati Catalyst package. When you are in console state aka exited to the prompt, you need to run in console there:
aticonfig --initial. That command makes the needed changes to the xorg.conf. After that in xorgwizard you can change to use xorg flgrx driver. After that when you go back to the x by xwin, you should have both fglrx drivers loaded, kernel module and xorg driver.
You can check also by lsmod do you see fglrx loaded.

Above is little complicated, fglrx drivers are the essential stuff that ATI Catalyst produces. All the other are framework libraries, scripts and so on.


Pemasu, thanks for the instructions. may get in late and post tomorrow but will follow up.
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5678
Location: Kentucky

PostPosted: Fri 22 Jul 2011, 00:00    Post subject:  

Finally got around to doing a manual frugal install of Polarpup 003 on my main Athlon XP box...... everything good on initial boot and no real problems.

Thu 21 Jul 2011 Operating System: Polarpup-003 Linux 2.6.39
0.0 VGA compatible controller: nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] (rev c1)
oem: NVidia product: NV18 () Board Chip Rev A2

X Server: Xorg Driver: unknown
X.Org version: 1.7.6
dimensions: 1440x900 pixels (411x263 millimeters)
depth of root window: 24 planes

direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
OpenGL vendor string: Mesa Project
OpenGL renderer string: Software Rasterizer
OpenGL version string: 2.1 Mesa 7.7.1

AMD Athlon(tm) XP 2400+
Core 0: 1998 MHz

...the above also recorded at '/tmp/root/report-video-glx'.

# glxgears
516 frames in 5.0 seconds
527 frames in 5.0 seconds
489 frames in 5.0 seconds
498 frames in 5.0 seconds


# free
total used free shared buffers
Mem: 1033860 468868 564992 0 60052
Swap: 1228936 0 1228936
Total: 2262796 468868 1793928
#
Back to top
View user's profile Send private message 
marco07

Joined: 18 Jan 2011
Posts: 176
Location: Lincoln , NE, USA

PostPosted: Thu 28 Jul 2011, 18:09    Post subject:  

Hey pemasu:
Long time, no hear!
I hope you are OK.
Since you last left without any announcement, I got worried about you. I am sure the other regulars are feeling the same and we would like to hear that you are hopefully a OK and doing fine.
Please let us know.
Thanks!
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 28 Jul 2011, 18:29    Post subject:  

Sure I am amongst other puppy users. I have participated with my minor skills to the Lucid 5.2.6 development. Tested Slacko development versions, Fatdotdog 520 versions, Drake 3.0 and many Lucid devel versions. I have purified right clicks open with linkages, learnt many ways which dont stop vdpau errors, etc....

Next I will wait Iguleders new squeeze build to test. I liked his squeeze experiments lot and also Insidious Puppy 002.

Right now I am preparing to leave to the Jyväskylä world championship cup Rally. I have to be there about 4.00 am. I will sell tickets so that our ski clup gets money. It is quite nicely paid job. About 10 of my friends participate also. Yes...a lot people pays to see cars driving fast.
I dont like it at all, but money is there and our skiers will need it next winter.

So I have still little time to use by posting this. Today after Rally I will probably sleep long.....

My other family participates to the famous horse racing happening. They work there to help my wifes sister. So the house is luckily quite empty when I come back.

There hasnt been any good new qt4 apps so far so I havent posted to this thread.

But....I am ok, but probably very tired after this night......
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 3208
Location: Ontario

PostPosted: Thu 28 Jul 2011, 20:29    Post subject:  

I have a new right click package for Lucid 525

I put in ffconvert by Shinobar but I added some

wording to help the user

Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Fri 29 Jul 2011, 05:14    Post subject:  

Don570. That looks good. Thank you of your work.
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 2055
Location: Ontario Canada

PostPosted: Sat 30 Jul 2011, 12:27    Post subject: Polarpup-003 with Qt4-4.8.0 and Gstreamer libs inbuild  

I installed polarpup to a 4 gb flash drive and installed the devx +
kernel source + ati-driver-installer-11-7-x86.x86_64.run.

Sat 30 Jul 2011 Operating System: Polarpup-003 Linux 2.6.39
0.0 VGA compatible controller: ATI Technologies Inc Device 68d9
oem: ATI ATOMBIOS product: REDWOOD 01.00

X Server: Xorg Driver: vesa
X.Org version: 1.7.6
dimensions: 1920x1080 pixels (507x285 millimeters)
depth of root window: 24 planes

direct rendering: Yes
server glx vendor string: ATI
server glx version string: 1.4
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 5570
OpenGL version string: 4.1.10907 Compatibility Profile Context

AMD Phenom(tm) II X4 810 Processor
Core 0: 2592 1: 2592 2: 2592 3: 2592 MHz

sh-4.1# glxgears
41286 frames in 5.0 seconds
41488 frames in 5.0 seconds
41474 frames in 5.0 seconds

pemasu, I made a vlc-1.1.11-i686.pet in wary 080 with your 2.6.38.4
kernel and it is working in polarpup so if you'd like me to pm you a
download link so you can try it out let me know.
polarscrn.jpg
Description 
jpg

 Download 
Filename  polarscrn.jpg 
Filesize  989.64 KB 
Downloaded  194 Time(s) 
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 17 of 34 [498 Posts]   Goto page: Previous 1, 2, 3, ..., 15, 16, 17, 18, 19, ..., 32, 33, 34 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1041s ][ Queries: 13 (0.0114s) ][ GZIP on ]