Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 02 Sep 2014, 15:38
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Polarpup-005 with Qt4-4.8.0 and Gstreamer libs inbuild
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 16 of 34 [499 Posts]   Goto page: Previous 1, 2, 3, ..., 14, 15, 16, 17, 18, ..., 32, 33, 34 Next
Author Message
marco07

Joined: 18 Jan 2011
Posts: 176
Location: Lincoln , NE, USA

PostPosted: Thu 14 Jul 2011, 19:24    Post subject:  

pemasu wrote:
That yellow box says Please wait, updating help page, and it does pop up for me but then the fixmenus and restart wm does not happen.
Weird.


Exatly the same happens here.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 14 Jul 2011, 19:33    Post subject:  

Anyway the petget installation script goes to the end and even updates the ppm database. So, only fixmenus command and wm restarting lacks.
Do them manually and there you go. I have latest petget folder scripts so it must be something of that libre office structure. I probably will add pinstall.sh to the pet which performs those commands.
Back to top
View user's profile Send private message 
marco07

Joined: 18 Jan 2011
Posts: 176
Location: Lincoln , NE, USA

PostPosted: Thu 14 Jul 2011, 20:36    Post subject:  

pemasu wrote:
Anyway the petget installation script goes to the end and even updates the ppm database. So, only fixmenus command and wm restarting lacks.
Do them manually and there you go. I have latest petget folder scripts so it must be something of that libre office structure. I probably will add pinstall.sh to the pet which performs those commands.


So, should I be waiting for a new LO .pet package that you will soon develop?
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2455
Location: Texas, USA

PostPosted: Thu 14 Jul 2011, 21:30    Post subject:
Subject description: NVIDIA Compliation
 

Hi pemasu,

My frugal installation is working great and I continue to marvel at the completeness and up-to-date software in your distributions.

I do get an error on installation of the correct Nvidia driver.

ERROR: Unable to load the kernel module 'nvidia.ko'. This happens most frequently when this kernel module was built against the wrong or mproperly configured kernel sources, with a version of gcc that differs from the one used to build the target kernel, or if a driver such as rivafb, nvidiafb, or nouveau is present and prevents the NVIDIA kernel module from obtaining ownership of the NVIDIA graphics device(s), or NVIDIA GPU installed in this system is not supported by this NVIDIA Linux graphics driver release.

Nouveau was the culprit in the past when this message occurred with your distributions, however, it has been completely removed and the nv driver is being used. I suspect the problem is an improperly configured kernel sources this time.

Has anyone else had success installing the proper Nvidia driver with this release?

Thanks,
Jim
Back to top
View user's profile Send private message 
jim3630


Joined: 13 Feb 2011
Posts: 792
Location: Northern Nevada

PostPosted: Thu 14 Jul 2011, 22:47    Post subject:  

downloaded new pp003, manual copied files for frugal install using same savefile. not sure fully unsterstand the sfs problems but could load sfs files, devx and vlc at boot. vlc functions as expected and devx programs, glade, are present.

pemasu like your sunset pic.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Fri 15 Jul 2011, 04:32    Post subject:  

Marco07. Why dont you just execute in console: fixmenus and restart windowmanager. It is that easy.


Jim1911. I just tested the ati fglrx driver compilation. I got that kernel lock error again. And I am sure I checked that Kernel hacking section, there wasnt that option anymore. I thought it was left out. But it seems to be there somewhere.
I dont know if this affects to nvidia driver compiling but surely I will have to make new kernel to get ati working again. I searched the net, there were 3 posts about same problem than I got, only 3, so it should be easily resolved.
I will search the net about nvidia driver compiling also.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Fri 15 Jul 2011, 04:56    Post subject:  

ATI driver installation problem now understood. Latest ATI installer still looks for big kernel lock but it is totally removed from 2.6.39.3 kernel. So....new ATI driver package is needed which solves that problem.

Nvidia package should be updated for above problem, if you use the latest Nvidia driver package. Is there something else missing, I dont know yet.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Fri 15 Jul 2011, 07:09    Post subject:  

Just to be sure. I downloaded Barrys latest 2.6.39.3 source, compiled it with my specs and get same errors.
So... I dont think that my uploaded source is faulty. There is obstacles now in that 2.6.39.3 kernel to compile proprietary NVIDIA and ATI drivers.
I will investigate it more.
ATI reason is clear. The latest driver packages shouts after big kernel lock which isnt in 2.6.39.3 kernel anymore. Probably next ATI package resolves that.

NVIDIA though is mystery. That big kernel lock bug should have been resolved months ago. There is something else now.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Fri 15 Jul 2011, 16:18    Post subject:  

I downloaded NVIDIA-Linux-x86-270.41.19 and NVIDIA-Linux-x86-280.04. Then I extracted both of them.
Code:
./NVIDIA-Linux-x86-280.04 --extract-only

In extracted folder I compiled nvidia.ko. It succeeded without problem. I cant test installing them or installer since I dont have nvidia graphics.

About that error message Jim1911 got. It means that nvidia.ko compiling succeeded but something inhibited the installing of the module.
/var/log/nvidia-installer.log should give information what failed.
Someone who tries to install nvidia, could post that log file if it fails.

Straight link to nvidia ftp site: ftp://download.nvidia.com/XFree86/Linux-x86/
Click the last modified and you get at the end the latest nvidia installers.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Fri 15 Jul 2011, 18:25    Post subject:  

Libreoffice 3.4.1 pet should now create appropriate menu entrys.

Download link: http://www.smokey01.com/pemasu/Pets/libreoffice-3.4.1.pet
Back to top
View user's profile Send private message 
marco07

Joined: 18 Jan 2011
Posts: 176
Location: Lincoln , NE, USA

PostPosted: Fri 15 Jul 2011, 19:25    Post subject:  

pemasu wrote:
Libreoffice 3.4.1 pet should now create appropriate menu entrys.

Download link: http://www.smokey01.com/pemasu/Pets/libreoffice-3.4.1.pet


Thanks!
Back to top
View user's profile Send private message 
smokey01


Joined: 30 Dec 2006
Posts: 1806
Location: South Australia

PostPosted: Fri 15 Jul 2011, 20:39    Post subject:  

Forbidden

You don't have permission to access /pemasu/Pets/libreoffice-3.4.1.pet on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache mod_fcgid/2.3.5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at www.smokey01.com Port 80

Whoa, I don't have permission to download from my own site.

MMmm, investigating.

The folder permission had changed. Fixed.

_________________
Puppy Software <-> Distros <-> Puppy Linux Tips
Back to top
View user's profile Send private message Visit poster's website 
Jim1911

Joined: 19 May 2008
Posts: 2455
Location: Texas, USA

PostPosted: Fri 15 Jul 2011, 21:42    Post subject:  

Hi pemasu,

You've really been working on the driver problems. Thank you.

I tried to install NVIDIA=Linux=x86-270.41.19 which works with my card, the /var/log/nvidia-installer.log from the failed installation is attached as requested/

Regards,
Jim
nvidia-installer.tar
Description 
tar

 Download 
Filename  nvidia-installer.tar 
Filesize  50 KB 
Downloaded  168 Time(s) 
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 16 Jul 2011, 02:24    Post subject:  

Jim1911. From your posted log, it looks like my kernel sources sfs really had problems.
Quote:
nvidia: disagrees about version of symbol module_layout
ERROR: Installation has failed.

I have recompiled the kernel and reuploaded kernel source sfs for lupe28.
Download lupe28 version and try again.

http://www.smokey01.com/pemasu/Kernel_sources/kernel_src-2.6.39-3-patched-lupe28.sfs
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 16 Jul 2011, 07:58    Post subject:  

Today I studied ATI Catalyst 11.6 which does not compile with 2.6.39.3. I searched net and I found tips how to cheat the installer.

I made notes to my notecase:
Quote:
extract package ./ati.....run --extract
edit /common/lib/modules/fglrx/build_mod/firegl_public.c

for (i = 0; i < __KE_MAX_SPINLOCKS; i++)
- dev->spinlock[i] = SPIN_LOCK_UNLOCKED; << change this row
+ spin_lock_init(&dev->spinlock[i]);

for (i=0; i < __KE_MAX_SEMAPHORES; i++)
sema_init(&dev->struct_sem[i], 1);

change that above row to be: spin_lock_init(&dev->spinlock[i]);
Copy from older kernel source and place to: /usr/src/linux-2.6.39/include/linux/smp_lock.h
run ./ati-installer.sh 11.6 --buildpkg
It creates Slackware package under /packages/Slackware/working_tree
Delete unnecessary, add pinstall.sh and create pet.


Then I made two pets, the whole one with ati catalyst command center 31 Mb and stripped down version with only essential 21 mb.

And it works !!! Glxgears seqfaults but there was quite a lot updated and the code is hacked.

Download link for full ATI Catalyst 11.6:http://www.smokey01.com/pemasu/Drivers/ati-11-6-k2.6.39.3-lupe28.pet
Download link for stripped ATI Catalyst 11.6:http://www.smokey01.com/pemasu/Drivers/ati-11-6-k2.6.39.3-lupe28-stripped.pet
ATICatalyst11.6.jpg
Description 
jpg

 Download 
Filename  ATICatalyst11.6.jpg 
Filesize  324.06 KB 
Downloaded  185 Time(s) 

Last edited by pemasu on Sat 16 Jul 2011, 12:53; edited 3 times in total
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 16 of 34 [499 Posts]   Goto page: Previous 1, 2, 3, ..., 14, 15, 16, 17, 18, ..., 32, 33, 34 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1017s ][ Queries: 13 (0.0208s) ][ GZIP on ]