Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Dec 2014, 22:54
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Polarpup-005 with Qt4-4.8.0 and Gstreamer libs inbuild
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 12 of 34 Posts_count   Goto page: Previous 1, 2, 3, ..., 10, 11, 12, 13, 14, ..., 32, 33, 34 Next
Author Message
marco07

Joined: 18 Jan 2011
Posts: 176
Location: Lincoln , NE, USA

PostPosted: Mon 11 Jul 2011, 11:12    Post_subject:  

Hi pemasu:
Thanks for polar puppy 002! i have installed it on my oldr desktop an ESI box with Pentium III, 1 GHz, 1.5 GB ram, and on my laptop a Thinkpad R60. They both are performing well and have had no problem so far. Also installed Thunderbird mail client from the the quickpet. I am enjoying their performance. Great Job!
Would you advise what is the best way to install Libre office and Java packages for P002?
Is installation of sfs from quick pet OK? Or are there .pet packages available?
Thanks again!
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Mon 11 Jul 2011, 11:15    Post_subject:  

Jim3630. Hah. I think you have found Clementine usable then. I have not tried to use external speakers.
Do you connect by mini-jack ?
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Mon 11 Jul 2011, 11:27    Post_subject:  

Jim3630. I believe you have to get external speakers detected at system level, not from Clementine.
I just tested the connection to my living room stereos. I connected the mini-jack plug to the headphone hole. Then in alsamixer I increased the level in headphone and the sound came from speakers connected to the stereos.
Note, I didnt do any s/pdif tinkering, just headphone setting.
Audio settings are sometimes quite hw spesific. The entries in alsamixer and Retrovol differs in different hw.
And I am not expert in this. Smokey01 is surely more handy for example in audio settings.
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Mon 11 Jul 2011, 11:37    Post_subject:  

Marco07. For java, you can use the java pet from the link.
For Libre Office. I think that 01Mickos Libre Office gui pet is usable. I have still Libre Office as standalone installation and I havent updated it yet.
Iguleder also has something going on regarding Libre Office.

I remember that I had thiskind discussion in Ice Puppy thread and there was some solutions after my miserable intervention.

http://www.smokey01.com/pemasu/Pets/jre-1.6u25-i586.pet

For Libre Office 3.4
http://www.murga-linux.com/puppy/viewtopic.php?t=65918

For older sfs libre office:
http://distro.ibiblio.org/puppylinux/pet-packages-lucid/LibreOfc-3.3.1_en_US_sfs4.sfs
Back to top
View user's profile Send_private_message 
jim3630


Joined: 13 Feb 2011
Posts: 792
Location: Northern Nevada

PostPosted: Mon 11 Jul 2011, 11:48    Post_subject:  

pemasu wrote:
Jim3630. I believe you have to get external speakers detected at system level, not from Clementine.
I just tested the connection to my living room stereos. I connected the mini-jack plug to the headphone hole. Then in alsamixer I increased the level in headphone and the sound came from speakers connected to the stereos.
Note, I didnt do any s/pdif tinkering, just headphone setting.
Audio settings are sometimes quite hw spesific. The entries in alsamixer and Retrovol differs in different hw.
And I am not expert in this. Smokey01 is surely more handy for example in audio settings.


I'm connected by DMDI 0 (hw 0.3). was able today to output sound to the tv with vlc and SMplayer as they have that function selection built in.

added gnomad2-2-96 and gstreamer_phono-deps-0.0.1 and now have no sound output in notebook or external.
Back to top
View user's profile Send_private_message 
jim3630


Joined: 13 Feb 2011
Posts: 792
Location: Northern Nevada

PostPosted: Mon 11 Jul 2011, 11:54    Post_subject:  

also ALSA sound wizard flashes open but closes when choose "One: Adjust levels"

looks like new savefile.
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Mon 11 Jul 2011, 11:58    Post_subject:  

Jim3630. That gstreamer-phono libs package is the one I made for Polarpup and it is already installed during woof building stage. It has combined Ubuntu libs for audio-video-media functionality and gstreamer libs with about 190 plugins.
You should not install it. It is not useful and only eats your savefile.

Installing Gnomad2 didnt brake sound in my laptop.

I think that installing again that massive libs pet might have broken your existing system. Gstreamer has somekind mechanism to detect and preserve system information of hardware and functionality. At least some gstreamer plugins might not be used as they used to be.

I uploaded that massive gstreamer enabling libs pet if someone wants the functionality of it in Lucid based Puppy without need to install them one by one from the PPM.
Back to top
View user's profile Send_private_message 
gcmartin


Joined: 14 Oct 2005
Posts: 4507
Location: Earth

PostPosted: Mon 11 Jul 2011, 12:05    Post_subject: /etc/hostname, /etc/hosts, environment variable HOSTNAME  

On hostname command
_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile
Back to top
View user's profile Send_private_message 
jim3630


Joined: 13 Feb 2011
Posts: 792
Location: Northern Nevada

PostPosted: Mon 11 Jul 2011, 12:10    Post_subject:  

this is a time when an option to close without saving would undo this correct?
Back to top
View user's profile Send_private_message 
jim3630


Joined: 13 Feb 2011
Posts: 792
Location: Northern Nevada

PostPosted: Mon 11 Jul 2011, 12:29    Post_subject:  

posting from 263 noticed has updated version of ALSA wizard 1.0.24.2 and Alsamixer in multimedia. I'm easily able to select setting for external speakers HDA intel: HDMI 0 (hw 0.3). Nice
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Mon 11 Jul 2011, 12:41    Post_subject:  

Jim3630. Polarpup has alsa 1.0.24.2 also, lol, so not so old. And thank you of that alsamixer in menu tip. I will include it to the next build.
In Polarpup alsamixer works from the console. But the entry in menu is much better.
I just usually do changes in Retrovol so I havent thought about menu entry for alsamixer.
Back to top
View user's profile Send_private_message 
jim3630


Joined: 13 Feb 2011
Posts: 792
Location: Northern Nevada

PostPosted: Mon 11 Jul 2011, 15:16    Post_subject:  

pemasu wrote:
Jim3630. Polarpup has alsa 1.0.24.2 also, lol, so not so old. And thank you of that alsamixer in menu tip. I will include it to the next build.
In Polarpup alsamixer works from the console. But the entry in menu is much better.
I just usually do changes in Retrovol so I havent thought about menu entry for alsamixer.


yes alsa is same in 263 just looks different. alsa wizard does offer device option but I'm unable to get it to recognize external speaker regardless of syntax used. tried HDMI 0. HDMI 0 (hw 0.3). 0.3

pulled up alsamixer but unable to get exteral speakers working in clementine. those programs that have the selection option built in like vlc, smplayer then it does work.

Retrovol also works from console but doesn't give option for device.
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Mon 11 Jul 2011, 15:31    Post_subject:  

Jim3630. HDMI sounds much more familiar than DMDI. Now I know what you try to do. I think alsa 1.0.24 is the first alsa version which offers HDMI usability. I can be wrong.

Alsawizard usage is bad because it hardcodes the selection. Dont use it if you can. Barry has now even made the gui to warn about using it.

But.....You can try with Multiple soundcard wizard pet if you can change the soundcard to use HDMI.

I am not tested HDMI connection in Puppies. Interesting thing that you get it working in Luci 263. I need to test HDMI also in Polarpup and in Luci 263.
I have unfortunately quite difficult hw for audio. I didnt get sound at latest spup with pmusic at all.

It can be also that my 2.6.38 kernel and alsa detection is not 100 % working. So maybe lack of HDMI is the distro problem. Lets see.
Multiple_Soundcard_Wiz-1.0.pet
Description 
pet

 Download 
Filename  Multiple_Soundcard_Wiz-1.0.pet 
Filesize  1.19 KB 
Downloaded  183 Time(s) 
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Mon 11 Jul 2011, 16:47    Post_subject:  

Jim3630. I just want to be sure. Did you get HDMI audio working in Polarpup with VLC and Umplayer or did you mean Luci 263 only.
Back to top
View user's profile Send_private_message 
jim3630


Joined: 13 Feb 2011
Posts: 792
Location: Northern Nevada

PostPosted: Mon 11 Jul 2011, 16:57    Post_subject:  

pemasu wrote:
Jim3630. I just want to be sure. Did you get HDMI audio working in Polarpup with VLC and Umplayer or did you mean Luci 263 only.


Glad you recognized my fubar. Yes got working in Polarpup with above packages. Used your multicard pet, rebooted and it works outputting audio to the tv!!

what's not working is flsyclient it only remains off moments once saved the choice for off.

Pulled a symlink to desktop from opera portable and it's gone from the desktop after reboot.

Like the new wallpaper alot.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 12 of 34 Posts_count   Goto page: Previous 1, 2, 3, ..., 10, 11, 12, 13, 14, ..., 32, 33, 34 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0874s ][ Queries: 13 (0.0127s) ][ GZIP on ]