Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 30 Jul 2014, 23:23
All times are UTC - 4
 Forum index » Off-Topic Area » Programming
Zenity/Yad and scripts
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 5 [66 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Author Message
stu90


Joined: 25 Feb 2010
Posts: 1401
Location: England. Dell Inspiron 1501. Dpup

PostPosted: Tue 17 May 2011, 22:43    Post subject:  

No probs lithpr - thanks for making .pet
Cool
Back to top
View user's profile Send private message 
lithpr


Joined: 10 Mar 2011
Posts: 186

PostPosted: Fri 27 May 2011, 18:06    Post subject:  

hi all. Finally got around to messing with yad.. it's awesome. So fun and easy to use (at least for the simple case). Here's my first experiment: a little script to help find wallpapers at the users current screen resolution:

Code:

#!/bin/bash
dataline=$(wmctrl -d | grep '*')
width=$(echo "$dataline" | cut -d ' ' -f 5 | cut -d \x -f 1)
height=$(echo "$dataline" | cut -d ' ' -f 5 | cut -d \x -f 2)
search=$(yad \
  --title="Find Wallpapers" \
  --text="This will help you find wallpapers that fit well within your current screen resolution.\n" \
  --window-icon=/usr/share/pixmaps/google-chrome.png \
  --entry --entry-label="Wallpaper Search:")

search=$(echo "$search" | sed "s/ /%20/g")
searchURL="http://images.google.com/images?q=imagesize%3A${width}x${height}+${search}"
defaultbrowser "$searchURL"

I'l definitelyl be messing with it more in the coming weeks.
Back to top
View user's profile Send private message 
Iguleder


Joined: 11 Aug 2009
Posts: 1872
Location: Israel, somewhere in the beautiful desert

PostPosted: Fri 10 Jun 2011, 14:39    Post subject:  

Another PET, this time of 0.12.1 Smile

Clean install, no extras or patches.
yad-0.12.1.pet
Description 
pet

 Download 
Filename  yad-0.12.1.pet 
Filesize  67.89 KB 
Downloaded  603 Time(s) 

_________________
My homepage
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
ICQ Number 
vovchik


Joined: 23 Oct 2006
Posts: 1285
Location: Ukraine

PostPosted: Sat 11 Jun 2011, 01:50    Post subject: Yad icon browser  

Dear lguleder,

Thanks for the new yad pet. I also compiled it (in lucid) and included in my ./configure the option to create the little yad-icon-browser (18k). Here it is. I think it is useful if you are designing gtkdialog/yad/zenity/gtkdialog-splash scripts and want to see what icons you have available that are part of the system.

With kind regards,
vovchik

PS. It installs a menu entry in System.
yad-icon-browser-0.12.1.pet
Description 
pet

 Download 
Filename  yad-icon-browser-0.12.1.pet 
Filesize  7.93 KB 
Downloaded  612 Time(s) 
yad-icon-browser.jpg
 Description   
 Filesize   43.82 KB
 Viewed   2682 Time(s)

yad-icon-browser.jpg

Back to top
View user's profile Send private message 
stu90


Joined: 25 Feb 2010
Posts: 1401
Location: England. Dell Inspiron 1501. Dpup

PostPosted: Sat 11 Jun 2011, 08:21    Post subject:  

Iguleder wrote:
Another PET, this time of 0.12.1 Smile

Clean install, no extras or patches.

Thanks for .pet Iguleder Cool
Back to top
View user's profile Send private message 
L18L

Joined: 19 Jun 2010
Posts: 2505
Location: Burghaslach, Germany somewhere also known as "Hosla"

PostPosted: Sat 18 Jun 2011, 17:33    Post subject:  

Iguleder wrote:
Another PET, this time of 0.12.1 Smile

Clean install, no extras or patches.

latest is 0.12.2 now
Back to top
View user's profile Send private message 
stu90


Joined: 25 Feb 2010
Posts: 1401
Location: England. Dell Inspiron 1501. Dpup

PostPosted: Tue 21 Jun 2011, 07:04    Post subject:  

Yad .pet for 0.12.2 compiled on Lucid puppy - nothing stripped out.
yad-0.12.2-i486.pet
Description  yad-0.12.2-i486.pet
pet

 Download 
Filename  yad-0.12.2-i486.pet 
Filesize  70.63 KB 
Downloaded  758 Time(s) 
Back to top
View user's profile Send private message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2373
Location: UK

PostPosted: Tue 21 Jun 2011, 07:27    Post subject:  

as far as I know, as mentioned before, all puppies seem to say GTK 2.10, but that is only the DEV part of it.. Correct me if I am wrong, but I have 2.10 listed from pkconfig, but am using 2.12.1

I tried to compile Yad on 4.2 and it did say GTK was too old.

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send private message 
stu90


Joined: 25 Feb 2010
Posts: 1401
Location: England. Dell Inspiron 1501. Dpup

PostPosted: Tue 21 Jun 2011, 07:43    Post subject:  

sc0ttman wrote:
as far as I know, as mentioned before, all puppies seem to say GTK 2.10, but that is only the DEV part of it.. Correct me if I am wrong, but I have 2.10 listed from pkconfig, but am using 2.12.1

I tried to compile Yad on 4.2 and it did say GTK was too old.


Hi sc0ttman,

Does it still compile when you get this message?
I can't recall if i get this message or not as i just bash enter all the way through with out reading the display Laughing

Any idea of what the GTK package would be called? looking though the packages downloaded in woof for squeeze puppy there is a gtk2-engines-pixbuf_2.20.1-2_i386.deb
Back to top
View user's profile Send private message 
L18L

Joined: 19 Jun 2010
Posts: 2505
Location: Burghaslach, Germany somewhere also known as "Hosla"

PostPosted: Tue 21 Jun 2011, 07:50    Post subject: yad
Subject description: version
 

stu90 wrote:
Yad .pet for 0.12.2 compiled on Lucid puppy - nothing stripped out.

Thanks for compiling.

Here is a code snippet to control required version
Code:
# test of yad version
 yad_version_min_required="0.12.1"
 yad_version=`yad --version`
 yad_version1="`yad --version | cut -d '.' -f 1`"
 yad_version2="`yad --version | cut -d '.' -f 2`"
 yad_version3="`yad --version | cut -d '.' -f 3`"
 #echo $yad_version3
 #echo $yad_version_min_required | cut -d '.' -f 3
 if    [ "$yad_version1" -lt "`echo $yad_version_min_required | cut -d '.' -f 1`" ]; then ver_err=1
 elif [ "$yad_version2" -lt "`echo $yad_version_min_required | cut -d '.' -f 2`" ]; then ver_err=1
 elif [ "$yad_version3" -lt "`echo $yad_version_min_required | cut -d '.' -f 3`" ]; then ver_err=1
 fi
 [ "$ver_err" = "1" ] && printf "your yad version %s is less than the required version %s \n" $yad_version $yad_version_min_required && exit
# /test of yad version

Note, [ "$ver_err" = "1" ] && ......... && exit is ONE line.
Tested succesfully simulating a higher yad_version_min_required
Back to top
View user's profile Send private message 
seaside

Joined: 11 Apr 2007
Posts: 886

PostPosted: Tue 21 Jun 2011, 10:11    Post subject:  

I think technosaurus made a pet for Gtk216 (which apparently works with fewer problems than 218 in Puppy).

However, the pet seems to have been lost when one of the housing sites went down.

Anyone seen this one somewhere?

Cheers,
s
Back to top
View user's profile Send private message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2373
Location: UK

PostPosted: Fri 24 Jun 2011, 06:11    Post subject:  

stu90 wrote:
sc0ttman wrote:
as far as I know, as mentioned before, all puppies seem to say GTK 2.10, but that is only the DEV part of it.. Correct me if I am wrong, but I have 2.10 listed from pkconfig, but am using 2.12.1

I tried to compile Yad on 4.2 and it did say GTK was too old.


Hi sc0ttman,

Does it still compile when you get this message?
I can't recall if i get this message or not as i just bash enter all the way through with out reading the display Laughing

Any idea of what the GTK package would be called? looking though the packages downloaded in woof for squeeze puppy there is a gtk2-engines-pixbuf_2.20.1-2_i386.deb

No it does not compile.

And the package would be the DEV package of GTK - something like gtk+-2.12.1-i486-w5.pet (i made that from memory, may be wrong)

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send private message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2373
Location: UK

PostPosted: Fri 24 Jun 2011, 06:41    Post subject: Yad 0.9.1
Subject description: should work in puppy 4 and later
 

Here is Yad 0.9.1

The 0.9.x series is the last to work in puppy 4, as far as I know.

it should work in puppy 4 and later, alhtough I am not sure..
Maybe only my mongrel install.. For testing only, I guess...

EDIT... NOPE, this one won't run pur-gui, but it runs the icon browser..
yad-0.9.1-1-i486-pup4.pet
Description  should work in most pups
pet

 Download 
Filename  yad-0.9.1-1-i486-pup4.pet 
Filesize  63.25 KB 
Downloaded  511 Time(s) 

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send private message 
stu90


Joined: 25 Feb 2010
Posts: 1401
Location: England. Dell Inspiron 1501. Dpup

PostPosted: Fri 01 Jul 2011, 07:36    Post subject:  

update for yad-0.12.4
compiled on lucid puppy
yad-0.12.4-i486.pet
Description  yad-0.12.4.pet
pet

 Download 
Filename  yad-0.12.4-i486.pet 
Filesize  51.21 KB 
Downloaded  707 Time(s) 
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 1327
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Fri 01 Jul 2011, 23:46    Post subject:  

stu90,

Here it is, my monster yad compiled on quirky 1.20, I don't know how it will work with other quirky's as it was compile on my hybrid, let me know if it is ok , if not I will kill the beast. Laughing
yad_quirky_1.20-0.12.4-i486.pet
Description  yad compiled on quirky 1.20 may not work with stock quirky
pet

 Download 
Filename  yad_quirky_1.20-0.12.4-i486.pet 
Filesize  185.49 KB 
Downloaded  485 Time(s) 
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 5 [66 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Off-Topic Area » Programming
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0949s ][ Queries: 13 (0.0144s) ][ GZIP on ]