Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 20 Nov 2014, 17:21
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
IcePuppy-014 for newer and Ice Puppy-015 for older computers
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 53 of 56 [839 Posts]   Goto page: Previous 1, 2, 3, ..., 51, 52, 53, 54, 55, 56 Next
Author Message
gcmartin

Joined: 14 Oct 2005
Posts: 4434
Location: Earth

PostPosted: Fri 17 Jun 2011, 21:19    Post subject: Measure ICE15 on 512MB PC  

James C inspired me to pull an old IBM P4 with 512MB of memory out of moth balls for testing ICE15. It seem to work fine without any issues. I then booted ICE14, and it seems to run faster. I then started on comparison, when it occured to me one problem that generates an inconsistent measure....the 2 ICE's are different in several ways. So my measurement would not be an "apples to apples" measurement. ICE15, has some updates and application version changes which ICE14 does not have yet.

But, my stop-watch shows ICE14 appears to be a slightly better utilization of resources for its performance with Videos and browsing. But, the workload I have is small and IS prone to human error. Therefore, I reject my comparison measurements for any validity.

One valid measure is the Video-Hardinfo report attached. Since we all know that the ICE15 is built for older uniprocessor PCs with 3.1GB RAM, its comparison would be better compared against SNOW20 versus ICE14. (In fact, maybe the number for "non-PAE" ICE should be the same suffix number as used with SNOW. Thus an objective comparison could be easily spotted.)

Hope this helps (if you want to know about ICE14 on a 512MB uniproccessor P4 PC. It works just as well as ICE15+SNOW20)

And James C, thanks for the inspiration. It makes me think.
IBMP4-512MB_Video_Hardinfo-Report.tar.gz
Description  Hardinfo IBM uni P4 512MB
gz

 Download 
Filename  IBMP4-512MB_Video_Hardinfo-Report.tar.gz 
Filesize  89.57 KB 
Downloaded  209 Time(s) 

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5464
Location: Finland

PostPosted: Sat 18 Jun 2011, 01:54    Post subject:  

Gcmartin. Ice Puppy-015 compiled kernel is SMP enabled, so it utilizes multiprocessors. But it is optimized conservatively for 486 aka old processors for better compatibility. Also memory resources usage is about 18 Mb smaller without highmem+pae so it is better with less memory.

Main reason to build this kernel was to cover those computures which didnt like core2 optimization.
Back to top
View user's profile Send private message 
davids45


Joined: 26 Nov 2006
Posts: 655
Location: Chatswood, NSW

PostPosted: Sat 18 Jun 2011, 06:00    Post subject:
Subject description: No Save file option using Frugal Install
 

G'day pemasu,
I've liked all your water-white Puppies but I am having a problem when using the Universal Installer to automatically add your latest Pups to my computer in the Frugal form.

Following the usual procedure of live CD (pfix=ram) and using the Universal Installer for a FRUGAL install, the files are copied from the CD to the new Pup sub-directory and the Installer tells me I will be offered to create a Save file as the computer shuts down.

But when I hit the 'Reboot' button on the Shut-Down dialog box, the monitor screen immediately goes black and the 'no signal' box soon appears - the computer however is still whirring away and only stops or reboots some minutes later.
No Save file has been created.

This Frugal failure has been happening to my new desktop computer for most but not all new Pup derivatives when I try a Frugal install.

tazoc at Lighthouse Pup has suggested some extra boot parameters to try (pfix=vesa,ram nomodeset) which I did with IcePup015 but these failed to let a Frugal Save file be offered at shut down. LHP64 also wont Frugal-Save for me yet.

My computer has a radeon graphics card and the monitor is a 1600x900 LED.

If it would help, IcePup015 (Frugal) reports:
"Sat 18 Jun 2011 Operating System: Ice Puppy-015 Linux 2.6.38
0.0 VGA compatible controller: ATI Technologies Inc Device 68f9
oem: ATI ATOMBIOS product: CEDAR 01.00

X Server: Xorg Driver: radeon
X.Org version: 1.7.6
dimensions: 1600x900 pixels (423x238 millimeters)
depth of root window: 24 planes

direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
OpenGL vendor string: Mesa Project
OpenGL renderer string: Software Rasterizer
OpenGL version string: 2.1 Mesa 7.7.1

Pentium(R) Dual-Core CPU E5800
Core 0: 3226 1: 3226 MHz"

Full installs of my non-saving Frugals are fine - but I cannot fit as many interesting Pup Full installs on a hard disk as I can Frugals. And Fulls are, or used to be, more hard work to set up.

And I can do a manual three file copy Frugal Install then create an empty Save file in the new sub-directory, and name this Save file using the pre-fix from /etc/DISTRO_SPECS so I then have what I hoped the Universal Installer would provide, like it used to.

I got this Frugal IcePup015 set up with a Save file by copying my Frugal IcePup014 save file and letting Puppy upgrade this which it does very well. In fact, my IcePup014 Frugal Save file was an upgraded IcePup012 Save file, so my no-Save-option problem has been happening in the last two IcePups.

So this is giving me interesting stuff to worry about, but I feel it would deter newcomers if this was their first experience of a Puppy Frugal via the Universal Installer. I have seen some recent forum posts about Save file problems, as well as my own.

Let me know if I could provide any extra info. about this problem.

Thanks for all your excellent Pups,

David S.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5464
Location: Finland

PostPosted: Sat 18 Jun 2011, 06:57    Post subject:  

davids45. I have read about your problem in other threads. It might be that /usr/sbin/snapmerepuppy script and your computer does not like each other. If you know older puppy which behaves well with your new computer, you could swap the snapmergepuppy from that puppy to the newer puppy. Snapmergepuppy script has improvements to create savefile from ram saved files faster. I have noticed that not all computers likes it or at least saving to the usb media has sometimes been problematic.
Back to top
View user's profile Send private message 
davids45


Joined: 26 Nov 2006
Posts: 655
Location: Chatswood, NSW

PostPosted: Sat 18 Jun 2011, 07:41    Post subject:  

G'day pemasu,
Thank you for your quick reply.
I'll test your idea with a Puppy that has Frugally installed with the expected Save file option on shut-down on my computer and try the snapmergepuppy file in some of those that didn't.
I will let you know how it goes.
Maybe it just my unlucky combination of hardware.
David S.
Back to top
View user's profile Send private message 
marco07

Joined: 18 Jan 2011
Posts: 176
Location: Lincoln , NE, USA

PostPosted: Sat 18 Jun 2011, 08:43    Post subject:  

Hi pemasu:
Two requests:
1- I have tried to install libre office from various links provuded here in the Puppy Forum to no avail. The download sites ( Rapidshare & media ???) are to confusing and redirect you to downloading other stuff but what you are seeking. Would you help me to find a download link or provide a SFS file for this. As you may know, it used to be in quickpet. But no longer any more (???).
2- I was wondering if you can provide a pet package of Kwallet for your puppies. The reason? I use Kmymoney and use the same data file that I use with other distros on my other box. These other distros use kwallet and passwrod protect Kmymoney. When I try to use it in either Snow or Ice Puppies, although I can access the data file, but when it comes to online updating then Kmymoney crashes instead of asking for a password which needs kwallet to handle that.
Sorry for too much to ask!
Thanks in advance!
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5464
Location: Finland

PostPosted: Sat 18 Jun 2011, 08:55    Post subject:  

Marco07. I will check that Libre Office. I use it with Snow Puppy and Ice Puppy from /mnt/home in its own folder.
I could create sfs of Libre Office and upload it to the ftp site if I dont find working version from the bit heaven.

About Kwallet. I dont promise anything because it is unknown application for me but I check it also.

Edit: Have you tried this:http://murga-linux.com/puppy/viewtopic.php?t=65918
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Sat 18 Jun 2011, 09:17    Post subject:  

Try 01micko's GUI for LibreOffice download.This app downloads LibreOffice stable or test version, plus localised help and locale files (optional) and combines them into an sfs with the language code in the name of the sfs, then offers to install. It's worked well with the earlier stable version.
Back to top
View user's profile Send private message 
marco07

Joined: 18 Jan 2011
Posts: 176
Location: Lincoln , NE, USA

PostPosted: Sat 18 Jun 2011, 09:32    Post subject:  

pemasu wrote:
Marco07. I will check that Libre Office. I use it with Snow Puppy and Ice Puppy from /mnt/home in its own folder.
I could create sfs of Libre Office and upload it to the ftp site if I dont find working version from the bit heaven.

About Kwallet. I dont promise anything because it is unknown application for me but I check it also.

Edit: Have you tried this:http://murga-linux.com/puppy/viewtopic.php?t=65918

Thanks! It will be appreciated.
BTW, I tried menue>setup>setup puppy>sfs distro specific sfs downloader. It has listed a few Libre office versions. But none works. Produces error message "broken Link".
Back to top
View user's profile Send private message 
marco07

Joined: 18 Jan 2011
Posts: 176
Location: Lincoln , NE, USA

PostPosted: Sat 18 Jun 2011, 09:33    Post subject:  

Jim1911 wrote:
Try 01micko's GUI for LibreOffice download.This app downloads LibreOffice stable or test version, plus localised help and locale files (optional) and combines them into an sfs with the language code in the name of the sfs, then offers to install. It's worked well with the earlier stable version.

I tried menue>setup>setup puppy>sfs distro specific sfs downloader. It has listed a few Libre office versions. But none works. Produces error message "broken Link".
Thanks!
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5464
Location: Finland

PostPosted: Sat 18 Jun 2011, 10:03    Post subject:  

Marco07. I made LibreOffice-3.4.0_en-US.sfs without extra locales and help files with that 01mickos libre qui downloader. 3.4 version seems to need java installed.
I will use LibreOffice as standalone application in /mnt/home/libreoffice folder.

I am now uploading it to the ftp site under Sfs folder.

About sfs downloader. It seems to be broken. The url is right, the files exist but it does not download.
Barry Kauler has changed the puppylinux folder contents. And there is also now symlink pet_packages-lucid pointing to the pet-packages-lucid, which was wrongly named at the beginning of Lucid Puppies saga.
There might be connection of these recent thing and download failure.

Kwallet. I should have guessed from name. It is KDE application.
Sorry, KDE is out of my scope.

Last edited by pemasu on Sat 18 Jun 2011, 10:12; edited 1 time in total
Back to top
View user's profile Send private message 
marco07

Joined: 18 Jan 2011
Posts: 176
Location: Lincoln , NE, USA

PostPosted: Sat 18 Jun 2011, 10:11    Post subject:  

pemasu wrote:


I am now uploading it to the ftp site under Sfs folder.

By ftp site, you mean the links on the first page of this thread?
pemasu wrote:

About sfs downloader. It seems to be broken. The url is right, the files exist but it does not download.

It is sad!

pemasu wrote:

Kwallet. I should have guessed from name. It is KDE application.
Sorry, KDE is out of my scope.

No big deal!
Thanks!
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5464
Location: Finland

PostPosted: Sat 18 Jun 2011, 10:14    Post subject:  

Marco07. Yes. I will check which version works without java also. I just dont like this java coupling. Libre Office is big enough without java demand.
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Sat 18 Jun 2011, 10:23    Post subject:  

Hi pemasu,

All Libreoffice versions require java for all features to work, however, writer and spreadsheet applications work without it.

From your post, I see that you got 3.4 to work in Ice Puppy. I've only been able to use 3.3.2.

Cheers,
Jim
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5464
Location: Finland

PostPosted: Sat 18 Jun 2011, 10:27    Post subject:  

Libre Office 3.3.3 works without java. It cries after it but accepts its fate without it and swriter starts.

Uploading now LibreOffice-3.3.3_en-US.sfs

I will investigate this sfs downloader failure. The script behind it is /usr/sbin/sfsget.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 53 of 56 [839 Posts]   Goto page: Previous 1, 2, 3, ..., 51, 52, 53, 54, 55, 56 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1060s ][ Queries: 13 (0.0193s) ][ GZIP on ]