Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 17:35
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Clementine *IS* Amarok
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Author Message
playdayz


Joined: 25 Apr 2008
Posts: 3788

PostPosted: Sat 04 Jun 2011, 19:14    Post_subject:  Clementine *IS* Amarok
Sub_title: Popular Music Player Now Plays WMA, MP3, M4A, MPC, OGG, FLAC and wavepack
 

Please redownload Songbird (JUN 06) if you want to play unprotected wma.

Clementine is based on the code from Amarok 1.4 (prior to kde4). As you can see.... http://www.clementine-player.org/

I can see why people like it so much. I especially like the Artist Info.



Global shortcuts can cause interference with the keyboard in Openbox. Please redownload if you have that problem.

The locales are included--it could be a bit smaller without them.... The pet is 37MB. It is only tested in Lucid 5.2.5.

http://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet-packages-lucid/Clementine-0.7.1-lucid525.pet

Whew.

Edited_times_total
Back to top
View user's profile Send_private_message 
DM was on fire!


Joined: 12 Sep 2009
Posts: 156
Location: N.E. Georgia Mountains, USA

PostPosted: Mon 06 Jun 2011, 01:12    Post_subject:  

Does it have Last.fm/Pandora support like Amarok?
Because if so, and it runs on the latest Puppy (I saw your screenshots), I am sold.

ETA - Never mind. I suppose it would help if I looked at the website lol.
Thank you for putting this into a .pet. :3
Back to top
View user's profile Send_private_message MSNM 
playdayz


Joined: 25 Apr 2008
Posts: 3788

PostPosted: Mon 06 Jun 2011, 13:25    Post_subject:  

There is just one more problem.




See the name of the song in the far right column. It is wrong--and the song will not play. In the bottom pic you see the actual song name. Other players don't have this problem. Any ideas?
Back to top
View user's profile Send_private_message 
yim


Joined: 01 Sep 2007
Posts: 167
Location: Blue Ridge Mtns

PostPosted: Mon 06 Jun 2011, 23:15    Post_subject:  

playdayz

I noticed you said that it conflicts with keyboard in openbox and to redownload, I have that problem after installing on 5.2.5 2.6.30.5 retro, just curious does a reinstall over the first install fix that , don't quite understand I have the latest pet I believe

thanks yim
Back to top
View user's profile Send_private_message 
yim


Joined: 01 Sep 2007
Posts: 167
Location: Blue Ridge Mtns

PostPosted: Mon 06 Jun 2011, 23:35    Post_subject:  

I went through the global shortcut list and set each one to none and hit ok don't know which one did it but now I have control over my keyboad with clementine running, will close down and do a relaunch and see if settings will stay,

hats off to you playdayz, I'm a big fan of clementine works great on pclinuxos and now puppy yeehaw

thanks for making a pet

yim
Back to top
View user's profile Send_private_message 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Tue 07 Jun 2011, 09:10    Post_subject:  

Looks promising however, I get this error trying it from a console:
Code:
# clementine
clementine: symbol lookup error: /usr/lib/libQtOpenGL.so.4: undefined symbol: _ZN14QPaintEngineEx19drawPixmapFragmentsEPKN8QPainter14PixmapFragmentEiRK7QPixmap6QFlagsINS0_18PixmapFragmentHintEE
#
Back to top
View user's profile Send_private_message 
playdayz


Joined: 25 Apr 2008
Posts: 3788

PostPosted: Tue 07 Jun 2011, 11:37    Post_subject:  

Quote:
I noticed you said that it conflicts with keyboard in openbox and to redownload, I have that problem after installing on 5.2.5 2.6.30.5 retro, just curious does a reinstall over the first install fix that , don't quite understand I have the latest pet I believe

I went through the global shortcut list and set each one to none and hit ok don't know which one did it but now I have control over my keyboard with clementine running, will close down and do a relaunch and see if settings will stay,

Yes, that is the fix. I am afraid I got confused and reuploaded the wrong one. But you have fixed it.
Quote:
Looks promising however, I get this error trying it from a console:
Code:
# clementine
clementine: symbol lookup error: /usr/lib/libQtOpenGL.so.4: undefined symbol: _ZN14QPaintEngineEx19drawPixmapFragmentsEPKN8QPainter14PixmapFragmentEiRK7QPixmap6QFlagsINS0_18PixmapFragmentHintEE
#

jim1911, Does it start from the menu? I don't get that error. I will test again on a pristine copy of Lucid 5.2.5. Can you reinstall the pet? Some of these pets also use Qt and if you uninstalled one it might delete something that Clementine needs--so just reinstall Clementine.

Yes, Jim, it does start from the menu and the console with a pristine copy of Lucid 5.2.5. It also starts with Xorg_high installed (since the error file is libQtOpenGL). It is also possible you have another package installed that uses Qt and there is a conflict. .
Back to top
View user's profile Send_private_message 
muggins

Joined: 20 Jan 2006
Posts: 6688
Location: lisbon

PostPosted: Tue 07 Jun 2011, 12:00    Post_subject:  

As most QT4's install to /opt, Jim possibly has some libQt* files in /usr/lib that are conflicting. I had a similar error with some app, & it was OK after deleting the conflicting libs.
Back to top
View user's profile Send_private_message 
playdayz


Joined: 25 Apr 2008
Posts: 3788

PostPosted: Tue 07 Jun 2011, 12:13    Post_subject:  

Quote:
As most QT4's install to /opt, Jim possibly has some libQt* files in /usr/lib that are conflicting. I had a similar error with some app, & it was OK after deleting the conflicting libs.

Unfortunately, this will happen as we make more packages for lucid 5.2.5. My policy has been to make everything included in one package, since I think that is easiest for people to use, but it does mean possible conflicts. There are at least 3 versions of Qt in play now, 4.6. 4.7.2, and 4.7.3, probably more, so there would be possible conflicts regardless--and some packages do not need full Qt (which is huge anyway). I would not have time to remake packages with separate Qt, even if that would solve problems, so we will have to just work around it.
Back to top
View user's profile Send_private_message 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Tue 07 Jun 2011, 13:08    Post_subject:  

playdayz wrote:
Quote:
As most QT4's install to /opt, Jim possibly has some libQt* files in /usr/lib that are conflicting. I had a similar error with some app, & it was OK after deleting the conflicting libs.

Unfortunately, this will happen as we make more packages for lucid 5.2.5. My policy has been to make everything included in one package, since I think that is easiest for people to use, but it does mean possible conflicts. There are at least 3 versions of Qt in play now, 4.6. 4.7.2, and 4.7.3, probably more, so there would be possible conflicts regardless--and some packages do not need full Qt (which is huge anyway). I would not have time to remake packages with separate Qt, even if that would solve problems, so we will have to just work around it.
Very likely, that MuseScore may be conflicting. However, I believe that I prefer Deadbeef to Amarok now, so prefer to keep MuseScore.

Cheers,
Jim
Back to top
View user's profile Send_private_message 
playdayz


Joined: 25 Apr 2008
Posts: 3788

PostPosted: Tue 07 Jun 2011, 17:05    Post_subject:  

Jim1911, It's good to have choices, eh? One of my original goals in Lucid was to have a lot of good linux software tested and configured. We sure have a lot of music players anyway Wink

If you have any wma audio files, I just posted in the deadbeef thread how to play them. Which version are you using? I make make a full version with everything, unless someone else already has.

http://www.murga-linux.com/puppy/viewtopic.php?p=531855#531855

Ah, I found Deadbeef version 0.5.1 -> http://www.murga-linux.com/puppy/viewtopic.php?t=68640
.
Back to top
View user's profile Send_private_message 
stifiling

Joined: 29 Dec 2007
Posts: 388

PostPosted: Wed 08 Jun 2011, 16:25    Post_subject: last.fm  

is last.fm working for anyone?
Back to top
View user's profile Send_private_message 
playdayz


Joined: 25 Apr 2008
Posts: 3788

PostPosted: Wed 08 Jun 2011, 19:26    Post_subject:  

Quote:
is last.fm working for anyone?

I saw that

Quote:
Only paid subscribers can stream last.fm radio from Clementine


That is not very helpful. I can stream radio with a browser. I am losing patience with Clementine.

In fact, witness the controversy with Banshee and Ubuntu--our Free and Open Source colleagues are fighting over the money!!! How tacky.
Back to top
View user's profile Send_private_message 
DM was on fire!


Joined: 12 Sep 2009
Posts: 156
Location: N.E. Georgia Mountains, USA

PostPosted: Thu 16 Jun 2011, 12:43    Post_subject:  

I think I got the old file. I can only use my keyboard if my caps lock is on with Clementine on. Thought it was a 5.2.5 problem until I determined that the issue started when Clementine was on.
If I download this one will it work again?
Back to top
View user's profile Send_private_message MSNM 
playdayz


Joined: 25 Apr 2008
Posts: 3788

PostPosted: Thu 16 Jun 2011, 18:19    Post_subject:  

Quote:
I think I got the old file. I can only use my keyboard if my caps lock is on with Clementine on. Thought it was a 5.2.5 problem until I determined that the issue started when Clementine was on.
If I download this one will it work again?

Easier fix -> Go to Tools -> Preferences -> Global Shortcuts, and highlight each shortcut and choose the None option. Then your keyboard should be all right. That's all the fixed version does.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0814s ][ Queries: 13 (0.0043s) ][ GZIP on ]