(OLD) (ARCHIVED) Puppy Linux Discussion Forum Forum Index (OLD) (ARCHIVED) Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info

This forum can also be accessed as http://oldforum.puppylinux.com
It is now read-only and serves only as archives.

Please register over the NEW forum
and continue your work there. Thank you.

 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups    
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 21 Jan 2021, 22:53
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Lighthouse 64 5.11 Alpha for 64-bit processors
Moderators: Flash, JohnMurga
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
Page 3 of 6 [90 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Author Message

Joined: 26 Nov 2006
Posts: 1327
Location: Chatswood, NSW

PostPosted: Wed 15 Jun 2011, 22:47    Post subject:
Subject description: No Save file prompt during Frugal Install (again)

G'day tazoc,

Roy is not quite alone.

Last night, I tried the 64-bit LHP and got the now usual failure of most new Pups to create a Save file on shut-down after using the Universal Installer to set up a Frugal install.
On hitting "Reboot", monitor goes black/dark grey, computer runs on for a while then reboots. I see none of the previously regular messages about what is happening during shut-down and no "Save File" option.

Re-booting to the new LHP64 Frugal subdirectory, there is no Save file found so I get prompted again for the usual new install data. There is no save file when I look with Rox.

My work-around try for LHP64 was to copy over a FatDog64 Save file and re-name to L64save.xxx - I've been told that /etc/DISTRO_SPECS will list what prefix to use for the Save file so a Puppy can use it (or an empty SFS) during a Frugal boot.

This copy&re-name worked so I now have a LHP64 Frugal booting directly however this has "merged" my old FatDog64 save-file and the new stuff from LHP64, which made for an interesting pinboard on re-booting again - lots of overlapping icons from each Pup plus my sfs's from FatDog running nicely without having to tell LHP64 what to load at boot.

So, like Roy's description, I'm getting this Frugal-install failure (black screen, no Save File prompt, no shutting down messages) with most new Pups whereas old Pups install as they always have.
But unlike Roy, I have a Radeon-driver. So it's not an nvidia problem? But could be new hardware-involved as I am on a new desktop and having all these Frugal-NoSaveFile problems - Fulls are fine, so far.

LHP64 is otherwise very good, just like your 32-bit LHPs.

Having done the Green Cape Lighthouse tour, I appreciate your use of its image for your wallpapers. Like most lighthouses, a very interesting location and atmosphere. But your image doesn't seem to capture the windiness of Green Cape that I remember.

Hoping the Frugal No-Save gets fixed for all Pups as well as LHP64, or at least, explained to me what's going on,

David S.
Back to top
View user's profile Send private message 

Joined: 07 Apr 2009
Posts: 3721
Location: Ontario Canada

PostPosted: Thu 16 Jun 2011, 09:05    Post subject: Lighthouse 64 5.11 Alpha for 64-bit processors
Subject description: frugal install

I do a frugal install but I don't use the universal installer, instead
I boot from another puppy installation,live cd or one on the hard
I made a lighthouse directory on the hard drive and then clicked on
the Lighthouse64-5.11-A.iso to mount it, then select all the files and
copy them to the lighthouse directory,then click on the iso again to unmount it.
Then I run grub4dos and edit the menu.lst file entry for lighthouse to
"nomodeset pfix=vesa,ram", I need this on this particular pc even
though it has ati graphics or I'll get a black screen at some
point.Once the pc is rebooted I can download the driver pet (ati or
nvidia) and install that which allows a reboot with no black screen
and can create a save file,(need to remember to edit the menu.lst
entry back to pfix=fsck before rebooting).

This is what the Pupstate file shows now:
#v3.97: kernel with libata pata has both sata and pata drives in ATADRIVES...
#these directories are unionfs layers in /initrd...
#The partition that has the L64save file is mounted here...
#(in /initrd) ...note, /mnt/home is a link to it.
#this file has extra kernel drivers and firmware...
#complete set of modules in the initrd (moved to main f.s.)...
FASTPARTS='sda1|ext4 sda2|ext4 '

I wasn't aware of the frugal install problem with the universal
installer because I seldom burn a dvd or cd of the puppy iso.
Anyhow, this method is working here.
I had the kernel sources sfs from fatdog64 on this hard drive and was able download
and install the proprietary ati driver.

Thu 16 Jun 2011 Operating System: Lighthouse64-511 Linux
0.0 VGA compatible controller: ATI Technologies Inc Device 68d9
oem: ATI ATOMBIOS product: REDWOOD 01.00

X Server: Xorg Driver: fglrxdrm: vendor=FireGL - ATI Technologies Inc.
X.Org version: 1.9.0
dimensions: 1920x1080 pixels (508x285 millimeters)
depth of root window: 24 planes

direct rendering: Yes
server glx vendor string: ATI
server glx version string: 1.4
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 5570
OpenGL version string: 4.1.10750 Compatibility Profile Context

AMD Phenom(tm) II X4 810 Processor
Core 0: 2592 1: 2592 2: 2592 3: 2592 MHz

...the above also recorded at '/tmp/root/report-video-glx'.
bash-4.1# glxgears
39586 frames in 5.0 seconds = 7917.070 FPS
39789 frames in 5.0 seconds = 7957.797 FPS
39778 frames in 5.0 seconds = 7955.398 FPS
 Filesize   138.46 KB
 Viewed   2989 Time(s)


Back to top
View user's profile Send private message 

Joined: 11 Dec 2006
Posts: 1157
Location: Lower Columbia Basin WA US

PostPosted: Thu 16 Jun 2011, 19:25    Post subject: KMS  

Sorry about the difficulties with reboot and save file creation. It seems the problems are not just a particular brand of video card, but rather with kernel modules that handle video modesetting (KMS). Many display cards don't use KMS and tend to be immune from these problems. We are in a transition period where some software and hardware are KMS ready, while some are not.

We are also transitioning from using a text-mode interactive wizard to setup X to an automatic configuration 'boot to desktop' which sometimes works, but sometimes the proper driver or resolution is not available... The automatic part is handled by the script xorgwizard and the Personalize Settings first run dialog. The full interactive method currently requires exiting X to CL (text mode) and typing xorgwizard-puppy. This could be more straightforward I think. Again KMS complicates matters, as CL may not work if modesetting is enabled and the monitor or display adapter cannot use the chosen mode.

Using puppy pfix=vesa,ram nomodeset (or just vesa from the LiveCD) seems to be the best workaround, at least for the first boot and save file creation. As Billtoo found, the default boot options may work after the best display driver is installed.

32-bit LHP used nomodeset by default on the liveCD, while Fatdog 64-511 does not. I do not recall problems with KMS noted on the Fatdog threads, so I thought the new kernel and xserver may have eliminated the need for nomodeset. In any case, unless a better solution is found, I plan to make nomodeset the default, at least on the LiveCD for the next release.

I will also study the Universal Installer script to see if it needs the same treatment.

Thanks again for the feedback, screenshot and suggestions. As with Fatdog 64, Lighthouse 64 has combined the devx and kernel source into one large devx SFS. I wanted to include it on the Mariner ISO, but that would mean it could not fit on a CD. I don't know if that matters, as I would think most 64-bit machines would have a DVD burner anyway, although users who don't need to do any compiling from source might prefer the smaller ISO.

lhpup.org Lighthouse 64 6.02
Back to top
View user's profile Send private message Visit poster's website 

Joined: 31 Dec 2008
Posts: 453

PostPosted: Fri 17 Jun 2011, 12:38    Post subject:  

I can confirm that I did NOT have boot or save file issues with Fatdog64, if this helps in any way.

puppy pfix=vesa nomodeset on LHP64 brings me to the CL, but I cannot get to the desktop from there. Well, my machine barks once when I do a hard shutdown -- so I can guess that the desktop might actually be there beneath my totally black screen. Maybe I should specify that "I cannot get to a USABLE desktop" with that method, instead.

Also, although using 'puppy pfix=ram nouveau.modeset=0' in my boot parameters did eventually get my desktop and save file going, my ability to connect to the internet is intermittent. No guess as to 'why', but sometimes it connects to my ad-hoc hotspot, sometimes it won't. Reinstalling Frisbee beta2 pet from Fatdog does not help this (sometimes) problem. (My adhoc hotspot is sitting directly on top of my desktop, so I know it is not a signal strength issue.)

On the other hand, I have tried several DIFFERENT boot parameters and the ad-hoc connectivity problem might have been with some of those other parameters instead. I really MUST start keeping notes for myself.

Back to top
View user's profile Send private message 

Joined: 26 Nov 2006
Posts: 1327
Location: Chatswood, NSW

PostPosted: Sat 18 Jun 2011, 00:55    Post subject:  

G'day tazoc,

Thanks for your reply and reasonable explanation to my difficulties with many new Pups when I try a Frugal install on my new desktop+monitor set-up.

I'll try your suggested boot script "pfix=vesa,ram nomodeset" on a few Pups that I have had Save-File set-up problems with.

I have certainly found that the graphics on my new LED 1600x900 monitor are often non-ideal (don't 16:9 size properly) and when a Pup does work, I seem to end up with different Puppy-selected drivers for what looks to me like no obvious reason (sometimes it's the expected "radeon", sometimes "vesa", and one chose something like "fvb").

And like Roy, I'm a bit sorry I haven't kept a record of which Frugals installed and Frugal-saved as expected, and those that just died graphically when I hit the re-boot button expecting to see the 'Save to File' or at least the closing down texts. Maybe the message was there but the shut-down had somehow stopped the graphic display from appearing.

But I shall in future, starting with IcePup015 which I've just down-loaded.

And as this is a Lighthouse thread, I've attached a couple of alternative views of one of your favourites, Green Cape Lighthouse. The Cape is always very windy as a proper lighthouse site should be. The lighthouse is vertical - I was having trouble keeping the camera (and me) level in the wind to get the second picture. Much nicer inside the top of the lighthouse.

Thanks for all your excellent and innovative Pups - it's not just because I like lighthouses too.

David S.
 Description   the keepers' cottages from the lighthouse
 Filesize   30.54 KB
 Viewed   2912 Time(s)


 Description   From the tip of Green Cape.
 Filesize   21.3 KB
 Viewed   2766 Time(s)


Last edited by davids45 on Tue 21 Jun 2011, 21:11; edited 1 time in total
Back to top
View user's profile Send private message 

Joined: 26 Nov 2006
Posts: 1327
Location: Chatswood, NSW

PostPosted: Sat 18 Jun 2011, 03:36    Post subject:
Subject description: No Save File with IcePup + pfix=vesa,ram nomodeset

G'day tazoc,

Sorry to keep bothering you with my Frugal Save File problem but I have just tried your boot parameter suggestions with IcePup015.

Unfortunately, I got no option to create a Save file on re-booting after a live CD Universal Installer install using the extra parameters, nor after using grub to boot to the installed-but-Save-file-less IcePup015 and adding "pfix=vesa,ram nomodeset" to its Grub entry.

The Universal Installer did everything I have seen it do for a few years now, and even offered the message that on shutting down there would be an option to create a Save file. But there wasn't.

As soon as I hit 're-boot' button offered by the IcePup shut-down dialog box (called PSD?), the monitor gave an instant black screen and soon the 'no signal' message (I'm using dvi if that's important) and went to stand-by (its power LED went to orange). The computer kept running for a minute or two before re-booting.

I had no problem booting IcePup015 with the extra boot parameters. The preferences box said IcePup was using vesa at 1600x900 and looked good.

I'm now posting from a Frugal install of IcePup015 because I copied over the previous Save file from my Frugal IcePup014 which on booting IcePup015 upgraded the older Save file. Actually even the old IcePup014 save-file was a copied Save file from IcePup012 - so my Frugal Save inability with IcePup is at least 2 versions old (I should tell pemasu my problems too).

And with the upgraded old IcePup Save file and no special boot parameters, I'm told I'm now using the radeon driver, not vesa.

I'll next see if your extra boot parameters work with your Lighthouse trying to get set it up as a new Frugal on my computer. Let me know if you want to know any of my hardware details.

But first I've got to go and buy some hot dinner for a meal on a cold Saturday evening (it's almost down to single figures Celsius outside).

After dinner, I'll let you know what happens with LHP.

Thanks for your help,

David S.
Back to top
View user's profile Send private message 
Ray MK

Joined: 05 Feb 2008
Posts: 778
Location: UK

PostPosted: Sat 18 Jun 2011, 06:50    Post subject:  

Hi TazOC

Just a note to thank you for a superb start to LH64.

Booted from CD with no special parameters using the LH64 Mariner ISO.
Opted to allow std. installation of all SFS’s which took a little longer than I
expected, went to desktop and setup as expected, all seems fine.

Posting from LH64 now.

However, getting on to internet via wifi was a struggle, eventually successful but I’m not really sure exactly how.

Using a new laptop - e-machines (Acer) E732 with 2gig of ram and a i3-370M proc.

Used FD64-511 previously and was able to access internet via wifi with minimum difficulty (easily).

(JFYI - have not booted into Win7 64bit yet) but have booted Ice/Snow, Lupu, Wary and many derivatives of these - all from USB and SDcards and accessed internet via wifi with ease.

Personally, I like frisbee and pwireless and think they are excellent implimentations, however it took me over an hour to get connected.
(with much muttering and festering on my part).

I looked in PupControl to see if the std wireless and LAN connection tools or SNS were available to use - sadly no go there. I do appreciate that they may not sit comfortably with frisbee and pwireless.

Absolutely love GKrellM, Opera, the presentation and your overall choice of packages.

Your website and the attention to detail there plus the support you are offering is outstanding - many thanks - much appreciated.

Screenie and Hardinfo report attatched which hopefully with provide some useful info.

Many thanks again and very best regards - Ray.

Filename  hardinfo_report.html.tar.bz2 
Filesize  4.45 KB 
Downloaded  425 Time(s) 
Back to top
View user's profile Send private message 

Joined: 26 Nov 2006
Posts: 1327
Location: Chatswood, NSW

PostPosted: Sat 18 Jun 2011, 07:32    Post subject:
Subject description: Save file creation - success with LH64 & pfix=vesa,ram nomodeset

G'day tazoc,
Your magic code didn't work for me with IcePup015 but it does with LHP64.

First boot of my LHP64 CD with your extra parameters gave a distorted 1280x1084 display on this 1600x900 monitor under vesa but after using the Universal Installer to create a new Frugal install, on hitting Shut-down and re-boot, there was the "ol' faithful" Save file set-up.

I made a Save file and re-booted to the poor vesa display but was asked about booting some sfs files, so that looked like normality had returned.

Made a few small changes then re-booted and the changes were retained.
So then went to the display wizard and the xorgwizard started up the 1600x900 display using the radeon driver. Report-video reads:

"Lighthouse64, version 511 on Sat 18 Jun 2011
Chip description:
0.0 VGA compatible controller
ATI Technologies Inc Device 68f9
product: CEDAR 01.00
X Server: Xorg
Driver used: radeon
X.Org version: 1.9.0
dimensions: 1600x900 pixels (423x238 millimeters)
depth of root window: 24 planes"

And it now looks good - running Firefox to post this.

I hope this helps you, or someone somehow because it is still making what was a quick Frugal install process pretty long.

At least now I can try the extra boot parameters on the other non-Saving Pups, knowing they do work with at least one new Pup.

Thanks once more,

David S.
Back to top
View user's profile Send private message 

Joined: 19 May 2008
Posts: 2460
Location: Texas, USA

PostPosted: Sat 18 Jun 2011, 15:29    Post subject:
Subject description: OpenOffice 3.4

Hi Tazoc,

Oracle's OOO-3.4rc3 64 bit works great on LHP. I've not been successful getting the 3.4 64 bit version of LibreOffice to work. See attached image taken by radky's 64bit Pup Snap screen capture.

Back to top
View user's profile Send private message 

Joined: 14 Oct 2005
Posts: 6730
Location: Earth

PostPosted: Sun 19 Jun 2011, 12:29    Post subject: OOO or OpenOffice 3.4 in 64bit
Subject description: OpenOffice 3.4

Jim1911 wrote:
... Oracle's OOO-3.4rc3 64 bit works great on LHP
How does one get OOO into LH64? Sounds like something I would want to use.

Thanks in advance

Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engines or use DogPile
Back to top
View user's profile Send private message 
Ray MK

Joined: 05 Feb 2008
Posts: 778
Location: UK

PostPosted: Mon 20 Jun 2011, 10:49    Post subject:  

Hi again

Been running live for nearly 3 days with only the minor issue of frisbee taking what seems a little too long to get wpa_supplicant going and to eventually lock on to or allocate an IP: address for wifi.

It seems to take somewhere around 3 to 5 mins. after lifting the lid before wifi and therefore access to internet is available.

A fully populated desktop is up in seconds.

Acpi suspend/resume works as expected. (As it did in FD64-511)

Everything else seems better than fine.

After reading about some issues with creating a save_file, decided to try and all seemed to go well. Created a save_file of 512mb on the NTFS hard-disk.

Forgot to re-insert CD on reboot and Win7 started for the first time (aarrgghh), oh well - slow-ish but ok-ish.

Got over that and rebooted to LHP64 - save_file recognised ok and copied LH64.sfs from CD to hard-drive, and here I am.

However, the sfs’s that were previously in ram were gone - so loaded JRB’s
SFS-linker-2.2.pet and bingo, Opera etc loaded in seconds - brilliant.

So that’s about it for now - work to do - more later.

Many thanks again for a stonkingly good puppy to all involved.

Very best regards - Ray.
Back to top
View user's profile Send private message 

Joined: 14 Jun 2007
Posts: 298

PostPosted: Thu 23 Jun 2011, 01:12    Post subject:  L64 feedback  

Hi TazOC
I'm slow to pick this 64 bit version up - been on vacation for a while.
Happy to report that no problems getting L64 up and running on my Acer aspire Laptop with twin 64 bit processors. I did what I usually do:
Downloaded the Mariner .iso, checked the md5sum, made a directory in /Home for L64, mounted the .iso file and copied all of the system files and .sfs files to that directory, cloned the LHP503G entry in menu.lst to create a new entry for L64, and changed the directory names in the kernel and vmlinuz lines to point to files in the L64 directory. The boot parameters for me were:
psubdir=LHP64A pmedia=atahd pdev1=sda6 nmi_watchdog=0 pfix=fsck

I rebooted and made sure I edited the entry in the Grub list to pfix=ram for first boot, then pressed B to boot and "fingers crossed" it worked first time!

A very nice set up, new theme on the menu, frisbee worked flawlessly to set up my wifi connection. I love your "branding" of Firefox 4 with the custom lighthouse theme.

No problems creating a save file. I'm using ext3 for files and inside the save file right now but may move to ext4 when I fiddle the partitions around.

Impressions: I tried my usual subjective test - how fast does FF4 come up and load my Gmail? Very swiftly. At least as fast if not faster than fatdog64.
I tried the benchmarks and watched to CPU monitors in Gkrellmon. CPUZlib uses both processors (a very good comparison result) but the other tests seem to use only one processor, so no amazing gains there.

I can live without C-F and LXDE (which I use in 503G because it supports C-F) but Openbox is really all you need. Nice you've added icons on the shutdown menu to make it multi-purpose.

I'm running out of superlatives Taz. I'll continue testing as we go on.
Congratulations on a great "alpha".

Laptop: Acer Aspire 5810TZ
Back to top
View user's profile Send private message 

Joined: 15 Mar 2011
Posts: 103
Location: Québec

PostPosted: Thu 23 Jun 2011, 13:40    Post subject: Frugal Install  

Hi all,
For Puppy Linux, I always do frugal installs and never use the Universal Installer. There is no need. All you have to do is create a new directory, click on the iso and copy these files from the mounted iso to the new directory: initrd.gz, the sfs file(s) and the vmlinuz file.

Most of the time there is only one sfs file, but for Lighthouse there are more.

What could be simpler?


AA1 D255E-keucr slacko 5.3;luci;mijnpup; tw-os; with:Emacs,gawk,noteboxmismanager,treesheets, freeplane, libreoffice, tkoutline, Sigil, calibre, calendar. magic&Noteliner(wine), kamas (DOS)
Back to top
View user's profile Send private message 

Joined: 11 Dec 2006
Posts: 1157
Location: Lower Columbia Basin WA US

PostPosted: Fri 24 Jun 2011, 15:47    Post subject: L64_Update-511Au1.Pet
Subject description: Update 1 for Lighthouse 64-511 A

I just uploaded L64_Update-511Au1.pet. If no problems with it are reported this weekend, it will be made available via Lighthouse Update on Monday. This Pet will update Lighthouse 64 5.11 A to 5.11 Au1:
  • Updated PupClockset to work with LXPanel in Openbox (thanks to radky) and updated LXPanel configuration. Previous panel configuration (/root/.config/lxpanel/default/panels/panel) saved to /root/.config/lxpanel/default-panel.bak.

  • For screens heights of less than 1024 (e.g., 1366/1024x768, 1024x640) removed 'Zip' icon, raised missing Xlock and Trash icons to lower right corner of screen. Might still need some adjustment, but these 2 icons should at least be visible now (after X restart.)

  • Xdelta3GUI updated for urxvt to fix failure to apply xdelta updates.

  • xwin: Always show CL tip for xorgwizard-puppy, (thanks to Roy) (X restart required)
    pfix=xorgwizard uses full interactive dialog--xorgwizard-puppy.

  • xorgwizard, xorgwizard-puppy:
    CL: autostart xwin at completion, unless <TEST> button was pressed.
    GUI: fixed failure to start xorgwizard-puppy from Xorgwizard GUI.

  • Hardware detection: added /etc/modprobe.d/blacklist.conf. Should prevent some conflicts with certain kernel modules. Reboot to test this. If any new problems arise, delete /etc/modprobe.d/blacklist.conf and reboot.

  • New / updated: Frugal-symlink 0.6, Lighthouse sys-info 0.5, SFS Grabber 0.1-L1, (thanks to 01-micko and Jim1911) xdriinfo-x86_64

  • Report-video 0.4, report-video-glx 0.4: improved current video driver detection, (thanks to the logs posted by Roy. They were indispensable! Smile)

  • Personalize Settings bug fix: /etc/hosts wasn't updated with new host name, (thanks to pemasu, shinobar). Improved current video driver detection and NLS console fonts. CL dialog UTF-8 test script in /lib/consolefonts.

  • Networking: fixed button in Connect Wizard which starts Puppy's Network Wizard
    ipinfo: display updated host name without restarting Lighthouse, (thanks to gcmartin.)
    Frisbee: connect-lhp script: refined link detection function.

  • PupControl fontsize support and PupShutdown logout panel layout improvement, (thanks to radky.)

  • /root/.xinitrc updated to support different LXPanel restart scripts.

  • Extract-txz script updated to support tar.xz archives.
A couple of Pets: VirtualBox, VLC and Samba coming also...

lhpup.org Lighthouse 64 6.02
Back to top
View user's profile Send private message Visit poster's website 

Joined: 15 Mar 2011
Posts: 103
Location: Québec

PostPosted: Fri 24 Jun 2011, 16:21    Post subject: Experience  

Hi Tazoc,
After running Lighthouse 64 for awhile, am finding some issues with the boot-up and Firefox.

At boot-up, since have 12 partitions, really don't feel like going through the e2fsk routine every time I boot up. Where can I mod this to only run e2fsk every 20 times, say?

The other problem experiencing is with Firefox. Initially it was fast and responsive. Now it is has become slow and sluggish. The extensions I have are:

Adblock Plus + 2 helpers (pop-ups and element),
Autopager Lite,
Canadian English dictionary,
Dictionnaire classique (French),
Ghostery (with no alerts showing),
Dutch dictionary.


AA1 D255E-keucr slacko 5.3;luci;mijnpup; tw-os; with:Emacs,gawk,noteboxmismanager,treesheets, freeplane, libreoffice, tkoutline, Sigil, calibre, calendar. magic&Noteliner(wine), kamas (DOS)
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 6 [90 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0805s ][ Queries: 13 (0.0068s) ][ GZIP on ]