Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 31 Jul 2014, 18:07
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
SCIM won't switch input language OpenOffice SFS [WORKAROUD]
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [1 Post]  
Author Message
ShellyCat

Joined: 13 May 2011
Posts: 39
Location: USA

PostPosted: Tue 17 May 2011, 02:28    Post subject:  SCIM won't switch input language OpenOffice SFS [WORKAROUD]
Subject description: Re: openoffice-3.1.1-sfs4.sfs, Quickset Puppy Linux, SCIM, languages
 

Edit: Maybe I was wrong that merely being able to paste and save Japanese in OpenOffice.org meant the OpenOffice language pack was installed...or maybe the problem was something else.

In any case, I didn't realize that Shinobar had created his own SFS for this. So I used his instead, specifically: openoffice-3.1.1JP_wJRE1.6.0_17-sfs4.sfs.

His SFS worked out-of-the-box!



Hello! I am using Quickset Puppy Linux (bilingual), based off Puppy 4.3.1 Japanese Edition, as shown in my sig.

I just downloaded the SFS file openoffice-3.1.1-sfs4.sfs from http://distro.ibiblio.org/puppylinux/sfs4_modules-4/. (SFS files are yet another way to "package" software per Barry on the Puppy home page. You just configure the bootmanager to load it and then reboot Puppy, and it acts as though the OOo were on the CD.)

SCIM/Anthy comes as part of this Puppy, and already works with other applications (Seamonkey, Geany). At first the button didn't even appear in the system tray when I started OOo Writer, even after I enabled "Asian" in the "Language" section of "Options." However, I closed and opened OOo again, and the SCIM button now shows up. However, I cannot actually change the input language in OOo!

I have 'Alt' + '+' configured to switch to Japanese input via Anthy. I have 'Alt' + '-' configured to switch back to English/European. These are the shortcuts I use with other programs. The OpenOffice.org help manual has several pages about keyboard shortcuts...as far as I can see, these shortcuts are not already used in OOo. However, they have no effect.

I wondered if maybe the OpenOffice SFS does not have the language packs installed, but I was able to type Japanese in another application and paste it. Saving and re-opening the document, the characters display correctly.

Is there something else I need to do to get the OpenOffice SFS to work with SCIM? Are language packs not included with the SFS? Or will SCIM just not work with SFS packages?

_________________
Puppy Distro: pup-431JPqs3 "Quickset Puppy Linux (Japanese/English bilingual)"
Previous distros: Slackware (preferred), Fedora Core 6 (in school), Ubutntu (not much)
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [1 Post]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0403s ][ Queries: 12 (0.0037s) ][ GZIP on ]