Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 23 Oct 2014, 11:09
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Bibletime Bible study tool
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 4 [47 Posts]   Goto page: 1, 2, 3, 4 Next
Author Message
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Sat 19 Mar 2011, 16:40    Post subject:  Bibletime Bible study tool
Subject description: A powerful Bible study tool for Linux
 

BibleTime is a powerful cross platform Bible study tool. It uses the SWORD programming library to work with Bible texts, commentaries, dictionaries and books provided by the CrossWire Bible Society.

It is one of the best free Bible study tools that is available for linux.

The latest Lucid 5.2 makes it easy to install. Just open Quickpet>Sfs Get and install Bibletime_Lucid.

Lighthouse Pup also has Bibletime, go here and download Bibletime-2.7.2b.sfs, place it in /mnt/home and select it with the bootmanager.

Note: There is a later version, Bibletime-2.8 available, however, there is a bug that prevents it from using all available sword modules. I recommend that only Bibletime-2.7.2 be used with puppy for the present.
Back to top
View user's profile Send private message 
Ben

Joined: 02 Mar 2011
Posts: 10

PostPosted: Tue 12 Apr 2011, 12:16    Post subject: Re: Bibletime Bible study tool
Subject description: A powerful Bible study tool for Linux
 

Jim1911 wrote:
The latest Lucid 5.2 makes it easy to install. Just open Quickpet>Sfs Get and install Bibletime_Lucid.

Hello Jim,
thank you very much. The installation worked very well under Lucid 5.2.

Please note the screenshot with the WLC module (Hebrew). How do I resolve these squares?

Many greetings.
Ben
bibletime-wlc.png
 Description   BibleTime screenshot with the Westminster Liningrad Codecs (WLC) and a font bug
 Filesize   187.92 KB
 Viewed   1617 Time(s)

bibletime-wlc.png

Back to top
View user's profile Send private message 
eztuxer


Joined: 06 Nov 2008
Posts: 483
Location: Belgium

PostPosted: Sun 17 Apr 2011, 16:35    Post subject:    

Thanks for this great .pet !

I like and use it a lot.

BUT : It never fails, as soon as installed on any 520 based puplet, Mplayer ceases to work ... Sad

Please HELP !

_________________
Don't poop it down... Pup it Up ! http://pupitup.org/
Back to top
View user's profile Send private message Visit poster's website 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Mon 18 Apr 2011, 12:05    Post subject:  

Hi, Sorry about late reply, but I've not had access to my desktop computer for about a month.

@Ben, I have no ideas concerning your problem, other than trying another installation and downloading the problem module again. I have had a similar problem that was corrected by a new installation and re-downloading the modules.

@eztuxer, I cannot duplicate your problem, it doesn't appear to be related to Bibletime. It's possibly due to another program that you have installed. Have you tried Bibletime as the first program to be installed to your Lucid installation? Incidently, are you using a full hd installation of Lucid, otherwise, you are not using a Lucid .pet file? Quickpet only has an sfs version of Bibletime.

Regards,
Jim

_________________
Favorites: Lighthouse 64 and Lucid + theWord
Back to top
View user's profile Send private message 
eztuxer


Joined: 06 Nov 2008
Posts: 483
Location: Belgium

PostPosted: Mon 18 Apr 2011, 15:19    Post subject:  

Hi Jim,

Thanks for your reply.
I'm using the bibletime.pet, not the .sfs although I've tried both before.
I have both an HDD install on puppy studio (3.3, 520 based), and puppy 520, plus an USB stick install of puppy 5.2.5 and on that one I installed bibletime.pet as first additional software to narrow down the investigation.
In the meantime, I have added xcine and VLC players as a work around, but I use jubler subtitle editor with built in player that use inbeded mplayer.
So I use 2 different puppies, one with jubler, and one with bible time...
I'll look around if I could redefine another player for jubler, but this might involve coding way beyond my learning curve position at this moment.

http://jubler.org/

Yahweh bless, Yves

_________________
Don't poop it down... Pup it Up ! http://pupitup.org/
Back to top
View user's profile Send private message Visit poster's website 
eztuxer


Joined: 06 Nov 2008
Posts: 483
Location: Belgium

PostPosted: Mon 18 Apr 2011, 15:24    Post subject:  

Come to think of it: Could this be Java related ? I have the jre-1.6.0.22.pet installed for jubler.
_________________
Don't poop it down... Pup it Up ! http://pupitup.org/
Back to top
View user's profile Send private message Visit poster's website 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Tue 19 Apr 2011, 09:59    Post subject:  

Hi eztuxer,

I'm not aware of any .pet, developed for use by Lucid, other than the one that 01micko generates for Lucid using his SFS grabber.

I still suspect that some other program is causing your sound problem. I don't believe that java is the problem since I also use it without problem. Possible, the java Bible applications, Alkitab or BibleDesktop, may suit your needs as an alternative to Bibletime. They use the same opensource Crosswire Sword resources that are used by Bibletime. You'll find a thread on both of these in the Howto section.

Regards,
Jim

_________________
Favorites: Lighthouse 64 and Lucid + theWord
Back to top
View user's profile Send private message 
Ben

Joined: 02 Mar 2011
Posts: 10

PostPosted: Wed 20 Apr 2011, 10:47    Post subject: Fonts or Font parts not installed / supported ?  

Jim1911 wrote:
Hi, Sorry about late reply, but I've not had access to my desktop computer for about a month.

No problem. I'm glad anyway, that you made it back. BibleTime is quite an important tool for me Smile . Thank you.

Jim1911 wrote:
@Ben, I have no ideas concerning your problem, other than trying another installation and downloading the problem module again. I have had a similar problem that was corrected by a new installation and re-downloading the modules.

That doesn't seem to work. It happens with several modules, as if certain fonts are not recognized / displayed. Same problem with module Syriac Vocalized Peshittah. Is there a central place, where fonts need to be installed? Question
Many greetings,
Ben:)
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Wed 20 Apr 2011, 17:47    Post subject:  

Hi Ben,

Sorry, that's above my skill level. Consider starting a new thread concerning the font issue, possibly ttuuxxx or someone may have ideas on how to solve it.

Have you tried theWord or e-Sword using Wine, maybe they don't have the font issue, both are fine programs and of course there are some good java applications, Alkitab and BibleDesktop.

Regards,
Jim

_________________
Favorites: Lighthouse 64 and Lucid + theWord
Back to top
View user's profile Send private message 
Ben

Joined: 02 Mar 2011
Posts: 10

PostPosted: Thu 21 Apr 2011, 05:47    Post subject: Will try your suggestions later
Subject description: font issue with semantic languages in BibleTime
 

Jim1911 wrote:
...Consider starting a new thread concerning the font issue ... Have you tried theWord or e-Sword using Wine, maybe they don't have the font issue, both are fine programs and of course there are some good java applications, Alkitab and BibleDesktop.

Hello Jim,
that is a good idea. Thank you for your efforts anyway. Ok, first, I'll try to dig into threads about installing / using Wine, when I get the time. It was just a good thing to have the Bible Time in the package manager next to other usefull programms for easy install.
Cheers,
Ben:)
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Thu 21 Apr 2011, 12:11    Post subject:  

Hi Ben,

Check these threads for assistance e-Sword installation and theWord.

Regards,
Jim

_________________
Favorites: Lighthouse 64 and Lucid + theWord
Back to top
View user's profile Send private message 
Ben

Joined: 02 Mar 2011
Posts: 10

PostPosted: Fri 22 Apr 2011, 11:10    Post subject: installation assistance
Subject description: wine e-Sword The Word
 

Hello Jim,
thank you for the links. Have to check them later. Would have been nice to not having to install wine. Maybe I'll try Lighthouse instead of lucid and see, how the Hebrew or Syriac font show up there in BibleTime.
Thankful
Ben:)
Back to top
View user's profile Send private message 
joe0855

Joined: 05 Oct 2010
Posts: 60
Location: Raleigh, North Carolina, U.S.A.

PostPosted: Tue 20 Sep 2011, 23:44    Post subject:  

Hey Jim1911,

Bibletime worked on my copy of Puppy 5.2.5. However I just bought a new laptop that did not like 5.2.5 or 5.2.8 for that matter (HW driver support issues). Long story short, I'm running Fatdog64 which works well with my new laptop. However when I install the Bibletime SFS or pet (tried Bibletime_lucid-2.7.2a.sfs, Bibletime-2.7.2-Lucid.pet), I am missing many libs. I started adding the missing libs until replacing 'libstdc++.so.6' caused my OS to no longer boot up properly. Have your ever tried Bibletime on Fatdog64? Would you suggest a better way to approach this method? Not familiar with compliling, but willing. Thanks!
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Wed 21 Sep 2011, 10:56    Post subject:  

joe0855 wrote:
Hey Jim1911,

Bibletime worked on my copy of Puppy 5.2.5. However I just bought a new laptop that did not like 5.2.5 or 5.2.8 for that matter (HW driver support issues). Long story short, I'm running Fatdog64 which works well with my new laptop. However when I install the Bibletime SFS or pet (tried Bibletime_lucid-2.7.2a.sfs, Bibletime-2.7.2-Lucid.pet), I am missing many libs. I started adding the missing libs until replacing 'libstdc++.so.6' caused my OS to no longer boot up properly. Have your ever tried Bibletime on Fatdog64? Would you suggest a better way to approach this method? Not familiar with compliling, but willing. Thanks!
Hi Joe,

I've not been successful installing Bibletime to Fatdog. I don't know if there is a 64-bit version for you to try compiling. I recommend that you consider theWord, a Windows program which IMHO is the best free Bible software available. With Fatdog, I personally use Windows versions of BibleAnalyzer, eSword, and theWord. The only reason I keep eSword is that is has a purchased NASB version which is one of my favorites.

Regards,
Jim

_________________
Favorites: Lighthouse 64 and Lucid + theWord
Back to top
View user's profile Send private message 
L18L

Joined: 19 Jun 2010
Posts: 2525
Location: Moved from Hosla to www.eussenheim.de

PostPosted: Wed 21 Sep 2011, 15:26    Post subject: Re: Fonts or Font parts not installed / supported ?  

Ben wrote:
Jim1911 wrote:
Hi, Sorry about late reply, but I've not had access to my desktop computer for about a month.

No problem. I'm glad anyway, that you made it back. BibleTime is quite an important tool for me Smile . Thank you.

Jim1911 wrote:
@Ben, I have no ideas concerning your problem, other than trying another installation and downloading the problem module again. I have had a similar problem that was corrected by a new installation and re-downloading the modules.

That doesn't seem to work. It happens with several modules, as if certain fonts are not recognized / displayed. Same problem with module Syriac Vocalized Peshittah. Is there a central place, where fonts need to be installed? Question
Many greetings,
Ben:)

Hi Ben & Jim,

Here is a font with fixed width, should render Hebrew, too. I think

Hope this helps

Cheers
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 4 [47 Posts]   Goto page: 1, 2, 3, 4 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0868s ][ Queries: 13 (0.0043s) ][ GZIP on ]