Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 23 Nov 2014, 03:46
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Wifi adapter D-link DWA-140 not being detected
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [13 Posts]  
Author Message
Dimka

Joined: 04 Jan 2011
Posts: 2

PostPosted: Tue 04 Jan 2011, 20:23    Post subject:  Wifi adapter D-link DWA-140 not being detected  

Hello all,

I installed macpup 511 (I believe it's based on this distro?), it seems the OS doesn't detect my wifi adapter. It's a USB D-link DWA-140.

There is eth0 (wired lan) but no other ethX interfaces.
I tried manually load different drivers but didn't work...

Even tried some related commands, and here is the result:


Can anyone help?
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5285
Location: Australia

PostPosted: Tue 04 Jan 2011, 22:00    Post subject:  

Dimka wrote:
I installed macpup 511 (I believe it's based on this distro?)

Yes, it is based on this distro, but "puplet developers" often change the technical underpinnings of official Puppies, sometimes without even realising it, and it's near-impossible for we users of official Puppies to guess what they have done. Your request for help would be most appropriate in the thread dedicated to Macpup -
http://www.murga-linux.com/puppy/viewtopic.php?t=62013
They built it, they should know how to fix it.

Dimka wrote:
Even tried some related commands ...

The "related" command you have illustrated is "lsmod".

Dimka wrote:
it seems the OS doesn't detect my wifi adapter.
Code:
usbcore    91279  8 rt2870sta,rt2800usb, ...

Well actually the OS does detect your wifi adapter - two competing drivers have loaded for it; rt2870sta and rt2800usb.
And that's quite possibly your problem. You could probably fix the problem to going to -
Menu > System > BootManager configure bootup > Give preference to one module over another:
Then you should set preference to the more advanced rt2870sta driver ...

... but ultimately, this is for the Macpup developers to determine.
Back to top
View user's profile Send private message 
Dimka

Joined: 04 Jan 2011
Posts: 2

PostPosted: Wed 05 Jan 2011, 07:26    Post subject:  

Thanks! setting preference was the issue, I just added the line "rt2800usb:rt2870sta" and it detected it as wlan0.

I had some problems with connection, but after tinkering with it, seems ok now.
Back to top
View user's profile Send private message 
Gooner

Joined: 09 Apr 2011
Posts: 5

PostPosted: Sat 09 Apr 2011, 13:05    Post subject:  

Hi

I have the same D-link DWA-140 wireless usb adapter which i can't get to work with Puppy 5.1.1.

I've installed the rt2870sta driver but its not working.

Any help would be appreciated.

I've attached a screenshot of my lsmod below.
wireless1.png
 Description   
 Filesize   2.28 KB
 Viewed   1183 Time(s)

wireless1.png

Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5285
Location: Australia

PostPosted: Sat 09 Apr 2011, 21:17    Post subject:  

You should do the same fix as Dimka did.
Back to top
View user's profile Send private message 
Gooner

Joined: 09 Apr 2011
Posts: 5

PostPosted: Mon 11 Apr 2011, 04:03    Post subject:  

I would but he didn't say what the tinkering was that he did.
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5285
Location: Australia

PostPosted: Mon 11 Apr 2011, 04:12    Post subject:  

Five posts earlier:
tempestuous wrote:
You could probably fix the problem by going to -
Menu > System > BootManager configure bootup > Give preference to one module over another:
Then you should set preference to the more advanced rt2870sta driver ...


Four posts earlier:
Dimka wrote:
Thanks! setting preference was the issue, I just added the line "rt2800usb:rt2870sta"
Back to top
View user's profile Send private message 
Gooner

Joined: 09 Apr 2011
Posts: 5

PostPosted: Mon 11 Apr 2011, 07:13    Post subject:  

I did try that. That alone didn't work. I think its the tinkering with the connection that he referred to afterwards that might fix it.
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5285
Location: Australia

PostPosted: Tue 12 Apr 2011, 04:21    Post subject:  

As I'm currently discussing in several other threads, you need to experiment with different forms of encryption at the wifi router, and also whether your router's SSID should be "un-hidden".
Back to top
View user's profile Send private message 
Gooner

Joined: 09 Apr 2011
Posts: 5

PostPosted: Tue 12 Apr 2011, 09:13    Post subject:  

Does the wireless adapter have to be detected 1st?
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5285
Location: Australia

PostPosted: Tue 12 Apr 2011, 09:48    Post subject:  

Yes. The Network Wizard should indicate that you have a valid wifi interface, probably called "wlan0".

It's starting to sound like you don't have exactly the same device as forum member Dimka, and Google tells me that there are at least 4 different versions of the DWA-140. It's at the point where we really need to identify your device. Please run this command -
Code:
cat /proc/bus/usb/devices

and report the "Vendor" and "ProdID" values for your wifi device.
Back to top
View user's profile Send private message 
Gooner

Joined: 09 Apr 2011
Posts: 5

PostPosted: Sat 08 Oct 2011, 08:11    Post subject:  

Vendor=07d1 ProdID=3c0a

The version of Puppy Linux is Wary 5.1.1.
Thanks.
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5285
Location: Australia

PostPosted: Sat 08 Oct 2011, 08:55    Post subject:  

Wow, it took you 5 months to respond!

Gooner wrote:
Vendor=07d1 ProdID=3c0a
The version of Puppy Linux is Wary 5.1.1.

Ralink rt3070sta wifi driver for Wary here -
http://murga-linux.com/puppy/viewtopic.php?p=546364#546364

or for Lucid Puppy 5.1 - 5.2.8 here -
http://www.murga-linux.com/puppy/viewtopic.php?p=513360#513360
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [13 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0727s ][ Queries: 13 (0.0100s) ][ GZIP on ]