Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 18:21
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Virtualization
VirtualBox for many Puppies
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 3 of 13 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, ..., 11, 12, 13 Next
Author Message
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Fri 08 Apr 2011, 17:46    Post_subject:  

Darkgame wrote:
ive wanted to use vbox on puppy, for a 'portable' gamimg usb drive.
How do u install from sfs?
Or can anyone make or upload the pet version?
I saw it once,4.0.0, but i deleted by pupsave by accident and the pet is now gone?!

With a frugal installaion (when Puppy has a savefile), you just place the SFS in the folder "/mnt/home/" and go to the boot manager (in the menu, "MENU --> System --> BootManager") and select which will load when Puppy starts up.

If you still want a PET, though, I can slap one together later and upload it. (All my packages are available as PETs, but I've removed versions 4.0.0 and 4.0.4 since uploading 4.0.4. I can always make an older version available again for limited downloads.)

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
Darkgame

Joined: 18 Mar 2011
Posts: 203

PostPosted: Sat 09 Apr 2011, 08:53    Post_subject:  

thanks, but nevermind. Ive got it from quickpet and now im playing warcraft 3
Back to top
View user's profile Send_private_message 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Sat 09 Apr 2011, 11:58    Post_subject:  

Darkgame wrote:
thanks, but nevermind. Ive got it from quickpet and now im playing warcraft 3

Glad to hear it's worked out!
Back to top
View user's profile Send_private_message Visit_website 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Sun 01 May 2011, 03:39    Post_subject:  

Alright, everyone. I've made up some packages for 4.0.6. Audio issues with Lucid 525 are worse than ever, though- no sound options work at all. Still seems fine with everything else, though, and 4.0.4 and 3.2.8 can still be made to serve up working audio on 525.

I'll be uploading those later this morning.

(One change I could find: something called "balloon-ctrl" is now in VBox, and I have no idea what it is. It's also either very new or obscure, because web searches didn't help either. If anyone knows what the heck this is, I'm very curious to find out.)

I'll probably also eliminate most of the 4.0.4 packages, except for those Puppy versions which don't work or work albeit more poorly with 4.0.6. (525 with its audio issues comes to mind.)


Be back soon!
Back to top
View user's profile Send_private_message Visit_website 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Sun 01 May 2011, 21:22    Post_subject: UPDATE  

Updated packages to version 4.0.6.

Slight organizational update was also carried out, and is still in progress for older packages.
Back to top
View user's profile Send_private_message Visit_website 
Brown Mouse


Joined: 09 Jun 2009
Posts: 449
Location: Tenerife Canary Islands

PostPosted: Mon 02 May 2011, 09:48    Post_subject:  

TheAsterisk! wrote:
Alright, everyone. I've made up some packages for 4.0.6. Audio issues with Lucid 525 are worse than ever, though- no sound options work at all. Still seems fine with everything else, though,


I just installed your new 4.0.6 as host to Lucid 520 and ran Lucid 525 as guest with perfect sound.Your getting there.Well done Very Happy
Back to top
View user's profile Send_private_message 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Tue 03 May 2011, 12:05    Post_subject:  

Brown Mouse wrote:
I just installed your new 4.0.6 as host to Lucid 520 and ran Lucid 525 as guest with perfect sound.Your getting there.Well done Very Happy

Oh, it very well may work as a guest. 525's audio issues (the ones I mentioned, anyway) were with 525 as a host.

Anyway, thanks!
Back to top
View user's profile Send_private_message Visit_website 
gcmartin

Joined: 14 Oct 2005
Posts: 4368
Location: Earth

PostPosted: Sat 07 May 2011, 14:48    Post_subject: FATDOG version  

TheAsterisk! wrote:
... Oh, it very well may work as a guest. 525's audio issues (the ones I mentioned, anyway) were with 525 as a host. ...
Is there a PET for FATDOG?
Thanks.

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile
Back to top
View user's profile Send_private_message 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Sat 14 May 2011, 10:51    Post_subject: Re: FATDOG version  

gcmartin wrote:
TheAsterisk! wrote:
... Oh, it very well may work as a guest. 525's audio issues (the ones I mentioned, anyway) were with 525 as a host. ...
Is there a PET for FATDOG?
Thanks.

No, sorry. I don't have a 64-bit computer to run Fatdog on, and my computers don't have enough muscle to run a full-fledged emulator. (A big VM is pushy it pretty far for me, honestly.)

Having said that, the 32-bit installer runs as it is from Oracle's site, so if you load the devx and kernel source for Fatdog then run the 64-bit installer, you might be able to install it that way.

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
KusaNoKaito


Joined: 19 Feb 2010
Posts: 99
Location: Florida

PostPosted: Tue 24 May 2011, 06:28    Post_subject:  

I'm using Lucid Puppy 5.1.1 and when running /etc/init.d/vboxdrv setup, all I get is this:

Code:
WARNING: Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/.
Stopping VirtualBox kernel modules ...done.
Uninstalling old VirtualBox DKMS kernel modules/etc/init.d/vboxdrv: line 284: /opt/VirtualBox/src/vboxhost/do_dkms: No such file or directory
 ...done.
Trying to register the VirtualBox kernel modules using DKMS/etc/init.d/vboxdrv: line 302: /opt/VirtualBox/src/vboxhost/do_dkms: No such file or directory
 ...failed!
  (Failed, trying without DKMS)
Recompiling VirtualBox kernel modules ...failed!
  (Look at /var/log/vbox-install.log to find out what went wrong)


I ideas?

_________________
Puppy Packages
My Website
Back to top
View user's profile Send_private_message Visit_website 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Wed 03 Aug 2011, 17:31    Post_subject:  

KusaNoKaito wrote:
I'm using Lucid Puppy 5.1.1 and when running /etc/init.d/vboxdrv setup, all I get is this:

Code:
WARNING: Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/.
Stopping VirtualBox kernel modules ...done.
Uninstalling old VirtualBox DKMS kernel modules/etc/init.d/vboxdrv: line 284: /opt/VirtualBox/src/vboxhost/do_dkms: No such file or directory
 ...done.
Trying to register the VirtualBox kernel modules using DKMS/etc/init.d/vboxdrv: line 302: /opt/VirtualBox/src/vboxhost/do_dkms: No such file or directory
 ...failed!
  (Failed, trying without DKMS)
Recompiling VirtualBox kernel modules ...failed!
  (Look at /var/log/vbox-install.log to find out what went wrong)


I ideas?


The binary packages for different Puppy versions don't include the sources to compile the kernel drivers; I cut them out to save some size. That's why it complains the files aren't present.

If things work properly, you shouldn't need to compile them. (You should be using the package "virtualbox-4.0.6-k2.6.33.2.lupu5.pet" if you're running Lucid 511 with the regular kernel, by the way.)

If you do need to compile the kernel drivers, though, you can always download the "virtualbox-4.0.6-all_kernels.pet" package, which does not include already-compiled drivers but still has the source included in the package, and which will compile the drivers during installation of the dot-pet. (Just make sure you have the kernel source module and devx module installed for your Puppy version.)
(Lucid Puppy's kernel source is here.)

I am preparing packages for VBox version 4.1.0 as we speak. The "all_kernels" package has already been prepared and uploaded. I'll update the thread title and post once everything is in place.
In the meantime, if you want to get started right away (Cool), you can go to http://www.silverdollarsolutions.com/PuppyLinux/asterisk/VirtualBox/VBox-4.1.0/, but you'll have to fend for yourself until I've uploaded the HTML guide page.

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Sat 20 Aug 2011, 19:55    Post_subject:  

Nevermind version 4.1.0. I ended up skipping right past it, for the most part! Smile

Updated to version 4.1.2
Please see the first post for more details.
Back to top
View user's profile Send_private_message Visit_website 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Sun 28 Aug 2011, 01:54    Post_subject:  

I went in and cleaned up (well, a little bit) the scattered HTML pages I had to sort through the packages. It should be a little simpler now.

I also added another simple page the just lists the different packages, because there are some Puppy versions covered only by older packages, namely a few Wary and Quirky releases. It can be easy to just look at the latest VBox page, see nothing for your Puppy and give up.

It's accessible from the main page I link to at the beginning of the thread, and here: all_paks.html

Looking at it, I'm considering deleting all of 4.0.0, 4.0.2, 4.0.4, and 4.1.0. They offer nothing extra in features or compatibility/lack of bugs next to the rest, and I have no packages exclusive to them in terms of kernel or Puppy version, so I don't see the point in hanging on to them. (The rest would remain available, even 3.1.4.) Let me know if anyone needs those packages, otherwise I'll probably delete them in a week or two to save some space.
Back to top
View user's profile Send_private_message Visit_website 
drblock2

Joined: 19 Jan 2009
Posts: 141

PostPosted: Wed 07 Sep 2011, 04:55    Post_subject:
Sub_title: VirtualBox 4.1.0 in slacko beta2
 

Asterisk! and Geoffrey - Many thanks.

I have been experimenting with Slacko beta 2, which has the 2.6.37.6 kernel. I downloaded VirtualBox-4.1.0-73009-Linux_x86.run from virtualbox.org, installed the devx file and the kernel sources. VBox compiled with no problems but refused to run because of missing library files.

I had the SDL-1.2.14-i486 package already installed for DosBox so I just downloaded Geoffrey's quirky1.20-libGLU.tar.gz and unpacked the contents into /usr/lib.

Worked perfectly, sound and all.

Keep up the good work!
Back to top
View user's profile Send_private_message 
gcmartin

Joined: 14 Oct 2005
Posts: 4368
Location: Earth

PostPosted: Wed 07 Sep 2011, 19:46    Post_subject:  

Removed Placeholder
_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile

Edited_time_total
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 3 of 13 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, ..., 11, 12, 13 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Virtualization
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0913s ][ Queries: 13 (0.0063s) ][ GZIP on ]