Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 01 Sep 2014, 07:48
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Games
mupen64plus-1.99.4
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [10 Posts]  
Author Message
sc0ttman


Joined: 16 Sep 2009
Posts: 2376
Location: UK

PostPosted: Mon 21 Mar 2011, 19:14    Post subject:  mupen64plus-1.99.4
Subject description: N64 emulator
 

Mupen64plus-1.99.4 - N64 emulator

Homepage - http://code.google.com/p/mupen64plus/

Needs SDL, and OpenGL installed and working.

I have compiled this on Puppy 4.2, I think it needs checking.
It is a first attempt, and should be considered for testing only.

This one does not support zipped rom files (not sure why).

There is no GUI. To use it, open a terminal and type:
Code:
mupen64plus /path/to/romfile


PLEASE REPORT YOUR TESTING HERE, IF YOU USE THIS
mupen64plus-extraplugins-linux32-1.99.4.tar.gz
Description  extra plugins
gz

 Download 
Filename  mupen64plus-extraplugins-linux32-1.99.4.tar.gz 
Filesize  497.98 KB 
Downloaded  396 Time(s) 
mupen64plus-1.99.4-pup4.pet
Description 
pet

 Download 
Filename  mupen64plus-1.99.4-pup4.pet 
Filesize  1.4 MB 
Downloaded  759 Time(s) 

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search

Last edited by sc0ttman on Tue 22 Mar 2011, 13:59; edited 1 time in total
Back to top
View user's profile Send private message 
Makoto


Joined: 03 Sep 2009
Posts: 1793
Location: Out wandering... maybe.

PostPosted: Mon 21 Mar 2011, 19:41    Post subject:  

Quote:
This one does not support zipped rom files (not sure why).


Probably something to do with zlib, I'm sure - I think your VBA/-M .pets have the same issue. Sad Maybe they require a specific version of zlib to be installed (or even compiled into the program)?

I'll have to give this a try... maybe it won't freeze the system on me like the previous version. Embarassed Although with the number of possible buttons (including pad directions) on an N64 controller, figuring out the default keys is always fun. Razz

Edit: I just keep getting this:
Code:
dlopen('./libmupen64plus.so.2') error: ./libmupen64plus.so.2: cannot open shared object file: No such file or directory
AttachCoreLib() Error: failed to find Mupen64Plus Core library


...even though the symlink and actual lib are indeed in /usr/lib/ - is it looking for them in a different directory, like the root directory? I've tried running it from both /my-documents/tmp/ and /usr/bin/, with the same result.

Edit 2: More tests. Placing an absolute (temporary) link to the lib in the root folder (with the name libmupen64plus.so.2) gives the same error. Moving it to the current folder (from which I'm executing the mupen64plus command) changes the error to this:

Code:
dlopen('./libmupen64plus.so.2') error: ./libmupen64plus.so.2: undefined symbol: SDL_JoystickOpened
AttachCoreLib() Error: failed to find Mupen64Plus Core library

_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2376
Location: UK

PostPosted: Tue 22 Mar 2011, 04:48    Post subject:  

Hey Makoto... Hope you're well... Thanks for testing...

Definitely worth a test, as I don't get ANY of those errors - although I've yet to get past the "SDL_SetVideoMode: could not create GL context" (even thuogh OpenGL is enabled)...

But thanks for checking... I guess I will spend a few hours today trying to track down the problems! Not sure why you get them..

If anyone else wants to test, and tell if what errors they get (if any), that would be great...

About zlib, I even compiled and installed that latest zlib when I made this (as I did with SDL as well)... So I will look at the 'configure' options again, see what I missed.

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send private message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2376
Location: UK

PostPosted: Tue 22 Mar 2011, 13:14    Post subject:  

Makoto, which version of SDL are you using?
Maybe this version of Mupen requires SDL 1.2.9, which can be found here: http://ppm.scottjarvis.com/libs/sdl/sdl-1.2.9.pet

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send private message 
Makoto


Joined: 03 Sep 2009
Posts: 1793
Location: Out wandering... maybe.

PostPosted: Tue 22 Mar 2011, 14:17    Post subject:  

Yeah, I was wondering if it was still rather picky about the version of SDL installed, as you mentioned. I'd already removed all those SDL packages I had installed, and only have a single 1.2.13 package installed, now.

I'm not sure that would cause the weird behavior (on my system) with Mupen being unable to either find its libs, or know what to do with them, though. Very Happy It could possibly have something to do with the SDL errors you're receiving (did you install your .pet and the errors stop?)

_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2376
Location: UK

PostPosted: Tue 22 Mar 2011, 14:25    Post subject:  

Makoto wrote:
Yeah, I was wondering if it was still rather picky about the version of SDL installed, as you mentioned.

Seems so...

Makoto wrote:
I'm not sure that would cause the weird behavior (on my system) with Mupen being unable to either find its libs, or know what to do with them, though. Very Happy

I agree... Not SDL related, and still puzzling me... Embarassed

Makoto wrote:
It could possibly have something to do with the SDL errors you're receiving (did you install your .pet and the errors stop?)

I am just about to test a new SDL package, having found that my SDL setup was not quite right at the time of posting... I installed a different SDL .pet and AssaultCube started working again...

So, I think this SDL package is a good one: http://ppm.scottjarvis.com/libs/sdl/SDL-1.2.14-i486.pet

I'm gonna test Mupen now, as I I have the above SDL package installed at the moment, and I will let everyone know how it goes.

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send private message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2376
Location: UK

PostPosted: Tue 22 Mar 2011, 14:30    Post subject:  

Woooooo, it works.... Very Happy

I have linked to the SDL package which works for me in the first post (it's the one above).
If you have problems, try the SDL download there or in the main post.

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send private message 
Makoto


Joined: 03 Sep 2009
Posts: 1793
Location: Out wandering... maybe.

PostPosted: Tue 22 Mar 2011, 16:20    Post subject:  

...well, the bizarre thing is, it does seem to have been related to the SDL package I had installed. Shocked

After uninstalling that package, and installing the 1.2.14 package, I no longer get those errors. (I've no idea what in the world about SDL would be causing errors like that...)

Mupen now displays the header information for most of the game images I tried (about five or six, or so). However, they all stop at this point:

Code:
UI-Console: Cheat codes disabled.
Illegal instruction

_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2376
Location: UK

PostPosted: Sun 03 Apr 2011, 12:44    Post subject:  

Makoto: After more testing, I must say, I cannot seem to identify the problem you are having - as it works well for me now that I got the right SDL deps installed.. Hmm... Maybe someone else who tried this might know..
_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send private message 
Makoto


Joined: 03 Sep 2009
Posts: 1793
Location: Out wandering... maybe.

PostPosted: Sun 03 Apr 2011, 18:38    Post subject:  

Mupen just doesn't like my system, that's all. Very Happy

Is that the point where the actual emulation more or less begins? That's essentially where it would freeze on the previous version. So, maybe something similar is happening with this version when it tries to start the emulated machine.

I don't think it should be a problem with the system's hardware, but I'm not ruling that out, yet. I'll have to see if I can try other N64 emulators (such as MESS), and see if they have any similar problems.

_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [10 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Games
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0703s ][ Queries: 13 (0.0042s) ][ GZIP on ]