Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 25 Jul 2014, 12:04
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Unable to connect to network Lan with Aspire one (Solved)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 3 [40 Posts]   Goto page: Previous 1, 2, 3
Author Message
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Mon 15 Nov 2010, 20:54    Post subject:  

There are a couple of unknown devices. The lan might be one of them.
Now I see the ath9k driver, some bell starts to ring.
I think that one gave problems in 4.3.1.
I looked a bit with the puppysearch in my sig, but couldn't find something concrete.
I would, if I were you, PM rerwin and ask advice.
I think there is a bad story about ath9k.

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5218
Location: Australia

PostPosted: Tue 16 Nov 2010, 08:41    Post subject:  

Guys, don't get caught up with descriptions. What's important is the device ID. This determines the correct driver.

kent41 wrote:
01:00.0 Class 0200: 1969:2060 (rev c1)

OK, there's your ethernet device - device ID 1969:2060 is the Atheros AR8152. This is quite a new device, and the Linux atl1c/atl1e drivers have only just added support for it in the most recent 2.6.36 kernel.
I have just located updated source code, and can probably compile it for you shortly.

kent41 wrote:
02:00.0 Class 0280: 168c:002b (rev 01)

Béèm wrote:
Now I see the ath9k driver, some bell starts to ring.

Yes, device ID 168c:002b is an Atheros miniPCI wifi device, supported by the ath9k Linux driver.
Béèm wrote:
I think that one gave problems in 4.3.1.

No, ath5k was the problematic wifi driver, as I reported here
http://www.murga-linux.com/puppy/viewtopic.php?p=444659#44465

Béèm wrote:
I would, if I were you, PM rerwin and ask advice.

rerwin's area of expertise is wireless modems. But that's a wifi adapter, not a wireless modem.
That wifi device should work fine with Puppy.

Let's not confuse ethernet adapters with wifi adapters and wireless modems.
The device in question is an ethernet adapter - pci ID 1969:2060, Atheros AR8152.
I will look into the driver situation shortly.
Back to top
View user's profile Send private message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Tue 16 Nov 2010, 09:46    Post subject:  

tempestuous, I didn't know rerwin only did the gprs modems.
Do you do the Ethernet and WiFi's then?

The only way I know to know more about that code for a device is the lspci command and the Pupscan script.
Is there a better way?

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5218
Location: Australia

PostPosted: Tue 16 Nov 2010, 11:24    Post subject:  

kent41, you need the updated atl1e ethernet driver, available for Puppy 4.3.x here
http://www.murga-linux.com/puppy/viewtopic.php?p=467846#467846
Back to top
View user's profile Send private message 
kent41


Joined: 26 Nov 2006
Posts: 242

PostPosted: Tue 16 Nov 2010, 15:11    Post subject:  

tempestuous wrote:
kent41, you need the updated atl1e ethernet driver, available for Puppy 4.3.x here
http://www.murga-linux.com/puppy/viewtopic.php?p=467846#467846



I don't know how to thank you except to say thanks thanks thanks you not only made my day but many days in the future. Also thanks for converting it to a .pet

It works great and now I don't have to return the netbook to the store.
Kent

_________________
Toshiba M35X S-111 - Aspire 5100-3357 using puppy 2.12 - 2.13 - 2.14 - 4.3.1 -
Bootable CD and no hard drive

Acer Aspire 1 netbook using thumbdrive or CD
Back to top
View user's profile Send private message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Tue 16 Nov 2010, 15:24    Post subject:  

Success and thanks for putting SOLVED.
_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
cthisbear

Joined: 29 Jan 2006
Posts: 3387
Location: Sydney Australia

PostPosted: Wed 17 Nov 2010, 00:26    Post subject:  

tempestuous:

Thanks big guy.
I did it a little bit differently....restarted x server.

Acer Netbook >> eMachines eM350-21G16i

http://murga-linux.com/puppy/viewtopic.php?p=468071#468071

You are a bloody terrific bloke Tempe...
as are all the past and present network gurus of this forum.

a la Jeff Fenech....I love youse all.

" The Marrickville Mauler is back for one more round.

A street thug made good, he was an Aussie battler who’s catch cry

“I Love You’se all.” is now part of our culture,
he captured three world titles, he’s in the International Boxing Hall
of Fame and when his bid for a fourth world title against Azumah Nelson went wrong, the whole of Australia was behind him. "

http://rrrrrumble.blogspot.com/2008/06/jeff-fenech-i-love-youse-all.html

Chris.
Back to top
View user's profile Send private message 
rvijay

Joined: 07 Mar 2011
Posts: 25

PostPosted: Mon 07 Mar 2011, 03:42    Post subject:  

I have the same issue.

Netbook: ACER ASPIRE ONE AOD255E-13248 10.1-INCH NETBOOK PC
Ethernet card: Atheros AR8152 PCI-E Fast Ethernet Controller (NDIS 6.20)
Location: PCI bus 1, device 0, function 0
Windows Driver: C:/Windows/system32/DRIVERS/L1C62x86.sys
Driver Version: 1.0.0.35 Driver Date: 24/08/2010
OS: Latest Version of Puppy Linux - Lupu, Lucid 5.2

Puppy Linux doesn't detect ethernet card on netbook as it has no Linux drivers for it.

Tried to download the PET package and install it. Still the card is not recognized.

When I try to probe for module, something like 8239 or so is being detected. I tried to load a few other modules for Atheros, all didn't work.
Rebooting PC, restarting puppy, reinstalling the PET package, replugging network cable etc., didn't work.
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5218
Location: Australia

PostPosted: Mon 07 Mar 2011, 10:30    Post subject:  

rvijay wrote:
OS: Latest Version of Puppy Linux - Lupu, Lucid 5.2

Tried to download the PET package and install it. Still the card is not recognized.

rvijay, the atl1e dotpet under discussion here is for Puppy 4.3, with the 2.6.30.5 kernel. That's made clear in the title of the thread where you downloaded the dotpet from: "Extras for Puppy 4.3 with 2.6.30.5 kernel"

Drivers (kernel modules) for the 2.6.30.5 kernel are completely incompatible with the more modern kernel in Puppy 5.1/5.2.

I have provided an updated version of the atl1e driver for Puppy 5.1/5.2 here -
http://www.murga-linux.com/puppy/viewtopic.php?p=467845#467845
This is probably (?!) what you need, but if you still have no success, we need to know the exact device ID of your ethernet device. So if you still need help, please run this command -
Code:
lspci -n

and report the results.
Back to top
View user's profile Send private message 
rvijay

Joined: 07 Mar 2011
Posts: 25

PostPosted: Mon 07 Mar 2011, 15:00    Post subject:  

Thanks that worked. Smile
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 3 [40 Posts]   Goto page: Previous 1, 2, 3
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0728s ][ Queries: 13 (0.0050s) ][ GZIP on ]