Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 20 Oct 2014, 07:56
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Audio
Audio works for Quriky,Wary but not Lucid Puppy. Solved!!!
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [9 Posts]  
Author Message
Tman


Joined: 22 Jan 2011
Posts: 814
Location: Toronto

PostPosted: Mon 14 Feb 2011, 00:34    Post subject:  Audio works for Quriky,Wary but not Lucid Puppy. Solved!!!  

Hello I started using Puppy since Nov.2010 and am new to linux in general. After trying Puppy 5.11 and 5.2 , I was impressed with the speed and size of the OS, but sadly my sound card would not work. 'Sad' After trying other derivatives, I found that Quirky 1.2 and 1.3 would play sound after I fiddled with the "Multiple Sound Card Wizard".

My computer specs: AMD Athlon64 5200+ CPU, 2GB RAM, "Zotac Zone" Nvidia GT 240 Video Card. MSI k9vgm-v motherboard with onboard "RealtekHD" sound card.

In Puppy, I have tried configuring alsaconf, alsamixer and retrovol to no avail. The only way I have managed to get Puppy play sound was to remove my Nvidia card and use the onboard video instead. However, I would like to leave my Nvidia card installed.

I was wondering if there is a "Multiple Sound Card Wizard" pet that I can try for Lucid Puppy 5.2 or if someone out there knows of a solution.

I am currently using my own remastered version of Quirky-NOP 1.20 and everything seems to work but I prefer Lucid Puppy 5.20 as there are more packages availiable and I've also noticed that Puppy 5.20 loads web pages faster (from the Internet, not from a saved file) than other distros that I have tried.

Last edited by Tman on Sun 20 Mar 2011, 13:22; edited 2 times in total
Back to top
View user's profile Send private message 
Sit Heel Speak


Joined: 30 Mar 2006
Posts: 2595
Location: downwind

PostPosted: Mon 14 Feb 2011, 05:27    Post subject:  

A similar problem is noted at the bottom of
http://www.murga-linux.com/puppy/viewtopic.php?p=479987#479987

Have you tried installing then running this:
http://diddywahdiddy.net/Puppy500/alsawizard_test.pet
?

HTH, SHS
Back to top
View user's profile Send private message 
Tman


Joined: 22 Jan 2011
Posts: 814
Location: Toronto

PostPosted: Sun 20 Feb 2011, 15:31    Post subject:  

I should correct my last post; I had to do a little more than just
fiddle with the Mutiple Sound Card Wizard to get the sound to work.
The following is a summary of what I did for both Quirky and Lucid-Pup.
---------------------------------------------------------
Quirky NOP 1.20 (Remastered) Sound Config
---------------------------------------------------------
1) Ran "Multiple Sound Card Wizard" and chose
the appropriate sound device

2) Ran "alsaconf" at the terminal. Sound card was detected.
Two barks were heard the but the volume was low.
If I skip step #1, then end, I get an error message and no barks are heard.

3) For Gnome-MPLAYER, I have to adjust the preferences to use
alsa as the default mixer instead of oss.

4) Ran "alsamixer" and increased the volume for "FRONT" speaker.
Volume is now very audible.

---------------------------------
Puppy 5.20 Sound config
---------------------------------
Puppy doesn't have the Multiple Sound Card Wizard, so I started with alsaconf.
At the end it gives an error message saying that no sound card was detected. No barks are heard.
I tried adjusting alsamixer, retrovol and Pmusic but mp3's wouldn't even play. (The trackbar was not scrolling through the songs)
In Puppy, retrovol and alsamixer don't detect the "PCM". I was having the same problems with Puppy 5.1.1

It's driving me nuts cause I really like the new lucid-pup.
I just need sound. 'Mad'

To: Sit Heel Speak; I believe the pet you've suggested reverts alsa back to the version in Puppy 5.1.1. My sound was not working with any Lucid pups or their derivatives. I will try though..it couldn't hurt. thanx

Last edited by Tman on Sun 20 Mar 2011, 13:26; edited 1 time in total
Back to top
View user's profile Send private message 
GustavoYz


Joined: 07 Jul 2010
Posts: 897
Location: .ar

PostPosted: Thu 24 Feb 2011, 02:27    Post subject:  Edited  

The cards are taken by alsa?
Code:
cat /proc/asound/cards


If yes, did you see an error playing in console?
Code:
aplay /path/toSome/Audiofile.ogg

_________________

Back to top
View user's profile Send private message 
Tman


Joined: 22 Jan 2011
Posts: 814
Location: Toronto

PostPosted: Sun 27 Feb 2011, 15:52    Post subject:  

To GustavoYz:

Alsamixer will allow me to choose the proper soundcard, but it won't detect the "PCM" in Lucid Puppy and no sounds will play. Quirky DOES detect my "PCM" device. I have no idea what PCM stands for, but I've concluded that I need it for my sound to work.

My Nvidia Video card is being detected as card0 (it has sound capabilities for the HDMI output). My RealtekHD soundcard is seen as card1. I think I just need a way to make my Realtek card seen as card0 and the sound will work. Right now, the only way I know how to do that is to take the Nvidia card out of my motherboard.

SitHeelSpeak's earlier suggestion did not work either. Sorry about the delay. Right now I only put some time aside on the weekends to fool around with Puppy's Settings. Until it the sound works, I'm sticking with Quirky NOP 1.20 as my main pup.
aplay.png
 Description   Terminal output for aplay
 Filesize   5.79 KB
 Viewed   2609 Time(s)

aplay.png

Back to top
View user's profile Send private message 
trapster


Joined: 28 Nov 2005
Posts: 2006
Location: Maine, USA

PostPosted: Sun 27 Feb 2011, 17:15    Post subject:  

aplay supports .ogg ??
_________________
trapster
Maine, USA

Asus eeepc 1005HA PU1X-BK
Frugal install: Puppeee4.31 + 1.0, Puppy4.10 + Lupu52
Currently using Slacko AND lupu52 w/ fluxbox
Back to top
View user's profile Send private message Visit poster's website 
GustavoYz


Joined: 07 Jul 2010
Posts: 897
Location: .ar

PostPosted: Mon 28 Feb 2011, 00:49    Post subject:  

trapster wrote:
aplay supports .ogg ??

Yes it does, but i have overwritten the default one... Not sure of the properties of it on LuPu 520.
Better use another extension to test it, just in case.

@Tman.
I'm not sure of this error meaning, but I'd like to see your /etc/asound.state (only curiosity).

_________________

Back to top
View user's profile Send private message 
Tman


Joined: 22 Jan 2011
Posts: 814
Location: Toronto

PostPosted: Sat 19 Mar 2011, 14:44    Post subject:
Subject description: Problem solved!!! My sound finally works in Lucid Puppy.
 

I finally solved my audio problem. Playdayz told me that I should try the Multiple Sound Card Wizard in Puppy. I couldn't find the appropriate pet on the internet, so I tried porting the files over from Wary 5.1.1. using the dir2pet script. I ran the pet and used the same steps that I used to get my sound working in Quirky and Wary. The steps are posted near the beginning of this thread. So far I have tried the pet in Puppy 5.2 and Snowpup 0.14. It has worked on both. Thanks to everyone for your suggestions. Special thanks to Playdayz for the idea. 'Laughing'

The pet can be downloaded ->here.
-

Last edited by Tman on Sat 13 Oct 2012, 13:56; edited 5 times in total
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 19 Mar 2011, 15:13    Post subject:  

Thank you of your report. I will include your pet to next snow puppy.

Cheers.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [9 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Audio
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0643s ][ Queries: 13 (0.0040s) ][ GZIP on ]