Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 22 Dec 2014, 18:46
All times are UTC - 4
 Forum index » Taking the Puppy out for a walk » Suggestions
Application Requests
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [21 Posts]   Goto page: 1, 2 Next
Author Message
Lancer

Joined: 03 Dec 2006
Posts: 13

PostPosted: Sat 29 Jan 2011, 05:03    Post subject:  Application Requests
Subject description: Got a program you really need to work on Puppy?
 

I've got my own program I'd like to see working under Puppy, though given it's a public forum, I'll leave this thread for others to have similar say. Is there a program you haven't been able to successfully get going under puppy?

For me, it would be MyPaint from http://mypaint.intilinux.com/
It exists in the Ubuntu-universe repositories, but after "successfully" installing, it turns out to be quite incompatible with puppy due to multiple python-related dependency issues. Along with this program, I'd like to see inbuilt support for pressure sensitive wacom tablets.

Okay then - any other thoughts?
Back to top
View user's profile Send private message 
Sylvander

Joined: 15 Dec 2008
Posts: 3557
Location: West Lothian, Scotland, UK

PostPosted: Sat 29 Jan 2011, 05:13    Post subject:  

I'd like to have "SaveMy Modem" [smm] [or something like it] able to do all that Mailwasher can do.

e.g.
Able to click on URL's and have the default web-browser take you there.
Able to copy and paste from smm.
Able to set up rules to block spamming domains or addresses or whatever.
Back to top
View user's profile Send private message 
Rattlehead


Joined: 11 Sep 2008
Posts: 230
Location: Madrid, Spain

PostPosted: Sat 29 Jan 2011, 19:41    Post subject:  

I am very curious about Writer's Café or some software of the kind for writers (I've seen Scrivener for Mac and it's a gorgeous toy Smile ).

I'd also like to see a good, easy to use and intuitive old school database for Puppy. The closest thing I have found (and it's quite close) is Portabase, but I have sometimes had problems with the files and lost information. Open Office's Base has also given me problems, and it's harder to configure for everyday use. I've read in this forum that Glom was not compiled because it was too big for Puppy, but I'd give it a try if it is a stable application.

(Another idea: maybe one of those collection managers with -AFAIK- customizable fields, like Tellico or Stuffkeeper, would do as a simple database).
Back to top
View user's profile Send private message 
harii4


Joined: 30 Jan 2009
Posts: 444
Location: La Porte City, IA , U.S.A.

PostPosted: Tue 01 Feb 2011, 20:38    Post subject:  

like to see adeskbar.
but it might be too bloated for puppy use?
http://www.omgubuntu.co.uk/2010/11/adeskbar-dock-panel-replacement-for-ubuntu/
http://crunchbanglinux.org/forums/topic/441/adeskbar-application-launcher-for-openbox/
Back to top
View user's profile Send private message Visit poster's website 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15122
Location: Paradox Realm

PostPosted: Wed 02 Feb 2011, 05:42    Post subject: Re: Application Requests
Subject description: Got a program you really need to work on Puppy?
 

Lancer wrote:

For me, it would be MyPaint from http://mypaint.intilinux.com/
It exists in the Ubuntu-universe repositories, but after "successfully" installing, it turns out to be quite incompatible with puppy due to multiple python-related dependency issues.


Looks good
It is in the PPM (for the Ubuntu Universe repository)
I installed all the dependencies and it came to 28MB
Then I got this:

Code:
# mypaint
ImportError: No module named numpy.core.multiarray

We are not correctly installed or compiled!
script: "/usr/bin/mypaint"
deduced prefix: "/usr"
lib_shared: "/usr/share/mypaint/"
lib_compiled: "/usr/lib/mypaint/"

Traceback (most recent call last):
  File "/usr/bin/mypaint", line 112, in <module>
    datapath, confpath, localepath = get_paths()
  File "/usr/bin/mypaint", line 62, in get_paths
    from lib import mypaintlib
  File "/usr/share/mypaint/lib/mypaintlib.py", line 25, in <module>
    _mypaintlib = swig_import_helper()
  File "/usr/share/mypaint/lib/mypaintlib.py", line 17, in swig_import_helper
    import _mypaintlib
ImportError: numpy.core.multiarray failed to import
#


Voice recognition is something I would like to see or hear Smile

_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
einar

Joined: 12 Nov 2010
Posts: 162

PostPosted: Wed 02 Feb 2011, 05:52    Post subject: Gwenview
Subject description: image viewer
 

Testet the new opensuse 11.4 ms.6 with KDE4.6 yesterday. and i loved the imageviewer. its called Gwenview. mutch quicker than anything ive tried on puppy.

http://en.opensuse.org/Gwenview

would love to se that on luci and fluppy
Back to top
View user's profile Send private message 
Lancer

Joined: 03 Dec 2006
Posts: 13

PostPosted: Sat 12 Feb 2011, 20:49    Post subject: Re: Application Requests
Subject description: Got a program you really need to work on Puppy?
 

Lobster wrote:

Looks good
It is in the PPM (for the Ubuntu Universe repository)
I installed all the dependencies and it came to 28MB
Then I got this:
Code:
# mypaint
ImportError: No module named numpy.core.multiarray


Yes, that's what I (and a sting of others after they have stopped insulting my Linux knowledge and actually tried to install MyPaint for themselves) have been hitting. It seems that Puppy is very different from Ubuntu, probably mostly in paths etc. Some programs like MyPaint are very unforgiving of this and it's fatal to their compatibility.

This is why I have cited MyPaint (which I really want) as a request. The current Ubuntu is not an option, therefore MyPaint is not available for Puppy as yet.

Comments I've had in chat rooms like "It's not a Puppy problem, it's a Puppy and some-other-package problem" state the obvious but don't actually help in as fr as me being able to run MyPaint. I want a Puppy-compatible package.
Back to top
View user's profile Send private message 
Pelo


Joined: 10 Sep 2011
Posts: 3452
Location: Mer méditerrannée (1 kms°)

PostPosted: Fri 04 Jan 2013, 20:53    Post subject: tellico
Subject description: Collection of anything
 

Puppy has nothing to manage collections of what you like. Tellico is a KDE one.
Perharps stuffkeeper one other but with cuztomization of fields possible
Could you do it .
Back to top
View user's profile Send private message Yahoo Messenger 
666philb


Joined: 07 Feb 2010
Posts: 1971
Location: wales

PostPosted: Sun 06 Jan 2013, 12:34    Post subject:  

hi pelo,

GCstar http://www.gcstar.org/ is available in the precise puppy PPM

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6690
Location: lisbon

PostPosted: Mon 07 Jan 2013, 19:09    Post subject:  

Maybe java-based Data Crow?
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6690
Location: lisbon

PostPosted: Mon 07 Jan 2013, 19:30    Post subject:  

Also older version of gcstar, v1.5.0, is available in lucid repo.
Back to top
View user's profile Send private message 
Pelo


Joined: 10 Sep 2011
Posts: 3452
Location: Mer méditerrannée (1 kms°)

PostPosted: Sat 30 Nov 2013, 23:16    Post subject: GCstar is available in the precise PPM  

GCstar is available in the precise PPM
Hum.... I shall see.
AND IN LUCID too ?!!!! incredible. How can i miss that ?
Back to top
View user's profile Send private message Yahoo Messenger 
RSH


Joined: 05 Sep 2011
Posts: 2420
Location: Germany

PostPosted: Sun 01 Dec 2013, 00:43    Post subject:  

Downloaded the DEB Files...
Combined into a single SFS Module...
Created a RunScript...
Runs and seems to work...

Though, it needs the DevX loaded to run!
image-2.jpg
 Description   
 Filesize   43.63 KB
 Viewed   440 Time(s)

image-2.jpg


_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send private message 
nilsonmorales


Joined: 15 Apr 2011
Posts: 538
Location: El salvador

PostPosted: Sun 01 Dec 2013, 02:20    Post subject:  

harii4
Quote:
like to see adeskbar.
but it might be too bloated for puppy use?


wget -c --content-disposition http://ubuntuone.com/0YPYBbPp3BnvyKCIBBzUh2



compiled in precise puppy derivated
need python-gmenu and python-vte mainly, id download from ppm
maybe other dependences but works
btw i dont like adeskbar Cool

_________________
My blog


Back to top
View user's profile Send private message MSN Messenger 
amigo

Joined: 02 Apr 2007
Posts: 2297

PostPosted: Sun 01 Dec 2013, 12:27    Post subject:  

"needs the DevX loaded to run" -boy that's helpful -does that database use gcc or binutils, or what?
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [21 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Taking the Puppy out for a walk » Suggestions
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0912s ][ Queries: 13 (0.0089s) ][ GZIP on ]