Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 31 Oct 2014, 01:04
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Barebones Lucid 5.01
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 2 of 5 Posts_count   Goto page: Previous 1, 2, 3, 4, 5 Next
Author Message
Sit Heel Speak


Joined: 30 Mar 2006
Posts: 2595
Location: downwind

PostPosted: Mon 07 Feb 2011, 19:06    Post_subject:  

As for transmission, before I can diagnose that I must ask, have you a preferred route for getting python into it? --in other words, which python .pet's are you loading?
Back to top
View user's profile Send_private_message 
hondasid


Joined: 31 Oct 2008
Posts: 259
Location: Perry, OK

PostPosted: Tue 08 Feb 2011, 02:07    Post_subject:  

Ok, so i just saw all your replies Sit Heel Speak. I will be dl'ing and trying that asap. I believe that you have found a fix for this and I want to say thank you in advance.
As far as python, i haven't added any. Transmission usually works without anything. I opened it up in console and it didn't spit out any errors, just sat there. I had no clue where to go from there. I'm still kinda sorting out a plan of action on this one. Any help is appreciated.
nooby, glad to hear it. i have a pupngo frugal installed as a test bed for a new Pentium Pro and MMX Puppy build. It is way minimal, more so than I'm really looking for, so IDK if I'll be using it. I do have to say, i am impressed with it. I never thought i would see a desktop Puppy using only 18 MB RAM and less than 2% CPU on my 1.4 Ghz. I am going to keep it around for something. I have a ton of Pro's and MMX's sitting here.
And I get bored a lot....

_________________
Instead of looking out Windows, I'm playing with my Puppy.
Back to top
View user's profile Send_private_message Visit_website AIM YIM MSNM 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Tue 08 Feb 2011, 02:54    Post_subject:  

Thanks Hondasid.

Can one borrow the Atheros Ethernet card drivers from Fluppy or Barebone or 511 or whatever and somehow add it to pUpnGo?
That way I would get it to go out on the internet.

Nooby always hoping for miracles Smile

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send_private_message 
Sit Heel Speak


Joined: 30 Mar 2006
Posts: 2595
Location: downwind

PostPosted: Sat 12 Feb 2011, 15:41    Post_subject: transmission fix for Barebones Lucid 5.01  

The gtk builds of transmission depend on a library file, libxcb-xlib.so.0 which is a part of libxcb. Or at least, it used to be part of it. Evidently, it has been dropped from new builds of libxcb --see

http://lists.freedesktop.org/archives/xcb/2009-April/004493.html
http://www.gentoo.org/proj/en/desktop/x/x11/libxcb-1.4-upgrade-guide.xml
http://ubuntuforums.org/showthread.php?t=1382332

I took the advice of this latter thread and downloaded libxcb-xlib from Ubuntu Hardy, attached. With this file installed, Michalis's transmission 2.20 .pet works. I also installed Michalis's recommended intltool-0.40.6-i486.pet, libevent-2.0.10-stable-i486.pet, and libevent_DEV-2.0.10-stable-i486.pet, but I don't know whether these were necessary or not.
libxcb-xlib0_1.1.pet
Description  libxcb-xlib from Ubuntu Hardy, so transmission-gtk works in Barebones
pet

 Download 
Filename  libxcb-xlib0_1.1.pet 
Filesize  2.37 KB 
Downloaded  392 Time(s) 
Back to top
View user's profile Send_private_message 
DPUP5520

Joined: 16 Feb 2011
Posts: 801

PostPosted: Thu 17 Feb 2011, 16:58    Post_subject:  

This may not be the smartest question or place to put it but I can't figure out how to delete the banner that keeps popping up on top every time I boot up, im using a live-cd so im sure that it's set to run on first boot unless im wrong however when using pfind to search for keyword welcome or banner I can't seem to find it and theres no indication of it in the startup folder.
Back to top
View user's profile Send_private_message 
hondasid


Joined: 31 Oct 2008
Posts: 259
Location: Perry, OK

PostPosted: Thu 24 Feb 2011, 20:31    Post_subject:  

Yeah, that is something built into puppy. It only shows up in live-boot with no save file. I believe it is an html file and there is no html viewer in barebones, so it probably wont show up. i believe the file itself is located somewhere in root.
_________________
Instead of looking out Windows, I'm playing with my Puppy.
Back to top
View user's profile Send_private_message Visit_website AIM YIM MSNM 
hondasid


Joined: 31 Oct 2008
Posts: 259
Location: Perry, OK

PostPosted: Thu 24 Feb 2011, 20:35    Post_subject:  

Nooby, I'm sure that those modules can be added into pupngo, but I would try and find one from the 4 series. U should be able to copy them over and then either modprobe or reboot and see if they are automatically added in.
_________________
Instead of looking out Windows, I'm playing with my Puppy.
Back to top
View user's profile Send_private_message Visit_website AIM YIM MSNM 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Fri 25 Feb 2011, 04:52    Post_subject:  

Quote:
I believe it is an html file and there is no html viewer in barebones, so it probably wont show up. i believe the file itself is located somewhere in root.


Delayedrun script loads that welcome page. And the loaded html files are located in /usr/share/doc.

welcome1stboot and welcome1stboot.htm are the loaded stuff.
I have made modified delayedrun script which does not load them at first boot.
Back to top
View user's profile Send_private_message 
DPUP5520

Joined: 16 Feb 2011
Posts: 801

PostPosted: Fri 25 Feb 2011, 22:37    Post_subject:  

Hmm I believe I'm talking about a different file, its a pink banner that shows up at the top of the screen that says "welcom, please click here for getting-started information" I can't first the file for it anywhere and it doesn't show up in 520 so I'm kinda lost on how to get rid of it.
Back to top
View user's profile Send_private_message 
DPUP5520

Joined: 16 Feb 2011
Posts: 801

PostPosted: Fri 25 Feb 2011, 22:37    Post_subject:  

Hmm I believe I'm talking about a different file, its a pink banner that shows up at the top of the screen that says "welcom, please click here for getting-started information" I can't first the file for it anywhere and it doesn't show up in 520 so I'm kinda lost on how to get rid of it.
Back to top
View user's profile Send_private_message 
Puppyt

Joined: 09 May 2008
Posts: 568
Location: Gatton, Queensland

PostPosted: Sun 13 Mar 2011, 23:22    Post_subject:
Sub_title: first impressions and problems with barebones 5.01
 

Cheers again hondasid,

I finally got around to constructing a small puplet using your 501 base on the weekend. The basic applications I wanted worked well (although I have a running issue within Firefox for selecting applications like ROX to open the containing folder for downloads - can't seem to solve the problem on the forum). One app I did have some grief with was unfortunately radky's PupControl 1.3. It didn't register PPM well at all, and although you could 'fake' it into refreshing the correct repository sub-categories by selecting different file types to filter - it failed to show packages already installed for possible removal. A gtk issue, perhaps? Everything else I tried, I was really happy with the results. (And with a frugal install I couldn't replicate DPUP5520's finding.)

Thanks!

_________________
Toowoomba Linux Community
http://groups.google.com/group/toowoombalinux
Back to top
View user's profile Send_private_message Visit_website 
DPUP5520

Joined: 16 Feb 2011
Posts: 801

PostPosted: Mon 14 Mar 2011, 15:07    Post_subject:  

@Puppyt
You couldn't replicate it because it only shows up on the live cd, pemasu was right it was the Delayedrun script that was causing the problem for me all I had to do was comment out the lines that ran the banner and it no longer showed up when I booted up the cd.
Back to top
View user's profile Send_private_message 
hondasid


Joined: 31 Oct 2008
Posts: 259
Location: Perry, OK

PostPosted: Mon 14 Mar 2011, 16:45    Post_subject:  

Ok, I've had some connectivity and work issues that haven't allowed me any free time lately. I did try the deps sfs to fix the Opera problem. They were already added in from a previous fix and did not work. The transmission fix works. As far as packages not showing up in PPM, I don't have a clue. I don't believe I removed anything having to do with PPM and I haven't had this problem. I will get the package you spoke of and try to replicate the problem. I'm still working on my other Barebones builds but progress is slow. I have just started a new business and it takes a lot of my time, but Puppy is always a priority for me. I will have results posted soon.
_________________
Instead of looking out Windows, I'm playing with my Puppy.
Back to top
View user's profile Send_private_message Visit_website AIM YIM MSNM 
DPUP5520

Joined: 16 Feb 2011
Posts: 801

PostPosted: Mon 14 Mar 2011, 23:03    Post_subject:  

BTW Hondasid Im lovin workin with this barebones that you made, definitely makes things easier when trying to make your own derivative, I managed to make the base os about 6MB smaller than you had it by taking out all the printer/sound files since I don't need them for the pup that i've been workin on but def keep up the great work.
Back to top
View user's profile Send_private_message 
claude


Joined: 14 Apr 2007
Posts: 153
Location: Saint-Jérôme, Qc

PostPosted: Fri 17 Jun 2011, 17:03    Post_subject:  Barebones Lucid 5.01
Sub_title: where to download it
 

How may I download Barebones Lucid 5.01 ?

I tried the link from FileDropper but no results.

Thank you.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 2 of 5 Posts_count   Goto page: Previous 1, 2, 3, 4, 5 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0854s ][ Queries: 13 (0.0081s) ][ GZIP on ]