Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 02 Oct 2014, 08:53
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Virtualization
VirtualBox for many Puppies
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 2 of 13 Posts_count   Goto page: Previous 1, 2, 3, 4, ..., 11, 12, 13 Next
Author Message
Geoffrey


Joined: 30 May 2010
Posts: 1401
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Thu 27 Jan 2011, 06:01    Post_subject:  

TheAsterisk!

I'll see if it will run in the original Quirky 1.20, there should be no reason that it won't with a couple of updates, I'll let you know how it go's

Geoffrey

Edit

Well I can confirm that virtualbox-4.0.2-k2.6.33.2-lupu5.pet works with Quirky1.20, it doesn't need all of the video drivers installed only
libGL.so.1.2, libGLU.so.1.3.060502 and the system links to them libGL.so.1 and libGLU.so.1 as well as SDL-1.2.14-q1.pet
I would imagine that is all that is required for Quirky1.20NOP also
Download for SDL-1.2.14-q1.pet ftp://distro.ibiblio.org/pub/linux/distributions/quirky/pet_packages-quirky/SDL-1.2.14-q1.pet

Here are the /usr/X11R7/lib files
quirky-virtualbox.jpg
 Description   
 Filesize   54.24 KB
 Viewed   1996 Time(s)

quirky-virtualbox.jpg

quirky1.20-libGLU.tar.gz
Description  contains libGL.so.1.2, libGLU.so.1.3.060502, libGL.so.1 and libGLU.so.1, extract or copy these files to /usr/X11R7/lib
gz

 Download 
Filename  quirky1.20-libGLU.tar.gz 
Filesize  263.37 KB 
Downloaded  1092 Time(s) 
Back to top
View user's profile Send_private_message 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Sun 30 Jan 2011, 08:47    Post_subject:  

I've added a package for Wary 5 and for Quirky 1.4, and made notes for those in both the packages guide and the dependencies text file.

I also added notes for sc0ttman's puplet "Puplite." I tested version 4.0, but it's probably more or less the same for earlier versions of Puplite.
Puplite sometimes encounters trouble starting the vbox services at installation, so I added a note on how to restart the service, too.

Finally got around to linking back to this thread in the HTML page, just in case anyone gets linked to that from elsewhere.
Back to top
View user's profile Send_private_message Visit_website 
BHINTZ

Joined: 08 Aug 2006
Posts: 143

PostPosted: Tue 08 Feb 2011, 21:14    Post_subject:  

Is there some special requirement to get sound working in Virtualbox. I have tried two different computers with lupu520 and vbox402. Everything seems fine except sound.

I have tried different puppies and even windows xp, so I am guessing it something to do with vbox.

any suggestions would be welcome.

bob
Back to top
View user's profile Send_private_message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Wed 09 Feb 2011, 07:00    Post_subject:  

Cool thanks indeed I have longed for to have Vbox in Lupu 511 and 520.

I want to use it for running TCL so I learn how to use it. Smile TCL can not use NTFS so if I format the virtual drive to be Ext2 then it should be able to save my changes.

Has any of you tested if TCL works fast in Vbox? Being only 10MB it should be able to run in half the memory I give it?

As I know Vbox ask for how much of Ram that it take from Puppy to run in so Puppy don't crash? so say I have 500MB or Puppy to run Vbox and 500MB for Vbox with TCL loaded?

I did dl and installed and run ran it too but I need how to get an iso installed on it as guest. Maybe there are forums for beginners of vbox?

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send_private_message 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Fri 11 Feb 2011, 14:27    Post_subject:  

BHINTZ wrote:
Is there some special requirement to get sound working in Virtualbox. I have tried two different computers with lupu520 and vbox402. Everything seems fine except sound.

I have tried different puppies and even windows xp, so I am guessing it something to do with vbox.

any suggestions would be welcome.

bob

I'm afraid something about Lucid Puppies 510, 511 and 520 just doesn't work as expected. It's a known issue; there's a note about it at the bottom of my little packages-chooser HTML page.
To get sound in the guest system, you lie to VBox and tell it the host uses PulseAudio or OSS instead of Puppy's actual ALSA. While this works to enable the guest's sound, though, Puppy then can't use sound while a VM is running.
I'll attach a screen shot showing the menu where you can make the change.

If simultaneous sound for both host and guest is a critical requirement for you, you can run VirtualBox on another Puppy version or you can install VMware Player, which doesn't seem to have any similar audio issues. (My thread for VMware Player is here.)
Alternatively, I had previously made packages for an older version of VBox ( 3.2.8 ), and they don't have any such audio issues. The thread is here if you want to try that option.

nooby wrote:
Cool thanks indeed I have longed for to have Vbox in Lupu 511 and 520.

I have a certain fondness for testing other distros in VBox, too! Laughing That's precisely why I keep making these packages!
Quote:
I did dl and installed and run ran it too but I need how to get an iso installed on it as guest. Maybe there are forums for beginners of vbox?

If you would please reference the bottom of my packages-chooser page (here), it contains links to all kinds of stuff, from notes about the Lucid audio issue discussed above to the guest additions *.iso.
lucid-510-511-520_audio.png
 Description   Audio Settings Kludge - Screen Shot
 Filesize   34.08 KB
 Viewed   1267 Time(s)

lucid-510-511-520_audio.png

Back to top
View user's profile Send_private_message Visit_website 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Fri 11 Feb 2011, 15:38    Post_subject:  

Thanks I take a look at it if all other means to get TCL going fails. And I need it also for things like Ubuntu and Mint and Ultimate and Arch linux and such that fail to boot in frugal install.


I made a bookmark to your site.

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send_private_message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2376
Location: UK

PostPosted: Sat 12 Feb 2011, 06:35    Post_subject:  

TheAsterisk! wrote:
I also added notes for sc0ttman's puplet "Puplite." I tested version 4.0, but it's probably more or less the same for earlier versions of Puplite.
Puplite sometimes encounters trouble starting the vbox services at installation, so I added a note on how to restart the service, too.

Just to let you know, while using these packages in Puplite, I had trouble getting the 'all kernels' version to work, but the version made for 2.6.25.16 works every time Smile Good stuff

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send_private_message 
BHINTZ

Joined: 08 Aug 2006
Posts: 143

PostPosted: Sat 12 Feb 2011, 11:55    Post_subject:  

many thanks. It works just fine and I do not anticipate needing both working at the same time.

Does one of your versions work in fluppy? I tried the universal one and it would not start.

bob
Back to top
View user's profile Send_private_message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Sat 12 Feb 2011, 13:20    Post_subject:  

Am I alone having this problem?
It says: Spawning session and then nothing happens. But it still works but I wonder what it does?

In ubuntu forums they say one should recompile the kernel
I am using lupu250 and that one does have some ubuntu in it so is that related?

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send_private_message 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Sun 13 Feb 2011, 17:31    Post_subject:  

BHINTZ wrote:
Does one of your versions work in fluppy? I tried the universal one and it would not start.

It ought to work if you have the kernel source and devx SFS modules installed, but I've never tested it on Fluppy. If that would be a popular package, though, I could try making a package in a few days (I'll be a bit too busy until maybe Thursday, I'm afraid).
EDIT (24 Feb.) - Since version 4.0.4 is out, when I package up those I'll try to add one for Fluppy while I'm at it.

nooby wrote:
Am I alone having this problem?
It says: Spawning session and then nothing happens. But it still works but I wonder what it does?
In ubuntu forums they say one should recompile the kernel
I am using lupu250 and that one does have some ubuntu in it so is that related?

Well, I'm not sure what the cause might be, but the kernel is probably fine. You might want to try recompiling the VBox drivers with the following command:
Code:
/etc/init.d/vboxdrv setup

That should do it, but you'll need to install the kernel source and devx SFS modules first.

sc0ttman wrote:
Just to let you know, while using these packages in Puplite, I had trouble getting the 'all kernels' version to work, but the version made for 2.6.25.16 works every time. Smile Good stuff.

Hmm...
You (or WOOF- I'm not sure exactly how you built your puplet) didn't change the way that Puplite handles the pinstall.sh script(s), did you? That's how I get the all_kernels package to compile the drivers at installation, and it's also how I (try to) get the compiled packages to start up the VBox services right away.
If Puplite's PPM or equivalent just isn't running the install scripts, for whatever reason, then that would explain things neatly.
If there's a change I can make to those scripts to make Puplite + VBox installations work better, please let me know.

UPDATE 26 Feb.: I've made packages for VBox 4.0.4, and the simpler pinstall.sh scripts they're using are working for me in Puplite 4.0 and in 5.0 (both kernels). I've included them in the package chooser HTML page, too.

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
yosi666

Joined: 13 May 2008
Posts: 111

PostPosted: Fri 25 Feb 2011, 10:12    Post_subject:  Nice!  

Working nicely in Wary 5 after installing libSDL 1.2 Very Happy
Back to top
View user's profile Send_private_message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2376
Location: UK

PostPosted: Sat 26 Mar 2011, 09:03    Post_subject:  

is it possible to compile vbox without any GUI? if so, how small would it be?

EDIT: I read up a bit on this, and while it can be compiled with no GUI, apparently it needs to be complied on a system with X installed, and it still asks for QT libs, even when compiling with no GUI...

Well, that's all good, it can be compiled with no GUI, which is nice because I am thinking about making a gtkdialog frontend for vbox..

I have found myself using the QT menu less and less once a VM (guest OS) is setup, in favour of the command-line. While a gtkdialog GUI would be missing a lot of run-time features, I basically don't want much of a GUI once the guest OS has loaded..

Also, I'm guessing that a vbox 'headless' (or no GUI) setup, loaded from a nice and small GUI, might be slightly less resource-intensive when the guest OS is actually up and running.

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send_private_message 
Darkgame

Joined: 18 Mar 2011
Posts: 203

PostPosted: Thu 07 Apr 2011, 10:38    Post_subject:  

ive wanted to use vbox on puppy, for a 'portable' gamimg usb drive.
How do u install from sfs?
Or can anyone make or upload the pet version?
I saw it once,4.0.0, but i deleted by pupsave by accident and the pet is now gone?!
Back to top
View user's profile Send_private_message 
fenex2004


Joined: 12 Jun 2010
Posts: 34

PostPosted: Thu 07 Apr 2011, 22:48    Post_subject:  

Darkgame,
What version Puppy are you using? The newest (Lupu 5.2) has the vbox sfs - check quickpet under sfs tab. When you first run it it will tell you that there is a new version (4.0.4) available and direct you to the website. then just unzip the tarball. that is how I installed it.
Only problem i'm having is that it is slow due to the memory requirements - i'm running it on a laptop with very little memory and slow CPU, so everything runs slow on it Smile

Hope this helped!
Back to top
View user's profile Send_private_message 
Darkgame

Joined: 18 Mar 2011
Posts: 203

PostPosted: Fri 08 Apr 2011, 02:07    Post_subject:  

Thanks! I will go check it out
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 2 of 13 Posts_count   Goto page: Previous 1, 2, 3, 4, ..., 11, 12, 13 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Virtualization
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1035s ][ Queries: 13 (0.0074s) ][ GZIP on ]