Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 11:39
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
How to install lexmark x2600 printer in puppy 4.2?
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Author Message
electric smurf

Joined: 21 Mar 2009
Posts: 9

PostPosted: Tue 07 Apr 2009, 14:15    Post_subject:  How to install lexmark x2600 printer in puppy 4.2?
Sub_title: printers
 

I have have been amazed with how well puppy works. It has made me want to ditch windows but I am unable to install my lexmark x2600.

I have managed to install puppy in 2 lap tops and 3 PCs as well as make bootable flash drives as gifts for friends and family. (Their printers worked right away)

But I cant figure out how to install my printer. Any help would be most appreciated.

And to everyone who has contributed to the puppy(s) project(s) my family and I want to say THANK YOU!
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9207
Location: Stratford, Ontario

PostPosted: Tue 07 Apr 2009, 15:20    Post_subject:  

If you go to openprinting.org, you will find this printer listed as "works" but you need a driver from the lexmark website. Unfortunately, this driver is quite large so you will either need a big pup_save file or a full install to use it.

There are also some references in the openprinting forum to the scripting language "lua" with the x2600 series. This may or may not work in Puppy.
Back to top
View user's profile Send_private_message 
electric smurf

Joined: 21 Mar 2009
Posts: 9

PostPosted: Tue 07 Apr 2009, 16:18    Post_subject:  

Thanks rcrsn51

I had found that this printer was listed as "works" but I am not sure how to download the driver.

You pointed out that the driver is quite large but my smallest pup_save file is one gig. on my hard drive and my largest is 4 gigs on a Superfloppy USB flash drive though I think the max puppy can recognize is 1.8 Gigs.

Anyway I assume I have enough because I already downloaded it (lexmark-inkjet-08-driver-1.0-1.i386.tar.gz.sh.zip) but I don't know what to do with it.

Thanks for your time.
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9207
Location: Stratford, Ontario

PostPosted: Tue 07 Apr 2009, 16:48    Post_subject:  

Click on the lexmark-inkjet-08-driver-1.0-1.i386.tar.gz.sh.zip file to unzip it.
This will get you a new file lexmark-inkjet-08-driver-1.0-1.i386.tar.gz.sh. This is the installer program. To run it, go to a console and type:
Code:
./lexmark-inkjet-08-driver-1.0-1.i386.tar.gz.sh
Back to top
View user's profile Send_private_message 
electric smurf

Joined: 21 Mar 2009
Posts: 9

PostPosted: Tue 07 Apr 2009, 18:11    Post_subject:  

Ok, I will list each step to see were I went wrong.

When I press download it ask me if I want to save to disk or open with pupzip.

I checked pupzip and downloaded.

After down load I clicked on the file and extracted it to /tmp.

Then tried to run it by going to the console and typing:

./lexmark-inkjet-08-driver-1. 0-1. i386. tar. gz. sh

Then press enter.

And it says "no such file or directory"

After you regain your composure from seeing the above error(s) could you please tell me what I did wrong?

Thanks again for the help.
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9207
Location: Stratford, Ontario

PostPosted: Tue 07 Apr 2009, 18:20    Post_subject:  

The command needs to be run from the folder where the file exists. Assuming that the file is still in /tmp, type:
Code:
cd /tmp
./lexmark-inkjet-08-driver-1.0-1.i386.tar.gz.sh

Or you could do it this way:
Code:
/tmp/lexmark-inkjet-08-driver-1.0-1.i386.tar.gz.sh
Back to top
View user's profile Send_private_message 
electric smurf

Joined: 21 Mar 2009
Posts: 9

PostPosted: Tue 07 Apr 2009, 19:48    Post_subject:  

Thank you very much!

I have the printer installed in all but one computer.

The one computer that has a pup_save file on the hard drive instead of on a flash drive is the only one that does not work because the pup_save file is to small like you had said.

On that one I might just do a full install as for the others I think I'll leave them the way they are because I don't see any advantages to a full install.

come to think about it there are more advantages to running off the flash drives because each of us (my family) can take the flash drives any were.

Thank you, Thank you, Thank you, Thank you, Thank you!
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9207
Location: Stratford, Ontario

PostPosted: Tue 07 Apr 2009, 20:02    Post_subject:  

Glad to help. That was easier than I thought it might be!
Back to top
View user's profile Send_private_message 
alfbar1

Joined: 07 Jan 2011
Posts: 8

PostPosted: Mon 24 Jan 2011, 13:14    Post_subject:  

I have a problem when run
Code:
./lexmark-inkjet-08-driver-1.0-1.i386.tar.gz.sh

console gives an error,

Code:
 go tar
tar fail #1
 


stop and exit, I think is simple to resolve, my OS 5.2
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9207
Location: Stratford, Ontario

PostPosted: Mon 24 Jan 2011, 18:33    Post_subject:  

I have converted this package into a PET. It supports the Lexmark 2600 series and the Z2300. Download it here.

Please report back with its success or failure.

This package also installs a scanner driver for Xsane.
Back to top
View user's profile Send_private_message 
horhota

Joined: 19 Feb 2010
Posts: 20

PostPosted: Thu 27 Jan 2011, 13:34    Post_subject: Lexmark x2600 install crashes  

Thanks to rcrsn51 for directing me here. I read through the above posts and downloaded the lexmark-inkjet-08-driver-1.0-1.i386.tar.gz.sh.zip from Lexmark site, unpacked it and tried to run the lexmark-inkjet-08-driver-1.0-1.i386.tar.gz.sh job/script. The processs looked familiar and then I checked back and found that I had already tried this a year or two ago. I followed the prompts and a window/box showed files being loaded and run. However the install then quickly crashed with the error:
Lua error detected: config/run.lua:325: Lua error detected: config/run.lua:1200: Could not execute command: sh /tmp/selfgz99479315/pkg/files/SCRIPTS/preinst
I clicked on okay and the install stopped. Couldn't find out what had happened because the install cleaned up all the files so ran the install again but left the error on the screen while I traced back through /tmp/selfgz9947... etc to see what it was doing. I got down to the /files folder or directory and found that there was no /SCRIPTS folder and therefore no preinst file.(In fact I couldn't find a file by that name anywhere in the path/directories) Since the /tmp/selfgz9947.. directories were all built during the install it looks as though something wasn't in the .tar.zip file or didn't get built by the unzip.
Just for interest, I ran the lexmark install on a second, larger desktop computer and got same results.
A year or so ago I was using Puppy 4.3.1, now I'm using 5.2(Lucid) and getting same results - crashing. Can't recall the exact problem from year ago.
So... does anyone have any ideas as to what is going wrong and how to fix this? It's not urgent - I don't use Puppy much anymore because of the printing but I'd appreciate any help or suggestions. Thanks!
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9207
Location: Stratford, Ontario

PostPosted: Fri 28 Jan 2011, 07:30    Post_subject:  

In the post directly above yours, I have packaged the Lexmark driver as a PET.
Back to top
View user's profile Send_private_message 
horhota

Joined: 19 Feb 2010
Posts: 20

PostPosted: Sat 29 Jan 2011, 14:32    Post_subject: PET file worked! X2670 up and running  

Thanks, rcrsn51. I tried the PET file and it worked in PuppyLinux 5.2. I downloaded the file and then just clicked on its icon and it said that it installed properly. Somewhere I read to check the usr/share/cups/model path/folders and I found a Lexmark folder with a X26xx.ppd file. When I ran the CUPS add-printer function, I ignored the box to select a manufacturer and model and went straight to the provide a .ppd file box. I can't find the option to enter a .ppd file in Puppy 4.3.1 but some day I may go back and try the PET file with that version as well.
It would seem to me that PET files are the way to go when installing a printer. Up to now, my attempts to install printers were complicated and frustrating - something that I could never suggest to others. The PET files provide a very simple and user friendly solution that I can recommend! Thanks again for your support and suggestions.
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9207
Location: Stratford, Ontario

PostPosted: Sat 29 Jan 2011, 15:12    Post_subject:  

Glad to help
Quote:
I ignored the box to select a manufacturer and model and went straight to the provide a .ppd file box.

There is no advantage to doing this. In fact it's misleading, because it suggests that you only need a PPD file to install a printer.

Puppy 4.3.1 has the older CUPS, so you will install it the standard way by selecting a Make and Model.

If you read here, you will find PET driver packages for many printer manufacturers.
Back to top
View user's profile Send_private_message 
alfbar1

Joined: 07 Jan 2011
Posts: 8

PostPosted: Thu 03 Feb 2011, 09:20    Post_subject:  

Thanks rcrsn51
I try only Xsane to scan, PET file works, lexmark x2650 and puppy 5.2
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0796s ][ Queries: 12 (0.0084s) ][ GZIP on ]