Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 28 Jul 2014, 04:55
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
spup-100 April 2011
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 30 of 52 [775 Posts]   Goto page: Previous 1, 2, 3, ..., 28, 29, 30, 31, 32, ..., 50, 51, 52 Next
Author Message
01micko


Joined: 11 Oct 2008
Posts: 7782
Location: qld

PostPosted: Tue 18 Jan 2011, 18:07    Post subject:  

sc0ttman wrote:
01micko wrote:
Ok guys

Here is a simple desktop configurator with a few templates for customising your desktop.

Does this disable the ROX pinboard when you select no icons and no drive icons?
(I'm downloading it and will hack it up and play with it to check anyway, but I just wondered - others might like to know as well..)

No sc0ttman, doesn't touch anything rox apart from PuppyPin. It also alters /etc/eventmanager, but you can get the same effect by running eventmanager in regard to the drive icons.
hth

Cheers

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
Jim1911

Joined: 19 May 2008
Posts: 2445
Location: Texas, USA

PostPosted: Tue 18 Jan 2011, 19:30    Post subject:  

Hi 01micko,

Your desktop configurator for customising your desktop works fine with spup and lucid. Great that you enable current custom setup to be saved. Finally an easy way to eliminate desktop clutter.

Looks great with stu90's wallpaper.

Thanks,
Jim
desktop.png
Description 
png

 Download 
Filename  desktop.png 
Filesize  133.3 KB 
Downloaded  319 Time(s) 
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7782
Location: qld

PostPosted: Tue 18 Jan 2011, 22:12    Post subject:  

Thanks Jim1911, there is a new version of desksetup http://www.murga-linux.com/puppy/viewtopic.php?p=487481#487481

It fixes a wallpaper bug with the custom setting.

I am going to add stu90's wall to 056, which may (or may not) be ready on the weekend. I like that notebook variation of the app too stu90. I may even adopt that approach and add radky's apps too.

One good thing about my app is that now, after you install an sfs it's a breeze to get your desktop back how it was. That bug (sfs) is also on my todo list but does involve tampering with critical system files.

Jim.. does TazOC have a fix for that, since LHP relies heavily on sfs?

Cheers

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
Jim1911

Joined: 19 May 2008
Posts: 2445
Location: Texas, USA

PostPosted: Wed 19 Jan 2011, 12:13    Post subject:  

01micko wrote:
Jim.. does TazOC have a fix for that, since LHP relies heavily on sfs?
Mick,
I usually use KDE4.4 with LHP and it has no problem with the desktop changing when adding sfs. I did switch over to JWM, added a sfs, rebooted, and there was no problem with that desktop either, so he may have a fix.

However, your new desktop configurator provides quick restoration of the desktop. I always manually backed up /Choices/ROX-filer/PuppyPin anyway so custom desktop could be quickly restored, now you've made that simple.

Radky's applications are a great addition. On my desktop, the last two items on wbar are his PupApps and PupShutdown. PupShutdown provides access to PupControl which allows access to all his applications. PupApps provides quick menu access to most used puppy programs.

You may also want to add your lucid wbar. All you have to do for it to work in spup is remove the default Quickpet selection.

Cheers,
Jim
Back to top
View user's profile Send private message 
playdayz


Joined: 25 Apr 2008
Posts: 3788

PostPosted: Wed 19 Jan 2011, 12:34    Post subject:  

01micko, I am thinking to post links to your desktop configurator plus radky's control panel in LupuNews. jim1911 said it works with Lucid. I'll check a bit--do you see any problems?

Oops, The minimal desktop icons worked fine, but the single drive icon didn't take--all the drive icons are back. I know you are not specifically supporting lucid here. It was in icewm btw. Same in jwm.

Hey stripe, I *am* taking a rest. Not being the "boss" is very relaxing Wink
Back to top
View user's profile Send private message 
yarddog


Joined: 30 Nov 2009
Posts: 187
Location: Great Smoky Mountains, TN USA

PostPosted: Wed 19 Jan 2011, 14:44    Post subject: spup-055 built from latest woof
Subject description: Desktop Setup-0.3.pet
 

installed desktop setup-0.3.pet. when I try to show only one drive icon or no drive icons receive message that x will be restarted but nothing happens
I restart x manually and nothing changed
Running full install to hard drive with several applications such as wbar, xchat, deadbeef, pupcontrol, xorghigh, roxterm, bibletime installed

any ideas

regards
yarddog
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2445
Location: Texas, USA

PostPosted: Wed 19 Jan 2011, 16:29    Post subject:  

playdayz wrote:
01micko, I am thinking to post links to your desktop configurator plus radky's control panel in LupuNews. jim1911 said it works with Lucid. I'll check a bit--do you see any problems?

Oops, The minimal desktop icons worked fine, but the single drive icon didn't take--all the drive icons are back. I know you are not specifically supporting lucid here. It was in icewm btw. Same in jwm.

Hey stripe, I *am* taking a rest. Not being the "boss" is very relaxing Wink
Hi playdayz,

Mick has posted updates that fixes some bugs. I've had no problems with it on my hardware using JWM or Openbox.

Also, consider adding all five of radky's applications to LupuNews, PupControl, PupApps, PupShutdown, PupClockset, and PupSnap. All five work well with Lucid and are a fine addition. I've used most of them daily through luci, lupu, and now 5.2.

Your "rest" is well deserved.

Cheers,
Jim
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7782
Location: qld

PostPosted: Wed 19 Jan 2011, 17:34    Post subject:  

playdayz wrote:
01micko, I am thinking to post links to your desktop configurator plus radky's control panel in LupuNews. jim1911 said it works with Lucid. I'll check a bit--do you see any problems?

Oops, The minimal desktop icons worked fine, but the single drive icon didn't take--all the drive icons are back. I know you are not specifically supporting lucid here. It was in icewm btw. Same in jwm.

Hey stripe, I *am* taking a rest. Not being the "boss" is very relaxing Wink


What it is is that lupu has a slightly different puppypin due to the fact that quickpet is on the desktop. What I would need to do is add cases for the current 52x series and the older 5x series because those older pinboards included a chat icon and QP was lower., no problem I can do it. It's is only dependant on rox running as the pinboard so wm shouldn't make a difference. That said, if rox isn't running (say as in xfce4) then I should put in code that stops the app running.

Yarddog.

I'm not sure what happened there, but it is possible that installing after many modifications may have caused a problem. Ideally this app should be in the iso by default to avoid those issues.
I'll see if I can reproduce your errors and see if there's a fix.

Cheers

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
playdayz


Joined: 25 Apr 2008
Posts: 3788

PostPosted: Wed 19 Jan 2011, 18:48    Post subject:  

Quote:
Also, consider adding all five of radky's applications to LupuNews, PupControl, PupApps, PupShutdown, PupClockset, and PupSnap. All five work well with Lucid and are a fine addition. I've used most of them daily through luci, lupu, and now 5.2.

I have got them jim1911. Pupclockset is already in the iso--oh, that might be a new one.

It's coming.
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7782
Location: qld

PostPosted: Wed 19 Jan 2011, 21:02    Post subject:  

desksetup-0.4

Ok, bug fixed, should work fine in lupu, spup, any post woof puppy (I think). I only tested in lupu-520 and spup-055 and 052.

There is a tiny bug in eventmanager. The pristine /etc/eventmanager file has double quotes wrapping all the true and false statements, but as soon as you run eventmanager either from menu or right clicking a drive icon those double quotes disappear. I have a workaround in place where if (and only if) the double quotes are detected then they are removed. This does not affect eventmanager at all. It still runs fine.

I also added cases for lupu less than 515 (for 500-511) and for 515 and greater. (luci wont work correctly, sorry)

All other puppies should be covered, but if used in a puplet with a custom pinboard then this will revert to stock puppy pinboard by default, defined by the DISTRO_FILE_PREFIX (see /etc/DISTRO_SPECS for an explanation)

Cheers!
desksetup-0.4.pet
Description 
pet

 Download 
Filename  desksetup-0.4.pet 
Filesize  3.98 KB 
Downloaded  456 Time(s) 

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
Stripe

Joined: 23 Jun 2010
Posts: 657
Location: In a field. England

PostPosted: Wed 19 Jan 2011, 21:12    Post subject:  

Hi all

trying to compile kde 3.5 and its asking for Qt3.3> <4.0 any ideas on a workaround? or do I need to compile an earlier version of qt?

cheers

stripe
Back to top
View user's profile Send private message 
stu90


Joined: 25 Feb 2010
Posts: 1401
Location: England. Dell Inspiron 1501. Dpup

PostPosted: Wed 19 Jan 2011, 21:58    Post subject:  

desksetup-0.4:
drive/desk settings working great here 01micko on Lucid 5.2
cheers.
Back to top
View user's profile Send private message 
yarddog


Joined: 30 Nov 2009
Posts: 187
Location: Great Smoky Mountains, TN USA

PostPosted: Wed 19 Jan 2011, 22:53    Post subject: spup-055 built from latest woof
Subject description: Desktop Setup-0.4.pet
 

that fixed problem for me with drive icons appearing properly - I still have a problem with restarting x - only way is click on menu option to restart then press ctrl-alt-del - possible problem with some of stuff i have added. will erase and do another full install tomorrow and report back .
thanks for help on desktop setup

yarddog
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7782
Location: qld

PostPosted: Wed 19 Jan 2011, 23:11    Post subject:  

Hi yarddog

Good the drive icons are fixed but it does seem to appear that something on your system is corrupt. If you have to press ctrl-alt-bkspce just to restart X then something is wrong. I can't see anything obvious with what you have installed but it appears X is not being killed. You list "xorghigh".. is this the one from lupu? If so that will be your issue. We do have a "mesa" package for spup that should do the same thing, available from the setup icon, "Update X Drivers" or the PPM, type "mesa*" in the search box with the spup repo checked. Make sure you uninstall xorg_high first, and pray that that doesn't break anything!

Thanks for reporting

Cheers

____________________________________________

Stripe,

I guess you got your answer in your question... kde3 needs qt3.
I'm going to try something foolish and try TazOC's kde4 for LHP in spup and see what's missing.. (EDIT, no I won't, it's 450M and needs mariner sfs.. gives it potential of being over 500M sfs in spup Shocked ) ... I haven't time to muck about with kde3/trinity just yet.

Cheers

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
Stripe

Joined: 23 Jun 2010
Posts: 657
Location: In a field. England

PostPosted: Thu 20 Jan 2011, 00:12    Post subject:  

Hi all

01micko have downloaded trinity but got sidetracked with icewm (lucid), don't know if its spup or my machine but it is flying compared to jwm, am going to try it on the old 800mhz box as well as compiling it in spup.

cheers

stripe
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 30 of 52 [775 Posts]   Goto page: Previous 1, 2, 3, ..., 28, 29, 30, 31, 32, ..., 50, 51, 52 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1013s ][ Queries: 13 (0.0154s) ][ GZIP on ]