Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 01 Jul 2015, 08:24
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
How Do I Get my 15" Widescreen Laptop to Display Proper
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message

Joined: 06 Jan 2006
Posts: 15

PostPosted: Mon 01 May 2006, 12:08    Post_subject:  How Do I Get my 15" Widescreen Laptop to Display Proper  


I checked the forum but couldn't find a posting that covered my situation (although I did see a similar post on a laptop with an ATI chipset).

I'm running Puppy 1.08 on a new Dell Inspiron B130. The screen is a 15" widescreen with what Dell calls, "Integrated Intel Graphics Media Accelerator 900, for Inspiron 1300/B130".

The default screen should be 1280 X 800. I can only choose 1024 X 768 or less in the Xorg wizard. All of the available resolutions have the wrong aspect ratio (4:3) but I need 16:10. Since my ratio is wrong all my images are squashed. I can read text fine, but the graphics display wrong.

Does anyone have any steps for fixing this problem? If I need special drivers, I've already looked at the Intel site but they reference drivers for certain versions of Linux. If I must use their driver, which driver from their site do I use?

I'm still new to Linux, but I can follow directions well enough that I managed to get my wireless network card working.

Any help would be most appreciated.

Back to top
View user's profile Send_private_message 

Joined: 29 May 2005
Posts: 3053
Location: Kitchener, Ontario, Canada

PostPosted: Mon 01 May 2006, 13:15    Post_subject:  

Note: this section of the forum is to Provide HOW-TO, solutions not to ask for how to do things.

Anyway, try editing your /etc/X11/xorg.conf file entering the correct refresh rates for your monitor and the correct geometry.

I searched the internet for "1280 X 800" "xorg.conf"


that basically says set the display resolution to maximum 1280 x 800 by doing this: Edit the file /etc/X11/xorg.conf. You will need to add these lines in the file:
Modes "1280x800" "1024x768" "800x600" "640x480"
Also, add this mode line (all one line):
ModeLine "1280x800" 98.9 1280 1352 1488 1696 800 801 804 833 -hsync +vsync

I know the most important thing is to know what to search for, now you know that video configuraition is stored in xorg.conf Wink
Let us know if it works.

http://rarsa.blogspot.com Covering my eclectic thoughts
http://www.kwlug.org/blog/48 Covering my Linux How-to
Back to top
View user's profile Send_private_message Visit_website 

Joined: 06 Jan 2006
Posts: 15

PostPosted: Wed 03 May 2006, 09:01    Post_subject:  

Strange. My xorg.conf had no insertion points. There was no monitor or device section. I found I was running xvesa so I ran the xorg wizard.

On reboot I was walked through the xorg configuration but the highest resolution it would give me was 1024 x 768. At least I had a proper xorg.conf when I was done but the driver was listed as vesa. Upon save session to CD and reboot I came back OK but xorg was not running, I was back to xvesa at 1024 x 768.

I remember seeing some program or probe I ran from within Puppy (don't remember which one) correctly identified the laptop embedded chip as: VBE version 3.0 (Intel 915GM/910ML/915MS Graphics Chip Accelerated Bios).

I've searched the forum and tried various bug fixes. I've manually
changed the driver in xorg.conf to read "i810", then "i810_drv", then "i915", and finally "i915_drv". At this point I figured a driver wasn't loading so I looked and there was nothing in lsmod that looked anything like a video driver.

I found the modules folder several child folders under /usr and saw a i810_drv.o so I tried to modprobe it. I get Modprobe: Can't locate module i810_drv. I've tried modprobe i810, i915, i815, i810_drv, i815_drv, and i_915_drv. All give me a "modprobe: can't locate module".

I've downloaded bug fix modules posted on the forum and placed them in my home folder. Still "can't locate module". Why can't it locate a module located in the most obvious location????

What does it take to get Puppy to load the Intel video driver? Does anyone have an Inspiron B130 or 1300 with this video chip and working drivers? Any guidance would be most appreciated.

I should add that I tried over a dozen variations of horizontal and vertical refresh rates in xorg but whenver the wizard ran the 40 second test I'd get colored horizontal bars or some other screen corruption and I get dropped back to 1024 x 768. Other places on the forum indicated that this meant I needed an Intel driver loaded.

Back to top
View user's profile Send_private_message 

Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Wed 03 May 2006, 09:19    Post_subject:  

you need no kernelmodules, they are required for Acelleration (3D) only.

You might need a newer driver for xorg.
Download this file:

if it does not work, this one:

This file must replace the existing

In xorg.conf, set
driver "i810"

If that fails, you might try Puppy2, that has a new driver for intels AGP-bridge:

Back to top
View user's profile Send_private_message Visit_website 
Puppy Master

Joined: 09 May 2005
Posts: 7441
Location: Perth, Western Australia

PostPosted: Thu 04 May 2006, 00:02    Post_subject:  

Yeah, it looks like you might need the intel-agp driver.
The next snapshot of puppy2 should load that automatically for you, so
hopefully xorgwizard will allow choice of the 1280x800.
I don't know about Xvesa, perhaps it will benefit from the intel-agp driver
also ???
Back to top
View user's profile Send_private_message Visit_website 

Joined: 10 Jun 2005
Posts: 5376
Location: Australia

PostPosted: Thu 04 May 2006, 04:25    Post_subject:  

For Puppy 1.0.8 with 2.4 kernel, you might try loading the (generic) agpgart.o module before X launches. Add "modprobe agpgart" to /root/.etc/rc.d/rc.local then reboot.

Or maybe you could install the full DRI package. Who knows, maybe then 1280x800 will work? Your Xorg driver is "i810", but your DRI kernel module is i915.

There's an xorg.conf listed here for i810 with 1280x800 and DRI - https://launchpad.net/distros/ubuntu/+source/xserver-xorg-driver-i810/+bug/39070
... notice that DRI is enabled in this config.
Back to top
View user's profile Send_private_message 

Joined: 06 Jan 2006
Posts: 15

PostPosted: Thu 04 May 2006, 21:30    Post_subject:  

I'm not getting any closer. I tried both i810 files. Modprobe couldn't find either.

I tested agpgart and got:

# modprobe agpgart
/lib/modules/2.4.29/char/agp/agpgart.o.gz: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.29/char/agp/agpgart.o.gz: insmod /lib/modules/2.4.29/char/agp/agpgart.o.gz failed
/lib/modules/2.4.29/char/agp/agpgart.o.gz: insmod agpgart failed

I tried the latest Puppy 2 but found I couldn't save to the CD (I can with 1.8). It failed to save if I chose the default save and if I chose to select a partition save it wanted a fresh CD.

What should I try next?

Back to top
View user's profile Send_private_message 

Joined: 06 Jan 2006
Posts: 15

PostPosted: Fri 05 May 2006, 08:03    Post_subject:  

I don't think I mentioned that my goal is to create a multisession CD. I don't want to modify the hard drive on the laptop which came installed with WinXP.

My Puppy 1.8 multisession CD boots fine. I set up ndiswrapper and it automatically wirelessly connects to the Internet. After I get the video to function at the native 1280 X 800 my next goal is to make the sound work.

When I try Pup 2 I have to shut off ACPI or the xorg wizard hangs at a blank screen. I can modprobe agpgart in Puppy 2. It was late when I gave up last night, but I think I got the Intel i915 to load although, if I understand the lsmod report correctly, it is not being used. I haven't tried agpgart with i915 at the same time because I can't get the Puppy 2 CD to save the session (even though Windows XP says the disk was burned for multisession and there is plenty of free space).

I tried saving my session to a USB key but the file containing Pearl used to set up ndiswrapper acts flaky - it shows in the root home folder after boot but never acts like it installed. Since I couldn't set up my wireless Internet I stopped using the USB flash.

As another side note, the USB for the Inspriron B130 (=1300) acts odd with Linux. If you enable it in BIOS to be on at boot, Puppy either can't find it or will hang while probing for it. If you disable it you can't boot off it, however Puppy can access it normally after boot.

Back to top
View user's profile Send_private_message 

Joined: 10 Jun 2005
Posts: 5376
Location: Australia

PostPosted: Fri 05 May 2006, 10:38    Post_subject:  

thekaz wrote:
I tried both i810 files. Modprobe couldn't find either.

There is an i810 DRI/DRM kernel module, but I think you're referring to the i810 Xorg driver. This is not a kernel module and you can't modprobe it.

The 2.4 agpgart.o module clearly won't play with your graphics chip/agp bridge. This module is no longer maintained, and it won't recognise a lot of modern graphics hardware.
It was really just an optimistic suggestion anyway. I suspect that a solution with kernel 2.4 might be found by just tweaking the xorg.conf file... but it's getting difficult so don't bother ...
go for Puppy2 and the better 2.6 agpgart.ko/intel-agp.ko modules. And install the advanced DRI driver package from MU's site, too.
Back to top
View user's profile Send_private_message 

Joined: 23 Jul 2006
Posts: 20

PostPosted: Tue 15 Aug 2006, 18:32    Post_subject:  


are there news about 1280x800? Will it work native with the 2.0x-release of Puppy?
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1592s ][ Queries: 12 (0.0423s) ][ GZIP on ]