Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 01 Oct 2014, 22:37
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
deb2pet & rpm2pet
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 4 of 4 Posts_count   Goto page: Previous 1, 2, 3, 4
Author Message
Master_wrong

Joined: 19 Mar 2008
Posts: 456

PostPosted: Tue 02 Jun 2009, 22:36    Post_subject:  

@Dejan

I have creted pet here : http://www.murga-linux.com/puppy/viewtopic.php?t=43131

please inform me if there any good proper way to put the lib files into usb/lib ? because in the package above it isn't installed automatically.


Thank you...
Back to top
View user's profile Send_private_message 
mistfire

Joined: 04 Nov 2008
Posts: 112

PostPosted: Tue 09 Nov 2010, 23:49    Post_subject: some components is missing  

I noticed that when I'm converting rpm to pet. It fails because there is component missing or conflicted. When i'm converting deb to pet, the undeb script was not included in this package. It cant to convert deb to pet until you download it. Can you include all the needed scripts in order to run it properly. What I mean is to include some required scripts for this app. (example: undeb is required for conversion so it must included on this pet package)
Back to top
View user's profile Send_private_message 
dejan555


Joined: 30 Nov 2008
Posts: 2666
Location: Montenegro

PostPosted: Wed 10 Nov 2010, 03:40    Post_subject:  

mistifire, ability to install debs on click is added to all newer puppy versions, so deb2pet is not really needed unless you're running some older puppy. undeb and unrpm are also provided in separate pet (read the main post)
_________________


Back to top
View user's profile Send_private_message Visit_website MSNM 
mistfire

Joined: 04 Nov 2008
Posts: 112

PostPosted: Fri 19 Nov 2010, 02:46    Post_subject:  

OK, by the way what versions of puppy does the installation of debs and rpms supported? Is it recognizable in Puppy Package manager. What I mean is when you install a deb or rpm file. The list of installed rpm or deb file can be found at PPM? Or do we need another Package manager to handle that kind of package? Is it possible to install a device driver in deb or rpm form in Puppy? Thank you in advance
Back to top
View user's profile Send_private_message 
dejan555


Joined: 30 Nov 2008
Posts: 2666
Location: Montenegro

PostPosted: Fri 19 Nov 2010, 03:17    Post_subject:  

Yes, puppy versions 5.x, dpup/squeeze pup and I think even quirky, really any of newer pups handles installation of debs through PPM.
_________________


Back to top
View user's profile Send_private_message Visit_website MSNM 
technosaurus


Joined: 18 May 2008
Posts: 4351

PostPosted: Fri 19 Nov 2010, 11:31    Post_subject:  

mistfire wrote:
Is it possible to install a device driver in deb or rpm form in Puppy? Thank you in advance
You may want to be careful not to mismatch your kernel version though. If a .deb for a kernel module is for kernel 2.6.27.X it may not work with a 2.6.3X.X puppy kernel and _may_ not even end up at the right place in /lib/modules unless there is a wrapper that I am unaware of.
_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send_private_message 
morgonzola


Joined: 21 Apr 2010
Posts: 160
Location: Los Angeles, CA

PostPosted: Tue 30 Nov 2010, 02:34    Post_subject:  

can you explain the difference between these scripts and alien2puppy?

is one better then the other?

also with alien2puppy you ha to put the dependencies in the same directory as the deb you wanted to convert and it would put them into one pet if i read correctly, does this one have to do that?
Back to top
View user's profile Send_private_message 
dejan555


Joined: 30 Nov 2008
Posts: 2666
Location: Montenegro

PostPosted: Tue 30 Nov 2010, 03:09    Post_subject:  

I've never used alien2puppy but no this one doesn't do that it converts single package
_________________


Back to top
View user's profile Send_private_message Visit_website MSNM 
mistfire

Joined: 04 Nov 2008
Posts: 112

PostPosted: Thu 02 Dec 2010, 02:34    Post_subject: questions about device drivers  

Technosaurus, im notice that compiling device drivers is compiling the kernel, Is there any way to compile a device driver without compiling a new kernel?

Dejan, does the PPM can upgrade and downgrade installed packages in PPM?
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 4 of 4 Posts_count   Goto page: Previous 1, 2, 3, 4
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0618s ][ Queries: 13 (0.0054s) ][ GZIP on ]