Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 27 Nov 2014, 06:43
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
IBM Lotus Symphony
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Tue 16 Mar 2010, 11:58    Post_subject:  IBM Lotus Symphony
Sub_title: installs from Ubuntu package
 

Lotus Symphony is a free-of-charge office suite derived from OpenOffice.org that you can download from here- there's a big download button off to the right- but IBM does make you register to get to the download.
The current version (not the beta) is based on a fairly old version of OO.o, and while it has a word processor, a spreadsheet editor and a presentation maker, there is no database or formula editor like you might find in newer versions of OO.o.


I prefer Symphony's interface over OpenOffice's, so I decided to give it a shot and install version 1.3 straight from the Ubuntu *.deb package that IBM offers.

It works, but it has it's quirks.

The file /usr/bin/symphony, which is the easiest way to launch the suite, is a symlink to an executable buried within a confusing mess of directories. Trouble is, that executable isn't actually set to be executable once it's installed, so you have to go and set the permissions yourself (the file in question is "/opt/ibm/lotus/Symphony/framework/shared/eclipse/plugins/com.ibm.productivity.tools.standalone.launcher.linux.x86_1.5.0.20090908-0900/IBM Lotus Symphony").
Once you do that, though, the suite runs perfectly well, assuming you either launch it from the command prompt by typing "symphony" or make a desktop shortcut manually.


I've actually managed to repackage the whole thing neatly into both an SFS (for Puppy 43x) and a PET, but I hesitate to distribute those packages since IBM does make you register to download.

I'm pretty sure I can, though, distribute a small PET that just has a *.desktop file to give the suite menu entries. If you want that small PET, it's here, and an md5sum is here if for some reason anybody wants it.


PLEASE NOTE that I have not tested the newer package, which should still be a beta release of version 3. I've only tried running version 1.3.
Also please remember that I have only tested this in Puppy 431.



The hardware and software requirements for Lotus Symphony 1.3 should be about the same as they are for OpenOffice (though I've run OpenOffice and Symphony on 128 MB of memory, so the 'official' requirements of either might not be completely accurate). Java is highly recommended.

So, there's yet another office suite that Puppy users can install and run, if they so desire!

Edited_times_total
Back to top
View user's profile Send_private_message Visit_website 
DC


Joined: 30 Apr 2006
Posts: 361
Location: Maidenhead, England

PostPosted: Tue 16 Mar 2010, 18:30    Post_subject:  

Hi,
I found the windows version of Lotus Symphony imported all my old Lotus 123 files much better than normal Open office (sheet formatting).
I'll have a look again time permitting Very Happy

thanks for the update

DC
Back to top
View user's profile Send_private_message 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Tue 09 Nov 2010, 18:05    Post_subject: Symphony 3.0  

A very similar situation is true of Lucid Puppy (I've used version 511) and Symphony 3.0 as was true of Puppy 431 and Symphony 1.3. (You might get it to work in 431, but I haven't tried it.)

The executable to actually be marked as executable:
"/opt/ibm/lotus/Symphony/framework/shared/eclipse/plugins/com.ibm.symphony.standard.launcher.linux.x86_3.0.0.20101015-2340/IBM Lotus Symphony"

This time, the symlink "/usr/bin/symphony" seems to point at nothing, so that'll have to be made to point at the executable named above.

You can use the same *.desktop pet package from the first post if you want.
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0473s ][ Queries: 12 (0.0038s) ][ GZIP on ]