Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 23 Nov 2014, 07:29
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
graphics poor on all puppylinux versions
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [11 Posts]  
Author Message
yr1945

Joined: 17 Apr 2010
Posts: 140

PostPosted: Thu 28 Oct 2010, 22:19    Post subject:  graphics poor on all puppylinux versions
Subject description: but, not on any other linux distros
 

i have tried to fix it by downloading various drivers including "quickpet" from puppy 5.1.1

i have a toshiba laptop 135A-4527

i even reinstalled Windows Vista (yuck) just to check graphics, the pc still works well with windows, too... and, as stated earlier, every other linux distro... which includes at least 25 of them including ubuntu, mint, fedora, opensuse, pclinuxos, etc, etc

the puppylinux versions are okay, but graphics and text are slightly "grainy"

any suggestions? thanks in advance for your help
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 5373
Location: Charleston S.C. USA

PostPosted: Thu 28 Oct 2010, 22:56    Post subject:  

This is a video driver, resolution setting, refresh rate issue.
The specs I found on your computer say you have an Intel Graphics Media Accelerator (GMA) 950.
Try the Xorg-high video driver in Quickpet.

For resolution settings and refresh rate, use the program Xorgwizard.

Last edited by bigpup on Thu 28 Oct 2010, 23:00; edited 1 time in total
Back to top
View user's profile Send private message 
technosaurus


Joined: 18 May 2008
Posts: 4376

PostPosted: Thu 28 Oct 2010, 22:57    Post subject:  

the key word to me was laptop - setting the correct dpi makes a difference for text... having more fonts can make a difference too.
That is just my first guess with limited info.
Can you be more specific as to what is "grainy"?

_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send private message 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Fri 29 Oct 2010, 02:06    Post subject:  

Also under the banner of "laptop", LCD displays are sharpest at their optimum resolution. Find the optimum resolution of your display from your tech specs and set your video driver to display at that resolution. Puppy requires you to do that manually. Many other, bigger Linux versions do that automagically, but the cost is bloat!

I hope that helps.

_________________
Actions speak louder than words ... and they usually work when words don't!
SIP:whodo@proxy01.sipphone.com; whodo@realsip.com
Back to top
View user's profile Send private message 
Sit Heel Speak


Joined: 30 Mar 2006
Posts: 2595
Location: downwind

PostPosted: Fri 29 Oct 2010, 04:38    Post subject: Improvement of fonts in Puppies Oct. 29 2010  

Here is what my fonts look like, on a Dell 2001FP 20" flatpanel monitor. This is in Quirky:
http://i53.tinypic.com/4lsld2.png

How to achieve this in Puppy, has recently become greatly simpler than it used to be:

After you install the Xorg-high video driver in Quickpet...and restart X...

Open a terminal and run
Code:
xdpyinfo | grep dimensions
xdpyinfo | grep resolution

Now open /etc/X11/xorg.conf in Geany or MEdit or whatever, scroll down to the Section "Monitor" and add a DisplaySize (i.e., dimensions) line and an Option "DPI" (i.e., resolution) line so it looks something like this. Use your own mm dimension size and DPI resolution values, of course, not the values I use for my own monitor:
Code:
Section "Monitor"
   #DisplaySize     410   310   # mm
   DisplaySize   423 317
   Option "DPI"   "96 x 96"
   Identifier   "Monitor0"
   VendorName   "DEL"
   ModelName    "DELL 2001FP"
   Option       "DPMS"
   HorizSync    31.0-80.0
   VertRefresh  56.0-72.0
   #UseModes     "Modes0" #monitor0usemodes
   Option      "PreferredMode" "1600x1200"
   EndSection

Now open /root/.Xresources and make its DPI line match what you actually have, for example mine is
Code:
!*font: -misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-*-*
!*font: -misc-fixed-medium-r-normal--13-120-75-75-c-70-*-*
*font: -misc-fixed-medium-r-normal--14-130-75-75-c-70-*-*
!*font: -misc-fixed-medium-r-normal--15-140-75-75-c-90-*-*

! Xft.dpi: 96

Note: do not use the "Set global font size" utility, in the menu under Desktop. It was and is, in my opinion, a foolish mistake to include this utility in Puppy. Using it will write a different (wrong) DPI value to /root/.Xresources.

Next,...to save space and reduce the distro size as much as possible, Puppy comes only with an extremely limited set of fonts. I suggest you add the latest complete set of DejaVu fonts and the Microsoft Core Webfonts. Get the DejaVu fonts from the DejaVu homepage on sourceforge, google (or duckduckgo or ixquick, if you value your privacy) to find out what the newest version is. Get the MCWfonts from here:
http://avi.alkalay.net/software/webcore-fonts/webcore-fonts-3.0.tar.gz

Download these two fontsets to, for example, /tmp, then click on each's .gz file, choose Extract, All, Extract Here, and for each fontset you get a new subdir with a lot of .ttf files in it.

Make a subdir /root/.fonts (if it doesn't already exist) and move all the .ttf files from the new font packages into /root/.fonts (hint: open Rox-Filer on the new subdir, Ctrl-A, drag'n'drop from /tmp/newsubdir to /root/.fonts)

Now some configuration magic.

Create a new file, /root/.fonts.conf.

(take care to not omit the leading "." in front of "fonts")

Make /root/.fonts.conf look like the attached (i.e. just copy it in, taking care to rename it with the "." in front of "fonts"). This will turn on subpixel rendering, full Bytecode Interpreter hinting, and anti-aliasing at font pixelsizes greater than 6, plus will perform some on-the-fly rendering modifications recommended by the DejaVu font team.

Note: if you are a perfectionist and have a lot of time on your hands, experiment with the value in this section of .fonts.conf:
Code:
 <match target="font" >
    <test compare="more" name="pixelsize">
      <double>6.5</double>
    </test>
  <edit mode="assign" name="antialias" >
  <bool>true</bool>
 </edit>
 </match>
to see at what threshold anti-aliasing becomes annoying on your particular monitor. Other values than 6.5 may work better. On my old Thinkpad T21 I like 13.

Now copy /root/.fonts.conf to /etc/fonts/local.conf:
Code:
mv -f /etc/fonts/local.conf /etc/fonts/local.conf-original
cp -af /root/.fonts.conf /etc/fonts/local.conf
so that both versions of the configuration file are identical. All up-to-date application programs for about a year now have been rendering fonts using pango, and pango expects the configuration file to be /root/.fonts.conf, but older programs may still be using /usr/lib/libfreetype.so (or, worse, the program may have libfreetype, an older version, statically linked) to do font-rendering, and libfreetype traditionally expects the configuration file to be /etc/fonts/local.conf --therefore I place the configuration file in both places, a belt-and-suspenders strategy.

If you are exceptionally cautious, as I am, then also copy the new font .ttf's (overwriting any which are already there) from /root/.fonts into the subdirectory where all Linuxes up til ...mm, I guess around late 2009, used to keep the fonts, which is

/usr/share/fonts/default/TTF

Place a duplicate set of the .ttf font files there, in case any programs from the mists of ancient history (e.g. 2009 or older) are still looking for fonts in the old usual place (or, to save diskspace, place all your .ttf fonts only in
/usr/share/fonts/default/TTF, and make /root/.fonts be just a symlink to /usr/share/fonts/default/TTF).

Now restart X (or reboot) to make it all take effect.

Your fonts should look somewhat better now.

HTH, SHS
fonts.conf.gz
Description  /root/.fonts.conf and /etc/fonts/local.conf for Puppies Oct 2010 with DejaVu fontset + Microsoft Core Webfonts (be sure to rename it correctly)
gz

 Download 
Filename  fonts.conf.gz 
Filesize  1.15 KB 
Downloaded  201 Time(s) 

Last edited by Sit Heel Speak on Sun 31 Oct 2010, 14:31; edited 1 time in total
Back to top
View user's profile Send private message 
yr1945

Joined: 17 Apr 2010
Posts: 140

PostPosted: Fri 29 Oct 2010, 19:21    Post subject: you will not
Subject description: believe this, but i did it
 

a big thanks to "bigpup / technosaurus / WhoDo / Sit Heel Speak" for all the suggestions...

(Sit Heel Speak)... i followed your directions very closely. The first couple of steps fixed my desktop icons and desttop text. next, i was able to download and extract the dejavu and msfonts. however, i could not load the fonts the way you described, so, i just found and opened the /root/.Fonts folder and manually (one-by-one) copied ALL the new fonts into the folder. Next, i just rebooted my pc and, VOILA.... no more seamonkey/firefox browser graininess problems. i don't know why... but, it worked.

THANKS again to all of you... yr1945

ps: i still have not figured out the correct way to apply downloaded/extracted files from tar.gz????
Back to top
View user's profile Send private message 
Sit Heel Speak


Joined: 30 Mar 2006
Posts: 2595
Location: downwind

PostPosted: Mon 01 Nov 2010, 04:04    Post subject:  

yr1945 wrote:
ps: i still have not figured out the correct way to apply downloaded/extracted files from tar.gz????

Rox-Filer is an extremely powerful tool, once you've mastered it. Takes longer to explain it than to do it. Pretty soon it will be second nature and you'll wonder why people put up with Windows Explorer. But meanwhile, feel free to ask for clarification if any of the below is confusing:

1. Click on the "Download" button where I offer fonts.conf.gz, above.

2. Presently, a dialog box will appear, giving you the choice of Open or Save, choose Save.

3. A dialog box appears, asking where you want to save it. In the left pane, double-left-click "root", then left-click the "Save" button in the lower right --BUT: on some monitors, not all of this dialogbox is placed onscreen, some falls off the screen. This is one problem with most of the very lightweight window managers which are supplied with "stock" Puppy. Better window managers for Puppy are fluxbox, Enlightenment e17, and, when painstakingly configured, Openbox, but you'll delve into those later.

In case of dialogbox off-screen placement, you must left-button-hold-down-drag-and-release the save dialogbox's titlebar so as to move the dialogbox up and to the left in order to see the "Save" button. Or, hold down the alt key while left-button-hold-down-dragging the window up and to the left so as to center it on the screen.

4.OK, you have now saved fonts.conf.gz to /root.

Now left-click Menu -> Filesystem -> ROX-Filer

This opens a ROX-Filer window on the subdirectory /root

5. (HINT: right-click in whitespace (between icons) in the ROX-Filer window, left-click "Options", left-click "Display" in the left pane, and use the scroll bar in "Default size" to choose Small Icons; then left-click-to-check the box "Order small icons vertically".

Now click the X at upper right to close the options dialog, again to close this Rox window, and do
Menu -> Filesystem -> ROX-Filer
again. With the new smaller icons and vertical ordering, Rox is much easier to use).

6. You will see fonts.conf.gz listed in /root. Left-click on its icon. This will call the gunzip (Gnu Unzip) program, it will ask if you want to unpack it where it is and delete the original. Answer yes and it will do exactly that.

7. Now right-click on the freshly unpacked fonts.conf, left-click Rename, and put a dot (".") in front of the "f" in "fonts" and then press Enter or click the ...mm, I forget, whatever the "OK" or "Save" or "Rename" button is called.

Now you have a file named .fonts.conf in /root. Any file with the . in front is a hidden file, and may not be visible in Rox depending on how you have Rox set up. There is an option in Options to show hidden files. If you can't see .fonts.conf, left-click the eye icon along the top of the Rox window and Rox will show hidden files.

8. When you have .fonts.conf visible in /root,
do Menu -> Shutdown -> Restart X Server (exact names vary among different Puppies) to restart X, and now /root/fonts.conf will take effect.

9. Now make a copy of it as /etc/fonts/local.conf, but first back up your existing /etc/fonts/local.conf, Do this:

Left-click Menu -> Filesystem -> Rox, left-click the up arrow to navigate to the top directory /, left-click the etc subdir icon, left-click fonts, right-click local.conf, left-click Rename, and rename it local.conf--original

10. Now left-button-hold-down-and-drag-n-drop /root/fonts.conf from a /root Rox window into the /etc/fonts Rox window. Then, right-click the new /etc/fonts/fonts.conf, Rename, and rename it local.conf.

11. Now do Menu -> Shutdown -> Restart X Server again, and bob's-yer-uncle.

12. To select all the files in the subdirectory shown in a Rox window, left-click in whitespace to de-select anything that is selected, then hold down the Ctrl key and tap the A key and release the ctrl key. All items in the subdirectory are now highlighted. You can left-button-hold-down-and-drag them as a unit to another Rox window, say for example a Rox window opened to
/usr/share/fonts/default/TTF, and this way copy all the .ttf files over from /root/.fonts in one fell swoop.

(note: the first letter of the filename fonts.conf and the directory name "fonts" should not be capitalized, case matters in Linux)

Rox also lets you lasso files, you'll learn that later.

Be careful when ctrl-A copying all the contents in a top directory (say, for example, /mnt/sda3), not to copy (or delete) the subdirectory "lost+found" (if it exists) as this is important to the filesystem structure and must remain where it is. To de-select an item from a Rox window in which you have selected everything using ctrl-A, hold down the ctrl key and left-click on the item you wish to deselect.

Welcome to Puppy, praise the Lord 'n' pass the ammunition,
SHS
Back to top
View user's profile Send private message 
abushcrafter


Joined: 30 Oct 2009
Posts: 1447
Location: England

PostPosted: Mon 01 Nov 2010, 09:40    Post subject:  

Sit Heel Speak wrote:
3. A dialog box appears, asking where you want to save it. In the left pane, double-left-click "root", then left-click the "Save" button in the lower right --BUT: on some monitors, not all of this dialogbox is placed onscreen, some falls off the screen. This is one problem with most of the very lightweight window managers which are supplied with "stock" Puppy. Better window managers for Puppy are fluxbox, Enlightenment e17, and, when painstakingly configured, Openbox, but you'll delve into those later.
Wrong, its a problem with older versions of GTK2.
_________________
adobe flash is rubbish!
My Quote:"Humans are stupid, though some are clever but stupid." http://www.dependent.de/media/audio/mp3/System_Syn_Heres_to_You.zip http://www.systemsyn.com/
Back to top
View user's profile Send private message Visit poster's website 
Sit Heel Speak


Joined: 30 Mar 2006
Posts: 2595
Location: downwind

PostPosted: Mon 01 Nov 2010, 15:31    Post subject:  

abushcrafter wrote:
Wrong, its a problem with older versions of GTK2.
Well, you may be right, I wouldn't know. Whether the cause is in the GTK2 toolkit upon which the window manager acts to draw things, or in the window manager itself's code, makes no difference as far as the instructions I gave to yr1945.

I may have missed any correction to this misbehavior in Puppy's default window manager, JWM, because I am not using current Puppy (Lucid 501, 511, luci-234, or wherever it is now), but rather a local woof-build of Quirky which I made last September, using painstakingly configured Openbox as the window manager.

So, I was drawing on memory in referring to the problem. I haven't actually seen the dialogbox offscreen problem in awhile.

It's good to know it's been fixed.

Best, SHS
Back to top
View user's profile Send private message 
yr1945

Joined: 17 Apr 2010
Posts: 140

PostPosted: Mon 08 Nov 2010, 17:42    Post subject:  

Sit Heel Speak...
I would like to THANK YOU again for all your support. I reinstalled Puppy 5.1.1 a second time. Then, I closely followed your instructions again. My graphics work/ look just fine, now.

Also, I am now working on your second set of instructions relative to "tar.gz" files. I am making good progress. At this point I am sure that I can figure everything out. Bye... and, thanks again for your detailed instructions.
yr1945
Back to top
View user's profile Send private message 
Sit Heel Speak


Joined: 30 Mar 2006
Posts: 2595
Location: downwind

PostPosted: Mon 08 Nov 2010, 21:13    Post subject:  

I've changed my mind about /root/.Xresources --I think you should leave it at its original Xft.dpi setting.

Changeing it to 98 or whatever, messes with the size of text in titlebars and gtkdialog boxes. So, leave it at
Code:
!*font: -misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-*-*
!*font: -misc-fixed-medium-r-normal--13-120-75-75-c-70-*-*
*font: -misc-fixed-medium-r-normal--14-130-75-75-c-70-*-*
!*font: -misc-fixed-medium-r-normal--15-140-75-75-c-90-*-*

! Xft.dpi: 78
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [11 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1062s ][ Queries: 13 (0.0040s) ][ GZIP on ]