Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 16 Apr 2014, 12:56
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
FFmpeg-0.7.6 and xine-lib for Puppy 4.x
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 3 [32 Posts]   Goto page: Previous 1, 2, 3 Next
Author Message
abushcrafter


Joined: 30 Oct 2009
Posts: 1447
Location: England

PostPosted: Mon 11 Oct 2010, 16:51    Post subject:  

technosaurus wrote:
the bitrate parameter has changed too - this causes some scripts to make really large or very poor quality output depending on the direction of the mismatch ... this should be somewhat stabilized since the 0.5.1 release ... anyone ever heard of a stable api?
Could you give a bit more info please.. because I can't see the difference. I compared the info from the "--help" parameter from the FFmpeg in puppy 4.3.1/ttuuxxx 4.3.2 v3 to the FFmpeg from this thread.
_________________
adobe flash is rubbish!
My Quote:"Humans are stupid, though some are clever but stupid." http://www.dependent.de/media/audio/mp3/System_Syn_Heres_to_You.zip http://www.systemsyn.com/
Back to top
View user's profile Send private message Visit poster's website 
technosaurus


Joined: 18 May 2008
Posts: 4133

PostPosted: Mon 11 Oct 2010, 17:54    Post subject:  

in 2007 the ffmpeg bitrate flags (-b and -ab) were changed. They were kbits/sec, but are now bits/sec. Examples older than ~3 years or so will thus be way to low on current ffmpeg build, and newer examples will yield extremely large output on ffmpeg builds older than about 3 years.

Most people should have a newer version than this - so the large file size shouldn't be a problem, but if they google an old example it will sound like @$$ unless a "k" is added.

edit: maybe if the value is less than 999 or so and doesn't have a following b,k,m,etc...?

_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send private message 
abushcrafter


Joined: 30 Oct 2009
Posts: 1447
Location: England

PostPosted: Tue 12 Oct 2010, 17:26    Post subject:  

Few Very Happy, the version in Puppy Linux 4.3.0(Guessing.),4.3.1,4.3.2 v3 by ttuuxxx use this version:
Code:
# ffmpeg -version
FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2007 Fabrice Bellard, et al.
  configuration: --arch=i486 --enable-libmp3lame --enable-liba52 --enable-libfaac --enable-libfaad --enable-pthreads --enable-small --enable-libogg --enable-libvorbis --enable-gpl --enable-shared --enable-pp --disable-debug --prefix=/usr
  libavutil version: 49.5.0
  libavcodec version: 51.44.0
  libavformat version: 51.14.0
  built on Jul 12 2009 11:29:41, gcc: 4.2.2
FFmpeg SVN-rUNKNOWN
libavutil   3212544
libavcodec  3353600
libavformat 3345920
#
Which was after the change.
Thanks for you time.

_________________
adobe flash is rubbish!
My Quote:"Humans are stupid, though some are clever but stupid." http://www.dependent.de/media/audio/mp3/System_Syn_Heres_to_You.zip http://www.systemsyn.com/
Back to top
View user's profile Send private message Visit poster's website 
edoc


Joined: 07 Aug 2005
Posts: 4307
Location: Southeast Georgia, USA

PostPosted: Tue 12 Oct 2010, 21:31    Post subject:  

Still stuck trying get a avi conversion that will work in our daughter's weird Chinese mp4 player.

I am in dpup 009 at the moment and loaded ffconvert-1.0.pet and ffmpeg1-0-i686-Lucid.pet

The app refuses to recognize any video I load as source - just says no video or audio.

Did I make a mess using the Ludic codecs?

I read somewhere that the codecs cannot be backed-out of Puppy ... which seems a contradiction to one of the principles of Puppy ... everything can be changed.

What do I do now?

The dpup 009 save file is not important, I am just testing, if I delete that and reboot will that clean out the Lucid ffmpeg codecs in dpup and I can start clean?

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
abushcrafter


Joined: 30 Oct 2009
Posts: 1447
Location: England

PostPosted: Mon 18 Oct 2010, 11:27    Post subject:  

I have made a new thread for FFmpeg Wrapper here: Puppy Linux Discussion Forum :: View topic - FFmpeg Wrapper 0.0.5.
_________________
adobe flash is rubbish!
My Quote:"Humans are stupid, though some are clever but stupid." http://www.dependent.de/media/audio/mp3/System_Syn_Heres_to_You.zip http://www.systemsyn.com/
Back to top
View user's profile Send private message Visit poster's website 
shinobar


Joined: 28 May 2009
Posts: 2384
Location: Japan

PostPosted: Mon 25 Oct 2010, 02:55    Post subject: FFmpeg on Puppy squeeze  

edoc wrote:
Still stuck trying get a avi conversion that will work in our daughter's weird Chinese mp4 player.
I am in dpup 009 at the moment and loaded ffconvert-1.0.pet and ffmpeg1-0-i686-Lucid.pet.
The app refuses to recognize any video I load as source - just says no video or audio.

WARNING: Installing any of ffmpeg pet, primerly installed ffmpeg and libraries are overwritten, and your multimedia environment may corrupt.

Although ffmpeg-runall-0.6-i686-p4.pet worked on dpup-009, by my quick test,
probably you need not install special ffmpeg, for the dpup-009 (squeeze).
Install ffconvert-1.0.pet only.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
shinobar


Joined: 28 May 2009
Posts: 2384
Location: Japan

PostPosted: Wed 27 Oct 2010, 23:53    Post subject: xine-lib-1.1.19  

Compiled xine-lib with ffmpeg-0.6 + recent codecs.
xine-lib-1.1.19-p4.pet available. See the top of this topic.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
abushcrafter


Joined: 30 Oct 2009
Posts: 1447
Location: England

PostPosted: Fri 29 Oct 2010, 18:42    Post subject:  

Thanks very much for this new xine-lib. I can now play theora video in gxine Very Happy but not webm Sad. Test video: http://lachy.id.au/lib/media/elephantsdream/Elephants_Dream-360p-Stereo.webm from: Custom controls WebM video.
_________________
adobe flash is rubbish!
My Quote:"Humans are stupid, though some are clever but stupid." http://www.dependent.de/media/audio/mp3/System_Syn_Heres_to_You.zip http://www.systemsyn.com/
Back to top
View user's profile Send private message Visit poster's website 
shinobar


Joined: 28 May 2009
Posts: 2384
Location: Japan

PostPosted: Sat 30 Oct 2010, 07:31    Post subject:  

abushcrafter wrote:
I can now play theora video in gxine Very Happy but not webm Sad.

Thanks, abushcrafter for the report and the link to the test video.
I confirmed it can be played with ffplay.sh but cannot by gxine as you reported.
Quote:
2010-07-25:
Release xine-lib 1.1.19
A new version of xine-lib is available. This is mainly bug fixes, but
there are one or two new features, notably support for the WebM container format.

Hum... i may mistook the compile options... Rolling Eyes

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
shinobar


Joined: 28 May 2009
Posts: 2384
Location: Japan

PostPosted: Sun 31 Oct 2010, 00:59    Post subject: WebM support in xine-lib-1.1.19  

xine-lib-1.1.19 release note says:
Code:
Recognise and handle the WebM container format.
  (VP8 video is not yet supported.)

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
abushcrafter


Joined: 30 Oct 2009
Posts: 1447
Location: England

PostPosted: Sun 31 Oct 2010, 10:00    Post subject: Re: WebM support in xine-lib-1.1.19  

shinobar wrote:
xine-lib-1.1.19 release note says:
Code:
Recognise and handle the WebM container format.
  (VP8 video is not yet supported.)
Oops. Sorry.
_________________
adobe flash is rubbish!
My Quote:"Humans are stupid, though some are clever but stupid." http://www.dependent.de/media/audio/mp3/System_Syn_Heres_to_You.zip http://www.systemsyn.com/
Back to top
View user's profile Send private message Visit poster's website 
AF Branden


Joined: 15 Sep 2009
Posts: 175
Location: United States, WA

PostPosted: Sun 26 Dec 2010, 19:27    Post subject:  

I installed ffmpeg-runall-0.6-i686-p4.pet and ffplay works great

but when I try to install this xine-lib-1.1.19-p4.pet Gxine segfaults

How do I get my gxine working with ffmpeg?

Gxine version 0.5.903 using xine-lib 1.1.8


Edit: danggg, I try to fix one thing and another problem arises, installing your ffmpeg-runall-0.6-i686-p4.pet really screwed up my opengl acceleration....gonna be a pain to fix it

I shoulda saw a red flag when it said it replaces libraries...

Edit: I inspected the .pet and it turns out it overwrites some SDL files reinstalling SDL-1.2.9.pet got my games and everything working
again but now ffplay doesn't work haha, linux is a pain sometimes

Can anybody tell me how to fix the conflicting sdl versions?

Edit: I think its fixed now, I redirected libSDL.so and libSDL-1.2.so.0 symlinks to point to the older SDL everything SEEMS to be working in harmony now, ffplay works and my games work

Gxine still segfaults with the new library and I don't know how to fix it, at least I backed up the old one...

_________________

Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2384
Location: Japan

PostPosted: Wed 25 Jan 2012, 22:13    Post subject: FFmpeg-0.7.2  

FFmpeg-0.7.2(most recent stable libav version) and codecs.
See the top post.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
kenbanistu

Joined: 08 Jan 2009
Posts: 30

PostPosted: Sun 22 Apr 2012, 01:18    Post subject: Re: FFmpeg-0.7.2  

shinobar wrote:
FFmpeg-0.7.2(most recent stable libav version) and codecs.
See the top post.


What CPU was this compiled for? Stuff compiled for an i686 tend not to work for me.
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2384
Location: Japan

PostPosted: Sun 22 Apr 2012, 02:41    Post subject: Re: FFmpeg-0.7.2  

[quote="kenbanistu"]
shinobar wrote:
What CPU was this compiled for?

Code:
# ffmpeg
ffmpeg version 0.7.2, Copyright (c) 2000-2011 the Libav developers
  built on Dec 26 2011 09:09:20 with gcc 4.2.2
  configuration: --prefix=/usr --cpu=i486 --enable-shared --enable-gpl --enable-nonfree --enable-x11grab --enable-network --enable-small --enable-runtime-cpudetect --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libdc1394 --enable-libfaac --enable-libfreetype --enable-libmp3lame --enable-libspeex --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxvid --enable-zlib --enable-postproc --disable-debug --enable-bzlib --enable-version3 --enable-libtheora --enable-swscale

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 2 of 3 [32 Posts]   Goto page: Previous 1, 2, 3 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0877s ][ Queries: 12 (0.0164s) ][ GZIP on ]