Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 02 Oct 2014, 02:47
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Success porting Openshot video editor to puppy.
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 4 of 6 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Author Message
smil99

Joined: 18 Aug 2007
Posts: 174

PostPosted: Tue 13 Jul 2010, 09:19    Post_subject:  

Quote:
tell me if this happens for you too.
import mp4, put it in a track, export to ogg theora. fine no problem.
then import the ogg theora to a new workspace put it in a track then export it to ogg theora or even just preview it. does it produce a multicolored pixilated screen that changes i.e, not your original video images at all.


I did all that but there was no problem playing back, previewing or re-exporting ogg theora files.Obviously, something must be wrong at your end. Nevertheless, let me know if I can do anything to help.

Cheers.
Back to top
View user's profile Send_private_message 
aarf

Joined: 30 Aug 2007
Posts: 3620
Location: around the bend

PostPosted: Tue 13 Jul 2010, 10:37    Post_subject:  

smil99 wrote:
Quote:
tell me if this happens for you too.
import mp4, put it in a track, export to ogg theora. fine no problem.
then import the ogg theora to a new workspace put it in a track then export it to ogg theora or even just preview it. does it produce a multicolored pixilated screen that changes i.e, not your original video images at all.


I did all that but there was no problem playing back, previewing or re-exporting ogg theora files.Obviously, something must be wrong at your end. Nevertheless, let me know if I can do anything to help.

Cheers.

thanks smill99. something strange going on. going to look in the openshot forum for ideas and tips.

_________________

ASUS EeePC Flare series 1025C 4x Intel Atom N2800 @ 1.86GHz RAM 2063MB 800x600p ATA 320G
_-¤-_

<º))))><.¸¸.•´¯`•.#.•´¯`•.¸¸. ><((((º>
Back to top
View user's profile Send_private_message Visit_website 
enhu


Joined: 26 May 2009
Posts: 301

PostPosted: Thu 05 Aug 2010, 16:27    Post_subject:  

has anyone made it to work in lucid pup ?
Back to top
View user's profile Send_private_message Visit_website 
neurino


Joined: 15 Oct 2009
Posts: 360

PostPosted: Wed 25 Aug 2010, 06:05    Post_subject:  

I'm using Wary 030, but guess it's the same in Quirky, and the devx sfs ships python 2.6.4.

Wouldn't be possible to have it compiled for that version of python rather than 2.5.2?

Also an openshot SFS to work along with devx one would be a good thing since the use of a Video editor is not in a dayly basis (nor weekly) for most users.

Tips?
Back to top
View user's profile Send_private_message 
smil99

Joined: 18 Aug 2007
Posts: 174

PostPosted: Wed 25 Aug 2010, 10:23    Post_subject:  

enhu writes:
Quote:
has anyone made it to work in lucid pup?

Yes, it works fairly well in Lucid Puppy. You can now download it from Puppy Linux News

This includes all the dependencies so you don't need to add anything from here.

Cheers.
Back to top
View user's profile Send_private_message 
smil99

Joined: 18 Aug 2007
Posts: 174

PostPosted: Thu 28 Oct 2010, 20:44    Post_subject: Openshot-1.2.2 available for luci-233  

Openshot-1.2.2 is now available for luci-maverick testing series. Might also work in luci 5.1 final version.

Download from here:
Openshot-1.2.2-Lucid.pet

Although this version is supposed to hook up with an installed Blender-2.54 for the new 3D-animation titles rendering, I couldn't make it work. Other than that, it works quite well.


Note:
Below is the error I reported in the Openshot forum and the reply I got from Jonathan, the developer of Openshot.

Quote:
# openshot
Added /usr/share/openshot to system path
--------------------------------
OpenShot (version 1.2.2)
--------------------------------
Process no longer exists: 19431. Creating new pid lock file.
socket(): Address family not supported by protocol
state saved
on_mnu3dTitle_activate called with self.GtkImageMenuItem
on_treeTemplates_button_release_event
Traceback (most recent call last):
File "/usr/share/openshot/windows/BlenderGenerator.py", line 229, in on_treeTemplates_button_release_event
self.params[param.name] = [color.red_float, color.green_float, color.blue_float]
AttributeError: 'gtk.gdk.Color' object has no attribute 'red_float'
on_btnRender_clicked
Done with Render() method


Jonathan's response:
Quote:
@smil99,
That error is caused by using an older version of pyGTK / GTK. This was the same error I got while trying to test on Ubuntu 9.04. To use version 1.2.2 (with the Blender integration) you must have GTK version 2.18 or greater.

Thanks,
-Jonathan.


Any clues about the GTK error?

Cheers.
Back to top
View user's profile Send_private_message 
disciple

Joined: 20 May 2006
Posts: 6439
Location: Auckland, New Zealand

PostPosted: Fri 29 Oct 2010, 17:36    Post_subject:  

What do you mean "any clues"? He told you that you need a newer GTK.
_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send_private_message 
smil99

Joined: 18 Aug 2007
Posts: 174

PostPosted: Fri 29 Oct 2010, 19:49    Post_subject:  

@disciple
Quote:
What do you mean "any clues"? He told you that you need a newer GTK

Yes. I mean how do we implement a newer GTK (or parts thereof) in puppy so as to overcome this problem?
Sorry my earlier post wasn't explicit enough.

Cheers.
Back to top
View user's profile Send_private_message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Fri 29 Oct 2010, 20:45    Post_subject:  

Quote:
Openshot-1.2.2 is now available for luci-maverick testing series.


Thanks smil99, that is where I am using it with enjoyment.

Openshot is not yet completely stable but very easy to use.

A cheap portable video camera and some time editing . . .
and you have your own film making resources
http://www.youtube.com/user/crustylobster

_________________
Puppy WIKI
Back to top
View user's profile Send_private_message Visit_website 
disciple

Joined: 20 May 2006
Posts: 6439
Location: Auckland, New Zealand

PostPosted: Sat 30 Oct 2010, 00:03    Post_subject:  

smil99 wrote:
@disciple
Quote:
What do you mean "any clues"? He told you that you need a newer GTK

Yes. I mean how do we implement a newer GTK (or parts thereof) in puppy so as to overcome this problem?
Sorry my earlier post wasn't explicit enough.

Cheers.

Sorry, no. You're using "luci-maverick". I don't know exactly what that means, but I imagine it does have a new enough GTK. So you probably need a newer Py-GTK, which was his other suggestion. See if you can find a newer version on the forum; I think I saw a reasonably recent .pet. Or maybe try a package from Ubuntu or whatever it is that luci-maverick is based on.

_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send_private_message 
smil99

Joined: 18 Aug 2007
Posts: 174

PostPosted: Sat 30 Oct 2010, 02:06    Post_subject:  

Quote:
So you probably need a newer Py-GTK

Exactly. I am still searching. One thing though, Openshot is very sensitive to changes in these py files. I tried changing the one I bundled with the Openshot pet and it opened up many new cans of worms like requesting for newer versions of ffmpeg and its associated libs. So I had to revert back to what works for now.
Quote:
You're using "luci-maverick". I don't know exactly what that means

It is the same luci-233 under testing now. It is indeed interesting how we are still sticking to the name "Luci or lupu" whilst luci-233 is based mostly on Ubuntu Maverick binaries.
Perhaps "Mapu" sounds more appropriate.
Just a thought.

Cheers.
Back to top
View user's profile Send_private_message 
l0wt3ch
Guest


PostPosted: Mon 01 Nov 2010, 22:47    Post_subject:  

Congratulations getting the new OpenShot working. I was messing with it a bit, and it wasn't working for me then. I'll have to try it out.
Back to top
mama21mama

Joined: 03 Apr 2010
Posts: 526
Location: Lincoln, Buenos Aires, Argentina

PostPosted: Sun 05 Dec 2010, 09:57    Post_subject: Re: Openshot-1.2.2 available for luci-233  

smil99 wrote:
Openshot-1.2.2 is now available for luci-maverick testing series. Might also work in luci 5.1 final version.

Download from here:
Openshot-1.2.2-Lucid.pet


Gracias
thanks Rolling Eyes
Back to top
View user's profile Send_private_message Visit_website AIM YIM MSNM 
smil99

Joined: 18 Aug 2007
Posts: 174

PostPosted: Wed 02 Mar 2011, 22:35    Post_subject: Openshot-1.3 is out  

Openshot 1.3 is out and it is working at my end in luci252. I made some modifications to /usr/share/openshot/windows/BlenderGenerator.py (from line 285) and /usr/share/openshot/windows/MainGTK.py (from line 1466) and Openshot now seems to work ok. These were done so as to have Blender work seamlessly with Openshot. You may therefore hook it up with Blender2.56 if you want 3D titles.

Give it a spin and let me know how it goes.

Openshot-1.3
Install this new python also:
Python2.6

Note: This has been tested only in luci252.
Cheers.
Back to top
View user's profile Send_private_message 
nilsbird

Joined: 05 Apr 2011
Posts: 1

PostPosted: Tue 05 Apr 2011, 04:00    Post_subject: Python library files missing
Sub_title: How to get them?
 

Downloaded python from pet package manager. How do I update the python library files that are missing?

Nilsbird
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 4 of 6 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0885s ][ Queries: 13 (0.0054s) ][ GZIP on ]