Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 30 Oct 2014, 10:47
All times are UTC - 4
 Forum index » Advanced Topics » Hardware
Puppy not detecting my usb HP 940c inkjet printer
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
Dragonopolis

Joined: 08 Apr 2006
Posts: 10

PostPosted: Sat 08 Apr 2006, 09:44    Post_subject:  Puppy not detecting my usb HP 940c inkjet printer  

Puppy version 1.08r1
I have a HP pav a530n
2Ghz athlon 64
200GB, hp 300i dvd writer, asus cd-rom,
floppy drive with multi-reader flash cards + a firewire and USB 2.0 port (front)
I have ps/2 mouse/keyboard, 4 USB 2.0 ports and 1 firewire port (rear)
Printer: HP940c (900 series)
Now I have not had a problem with hardware detection for a long time. It has been a Long time since I used anything with a 2.4 kernerl. I sure hope its not a kernel issue. Here's the problem.

I am showing my old usb canon scanner and my usb AK5370 (logitech mic) but for some odd reason I can't get puppy to see my usb printer. I haven't had a distro in over a year (I have tried alot of distros) give me problem with this printer. I'm fresh out of ideas. I've used your wizard first and when it didn't work I check USB view in the control panel and I didn't see it listed. I tried probing for it using a terminal no luck. I have for a long time used the front usb connection because of convenience. I tried using one of the rear usb ports and the same problem occured. Any suggestions.


Crying or Very sad
Back to top
View user's profile Send_private_message 
eccentric

Joined: 05 Jan 2006
Posts: 139
Location: Khon Kaen Thailand.....NOW back in the UK

PostPosted: Sun 09 Apr 2006, 04:32    Post_subject:  

Hi Dragonopolis.
I use the same puppy driver as you for the HP920c printer. it works in both USB &Par. the only thing i found was i had to resatart puppy and turn the printer off for twenty seconds, then when reinstalled all works fine.
Just to let you know the driver works fine.

Michael an eccentric
Back to top
View user's profile Send_private_message YIM MSNM 
Dragonopolis

Joined: 08 Apr 2006
Posts: 10

PostPosted: Sat 15 Apr 2006, 05:28    Post_subject: Well I'm not seeing it and I tried the same thing you did  

My usb printer is not even recognized by the OS. Puppy reports that there is a device plugging in the usb port but reports that it does not know what it is. And when I use the usb device utility to look, only my scanner and AK5370 usb Mic (which has not worked in most linux distros I have tried) show up as devices. This is a shock because I have never had problems with this printer in any Linux distro I have tried. Would be nice to know if there is a fix. For instance, HP makes printer drivers for Linux problem is it is in a tar and I have been unsuccessful in Compiling anything on Puppy. I tried putting the usr_devx.sfs in the root folder, in actual / and in the place where Puppy001 resides. I rebooted every time I tried still I got errors saying there was no gcc or compiler. Oh well, would be nice if Puppy would come with a compiler already set-up. Any other suggestions on fixing my usb problem would be helpful.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0473s ][ Queries: 12 (0.0087s) ][ GZIP on ]