Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 11:44
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
JWM Corrupt Config
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
UberNoob


Joined: 23 Jan 2010
Posts: 33
Location: Potsdam NY USA

PostPosted: Thu 25 Feb 2010, 19:43    Post_subject:  JWM Corrupt Config  

Just tried changing some JWM settings (specifically tray management) and got a
NEW CONFIG CORRUPT. KEEPING ORIGINAL.
All other JWM Config Manager settings work appropriately.
I'm running 4.3.1 Full on a Dell Inspiron B130 and have no idea how I did this though a similar problem is mentioned here:
http://www.murga-linux.com/puppy/viewtopic.php?p=143742&sid=3c2600793789c077aaa4f5bf14536f19
Is there a way to manually replace or repair my JWM config file?

_________________
Follow the misadventures of "Timmy and his new puppy"
http://puppylinuxnoob.blogspot.com/
About My Puppy: 4.3.1 FULL on a DELL INSPIRON B130
Back to top
View user's profile Send_private_message 
pri


Joined: 09 Oct 2009
Posts: 330
Location: Bandung Indonesia

PostPosted: Thu 25 Feb 2010, 20:13    Post_subject:  

try this one to fix jwm
jwmconfig2-20090207.pet

_________________
Learning by Doing
Back to top
View user's profile Send_private_message Visit_website YIM 
UberNoob


Joined: 23 Jan 2010
Posts: 33
Location: Potsdam NY USA

PostPosted: Thu 25 Feb 2010, 21:18    Post_subject:  

Crying or Very sad
The .pet installed okay, re-booted, same problem.
I DO appreciate the try though, thanks!

_________________
Follow the misadventures of "Timmy and his new puppy"
http://puppylinuxnoob.blogspot.com/
About My Puppy: 4.3.1 FULL on a DELL INSPIRON B130
Back to top
View user's profile Send_private_message 
technosaurus


Joined: 18 May 2008
Posts: 4353

PostPosted: Thu 25 Feb 2010, 21:38    Post_subject:  

maybe?
Code:
cp -f /initrd/pup_ro2/root/.jwmrc-tray /root/.jwmrc-tray

followed by a fixmenus

jwm -p #tells you where it goes wrong

_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send_private_message 
pri


Joined: 09 Oct 2009
Posts: 330
Location: Bandung Indonesia

PostPosted: Thu 25 Feb 2010, 21:45    Post_subject:  

owh..

this is my jwm tray
Quote:
<JWM>
<Tray autohide="false" insert="right" x="0" y="-1" border="1" height="28" >

<!-- Additional TrayButton attribute: label -->
<TrayButton label="Start Menu" icon="mini-dog.xpm">root:3</TrayButton>

<!-- <TrayButton popup="Run commandline" icon="gexec.xpm">exec:gexec</TrayButton> -->
<TrayButton popup="Show Desktop" icon="mini-desktop.xpm">showdesktop</TrayButton>
<TrayButton popup="Free space in drives" icon="mini-hdisk.xpm">exec:partview</TrayButton>

<!-- Additional Pager attributes; width, height -->
<Pager/>

<!-- Additional TaskList attribute: maxwidth -->
<TaskList/>

<Dock/>

<!-- Additional Swallow attribute: height -->

<Swallow name="blinky">
blinkydelayed -bg "#DCDAD5"
</Swallow>

<Swallow name="asapm">
asapmshell -u 4
</Swallow>

<Swallow name="freememapplet" width="34">
freememappletshell
</Swallow>

<Swallow name="xload" width="32">
xload -nolabel -bg "#888888" -fg red -hl white
</Swallow>

<Clock>minixcal</Clock>
</Tray>
</JWM>


try copied this to your /root/.jwmrc-tray

to make it autohide, change false with true

<Tray autohide="false" insert="right" x="0" y="-1" border="1" height="28" >

_________________
Learning by Doing
Back to top
View user's profile Send_private_message Visit_website YIM 
UberNoob


Joined: 23 Jan 2010
Posts: 33
Location: Potsdam NY USA

PostPosted: Thu 25 Feb 2010, 23:30    Post_subject:  

@pri & technosaurus
Thanks for the ideas. Neither one helped with my odd problem HOWEVER in the spirit of making lemonade with those lemons I spent some time devouring the JWM docs I could find online and discovered that directly manipulating the .jwmrc-tray file was easy enough and gave me additional options left out of the GUI! Guess I liked my problem more than the original state!

BTW, all I got out of "jwm -p" was a pair of tag errors in jwmrc-theme

Thanks again for your effort!
Cheers.

_________________
Follow the misadventures of "Timmy and his new puppy"
http://puppylinuxnoob.blogspot.com/
About My Puppy: 4.3.1 FULL on a DELL INSPIRON B130
Back to top
View user's profile Send_private_message 
puppymartin


Joined: 29 Mar 2009
Posts: 207
Location: The Netherlands

PostPosted: Wed 20 Oct 2010, 15:19    Post_subject:  

A new version of "/usr/local/jwmconfig2/taskbarConfig".
It just changes autohide="false" to autohide="true" (or autohide="true" to autohide="false") and a JWM restart.
taskbarConfig2.tar.gz
Description  taskbarConfig2 to replace taskbarConfig
gz

 Download 
Filename  taskbarConfig2.tar.gz 
Filesize  792 Bytes 
Downloaded  252 Time(s) 
Back to top
View user's profile Send_private_message Visit_website 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Wed 20 Oct 2010, 15:27    Post_subject:  

Often this is caused by a <corner> tag in the theme file. <corner> tags are no longer supported. Go to /root/.jwm/jwmrc-theme and open it as text. (right click, select 'open as text'
Look for any mention of 'corners' Comment it out so it looks like this:
Code:
    <Inactive>
    <Opacity>.8</Opacity>
       <Text>#000000</Text>
       <Title>#ebe4e4:#c0bebe</Title>         
<!--       <Corner>#ebe4e4</Corner> -->
       <Outline>#ebe4e4</Outline>
    </Inactive>
</WindowStyle>


Comment out each instance you find. Please report back if this is the case as there is another step to complete.

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send_private_message 
technosaurus


Joined: 18 May 2008
Posts: 4353

PostPosted: Thu 21 Oct 2010, 00:39    Post_subject:  

UberNoob wrote:
BTW, all I got out of "jwm -p" was a pair of tag errors in jwmrc-theme...Thanks again for your effort!

_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send_private_message 
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Thu 21 Oct 2010, 03:37    Post_subject: jwmconfig2-20100823  

The 'Application launch buttons in tray' of JWM configuration did not work for a long time.
The Japanese Forum member, himajin and shinobar, fixed the code.

See:
http://murga-linux.com/puppy/viewtopic.php?t=59058

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0686s ][ Queries: 13 (0.0044s) ][ GZIP on ]