Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 23 Feb 2019, 02:58
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Pupp108rl installs Comal026.pup but gives run error (Solved)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
r__hughes

Joined: 13 Apr 2006
Posts: 356
Location: Montreal, Canada

PostPosted: Thu 13 Apr 2006, 00:25    Post subject:  Pupp108rl installs Comal026.pup but gives run error (Solved)  

I am using Live puppy v1.0.8rl
I installed OpenComal.0.2.6.pup from the built in Puppy Package manager
it seems to have installed OK but won't run from rxvt as per instructions.
When I type in 'opencomal' to start I get a run error :
-----
# opencomal
opencomal: error while loading shared libraries: libreadline.so.4: cannot open shared object file: No such file or directory
#
--------

Any ideas?
(wifi-1.0.4-beta2.pup & adv770.pup are installed & working fine)

Last edited by r__hughes on Sat 27 May 2006, 22:02; edited 1 time in total
Back to top
View user's profile Send private message 
GuestToo
Puppy Master

Joined: 04 May 2005
Posts: 4078

PostPosted: Thu 13 Apr 2006, 01:27    Post subject:  

you could try making a symlink:

ln -s /usr/lib/libreadline.so.4.3 /usr/lib/libreadline.so.4

or right click /usr/lib/libreadline.so.4.3 in Rox to make a symlink
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13647
Location: Karlsruhe, Germany

PostPosted: Thu 13 Apr 2006, 12:40    Post subject:  

http://noforum.de/dotpups/libreadline-so-4.pup
Mark
Back to top
View user's profile Send private message Visit poster's website 
r__hughes

Joined: 13 Apr 2006
Posts: 356
Location: Montreal, Canada

PostPosted: Thu 13 Apr 2006, 14:35    Post subject:  

GuestToo wrote:
you could try making a symlink:

ln -s /usr/lib/libreadline.so.4.3 /usr/lib/libreadline.so.4

or right click /usr/lib/libreadline.so.4.3 in Rox to make a symlink


Thanks for the suggstion but alas to no avail -
I first searched the entire system to make sure there was no evidence of libreadline.so.4 then I made a dummy /usr/lib/libreadline.so.4.3 script with its shortcut called /usr/lib/libreadline.so.4

Now when I type 'opencomal' in rxvt it seems to find the libreadline file but since it's a dummy I get a 'file too short error' :-

# opencomal
opencomal: error while loading shared libraries: /usr/lib/libreadline.so.4: file too short

Seems that something is missing from the Comal dotpup (I assume it should have installed this libreadline.so.4 file into /usr/lib/)

I have tried reinstalling comal by direct download of the dotpup file & a click to install - but results are the same
Back to top
View user's profile Send private message 
r__hughes

Joined: 13 Apr 2006
Posts: 356
Location: Montreal, Canada

PostPosted: Thu 13 Apr 2006, 14:47    Post subject:  

MU wrote:
http://noforum.de/dotpups/libreadline-so-4.pup
Mark


Thank you very much - That did the trick!!!
Comal is now up and working.

Many thanks to you and GuestToo for blindingly fast responses.
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13647
Location: Karlsruhe, Germany

PostPosted: Thu 13 Apr 2006, 14:58    Post subject:  

fine, we try our best Cool
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0322s ][ Queries: 12 (0.0102s) ][ GZIP on ]