Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 31 Jul 2014, 16:08
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Lucid Puppy 5.1.1 Release - This is the official release
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 44 of 51 [754 Posts]   Goto page: Previous 1, 2, 3, ..., 42, 43, 44, 45, 46, ..., 49, 50, 51 Next
Author Message
gcmartin

Joined: 14 Oct 2005
Posts: 4129
Location: Earth

PostPosted: Thu 16 Sep 2010, 18:32    Post subject: Howto Build Your Own Puppy  

Building a PUP from Scratch is an interesting discussion here.

The topic covered here by @Stripe, @playdayz and @pemasu is great. But, I have a request for either/both of tyou. After you work thru the stumbling issues, would you post a HOWTO that shows how you build a Puppy with the releases that you are currently working on?

A step by step on how you achieved your resulting systems ISO would be extremely useful, I think, to the community at large. Think it over.

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile
Back to top
View user's profile Send private message 
steve_s


Joined: 26 May 2008
Posts: 1545
Location: Austin, TX, USA

PostPosted: Thu 16 Sep 2010, 21:43    Post subject: Re: Misc issues  

Dave_B wrote:
I first want to say that I really like Puppy 5.11 and my thanks go to all the folks involved in creating this jewel.


I realized I hadn't said that either! Dave_B said it right: well done to all of you! Thank you for all you do! Cool
Back to top
View user's profile Send private message Visit poster's website 
Dave_B

Joined: 02 Aug 2010
Posts: 36
Location: Idaho, USA

PostPosted: Thu 16 Sep 2010, 22:01    Post subject: Re: Misc issues  

Shep wrote:
Dave_B wrote:
I have installed Open Office and my files didn't associate with OO apps. Is there a way to do this?

right-click on that file in the file manager -> select Open With ..... -> Customise

Once you wade through it the first time, you'll see it makes sense. (I'm not using Lucid yet but assume pups from the same litter are all similar.) Laughing

HTH Smile


Shep,
Thank you! I actually discovered 'select Open with...' a few minutes before I found your reply. Now I have to find the right icons. I'm still curious about the letters that are showing up with the Pwidgets apps. Does anyone have this 'feature'?
Dave
Back to top
View user's profile Send private message 
gjuhasz


Joined: 29 Sep 2008
Posts: 143

PostPosted: Fri 17 Sep 2010, 13:10    Post subject: Midori pet package
Subject description: Includes dependencies. Tested in Lucid Puppy 5.1.1
 

For Midori fans, I uploaded midori-0.2.7.pet here:

http://www.datafilehost.com/download-e64fd0c9.html

Includes dependencies. Tested in

Lucid Puppy 5.1.1
Puppy Squeeze 004

One-click install, one-click remove if you dislike it.
Well, it's 21 MB. Embarassed Maybe somebody can trim the fat...

Have a nice weekend.
Back to top
View user's profile Send private message 
technowomble


Joined: 11 Oct 2007
Posts: 76
Location: West Gloucestershire, UK

PostPosted: Sat 18 Sep 2010, 04:05    Post subject: Pwireless2 not working  

I'm having a problem getting pwireless2 working in 5.1.1. I've posted full symptoms over on the pwireless2 thread, but basically after I go through the standard procedure ( install pwireless2, remove profiles from Network-wizard, reboot ) pwireless can't see my wifi card, and just locks up when I click refresh or roam, and I have to kill it. In the small hours I remembered that 5.1.1 has an option to make Network-wizard the default connection option, and I'm pretty sure I clicked on that setting up after installing. Could that be stopping pwireless2 connecting properly, and if so can I undo the default setting or do I need to re-install?
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 18 Sep 2010, 12:27    Post subject:  

I am now building test build of luci512pre with added 50 .deb files. I would like to do some postinstall style adjustment. Like postinstall.sh script which has rows to execute adduser and addgroup like this:

Code:
addgroup --system pulse
adduser --system --ingroup pulse --home /var/run/pulse pulse
addgroup --system pulse-access


Where and how should I do above in woof after ./2createpackages phase.
Quote:

Building a PUP from Scratch is an interesting discussion here.

gcmartin. In fact I am doing opposite. Not building from scratch but making basic woofed lucid even bigger. Smile
When I have succeeded in what I am doing now, I might try to make luci without packages I dont need. But doing that there is risk that something basic breaks also.

But here is someone doing lucid smaller using woof:
http://www.murga-linux.com/puppy/viewtopic.php?p=451759#451759
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 3220
Location: Ontario

PostPosted: Sat 18 Sep 2010, 12:39    Post subject: new version of mhwaveedit opens retrovol  

I compiled a new version of mhwaveedit 1.4.20
that is able to launch retrovol
It works only in Lucid Puppy (perhaps because I compiled it in Lucid Puppy)
Download here

http://www.datafilehost.com/download-590211f0.html

________________________________________________
Back to top
View user's profile Send private message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Sun 19 Sep 2010, 03:27    Post subject:  



5.1.1 with Seamonkey 2.1a alpha with Compactmenu installed and Personas activated.
Transparency activated, instructions here http://www.murga-linux.com/puppy/viewtopic.php?p=452011#452011
Top autohide launchbar installed, instructions here http://www.murga-linux.com/puppy/viewtopic.php?p=440979#440979
And very light touch Blue JWM theme to maximise screen space.
Bluetheme.pet
Description 
pet

 Download 
Filename  Bluetheme.pet 
Filesize  96.48 KB 
Downloaded  274 Time(s) 

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sun 19 Sep 2010, 04:41    Post subject:  

Quote:
Hi pemasu
Looks like woof has been fixed, I have just downloaded a new version via bones, added Playdayz 4 original 512 files and everything downloaded OK, Its just on compiling now.
(where do we talk about woof?)
Hope this helps
Stripe


There might be people who thinks woofed luci 512pre or followups discussion hijacks this thread. Should it be continued in own thread ? I just thought that some people would learn something just by reading and also bugs might be found from the woof builded luci and it would be useful to discuss about them here. Of course success is main aim Smile

Stripe. Thank you. Downloading now. I will try next woofed luci 512pre ? today.

EDIT: howto make postprocessing adjustments and execute commands. zzLupu_Utilities-5.1.1.pet seems to be answer. It includes postinstall sript called pinstall.sh. Download .pet from http://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-5/zzLupu_Utilities-5.1.1.pet rename it to tar.gz, extract and then make your needed commands to the end of the file, save. Launch dir2pet to package it as .pet again. Next step not yet tested. Replace woof downloaded zzLupu_Utilities-5.1.1.pet with your own in woof > packages-pet directory.
Also you could create your own zz...pet which includes pinstall.sh only, make entry for it to Packages-puppy-lucid-official or someother and then copy your own pet packages-pet directory. I will test the first method first. Let` see if this works. If someone knows better, playdayz knows of course, let me know.

I have also noticed that using woof_gui confuses my building. I am going to edit files manually and launch woof scripts straight in terminal in this woofed luci.

Remind of basics of woofed luci by playdayz: http://www.murga-linux.com/puppy/viewtopic.php?p=423897&sid=c7d9115cbe6f0603e1752d37546eee83#423897
Back to top
View user's profile Send private message 
purplebelly

Joined: 21 Jul 2007
Posts: 6

PostPosted: Sun 19 Sep 2010, 09:58    Post subject: mplayer
Subject description: ignores dvd menu
 

mplayer appears to ignore dvd menus, though it will play a dvd as a whole.

Not a big issue, as vlc is available as a pet, and works with dvd menu.
Back to top
View user's profile Send private message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3956
Location: Kiel,Germany

PostPosted: Sun 19 Sep 2010, 13:17    Post subject: GRUB-1 vs GRUB-2  

Quote:
I was thinking about Grub2

from page 35 :

I`ve now X-Ubuntu 10.04 livecd installed on xfs partition :

/boot/grub/grub.cfg isn`t as tough as puppy`s menu.lst !

I made a lot of manual adjustments and
first time only 23 of 71 (?) entries showed up. putting the '}' closing bracket at the right place and adding one or even two emtpy lines between the entries made them showing up reboot&fixing-grub.cfg after reboot&fixing-grub.cfg

I downloaded the source of grub 1.96 ,1.97, 1.98 from Ubuntu and debian and many .src from these are lacking scripts like configure, conf.sub, stamp.h.in and so on

.src.rpm appear better for the content.

but I coulnd`t find any .rpm for 'os-prober' packages

`os-prober` seems to be important to write a grub.cfg with entries and `linux-boot-prober` really reads the old menu.lst files

I detected this because at one Macpup HD always a Suse linux boot entry showed up and after I uncommented the Suse lines at that menu.lst
Code:
# linux-boot-prober /dev/sda1
/dev/sda1:/dev/sda1::/boot/vmlinuz::root=/dev/sda1
/dev/sda1:/dev/sda1::/boot/vmlinuz::root=/dev/sda1

the lines are the right ones .

Software Packages in "lucid-updates", Subsection admin for grub 2

Software Packages in "lucid", Subsection admin for grub 1

and even "maverick" has got grub-0.97 as package

os-prober_1.39_i386.deb could be found on some of these places :
http://packages.debian.org/unstable/utils/os-prober
Back to top
View user's profile Send private message Visit poster's website 
gcmartin

Joined: 14 Oct 2005
Posts: 4129
Location: Earth

PostPosted: Sun 19 Sep 2010, 14:07    Post subject: SeaMonkey alpha is available and Current Seamonkey recently  

@DAveS
How did you go about installing SeaMonkey alpha? (maybe you could let us know at Puppy &SeaMonkey)
Thanks for your efforts.

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile
Back to top
View user's profile Send private message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Sun 19 Sep 2010, 15:28    Post subject: Re: SeaMonkey alpha is available and Current Seamonkey recently  

gcmartin wrote:
@DAveS
How did you go about installing SeaMonkey alpha? (maybe you could let us know at Puppy &SeaMonkey)
Thanks for your efforts.


http://www.murga-linux.com/puppy/viewtopic.php?p=452277#452277

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 20 Sep 2010, 01:04    Post subject:  

I have gathered links and written small howto use woof for building distro. At the end is luci spesific links.

http://www.murga-linux.com/puppy/viewtopic.php?p=452324&sid=57607594ea1d41d41ae4384e4f56d0bf#452324
Back to top
View user's profile Send private message 
OzOle

Joined: 20 Sep 2010
Posts: 3
Location: Laidley Queensland Australia

PostPosted: Mon 20 Sep 2010, 13:07    Post subject: How to upgrade 5.0.0 to 5.1.1 ?
Subject description: assistance with upgrading
 

Hi all,

Thanks for a truly great Linux (particularly to Barry).

My desktop widget tells me that my version is 5.0.0

Since I'm not very experienced with Puppy I haven't discovered how to upgrade to version 5.1.1.

Or is that not possible? Do I need to do a fresh install?

What I would like is a simply "click here" way of automatically upgrading to a newer version.

Please somebody point me in the right direction.

Thanks,

OzOle
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 44 of 51 [754 Posts]   Goto page: Previous 1, 2, 3, ..., 42, 43, 44, 45, 46, ..., 49, 50, 51 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1318s ][ Queries: 13 (0.0363s) ][ GZIP on ]