Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 23 Sep 2014, 04:22
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Lucid Puppy 5.1.1 Release - This is the official release
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 43 of 51 [754 Posts]   Goto page: Previous 1, 2, 3, ..., 41, 42, 43, 44, 45, ..., 49, 50, 51 Next
Author Message
svgt

Joined: 26 Mar 2008
Posts: 109
Location: Hamburg, Germany

PostPosted: Tue 14 Sep 2010, 15:31    Post subject: Booting 511 live at 12 year old machine causes kernel panic  

After booting the live cd I get these last messages:

setting up the layered filesystem ... done
performing a 'switch_root' to the layered filesystem
kernel panic - not syncing - attempted to kill init!

I think its not the quality of the cd, but the quality of the old machine. The same live cd is launching at newer machines.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Wed 15 Sep 2010, 01:26    Post subject:  

Still trying to get familiar with woof. I started from bones download to new woof-1. This time I needed to add packages 5 repo to DISTRO_PET_REPOS at the last row. Otherwise pet-5 packages didnt download.


PACKAGELISTS_PET_ORDER='Packages-puppy-quirky-official Packages-puppy-5-official Packages-puppy-woof-official Packages-puppy-4-official'

I still dont have clear idea howto add your own pet´s so that woof accepts them for building.
Back to top
View user's profile Send private message 
Iguleder


Joined: 11 Aug 2009
Posts: 1907
Location: Israel, somewhere in the beautiful desert

PostPosted: Wed 15 Sep 2010, 04:44    Post subject:  

It's simple, add the specs line to the first repo. I added this:
Code:
fotoxx-10.9.1|fotoxx|10.9.1||Graphic|603K||fotoxx-10.9.1.pet||Fotoxx photo gallery|debian|squeeze||


to the top of Packages-puppy-quirky-official, because that's my top priority repo. Then, put the pet in packages-pet.

In some cases you need to delete all other versions from the Packages-puppy-something-official if you want Woof to pick your custom package. In my case I had xine-lib 1.1.19 and the Quirky repo has 1.1.18, Woof picked the older Quirky package so I removed its entries.

_________________
My homepage
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
ICQ Number 
DM was on fire!


Joined: 12 Sep 2009
Posts: 156
Location: N.E. Georgia Mountains, USA

PostPosted: Wed 15 Sep 2010, 11:27    Post subject:  

svgt wrote:
After booting the live cd I get these last messages:

setting up the layered filesystem ... done
performing a 'switch_root' to the layered filesystem
kernel panic - not syncing - attempted to kill init!

I think its not the quality of the cd, but the quality of the old machine. The same live cd is launching at newer machines.


I tend to have similar issues as well. It's, in my case, scratches on the CD making it unbootable.
Since you said the machine is twelve years old, it sounds like it could possibly be insufficient memory? Since it's loaded into the ram on boot-up, and when you create a USB it says there should be atleast 512mb to load it into RAM...
Sad

Nothing is really more interesting (for a Linux user) when you get a kernel panic booting from a CD. XD

HEY GUYS I have Lupu 5.11 up and running on a 4gb SanDisk Cruzer thumb drive. I've had no hassles thus far (but my computer is like...well over the specs for Puppy), except for configuring my wireless. When I would enter my WEP key on the original Network Wizard (the one I've used on Puppy 4.3 as long as I've had it), it would say it's unable to find a live connection. But going through Barry's tool worked just fine. It was a lot easier too, I must say.

I can't wait to see as this goes along. Smile
In fact, if you guys give me some artwork (I typed it as arfwork. I guess it works) and logos, I'll make some wallpapers Smile
Back to top
View user's profile Send private message MSN Messenger 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Wed 15 Sep 2010, 11:46    Post subject:  

Second woof build luci512pre. Midori still segmentation faults. Seems to do so in squeeze dpup also, build by Iguleder and he uses lupu packages also. In PPM Luci repo again empty so I have missed again something. Libgoffice was missing. After installing it abiword 2.8.6 opened. So I have still work to do before I handle woof correctly. maybe I have to move pet-5 package repo after woof or .... or .......

But it works.

Iguleder: Thank you of your description. One obstacle out from building special Luci.

Why not just remastering working installation. Well... I want to have solid base system which is updatable with newer Lucid versions and general fixes by BK and easily updated to have those apps I need also. Woof should be capable to do that.
Back to top
View user's profile Send private message 
playdayz


Joined: 25 Apr 2008
Posts: 3788

PostPosted: Wed 15 Sep 2010, 20:35    Post subject:  

pemasu and others,

These are the custom templates that are used to build Lupu. If all you want to do is to build Lupu-5.1.2pre exactly as it is then you do not need them. Instead there are files such as "cups_lucid" that contain the cups program already built for Lupu. But if you want to use the Lupu SPECS to build some other version--or with different binaries such as dpup--then you should use the custom templates.

What I do is to go into the packages-templates folder and rename cups to cups.old and then copy the custom cups template in. Then you need to go to DISTRO_PKGS_SPECS_ubuntu lucid or whatever and find the entry

yes|cups_lucid||exe,dev,doc,nls and replace the yes with a no

and then find the entry no|cups|cups-bsd,cups..etc|exe, etc

and change that to yes. What that does is tell Woof to download and use the cups files from the binary distro--so download them and then tell Woof to build them and Woof will use the custom template to build cups out of the binaries--it might even work Wink

Do this also with ghostscript, xorg_base, and xserver_xorg.

Repeat, you do not need to do this if all you want is to build Lupu 5.1.2pre. I recommend that you go through the steps and get a good Lupu 5.1.2 pre before you start experimenting. Do every step except you do not need to add programs--skip that step.

Stripe, you should have already had the files that are on the previous page. Perhaps you could share your experience in building from scratch with pemasu? Thanks. Also stripe, you are probably better off with the Woof of Aug 22--it seems that there might have been some glitches in the latest Woof that Barry posted--possibly causing the problems such as midori and any others. But Barry will get it right pdq.

I will check here for questions if I can be of any assistance.

Pemasu, libgoffice should have been included in gnumeric.
custom_templates.tar.gz
Description 
gz

 Download 
Filename  custom_templates.tar.gz 
Filesize  269.13 KB 
Downloaded  367 Time(s) 
Back to top
View user's profile Send private message 
Dave_B

Joined: 02 Aug 2010
Posts: 36
Location: Idaho, USA

PostPosted: Wed 15 Sep 2010, 23:05    Post subject: Misc issues  

I first want to say that I really like Puppy 5.11 and my thanks go to all the folks involved in creating this jewel.

I've noticed that the xload? widget in the toolbar doesn't start all the time on boot up, it does start if I restart the xServer. The Pwidgets apps on the display have a leading uppercase character in a large white font preceeding the title.
I have installed Open Office and my files didn't associate with OO apps. Is there a way to do this?

I sure appreciate that the update from 5.1 left my files in place. Good work.

Dave

1998 HP Onmibook 500, PIII 750 Mhz, 512M ram
Back to top
View user's profile Send private message 
Shep

Joined: 08 Nov 2008
Posts: 851
Location: GIRT-BY-SEA

PostPosted: Wed 15 Sep 2010, 23:36    Post subject: Re: Misc issues  

Dave_B wrote:
I have installed Open Office and my files didn't associate with OO apps. Is there a way to do this?

right-click on that file in the file manager -> select Open With ..... -> Customise

Once you wade through it the first time, you'll see it makes sense. (I'm not using Lucid yet but assume pups from the same litter are all similar.) Laughing

HTH Smile
Back to top
View user's profile Send private message 
Stripe

Joined: 23 Jun 2010
Posts: 658
Location: In a field. England

PostPosted: Thu 16 Sep 2010, 01:05    Post subject:  

Hi all

Sorry Playdayz been a bit busy and am just catching up

If anyone has any questions I am always here to try and help (have used woof successfuly to create a previous version)

I found that installing woof using bones gave better results, (10gb partition)
http://bkhome.org/woof/index.html

I used a previous version of lucid to do it (but I think anything after 4.3.1 will do it.)

Once you have built Woof. Take the 4 downloads playdayz listed in the thread remove the .gz so they become text files and copy them into the woof-tree folder. If it asks you if you want to overwrite? just say yes

Then start the woof-gui and go to the first tab: Specifications
Compatible Distro and Compatible Distro version are the important ones, set them to ubuntu and lucid/ You can set the others to what you want. And then Update the Specs (big button).

Then go to the download Db's tab and choose Update Local Db's tab. That will take a while, maybe 30 minutes or so.

The next is Download packages--that will also take a while, a couple of hours maybe.

Next is Build packages--about 45 minutes. It might show that there is an error building linux_kernel-2.6.33.2... That is OK. It is the only way I know to get the kernel there at this time. It doesn't hurt anything.

After the packages are built, go to Kernel Options and drop down the menu. You want the one that says linux_kernel-2.6.33.2-patched-smp_L3.

Now you are ready to Build Distro. you have to click Enter a few times--but it doesn't need any manual adjustment--everything should run automatically.

The easiest at first might be to burn it to a CD after it is built--Woof gives that option.

I am sorry but I dont know how to alter the packages, but with the files Playdayz has supplied you wont need to, and you should end up with a copy of 5.1.2

Last time it took me about 5 hours in total from start to finish
Hope you have fun
Stripe
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 16 Sep 2010, 01:35    Post subject:  

Stripe. Thank you of your information. It always help to know how others use bones and woof. I have build luci512pre almost like you have. I have started from the scratch with bones, downloaded woof and then played with woof_gui. I have also checked availability and dependencies which are slow steps. Only glitch I had was with the second attempt that pet-5 packages didnt download. I had to edit PACKAGELISTS_PET_ORDER='Packages-puppy-quirky-official Packages-puppy-5-official Packages-puppy-woof-official Packages-puppy-4-official'

I tried downloading many times without success, but after above edit I got those pets from pet-5.

Midori seems to segfault. Also I think I got wrong version of gnumeric because libgoffice was missing. But basic functionality is ok. I still have issues that wireless infrequently loses the connection. If I use pwireless2, the problem vanishes. Wired connection was ok after I compiled the driver.
Maybe there is minor problem with the latest woof but my experience doesnt count much Smile

Last edited by pemasu on Thu 16 Sep 2010, 01:45; edited 1 time in total
Back to top
View user's profile Send private message 
Stripe

Joined: 23 Jun 2010
Posts: 658
Location: In a field. England

PostPosted: Thu 16 Sep 2010, 01:45    Post subject:  

I am just trying to build 512 with the latest version of woof and the files that Playdayz supplied, if I suffer the same problems I have another "Distro_Pet_Repos" file that worked previously, just in case it was the file
Hope this works
Stripe
DISTRO_PET_REPOS.gz
Description 
gz

 Download 
Filename  DISTRO_PET_REPOS.gz 
Filesize  3.53 KB 
Downloaded  482 Time(s) 
Back to top
View user's profile Send private message 
Iguleder


Joined: 11 Aug 2009
Posts: 1907
Location: Israel, somewhere in the beautiful desert

PostPosted: Thu 16 Sep 2010, 03:39    Post subject:  

Ummm ... it's kinda funny, you can build a totally sane dpup from the Lupu package list, all you need is 4-5 packages to be renamed and 2 to be removed. Of course, there are many bugs to sort out, but it still works Smile

Builds fine with the custom X/CUPS Razz

_________________
My homepage
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
ICQ Number 
Stripe

Joined: 23 Jun 2010
Posts: 658
Location: In a field. England

PostPosted: Thu 16 Sep 2010, 04:20    Post subject:  

Hi all

I think I have found the problem with building 512 with woof, I will try to get it fixed as soon as possible.

Cheers
Stripe
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 16 Sep 2010, 13:27    Post subject:  

Stripe. Your distro_pet_repos looks like in my first woof download. Only there was lupu) by BK`s mistake in my download.

Then I thought that I used distro_pet_repos copied from playdayz`s post but somehow I had wrong version. Dont even know from where I got it.

Well, waiting what you found from woof. I will now add my debs for pulseaudio. So far I have 51 .deb packages to add to get basic funcionality for pulseaudio and for pulseaudio-modules . Python and pygtk and some other libs is next.
Back to top
View user's profile Send private message 
Stripe

Joined: 23 Jun 2010
Posts: 658
Location: In a field. England

PostPosted: Thu 16 Sep 2010, 14:36    Post subject:  

Hi Pemasu

3 attempts and it still keeps missing the same files, going to try my old files and try to establish where the problem lies

Stripe

Edited to say: still missing the same files
Going to try an older version of woof

Edited to say: 18 hours and now the mirrors dont want to play, will get some sleep and try again
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 43 of 51 [754 Posts]   Goto page: Previous 1, 2, 3, ..., 41, 42, 43, 44, 45, ..., 49, 50, 51 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1077s ][ Queries: 13 (0.0162s) ][ GZIP on ]