Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 01 Sep 2014, 09:55
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Lucid Puppy 5.1.1 Release - This is the official release
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 42 of 51 [754 Posts]   Goto page: Previous 1, 2, 3, ..., 40, 41, 42, 43, 44, ..., 49, 50, 51 Next
Author Message
01micko


Joined: 11 Oct 2008
Posts: 7794
Location: qld

PostPosted: Sat 11 Sep 2010, 16:57    Post subject:  

bigpup,

I think tempestous, our resident driver afficianado is already aware.

See here

It's great to have tempestuous around, he fixed the driver issues with

acx, which I have in my old P3 (and playdayz included in 511 at my urgency Wink ) and that P3 has never worked so well with a puppy ootb since the 2.6.15.16 kernel.

Cheers

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Sat 11 Sep 2010, 17:01    Post subject:  

bigpup wrote:
Have you seen this?
http://www.murga-linux.com/puppy/viewtopic.php?t=59789


I posted a link to the article here yesterday http://www.murga-linux.com/puppy/viewtopic.php?t=59743

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sun 12 Sep 2010, 11:41    Post subject:  

Using the latest woof. My aim is to build special Lucid puppy mainly for my special needs with pulseaudio, python, pygtk, stream2ip included for getting wireless audio streaming to Apple Airport Express work.

I can see the installed packages in /root/.packages which I need to install from ubuntu repo. But do I need to know which package belongs to what as dependency. Or can I speciify each package with own row in DISTRO_PKGS_SPECS-ubuntu-lucid. So I would not need to chase the dependency chain. Of course there are a lot of libs which should be listed in the same row as main app, but.. does it do any difference if all the packages are included anyway ?

I am absolutely ignorant how things work in woof.I have used guidelines in the net by BK and from playdayz`s posts along the development. They have been really helpful when trying woof building.

EDIT: What is the best way to check dependencies. Check dependencies installed pkgs goes under the screen, there should be some keystroke which enables to scroll the page down but I dont remember it. Is there other tool to check dependencies ?
Back to top
View user's profile Send private message 
scruffy

Joined: 09 Apr 2010
Posts: 42
Location: UK

PostPosted: Sun 12 Sep 2010, 13:01    Post subject:  

pemasu wrote:
Check dependencies installed pkgs goes under the screen, there should be some keystroke which enables to scroll the page down but I dont remember it. Is there other tool to check dependencies ?


Can you drag the window up using <ALT><Left mouse Button> ?
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sun 12 Sep 2010, 13:07    Post subject:  

Quote:
Can you drag the window up using <ALT><Left mouse Button> ?


That worked. Thank you.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sun 12 Sep 2010, 15:20    Post subject:  

I believe this is Lucid Puppy 5.1.2pre or something. I have now woof-tree and first Lucid Puppy made and installed. Testing it now. Not everything went well. Midori segment faults and does not start. Lucid-puppy repo is empty in PPM. There is something also in the woof. BK`s and Iguleder`s report here from BK`s blog:

Quote:
Posted on 12 Sep 2010, 19:37 by Iguleder
DISTRO_PET_REPOS
Barry, something weird in latest Woof ... should be DISTRO_FILE_PREFIX or DISTRO_COMPAT_VERSION and lucid.

case $DISTRO_COMPAT_VERSION in #100911
lupu)
PACKAGELISTS_PET_ORDER="Packages-puppy-lucid-official ${PACKAGELISTS_PET_ORDER}"
;;
esac
Delete

Posted on 12 Sep 2010, 22:41 by BarryK
Re lucid)
Oops, yes, it should have been "lucid)".

Although, the error probably doesn't adversely affect a build of Lucid 5.1.2, as I think that playdayz intended for all the entries in Packages-puppy-lucid-official to not be chosen when building the live-CD, instead for the repo in PPM. He arranged for all required packages needed to build the live-CD to be in Packages-puppy-5-official.


I will try to get repo first visible, I should learn something in trying. Posting this from new Lucid Puppy. Firefox installed from quickpet so everything didnt fail.

EDIT: Lucid-puppy-official repo is back. I downloaded the latest repo file and copied it to /root/.packages. I also changed the DISTRO_PET_REPOS file with file from luci511. It had the above mentioned error. I dont know if it had any effect but now lucid-puppy repo is visible. I also made save file and rebooted before it came visible. Well.. that`s it for today.
Back to top
View user's profile Send private message 
Iguleder


Joined: 11 Aug 2009
Posts: 1888
Location: Israel, somewhere in the beautiful desert

PostPosted: Mon 13 Sep 2010, 06:10    Post subject:  

Kinda weird, Midori works fine in my dpup build Smile

Maybe you have a corrupt package or something ... if it works fine with Debian's packages it makes it more likely that your libraries (which Midori was built against) are corrupt.

Oh, and by the way: add the "lucid" repo in the PET repos list but after Quirky, so Woof doesn't pick any packages from it. Barry said that playdayz put all packages required for 5.1.2-pre in the 5 repo. The "lucid" repo has older packages, notably an older Abiword. I noticed that my Lupu gets built with Abiword 2.8.3 or something while 5.1 has 2.8.6 (which can be obtained from the Quirky repo), so I changed the repo order to 5-quirky-lucid.

EDIT: second build, getting segfaults. Crying or Very sad

_________________
My homepage
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
ICQ Number 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 13 Sep 2010, 09:51    Post subject:  

I believe also that corrupted packages is highly possible. Even when I download isos, almost every second time I get incorrect MD5 sum results with Uget. When downloading packages to woof-tree there is inevitably corrupted packages among the others.
I use normally only wireless connection. I dont have working driver for my laptop wired netcard in Lucid Puppy, but I had it working in some puppies. I might try downloading packages to woof using it.
It is kind of miracle that Luci512pre works this good. None other problems so far.
Back to top
View user's profile Send private message 
playdayz


Joined: 25 Apr 2008
Posts: 3788

PostPosted: Mon 13 Sep 2010, 10:02    Post subject:  

pet-packages-lucid is for the PPM and pet_packages-5 is where specific packages to build Lucid 5.1.2pre are. it should grab abiword-2.8.6-lupu--but sometimes it seems to grab the top file instead of the one with the latest version number, so I will delete abiword-2.8.3-lupu just in case. I might not have been specific enough about Abiword--the one you want is in pet_packages-5, abiword-2.8.6-lupu--you can download it manually if necessary into packages-pet.

Here are the relevant files that I used in testing--building Lucid 5.1.2pre from scratch----put them in the woof-tree directory. Just remove the phony gz. If you have time I would recommend starting over with these files. If not, then put them in woof-tree and redownload packages and watch carefully which are downloaded and then rebuild those packages that are downloaded. It has been built from scratch twice with these files--I am not saying it was perfect, but it was close.

I haven't tested with the Woof that Barry uploaded on September 11.

In DISTRO_PKGS_SPECS_ubuntu_lucid, you will see some files such as 'cups-lucid.' What that means is that cups needed a special template in order to build and run properly. There is no provision in Woof for transferring special templates so what I did was package the resulting built package into cups_lucid so that people could build successfully. Ghostscript, xorg_base, and xserver_xorg are also in this category. I will package up the special templates and post them here later.
Packages-puppy-lucid-official.gz
Description 
gz

 Download 
Filename  Packages-puppy-lucid-official.gz 
Filesize  14.2 KB 
Downloaded  237 Time(s) 
DISTRO_PKGS_SPECS-ubuntu-lucid.gz
Description 
gz

 Download 
Filename  DISTRO_PKGS_SPECS-ubuntu-lucid.gz 
Filesize  36.23 KB 
Downloaded  243 Time(s) 
PKGS_MANAGEMENT.gz
Description 
gz

 Download 
Filename  PKGS_MANAGEMENT.gz 
Filesize  8.33 KB 
Downloaded  238 Time(s) 
DISTRO_PET_REPOS.gz
Description 
gz

 Download 
Filename  DISTRO_PET_REPOS.gz 
Filesize  3.44 KB 
Downloaded  234 Time(s) 
Back to top
View user's profile Send private message 
Stripe

Joined: 23 Jun 2010
Posts: 658
Location: In a field. England

PostPosted: Mon 13 Sep 2010, 11:40    Post subject:  

Hi all

Playdayz after a full week of testing still cant get the new machines onboard sound to work properly with any woof built pup, so have just put a sound card in so that it will work with them.

With 512 is it just replace the downloaded files and do the same as before? will it be alright still using the 22 august woof?

Cheers
Stripe
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 5103
Location: Charleston S.C. USA

PostPosted: Mon 13 Sep 2010, 11:47    Post subject:  

scruffy wrote:
pemasu wrote:
Check dependencies installed pkgs goes under the screen, there should be some keystroke which enables to scroll the page down but I dont remember it. Is there other tool to check dependencies ?


Can you drag the window up using <ALT><Left mouse Button> ?


Barry has updated this program to correct this problem but I do not know if it is available for download.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 13 Sep 2010, 11:58    Post subject:  

Playdayz. Thank you of precise description. I am now little bit more aware how woof works with Lucid Puppy. I have the latest woof, but I think I have to first get more trustworthy net connection. I havent needed before wired net in the house, so I havent had need to compile netcard driver. But now I have excuse to do that. I have already source downloaded. DSL connection is fast enough and it should not be problem.

And I have Abiword 2.8.6.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 13 Sep 2010, 13:12    Post subject:  

AR81Family ethernet driver is now compiled in my Lucid Puppy 512pre. Autoconf.h and some other files were in unorthodox places. Needed to edit Makefile before compiling succeeded but now my wired Atheros 8151 works.

Driver module is atl1e. The version in Lucid Puppy didnt work but this newest version works fine.
atl1e.tar.gz
Description  AR81 Family driver atl1e.ko. Install to /lib/modules/2.6.33.2/kernel/drivers/net/atl1e/
gz

 Download 
Filename  atl1e.tar.gz 
Filesize  34.01 KB 
Downloaded  255 Time(s) 
Back to top
View user's profile Send private message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3964
Location: Kiel,Germany

PostPosted: Mon 13 Sep 2010, 16:35    Post subject:  

Hello evreyone !

Finally got me a new HD working that is a little bit too large for my BIOS (IDE 500 GB) -- many freezes in the beginning and many grub error

But now I managed it to run 511 official release frugal on an ext4 that is primarily a luci-218 OS -- and no freezes for now .

The only new occurance was that I had to unplug the USB modem at bootup to overcome a kernel hang at checking the first partition of the first HD .

Some frugals are saying that they can`t find their .sfs file but Upup-432 , Macpup-4.3 and now Lupu-511or are booting frugal Very Happy

All full installs are booting also . Crazy trying to boot 4.3 with kernel 2.6.33 to get the good poweroff funktion of Lupu-511 passed to the 4-series.

One of the main difference is the visibility at rox for the .desktop and .menu files compared to 4.3 !

I`m also figuring out `pgprs-shell` that is simpler but working very good !

For those about "HARDWARE NOT DETECTED" : modprobe DRIVER !

-- my USB MODEM is a HUAWEI and works well with the driver .named >> option << -- so it would be `modprobe option` -- HTH
partview.png
 Description   
 Filesize   14.57 KB
 Viewed   1765 Time(s)

partview.png

Back to top
View user's profile Send private message Visit poster's website 
Karl Godt


Joined: 20 Jun 2010
Posts: 3964
Location: Kiel,Germany

PostPosted: Tue 14 Sep 2010, 06:56    Post subject: Solved : sfs not found  

Quote:
Some frugals are saying that they can`t find their .sfs file


SOLVED : I made a /JUMP folder on each full install on the many partitions for the frugal boot ++ but renaming them to /JUMP-partition-5 , /JUMP-partition-6 ... now the initrd.gz finds the specific .sfs

Smile Wink
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 42 of 51 [754 Posts]   Goto page: Previous 1, 2, 3, ..., 40, 41, 42, 43, 44, ..., 49, 50, 51 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1251s ][ Queries: 13 (0.0237s) ][ GZIP on ]