Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 30 Oct 2014, 13:06
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
LupQ-510s FINALIZED - Lucid Puppy Quickset edition
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 15 Posts_count   Goto page: 1, 2, 3, ..., 13, 14, 15 Next
Author Message
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Wed 11 Aug 2010, 01:49    Post_subject:  LupQ-510s FINALIZED - Lucid Puppy Quickset edition
Sub_title: Beyond Lucid Puppy-5.1
 

Now available the Lucid Puppy Quickset editon(LupQ-511.(25 Sep 2010)
Let us move to the new topic:
http://murga-linux.com/puppy/viewtopic.php?t=60199


Lucid Puppy Quickset edition home

CHANGES:from lupq-510 to 511
  • Bugfix: Frugalinstaller was fail to install on unmounted NTFS partions
  • Stripped abiword and some excutable and libraries was not stripped.
  • Removed sylpheed shared libraries not used.
  • 'LC_ALL=C' in /usr/sbin/pupdial because the PupDial seem to fail with some European locale.

from lupq-509
  • Puppy Package Maneger bugfix with frugal install on flash.
  • Roaring Panguin bugfix thanks to yordanj94.
  • Bugfix: FlSynclient was lost settings.
  • Midori-wrapper warning.
  • Wrappers: bareview, basichtmlviewer
  • Update mhWaveEdit-1.4.20 new built by don570.
  • MtPaint look up on-line document.
  • Retrovol on the menu.
  • Main menu height 26px, sub-menu height 17px for clear icons thanks to the Japanese Forum member, koala and himajin.
  • Some ROX-Filer right-click menu.

KNOWN BUGS:
Post the QuickSet edition bug report as a reply of this topic.
Check also the topic Lucid Puppy 5.1 Bug Reports and Fixes and Lucid Puppy 5.1.1 Bugs, Fixes, & Feedback

See CHANGES on old bugs and CHANGES.

Language support now available Arabic, Hebrew, Spanish, German, French, Dutch, Hungarian, Chinese, Korean and Japanese. And still calling for additional translations.
See another topic Translate LupQ - QuickSet edition of Lucid Puppy

See the first desktop. Normally you reach here automatically.
You can change the loacle, timezone, keyboad at a time by GUI. If you change only the keyboard, you need not restart X.


On the LupQ-508, the e-mail client Sylpheed and the chat client Ayttm removed. The IceWM window manager and some applications are removed from Lucid Puppy 5.x. The main reason is i like the main release to be simple and to avoid confusion for the users. See the detail at CHENGES.

NOTE:
  • LupQ does not contain Adobe Flash Player. Install the libflashplayer PET from here.
  • Sylpeed and IceWM available from here.
  • Language packages for some languages are also available from here.
  • You can install additional pets form the quickpet and/or puppy-lcid repogitory but do not install 'Update Lupu510-003' nor 'UpdateLupu511-002'. They are already fixed on LupQ.
  • Upgrading from old lupqsave of lupq-00x, you may get dependency warning, like gtk+, tk, but no harm ignore them.
  • LupQ is now at beta stage. It is expected to work stable, but you are strongly encouraged to report on this topic.
  • devx: use lupu_devx_510.sfs available from 01micko. But you need to rename it as like lupu_devx510.sfs(remove '_' before '510') to use on lupq. Additional sfs files can be placed at root(/mnt/home) or at subdirectory(/mnt/home/<psubdir>).

TIPS:

WHATS ADD the QuickSet edition on Lucid Puppy 5.1:
Playdayz,01micko, WhoDo and the team produced the latest and brilliant release, Lucid Puppy version 5.1.
Lupu-5.1 is brilliant but is half way. i intend to offer its modification 'QuickSet Edition' as 'LupQ'.
I am appreciated if this one can be one of the basis of next Lucid Puppy and Pupplets.
  • Graphical boot menu with 'Safe mode'(no X). Or, how you can type 'puppy pfix=nox' or 'puppy pfix=ram' if your keyboard layout is different from 'us'?
  • Keyboard layout menu at 'Safe mode'(no X).(lupq-006 and later)
  • New GUI country wizard easy to set locale, time zone and keyboard.
  • Desktops are I18N ready.
  • Grub4Dos with GUI allows any file system Puppy supports(fat/ntfs/ext2/ext3/ext4/riserfs). This enables to install lupq on PCs, commonly in Windows pre-installed ones, without linux partitions.
  • Frugal installer, easy to install.
  • ACPID supports power button and lid of notebook PC's.(lupq-004 and later)
  • Winfonts, an aid for PC's dual booted with Windows. (lupq-004 and later)

The boot menu:
Try 'Safe mode' if you failed with direct desktop. The 'Safe mode' reaches the console, appears another menu to select your keyboard layout. Then you can type 'xorgwizard' to choose proper driver.


WHATS REMOVED from Lucid Puppy 5.1:
  • Removed translations of some major applications such as gnumeric and abiword - will be provided as additional packages.
  • Adobe flash Player - can be instaled via internet.
  • Some development files from /usr/lib
  • Documents like changelog from /usr/share/doc
  • Some graphic files in /usr/share/pixmas reduced size.

The diet results 114MB(lupq-507) .iso file, 16MB less than lupu-510.iso.
The size of main sfs file is important to run on 256MB RAM PC. The lupq-507.sfs is 109MB.

OTHER NOTES:
Additional SFS files
Lupq reads additional sfs files both from root(/mnt/home) and from subdirectory(/mnt/home/<psubdir>), same as the most recent woof.
But also Lupq uses special init script in initrd which is delived from the 431JP. Significant differences are in reading main and additional SFS files. One of the importance, the additional overrides main sfs if the sfs has conflict files.
See Puppy Linux 431JP release note section 'Differences from original version', item 2.

My intention is mainly because of two reasons.
  1. Lupu-5.1 goes directly to the desktop. It is happy for most of people. But not so happy for those using keyboard other than 'us'. They have to go to console and go through all the process, locale, timezone, keyboard and X.
  2. Lupu-5.1 has some translations for some languages, and it becomes fat... lupu-510.sfs has 126MB in size. It may be critical runnig on PCs with 256MB RAM.

I made countrywizard and lang_support_all-1.5 for the solution of these. And i thought that the main CD need not contain the translations anymore.

For the first time, i tried to remove only the translations which cannot display, such as CJK languages. But also i realized the translations for the rest languages still need more files. For example, the locale fr_FR makes the gnumeric menu into french but it still speaks 'Yes/No' instead of 'Oui/Non'. if i add those files, the size of the Live CD will increase 10-20MB more. It must be critical for the PC's with 256MB RAM.

In the QS edition, major translations, abiword, gnumeric, etc. are removed. Some translations, for example quickpet are still built in.
I made another diet to the original and the size of lupq-507.sfs is 109MB, whereas lupu-510.sfs has 126MB.

Main concept on the direct desktop, see my previous post:
http://www.murga-linux.com/puppy/viewtopic.php?p=436409#436409

CHANGES

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html

Edited_times_total
Back to top
View user's profile Send_private_message Visit_website 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Wed 11 Aug 2010, 04:28    Post_subject:  

I hope we might find an improved boot up menu in Lucid 5.2
At first I was going to say without the Windows option
but then I dual booted for many months before
kicking the Windows habit years ago - so maybe that is worth considering . . .
For me having an Ubuntu option would be useful
as I use Ubuntu Lucid Lynx aprox 10% of the time from HD to complement
my boot from Puppy Lucid DVD routine (I never bother with even a frugal install of Puppy)

Hope you are able to address some of the issues already raised in subsequent posts
Personally I will be sticking with the 'excellent' Puppy Lucid 5.1
Smile

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Wed 11 Aug 2010, 13:43    Post_subject: update to lupq-002  

update to lupq-002 (12aug2010)
* locale support (was missing some files in /usr/share/i18n/locales) - limited only locales DejaVu font can display.
* Getting-started info (was not shown)

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send_private_message Visit_website 
Tasgarth

Joined: 06 Oct 2008
Posts: 202
Location: France, Besancon

PostPosted: Wed 11 Aug 2010, 16:13    Post_subject: Test lupq 002 and fr_FR, azerty  

Hi shinobar,

TEST lupq002 :
'azerty' and fr_FR (France)

1) I dont get my locale (fr_FR) ; for example geany icon is 'edit'.
Idem for 'Start, Menu...
Only the QuickPet (01micko) is French language.

2) Keyboard :
-- If I choose 'azerty' (that I did in others Puppies) my keyboard is died.
Keys did not run and always the numlock led was on 'switch off'
......
New CD-Live...
I choosed 'fr' (and not 'azerty'):
My keyboard was good ( key a => a) but always... no fr_FR locale

With Lupu 510 and your new lang_support_all-1.5.sfs it's the same thing : died keys
But with lupu the 1-4.sfs was good.
------------------------------------------
3) The pupsave : fonts are too big....impossible to write a name ( same problem with the old lupu 508 Smile
----------
If that can help you.

Cheers
Back to top
View user's profile Send_private_message Visit_website 
sinc


Joined: 22 Jul 2009
Posts: 523
Location: Tampa, FL USA

PostPosted: Wed 11 Aug 2010, 22:13    Post_subject:  

I've done a full install (v. 001) and been running it most of the day. Been running perfectly for me so far. Nothing to report. Other tan the small things you just updated in 002. I'll keep you posted.
Back to top
View user's profile Send_private_message 
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Wed 11 Aug 2010, 22:52    Post_subject: Re: Test lupq 002 and fr_FR, azerty  

Tasgarth wrote:
1) I dont get my locale (fr_FR) ; for example geany icon is 'edit'.
Idem for 'Start, Menu...
Only the QuickPet (01micko) is French language.
2) Keyboard :
-- If I choose 'azerty' (that I did in others Puppies) my keyboard is died.
Keys did not run and always the numlock led was on 'switch off'
3) The pupsave : fonts are too big....impossible to write a name ( same problem with the old lupu 508 Smile

Tnx for testing report.
1)As for the translations, it is expected behavior. Lupq has not major translations.
2) confirmed 'azerty' does not work. Will you try the attached? extract and find /usr/sbin/keymap-set, override the existing file. /usr/share/i18n/layouts does not need to replace.
3) The console font problem is puzzling and needs more investigating.
keymap-set-20100812.tar.gz
Description  Replace /usr/sbin/keymap-set
gz

 Download 
Filename  keymap-set-20100812.tar.gz 
Filesize  3.41 KB 
Downloaded  825 Time(s) 
Back to top
View user's profile Send_private_message Visit_website 
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Wed 11 Aug 2010, 22:58    Post_subject: Thanks testing  

sinc wrote:
I've done a full install (v. 001)

Thanks sinc. v.002 has smal change only on the locale issue.
Wait for next v.003 Smile
Lupq has Frugalinstaller. Try it if you are interested in.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send_private_message Visit_website 
Tasgarth

Joined: 06 Oct 2008
Posts: 202
Location: France, Besancon

PostPosted: Thu 12 Aug 2010, 07:40    Post_subject:  

hi shinobar,

Test (without Nvidia Driver GeForce 7600)

I followed your advice and unpack the tar.gz
the '/usr/sbin/keymap-set' file did not exist but I put it in sbin.
... I rebooted with the same pupsave.

Keyboard and Locale 'fr' for Geany, Opera, Gnumeric are right.

Thanks for your work.
Back to top
View user's profile Send_private_message Visit_website 
esmourguit


Joined: 17 Nov 2006
Posts: 1288
Location: Sur l'ile aux oiseaux.

PostPosted: Fri 13 Aug 2010, 05:35    Post_subject:  

Hello shinobar,
Thank you for that version of Lupu.
A few small thing.
I had to change line 9 (#export LANG=C instead of export LANG=C) in /usr/sbin/gparted_shell, to get Gparted in French.
Otherwise no problem except that we must first accept the US keyboard and restart x before to choose the French keyboard.
I can make a package of the french .mo files for french users, if needed.
Cordialement Wink

_________________
Toutou Linux - Pets francisés
Back to top
View user's profile Send_private_message 
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Fri 13 Aug 2010, 08:28    Post_subject: French keyboard  

merci esmourguit,

As for some shell scripts and language packs, i am planning them as the next step.(EDIT: starts from lupq-003)

esmourguit wrote:
we must first accept the US keyboard and restart x before to choose the French keyboard.

even after you install keymap-set-20100812?
The first desktop is 'us' keyboard. then install keymap-set-20100812.pet, choose any of keyboad from the countrywizard... it shall change the keyboard settings on the fly, no?

If you change the timezone and/or locale, a dialog pops up asking 'You need to restart X...', but at this point of time (you can reply 'No' for the dialog), the keyboard already works as the new settings. You can confirm it on the virtual terminal or another applications.
Isn't it...?

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
esmourguit


Joined: 17 Nov 2006
Posts: 1288
Location: Sur l'ile aux oiseaux.

PostPosted: Sat 14 Aug 2010, 05:22    Post_subject:  

Bonjour à tous,

@shinobar,
CD install, no pupsave, puppy pfix=ram,
I replaced /usr/sbin/keymap-set before anything, i chose azerty layout and the keyboard was fine without restart X.

Cordialement Wink

_________________
Toutou Linux - Pets francisés
Back to top
View user's profile Send_private_message 
himajin


Joined: 08 Jul 2008
Posts: 54
Location: JAPAN

PostPosted: Sat 14 Aug 2010, 14:01    Post_subject: ご苦労さまです  

テストしてみます。
Back to top
View user's profile Send_private_message Visit_website 
himajin


Joined: 08 Jul 2008
Posts: 54
Location: JAPAN

PostPosted: Sat 14 Aug 2010, 14:34    Post_subject: おっと  

日本語環境は入ってないのね .
あれをいれなきゃダメか。

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Sun 15 Aug 2010, 04:19    Post_subject: Main and sub-menu on lupq-003  

The update release of lupq-003 has some translations of Main menu.
And the sub-menu is like that of Fatdog64.


I was wondering why the submenu on lupu is half broken, and they are regular on fatdog64.
The reason was the version of libgnome-menu: Lupu uses libgnome-menu.so.2.4.6, and fatdog /libgnome-menu.so.2.4.2.
I rolled back the libgnome-menu2 to the same as fatdog.

Quirky uses more older version, libgnome-menu.so.2.0.2. The submenu shows in quirky is the same as classic puppies:

Which do you like better?
Back to top
View user's profile Send_private_message Visit_website 
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Sun 15 Aug 2010, 05:23    Post_subject: French pack  

Even maybe esmourguit and another guys will make better one, but I made a french language package for the first test of language support on lupq.

HOW TO USE:
  1. Boot up lupq-003
  2. install lang_pack_fr_lupq-0.1.pet.
  3. (Not essential but recommended) Reboot to make lupqsave first.
  4. Run countrywizard and arrange locale and etc.
  5. Restart X to enable ROX-filer translation

The lang_pack also has translations for firefox and for seamonkey2, but i don't know an easy way to enable them... Crying or Very sad

Can be complex, but...
After installing firefox or seamonkey2, use command 'firefox.nls' or 'seamonkey.nls'.
You can manually edit the /usr/local/defaultbrowser, but also you can do next procedure:
  1. Click the globe icon,'Choose default browser', on the tray(the bar at the bottom of the desktop).
  2. Click 'netsurf', then netsurf lauches. Close.
  3. Click the 'Choose default browser' and click 'firefox'(or 'seaminkey2'.
  4. The firefox should launche with french translation.

Even after of this performed, launching the browser from the menu is still english. If you like to change, manually edit the file /usr/share/applications/Firefox.desktop.
Code:
Exec=/usr/lib/firefox/firefox

to
Code:
Exec=firefox.nls

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html

Edited_times_total
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 15 Posts_count   Goto page: 1, 2, 3, ..., 13, 14, 15 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1191s ][ Queries: 13 (0.0079s) ][ GZIP on ]