Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 22 Nov 2014, 11:25
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Lucid Puppy 5.1- A Full-Featured Compact Distro
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 70 of 145 [2171 Posts]   Goto page: Previous 1, 2, 3, ..., 68, 69, 70, 71, 72, ..., 143, 144, 145 Next
Author Message
playdayz


Joined: 25 Apr 2008
Posts: 3789

PostPosted: Wed 21 Jul 2010, 20:50    Post subject:  

Quote:
Lupu-503 boots into and shuts down fine from Xorg; using both
the live cd and another full install.

It has small fonts on shutdown script, but I don't want to use the
"video=640x480" code on the grub kernel line, that ICPUG uses.


The CD has video=640x480 as a command in isolinux.cfg. Did ti also have small letters on shutdown?
Back to top
View user's profile Send private message 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Wed 21 Jul 2010, 21:10    Post subject:  

playdayz wrote:
Quote:
Lupu-503 boots into and shuts down fine from Xorg; using both
the live cd and another full install.

It has small fonts on shutdown script, but I don't want to use the
"video=640x480" code on the grub kernel line, that ICPUG uses.


The CD has video=640x480 as a command in isolinux.cfg. Did ti also have small letters on shutdown?


The CD had normal size letters on shutdown.
I added 503 to menu.lst manually for the full install.

_________________

Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5932
Location: Kentucky

PostPosted: Wed 21 Jul 2010, 21:56    Post subject:  

Fresh manual frugal install of Lupu-503 on the trusty old P3.On initial boot no problems or surprises.......everything was configured correctly.

Installed Firefox and Xorg_High.................................


VIDEO REPORT: Lucid Puppy, version 503

Chip description:
Intel Corporation 82810E DC-133 (GMCH) Graphics Memory Controller Hub
Intel Corporation 82810E DC-133 (CGC) Chipset Graphics Controller

Driver used by Xorg:


Video mode used by Xorg:
Resolution: Depth:

...the above also recorded in /tmp/report-video
#

-OpenGL-
Vendor : Keith Whitwell
Renderer : Mesa DRI i810E 20050821 x86/MMX/SSE
Version : 1.2 Mesa 7.7.1
Direct Rendering : Yes

1416 frames in 5.0 seconds
1478 frames in 5.0 seconds
1477 frames in 5.0 seconds
1503 frames in 5.0 seconds
1495 frames in 5.0 seconds
1476 frames in 5.0 seconds
1502 frames in 5.0 seconds
1492 frames in 5.0 seconds
1503 frames in 5.0 seconds
1118 frames in 5.0 seconds
1446 frames in 5.0 seconds
1502 frames in 5.0 seconds
2873 frames in 5.0 seconds
3686 frames in 5.0 seconds
3898 frames in 5.0 seconds
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 2154
Location: Ontario Canada

PostPosted: Wed 21 Jul 2010, 21:59    Post subject: The Next Step Towards Lucid Puppy 5.1 - Lupu-503
Subject description: updating lupu 500 save file.
 

I booted the live cd with no parameters and it found a lupu-500 savefile
on the hd and updated that.I had to install the Xorg High -GLX.

# report-video
VIDEO REPORT: Lucid Puppy, version 503

Chip description:
ATI Technologies Inc Radeon HD 3200 Graphics
Conexant Systems, Inc. CX23885 PCI Video and Audio Decoder

Driver used by Xorg:


Video mode used by Xorg:
Resolution: Depth:

...the above also recorded in /tmp/report-video
# glxgears
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual
#
# report-video
VIDEO REPORT: Lucid Puppy, version 503

Chip description:
ATI Technologies Inc Radeon HD 3200 Graphics
Conexant Systems, Inc. CX23885 PCI Video and Audio Decoder

Driver used by Xorg:


Video mode used by Xorg:
Resolution: Depth:

...the above also recorded in /tmp/report-video
# glxgears
IRQ's not enabled, falling back to busy waits: 2 0
9024 frames in 5.0 seconds
9177 frames in 5.0 seconds
9177 frames in 5.0 seconds
9175 frames in 5.0 seconds
#
Tunapie and VLC (the version that had to be run as user spot) were two
of the additions I'd made to the lupu-500 install and they still work the
way they did in 500.
CPU frequency scaling wasn't activated and I would guess that it had been
but I don't know that for sure.
Amsn that I added in 500 still works.
Firefox is still 363 so I updated that in 363 to 367.
flashplayer plugin didn't need updating.

That's it I guess.

Edit:

When I click on the browser icon on the desktop it doesn't know that firefox
is already installed and it brings up the option to download a browser in quickpet.

Edit:

I loaded my updated savefile into 503 on the next boot and switched to icewm, I guess it's an old version of icewm because you can logout and use poweroff to shutdown but you can't shutdown from the icewm menu so that didn't get updated.

Am I confusing updating your old savefile with not breaking anything in your old savefile?

Last edited by Billtoo on Wed 21 Jul 2010, 23:31; edited 2 times in total
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Wed 21 Jul 2010, 22:05    Post subject: First-run GUI  

For the first-run, how about the GUI such as like this?

You can see my opinion from this screen shot.
  1. Should be what to do at a glance.
  2. Graphical icons help in any case the users are good at english or not.
  3. Messages should be short and simple.
  4. Current setting should be displayed.
  5. Timezone setting is essencial at this point of time. Imagine when you use email.
Back to top
View user's profile Send private message Visit poster's website 
playdayz


Joined: 25 Apr 2008
Posts: 3789

PostPosted: Wed 21 Jul 2010, 22:36    Post subject:  

Quote:
Should be what to do at a glance.
Graphical icons help in any case the users are good at english or not.
Messages should be short and simple.
Current setting should be displayed.
Timezone setting is essencial at this point of time. Imagine when you use email.


Well said. There would be practical problems trying to implement such a gui for 5.1, mainly that we are in feature freeze and are simply refining what we have without adding anything new. There would also be a considerable amount of code behind the gui. Much of the code is already written and could be recontextualized. It would have to account for the fact that the resolution, for instance, can be changed without creating a full xorg.conf as can the Language and Locale.

There are utilities that already exist in the desktop menu to change timezone. In the most common case, timezone doesn't much matter because the computer hardware clock is set to local time anyway--therefore the time that is displayed is the time on the hardware clock regardless of timezone. I never bother with it myself and leave it set at Perth to honor Barry.

What we were after is the very simplest first run dialog possible. On the first screen people can click Ok or click to make changes. On the second screen are the changes; no one will have to click more than two out of three.

Your interface is very similar to our earlier ideas for 5.2. We will certainly review the first run dialog for that release and would have time to make changes and test them thoroughly. My interest is in making the gui friendly and non-threatening. Too many settings to adjust all at once scares me. Ultimately I think it would be great to do away with the first run dialog altogether and have a Puppy with enough intelligence to figure most of them out itself.
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Wed 21 Jul 2010, 22:40    Post subject: icewm patches  

Ok...

A couple of patches for Icewm

menu icons

The icons are missing in the menu because of a woof buglet.

Technical details: In the "3builddistro" stage of woof certain templates are already in place and they override the installation of the new menu template.
No, that is wrong, I assumed it would be a template but no, it's a pet. If you want to build a lupu-503 from woof, PM me for the correct pet

Layman details: None. Just install the ice_menu_patch-1.pet and get on with what you want to do!

tray buttons (Partview and Browser Default)

These are missing in Icewm. My fault. This patch, icewm_su_tray_patch-1.pet fixes that and also suppresses the startup errors in /tmp/xerrs.log. Install the patch and restart X.

Cheers
ice_menu_patch-1.pet
Description 
pet

 Download 
Filename  ice_menu_patch-1.pet 
Filesize  1.04 KB 
Downloaded  488 Time(s) 
icewm_su_tray_patch-1.pet
Description 
pet

 Download 
Filename  icewm_su_tray_patch-1.pet 
Filesize  1.4 KB 
Downloaded  489 Time(s) 

_________________
Woof Mailing List | keep the faith Cool |

Last edited by 01micko on Thu 22 Jul 2010, 01:57; edited 2 times in total
Back to top
View user's profile Send private message Visit poster's website 
James C


Joined: 26 Mar 2009
Posts: 5932
Location: Kentucky

PostPosted: Wed 21 Jul 2010, 22:49    Post subject:  

Moving on along to my main Linux box........................Lupu-503 running live pfix=ram.

Everything configured correctly on initial boot.Installed SeaMonkey and Xorg_High............................

# graphix_test
For your S3 graphics card, S3 Inc. VT8375 [ProSavage8 KM266/KL266] , we think the best add on driver is Xorg_High.pet . It would be required for some programs and games with high graphcial content and your desktop might seem a bit more snappy. It is available in Quickpet under Drivers
S3 Inc. VT8375 [ProSavage8 KM266/KL266]
S3
ProSavage8

#


VIDEO REPORT: Lucid Puppy, version 503

Chip description:
oem: S3 Graphics ProSavage DDR Family BIOS
product: VBE 3.0 Rev 0.0

Driver used by Xorg:


Video mode used by Xorg:
Resolution: Depth:

...the above also recorded in /tmp/report-video
#


-OpenGL
Vendor : S3 Graphics Inc.
Renderer : Mesa DRI ProSavageDDR 20061110 x86/MMX+/3DNow!+/SSE
Version : 1.2 Mesa 7.7.1
Direct Rendering : Yes


# glxgears
1875 frames in 5.0 seconds
2086 frames in 5.0 seconds
2087 frames in 5.0 seconds
2087 frames in 5.0 seconds
2119 frames in 5.0 seconds
2087 frames in 5.0 seconds
7679 frames in 5.0 seconds
6870 frames in 5.0 seconds
7666 frames in 5.0 seconds
8101 frames in 5.0 seconds
8264 frames in 5.0 seconds
8250 frames in 5.0 seconds
8294 frames in 5.0 seconds
8255 frames in 5.0 seconds
Back to top
View user's profile Send private message 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Wed 21 Jul 2010, 23:03    Post subject:  

Grub is broke.

Tried doing full installs with universal installer to empty hard drive.
Neither the Grub in the installer or the Grub bootloader config
would install the files to partition or put Grub on MBR.

I hadn't tried this with Luci 213, so don't know how long this
has been a problem.

It only does up to 800x600 resolution on a p3, ATI laptop that
needs 1024x768 native resolution.

EDIT:

Tried the full install on Dimension 3000 pc. Grub worked!
I think the spare laptop hard drive may have problems.

EDIT:

Tried other installs on that drive; no problems.

Last edited by rjbrewer on Thu 22 Jul 2010, 10:21; edited 2 times in total
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5932
Location: Kentucky

PostPosted: Wed 21 Jul 2010, 23:17    Post subject:  

Back again.................. Laughing

Running Lupu-503 live pfix=ram in one of the dreaded Nvidia boxes.Booted in correct display,sound and internet. First run did not give a driver recommendation, but luckily I knew the right driver. Smile

Installed Opera and the 96.43.16 Nvidia pet from the PPM.


# graphix_test
For your nVidia video card, nVidia Corporation NV18 [GeForce4 MX 4000] (rev a4) we think the best add on driver is nvidia-96.43.16. It would be required for some programs and games with high graphcial content and your desktop might seem a bit more snappy. It is available in Quickpet under Drivers
nVidia Corporation NV18 [GeForce4 MX 4000] (rev a4)
nVidia
GeForce4
MX
#



VIDEO REPORT: Lucid Puppy, version 503

Chip description:
oem: NVIDIA
product: NV18 Board - p119s0nz Chip Rev A4

Driver used by Xorg:
nvidia

Video mode used by Xorg:
Resolution: Depth 24 Depth: "Display"

...the above also recorded in /tmp/report-video
#

-OpenGL-
Vendor : NVIDIA Corporation
Renderer : GeForce4 MX 4000/AGP/SSE2
Version : 1.5.8 NVIDIA 96.43.16
Direct Rendering : Yes


# glxgears
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
4850 frames in 5.0 seconds
4396 frames in 5.0 seconds
5755 frames in 5.0 seconds
5732 frames in 5.0 seconds
5767 frames in 5.0 seconds
5718 frames in 5.0 seconds
13871 frames in 5.0 seconds
15130 frames in 5.0 seconds
14787 frames in 5.0 seconds
15546 frames in 5.0 seconds
16240 frames in 5.0 seconds
16148 frames in 5.0 seconds
15227 frames in 5.0 seconds
Back to top
View user's profile Send private message 
scsijon

Joined: 23 May 2007
Posts: 1047
Location: the australian mallee

PostPosted: Wed 21 Jul 2010, 23:44    Post subject: lupu503 problems  

sorry folks, four pages of problems this time, but running low on peak time so summary only now, rest tomorrow morning (aest), same box as listed earlier, specs there.

did a FRUGAL install ok.

summary:
Video set to max again by default, setting to 1024x786 kills video (black screen of death) and nothing works (CAF1/F5 dead), setting to 600x480 gives white screen of death (new one), rest are ok now but fonts are "thin" walled.
No xvesa works, intel driver only
install of xorg_high may not be needed as 503 is also working in 1800x1440 quite well and glxgears over 5000.

still can't use quickpet via sat, timeout messages each time, even tried changing servers, no differances.

can use ppm ok, no problems

noticed in ppm xorg_high under system, nevidia stuff under setup

will test further tonight and full report upload early tomorrow my time.

reagrds
scsijon
ps, there are some +700,000 of these boxes out there somewhere as they were ther standard aussie gov't contract box at the time. It does need to work even if 10% are still alive.

Last edited by scsijon on Thu 22 Jul 2010, 04:21; edited 2 times in total
Back to top
View user's profile Send private message Visit poster's website 
James C


Joined: 26 Mar 2009
Posts: 5932
Location: Kentucky

PostPosted: Wed 21 Jul 2010, 23:48    Post subject:  

Back with an ATI box this time.................. Laughing

Lupu-503 live pfix=ram.....installed Opera and Xorg_High.............


# graphix_test
For your ATI graphics card, ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE] , we think the best add on driver is Xorg_High.pet . It would be required for some programs and games with high graphcial content and your desktop might seem a bit more snappy. It is available in Quickpet under Drivers
ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE]
ATI
Radeon

#


VIDEO REPORT: Lucid Puppy, version 503

Chip description:
oem: ATI RADEON III

Driver used by Xorg:


Video mode used by Xorg:
Resolution: Depth:

...the above also recorded in /tmp/report-video
#


-OpenGL
Vendor : Tungsten Graphics, Inc.
Renderer : Mesa DRI R100 (RV100 5159) 20090101 AGP 4x x86/MMX/SSE2 NO-TCL
Version : 1.3 Mesa 7.7.1
Direct Rendering : Yes


# glxgears
2464 frames in 5.0 seconds
2562 frames in 5.0 seconds
2566 frames in 5.0 seconds
2572 frames in 5.0 seconds
2567 frames in 5.0 seconds
2571 frames in 5.0 seconds
Back to top
View user's profile Send private message 
Iguleder


Joined: 11 Aug 2009
Posts: 1923
Location: Israel, somewhere in the beautiful desert

PostPosted: Thu 22 Jul 2010, 02:18    Post subject:  

playdayz, is there any chance that you include both libfribidi and a BiDi-enabled JWM? I can assure you many Arabic and Hebrew speakers will enjoy this. IceWM doesn't matter ... at least one window manager that works well is enough, that can wait for the next Luci Laughing

My aim is to get working RTL languages in Puppy. And I don't do all that because I speak Hebrew, I do this because so many people around the globe, mainly all Arabic-speaking nations, need that to be able to use Puppy.

I heard once about some Ubuntu Islam edition or something like that ... if there is a Christian Puppy, a Puppy that supports Arabic can be easily turned into an Islamic Puppy and bring Puppy to the Arabic world. That's great in my opinion.

_________________
My homepage
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
ICQ Number 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Thu 22 Jul 2010, 02:35    Post subject:  

Hi Iguleder

This is Barry's patch for JWM

http://bkhome.org/blog/?viewDetailed=01376

This is shinobar's compile of JWM-492 in 501, that will be fine same kernel, mostly the same libs.

http://www.murga-linux.com/puppy/viewtopic.php?p=386675#386675

I can't tell if it works or not but I do know that shinobar's tarball calls Jwm with "jwm-i18nl"... of course you just make a symlink to it to call jwm normally

HTH

Cheers

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
Iguleder


Joined: 11 Aug 2009
Posts: 1923
Location: Israel, somewhere in the beautiful desert

PostPosted: Thu 22 Jul 2010, 02:38    Post subject:  

But that's an i18n patch ... and for some reason JWM didn't compile on my Lupu (501) with libfribidi and libfribidi-dev installed ... Crying or Very sad

I'll try again on Luci, but I'll do my other experiements first Wink


EDIT: found something weird, remains of 2createpackages, /automake.

EDIT 2: 503 doesn't display Hebrew, Asian or Arabic characters. Why don't you download DejaVu Sans from the official website and use them instead of the Ubuntu/Woof fonts? They don't have all glyphs and that's one of the worst things for a user that doesn't know English well. I did that in my puplet and now it works better than any Puppy with those languages.

_________________
My homepage
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
ICQ Number 
Display posts from previous:   Sort by:   
Page 70 of 145 [2171 Posts]   Goto page: Previous 1, 2, 3, ..., 68, 69, 70, 71, 72, ..., 143, 144, 145 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1417s ][ Queries: 13 (0.0343s) ][ GZIP on ]