Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 29 Nov 2014, 03:28
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
SOLVED: How to install Redshift (eye strain reduction .deb)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
akbits69

Joined: 21 May 2010
Posts: 26

PostPosted: Sun 27 Jun 2010, 20:26    Post subject:  SOLVED: How to install Redshift (eye strain reduction .deb)  

Could someone give me hand in trying / installing the following?

http://jonls.dk/redshift/

Quote:
Redshift adjusts the color temperature of your screen according to your surroundings. This may help your eyes hurt less if you are working in front of the screen at night. This program is inspired by f.lux (read here for the reason why I started this project)
.

I have this working great in Ubuntu. Having read that Puppy worked well with deb files, I downloaded the Debian i386 file.

http://packages.debian.org/squeeze/i386/redshift/download

Puppy offered to install it. All seemed to work. I opened up terminal, tried to give it my lat & long (or heck, even use the Copenhagen lat&long, per the example on the Redshift page), but I keep getting -

Code:
redshift: symbol lookup error: redshift: undefined symbol: xcb_randr_get_screen_resources_current


I'm pretty clueless around linux (newbie) so am wondering - is this an issue of puppy not having the requisite files installed (that I need to find / install) or something else? What does the error message mean?

Could someone try this on their system and let me know the outcome? I'm using puppeee, FWIW, which is based on 4.3.1, (AFAIK)

Last edited by akbits69 on Mon 28 Jun 2010, 15:44; edited 1 time in total
Back to top
View user's profile Send private message 
RetroTechGuy


Joined: 15 Dec 2009
Posts: 2669
Location: USA

PostPosted: Mon 28 Jun 2010, 14:03    Post subject: Re: How to install Redshift (eye strain reduction .deb)  

akbits69 wrote:
Could someone give me hand in trying / installing the following?

http://jonls.dk/redshift/

Quote:
Redshift adjusts the color temperature of your screen according to your surroundings. This may help your eyes hurt less if you are working in front of the screen at night. This program is inspired by f.lux (read here for the reason why I started this project)
.

I have this working great in Ubuntu. Having read that Puppy worked well with deb files, I downloaded the Debian i386 file.

http://packages.debian.org/squeeze/i386/redshift/download

Puppy offered to install it. All seemed to work. I opened up terminal, tried to give it my lat & long (or heck, even use the Copenhagen lat&long, per the example on the Redshift page), but I keep getting -

Code:
redshift: symbol lookup error: redshift: undefined symbol: xcb_randr_get_screen_resources_current


I'm pretty clueless around linux (newbie) so am wondering - is this an issue of puppy not having the requisite files installed (that I need to find / install) or something else? What does the error message mean?

Could someone try this on their system and let me know the outcome? I'm using puppeee, FWIW, which is based on 4.3.1, (AFAIK)


Without actually trying it myself, I'm betting that you need some of the associated Debian libraries:

http://packages.debian.org/squeeze/i386/redshift

In particular, I would try installing "libxcb-randr0".

You may also need "libxcb1", but install the first one, run it from the command line, and see it it reports errors -- if so, try the second library.
Back to top
View user's profile Send private message 
akbits69

Joined: 21 May 2010
Posts: 26

PostPosted: Mon 28 Jun 2010, 15:51    Post subject:  

Hey - that does the trick! Awesome. Thanks RetroTechGuy.

A follow up question for anyone

After I launch the program (via console), Ithe Redshift documentation says I should be able to kill the program by issuing

Code:
killall -USR1 redshift


But that doesn't do anything (and neither does kill redshift)

Code:
# killall redshift
killall: redshift: no process killed
# killall -USR1 redshift
killall: redshift: no process killed


I also tried killing it in Task Manager (Puppeee comes with LXTask 0.1 installed) but that doesn't stop it either (despite highlighting Redshift and chosing 'Kill')

It's not so bad, as Redshift auto adjust according to time of day, but I'd like the ability to stop it when I choose, too. Any ideas?
Back to top
View user's profile Send private message 
RetroTechGuy


Joined: 15 Dec 2009
Posts: 2669
Location: USA

PostPosted: Mon 28 Jun 2010, 16:06    Post subject:  

akbits69 wrote:
Hey - that does the trick! Awesome. Thanks RetroTechGuy.

A follow up question for anyone

After I launch the program (via console), Ithe Redshift documentation says I should be able to kill the program by issuing

Code:
killall -USR1 redshift


But that doesn't do anything (and neither does kill redshift)

Code:
# killall redshift
killall: redshift: no process killed
# killall -USR1 redshift
killall: redshift: no process killed


I also tried killing it in Task Manager (Puppeee comes with LXTask 0.1 installed) but that doesn't stop it either (despite highlighting Redshift and chosing 'Kill')

It's not so bad, as Redshift auto adjust according to time of day, but I'd like the ability to stop it when I choose, too. Any ideas?


If you have a console window open:

Code:
ps xua | grep redshift


will probably identify the process number. Then (supposing the process is "12345"):

Code:
kill -9 12345


will kill it off ("-9" means "kill and and quit pussyfooting around!!!")
Back to top
View user's profile Send private message 
akbits69

Joined: 21 May 2010
Posts: 26

PostPosted: Mon 28 Jun 2010, 16:16    Post subject:  

Hi again.

Nope. Here's the output

Code:
# ps xua | grep redshift
root     12097  0.0  0.1   1956   628 pts/0    S+   04:10   0:00 grep redshift
# kill -9 1956
bash: kill: (1956) - No such process
# kill -9 12097
bash: kill: (12097) - No such process


(I wasn't sure which was the process number, so I tried both)

Interestingly enough, if I leave the original terminal window open, I can kill redshift by pressing Control + C. But, if I close that terminal window, then there seems to be no way to stop it other then dropping out of the GUI (Ctrl Alt Backspace) and typing xwin to re-enter.

The trials and tribulations of a newbie Embarassed Laughing
Back to top
View user's profile Send private message 
npierce

Joined: 28 Dec 2009
Posts: 858

PostPosted: Mon 28 Jun 2010, 18:14    Post subject:  

akbits69 wrote:
Code:
# ps xua | grep redshift
root     12097  0.0  0.1   1956   628 pts/0    S+   04:10   0:00 grep redshift

. . . (I wasn't sure which was the process number, so I tried both)

The process number was 12097, but in this case the process was grep, which usually finds itself. It looks like redshift was not running. If it was, you would have seen another line of output. What command and options did you start it with? Perhaps you ran redshift in "one-shot mode" with the -o option?

"kill" and "killall" were rather unfortunate choices for the names of those utilities. These can be used to send any signal, not just KILL. In fact, if you don't specify a signal on the command line the signal sent is actually TERM, which might ot might not kill the process. As RetroTechGuy indicated, to "quit pussyfooting around" and actually send the KILL signal, you need the -9.

Anyway, when you run
Code:
killall -USR1 redshift

you are sending the USR1 signal, not the TERM or KILL signal, so you are not killing the process. The USR1 signal does whatever the developer of the application programs it to do. In this case, the documentation says "The color adjustments done by Redshift can be temporarily toggled on and off by sending it the USR1 signal . . ." So redshift keeps running, it just stops making adjustments until you send it the USR1 signal again. Possibly nothing visible happens immediately when you send the signal.

If redshift is actually running, and you really want to kill it, not just stop the adjustments, RetroTechGuy's suggestion should do it.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0761s ][ Queries: 12 (0.0067s) ][ GZIP on ]