Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 16 Sep 2014, 05:38
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Lighthouse Pup 5.00 G 185M
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 46 [688 Posts]   Goto page: 1, 2, 3, ..., 44, 45, 46 Next
Author Message
tazoc


Joined: 11 Dec 2006
Posts: 1157
Location: Lower Columbia Basin WA US

PostPosted: Tue 25 May 2010, 22:21    Post subject:  Lighthouse Pup 5.00 G 185M
Subject description: Slack 13.1 JWM IceWM GIMP MPlayer Wine Multi-user | Add-ons: Xfce LO FF Opera VirtualBox Compiz KDE4
 




** Newer release thread here **


Graphics configuration for Lighthouse Pup 5.00
* When booting from a GRUB bootloader, please add xforcevesa nomodeset to the kernel line in your menu.lst.
(Booting from the CD does this by default, and using grubconfig in LHP to install GRUB also does.)

* How to configure KMS - Kernel ModeSetting. According to ICPUG, if you have Intel 855 graphics, boot with puppy i915.modeset=1 and either select the intel driver (Option 2 in xorgwizard) or auto-configure Xorg (Option 1 in xorgwizard).

2010.12.12 Lighthouse Pup 5.00 G (build 501)
A faster and leaner system than 5.00F, with a number of new features, including
* Choose your own browser
* Lighthouse Update for reliable access to many new Pets
* frugal-symlink (Move and Link Programs) maintains a smaller pupsave (on a Linux partition)
* Customized Pwidgets desktop applets in JWM, IceWM and Xfce.
* The Mariner ISO has a folder /pets for even faster access (ideal for dial-up Internet) to most of the new apps on Lighthouse Update.

Highlights and release notes are at http://www.lhpup.org/release-lhp.htm

2010.10.25 Lighthouse Update Manager PET notifies of available updates for Lighthouse Pup 5.00 F, including an update for the e-Sword installer and Adobe Flash plugin.

2010.10.07 Xfce-4.6.2a.sfs 24M Xfce 4.6.2 For Lighthouse Pup 5.00 F or later

* Proprietary display driver PET packages for Lighthouse 5.00:
ATI Catalyst 10.6 34M | NVIDIA 195 30M | NVIDIA 173 14M | NVIDIA 96 14M

2010.09.19 Lighthouse Pup 5.00 F (Build 500)
Mariner, KDE and Voyager add-ons also updated

2010.09.07 Opera-10.61-6430.sfs

2010.08.06 Lighthouse Pup 5.00 D (Build 495) Base ISO

* New for 5.00 D
    Audacious-2.3 audio player

    luvcview-0.2.6 (thanks to Michel Xhaard & Barburo) and MPlayer-TV-Webcam viewers

    Intel driver PET for LHP 5.00 C (thanks to Q5sys) This driver is now included in LHP 5.00 D, with the exception of cairo-1.9.6, which was reverted to cairo-1.8.8 to fix a compiling error "libcairo.so: undefined reference".

    Other updates listed in release notes
2010.08.06 Lighthouse Mariner ISO 5.00 D
* Mariner SFS updated to 5D_495
    Firefox 3.6.8, Thunderbird-3.1.1, TrueCrypt-7.0, Xine-ui-0.99.6, Qps bugfix (process manager for Mariner)
2010.08.06 KDE 4.4.4 D SFS - minor updates to KDE and Voyager SFS

2010.08.06 Kdenlive-0.7.8c.sfs 94M (Mariner SFS & KDE SFS required) a powerful multi-track video editor
_______________________________________
2010.07.12 Voyager SFS: Xscreensavers 5.11, rss-glx_0.9.1 Really Slick Screensavers, extra games and backgrounds (depends on Mariner)

2010.07.12 Compiz-Fusion SFS: Updated to CompizFusion-0.7.9-1f. C-F eye candy and Emerald window decorator
_______________________________________
2010.06.29 Lighthouse Pup 5.00 C Base ISO released

* Abiword, Gnumeric, SeaMonkey, Flash plugin and Transmission updated
* Added hplip-3.9.12 HP Scanner Driver (thanks to Jim1911) and ttf-thai-arundina (Thai font rendering).

2010.06.29 Lighthouse Mariner ISO 5.00 C
* Base ISO plus Mariner, Xfce, OpenOffice, Opera and VirtualBox SFS add-ons.
* Mariner SFS updated to 5C_490; (others unchanged)
updated Firefox 3.6.6, JavaRE-6u20 and added wqy-zenhei free font (Asian font rendering)

2010.06.29 KDE 4.4.4 C SFS

* KDE 4.4.4 plus Amarok 2.3.1b1, K3b Disc Burning, KDE Educational Suite and more.
* Alternative Plasma Netbook interface
________________________________________
2010.06.11 Lighthouse Pup 5.00 B Base ISO released

* Several bugfixes and updates

* New Wine e-Sword 9.6.0 Bible Study downloader and installer, based on a script by david_kt and adapted for Lighthouse.

2010.06.11 Lighthouse Mariner ISO 5.00 B - release notes

* Includes Mariner, Xfce, OpenOffice, Opera and VirtualBox SFS add-ons.

* Minor updates to Xfce 4.6.1d and Mariner 5B_485

* VirtualBox updated to 3.2.4

2010.06.11 Google-Chrome-stable_5.0 SFS - Fast browser with themes and add-ons
_________________________________________
2010.05.27 If boot ends with a blank (black) screen, type puppy pfix=ram nomodeset at the boot menu and see How to configure/disable KMS

2010.05.25 Lighthouse Pup 5.00 A (build 480) released
* Xorg-xserver 1.7.7, kernel 2.6.33.2, IceWM 1.3.6 (thanks to Jemimah)

* Many updates and new features

2010.05.25 Mariner ISO 5.00 A released

* Includes everything in the base ISO plus these add-ons:
Mariner 5A, Xfce 4.6.1, OpenOffice 3.2, Opera 10.10 and VirtualBox 3.1.8

* Mariner has updated Firefox, Thunderbird, Java, Mesa (OpenGL drivers), Geeqie (formerly GQView), GKrellM and Vuze

* VirtualBox allows installation of multiple operating systems without rebooting.

Release notes
-TazOC

_________________
lhpup.org Lighthouse 64 6.02

Last edited by tazoc on Mon 17 Jan 2011, 16:32; edited 26 times in total
Back to top
View user's profile Send private message Visit poster's website 
Barburo


Joined: 14 Jun 2007
Posts: 283

PostPosted: Wed 26 May 2010, 01:00    Post subject: Feedback  

Thanks for the new version - recognizes my wifi out of the box.
Quick heads up - I tried to SAVE the savefile a couple of times by pressing "Enter" - the panel only responded to "S". No suitable driver for my Intel graphics chip - will continue to experiment.
B.

_________________
Laptop: Acer Aspire 5810TZ
Back to top
View user's profile Send private message 
Q5sys


Joined: 11 Dec 2008
Posts: 1049

PostPosted: Wed 26 May 2010, 01:31    Post subject: woot!  

Ill test it out tomorrow on my 2 intel systems.
_________________



My PC is for sale
Back to top
View user's profile Send private message 
jasmac


Joined: 03 Jun 2009
Posts: 62
Location: Canberra, Australia

PostPosted: Wed 26 May 2010, 04:11    Post subject:  

Hey Tazoc,

Will have a play with your new one over the next couple of days and give any feedback I find. In the meantime here is that background again, this time I even managed to spell Lighthouse correctly, hehehe.

Cheers

Jason
lhpback1.png
Description 
png

 Download 
Filename  lhpback1.png 
Filesize  1.25 MB 
Downloaded  1078 Time(s) 
Back to top
View user's profile Send private message 
davec51

Joined: 13 Apr 2006
Posts: 491
Location: Virginia

PostPosted: Wed 26 May 2010, 07:49    Post subject: Intel Graphics Card -- No Xorg  

I'm eager to try the new Lighthouse, but I can't configure my old Intel graphics card with Xorg. Vesa will only give me 600/400 resolution, impossible to use conveniently on my monitor. Any fix or patch?
Back to top
View user's profile Send private message 
jasmac


Joined: 03 Jun 2009
Posts: 62
Location: Canberra, Australia

PostPosted: Wed 26 May 2010, 08:24    Post subject:  

Heya Tazoc,
I can't seem to load the new LHP. I always end up with - Performing a 'switch_root' to the layered filesystem....Kernel Panic not syncing: Attempted to kill init

This comes up after is says loading the pup.sfs to ram, which seems to be quick. I have burnt and reburnt the iso 7 ways to Sunday and have downloaded it twice. My system is still the same a Dell D810 with 2gb ram and a ATI 128mb mobility card, which has worked without issue with all other pups. Any ideas welcome.

Cheers

Jason
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2455
Location: Texas, USA

PostPosted: Wed 26 May 2010, 11:37    Post subject:  

Hi tazoc,

You need to disable your autodesktop setup. I've also been unable to boot, it starts initially and then goes to a black screen. Ctrl-Alt-Backspace wouldn't even work. Only out is a hard reboot.

Sorry,
Jim Sad
Back to top
View user's profile Send private message 
Payoon

Joined: 26 May 2010
Posts: 25
Location: Duisburg, Germany on the banks of the Rhine

PostPosted: Wed 26 May 2010, 11:47    Post subject: Live CD Crash on LHP 5.00 A
Subject description: Live CD crashes after loading kernel modules
 

Hi Folks,
my problem is, that when booting the Live CD the last line, that I can see is "loading kernel modules". Then the screen turns black and remains that way. I have tried several times with different boot options. The md5sum of the CD is OK. Older LHP worked well.Has anybody an idea, what to do?
Thanks.
Payoon
Back to top
View user's profile Send private message 
tazoc


Joined: 11 Dec 2006
Posts: 1157
Location: Lower Columbia Basin WA US

PostPosted: Wed 26 May 2010, 13:10    Post subject:  

@Jasmac,
Try using 'puppy pfix=nocopy' at the bootmenu. That's a new boot option for LHP 5.00 only, as the copy to ram sometimes fails. I don't know why--it appeared with the latest kernel and initrd.gz from Quirky. I need to add the option to the F2 panel but not sure if there is room! I will post it on the web site if it is helpful.

@Barburo,
Thanks for the heads up, the 's' works at first shutdown when saving your session? I didn't know that!

@All,
If you get a blank screen pls post the type of display adapter you're using. Also try using 'puppy pfix=nox loglevel=7 acpi=off' to see if you get a command prompt or not. Sounds like a bug that could sink this voyage Exclamation but it might help if I could narrow it down to a specific hardware configuration.

@Jim, by autodesk are you referring to auto-fstab? I don't know if that would be related, and I'll look at it again. Yes I could disable by default.
Thanks,
TazOC

_________________
lhpup.org Lighthouse 64 6.02
Back to top
View user's profile Send private message Visit poster's website 
Q5sys


Joined: 11 Dec 2008
Posts: 1049

PostPosted: Wed 26 May 2010, 14:05    Post subject:  

This sounds familiar sadly. Issues with Intel video were talked about on this post in Barry's Blog.

To quote: "People just get a black screen."

When I get some time this evening i'll try working with it and compiling the new and older intel drivers and if I can manage to make something work. But if it is an issue of kernel vs puppy vs intel ... dont think we are going to have much success.
But I'll see what I can do.

_________________



My PC is for sale
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2455
Location: Texas, USA

PostPosted: Wed 26 May 2010, 14:29    Post subject:  

tazoc wrote:
@All,
If you get a blank screen pls post the type of display adapter you're using. Also try using 'puppy pfix=nox loglevel=7 acpi=off' to see if you get a command prompt or not. Sounds like a bug that could sink this voyage Exclamation but it might help if I could narrow it down to a specific hardware configuration.
@Jim, by autodesk are you referring to auto-fstab? I don't know if that would be related, and I'll look at it again. Yes I could disable by default.
Thanks,
TazOC
pfix=nox didn't help. What I was referring to is your autoconfiguration of the video drivers which then boots you straight to a desktop. You need to go back to a manual initial setup until the video problems are sorted out with the new kernel. Lucid had to do the same thing, however, it seemed that intel video cards are the headache there, only a few other older cards reported a problem.

System: BFG NVIDIA Geforce 8400 GS 512MB, Asus P6T Motherboard, Intel core i7-920 (8MB Cache, 2.66 GHz), DDR3 3GB 1333MHz ram, Pioneer DVR-2910 DVD+-RW Dual Layer Burner, Realtek ALC1200 Audio, HP Photosmart 5280 All-in-One
Back to top
View user's profile Send private message 
Barburo


Joined: 14 Jun 2007
Posts: 283

PostPosted: Wed 26 May 2010, 16:58    Post subject:  

Hi TazOC,
I have an up-and running configuration with lxde as the WM - the driver is Vesa at 1024x768 which of course makes everything look squashed on my wide-screen notebook. Other than that most of the apps I use seem to check out OK. I am posting this from 5.0a. I checked the bootkernel and /var/message logs and I see no errors - just a couple of warnings.

I tried every variation of Probe and Choose - Probe goes black screen and choosing a possible driver (Intel or i740) also goes nowhere. XORG force VESA is the only option that works because of the VESA fallback.

I have previously tried lucid puppy 5.01 which I believe uses the same Kernel (not sure about which version of xorg) and got a the correct screen resolution.
Does lucid use an i810 Intel driver?
B.

_________________
Laptop: Acer Aspire 5810TZ
Back to top
View user's profile Send private message 
Q5sys


Joined: 11 Dec 2008
Posts: 1049

PostPosted: Wed 26 May 2010, 18:19    Post subject:  

After my first attempt at compiling the latest Intel Drivers and trying it out, this is what I get. Tried compiling the older ones too, same thing.
Barry had issues with Xorg 7.5 Its possible that for Intel support we need to roll back to 7.3

Code:
X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: Slackware 13.1 Slackware Linux Project
Current Operating System: Linux Mariner 2.6.33.2 #1 SMP Mon Apr 5 12:55:04 Local time zone must be set--see zic m i686
Kernel command line: BOOT_IMAGE=vmlinuz initrd=initrd.gz pmedia=usbflash pfix=copy
Build Date: 05 May 2010  01:54:53AM
 
Current version of pixman: 0.17.14
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue May 25 13:17:12 2010
(==) Using config file: "/etc/X11/xorg.conf"
(EE) intel(0): No kernel modesetting driver detected.
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

giving up.
/usr/bin/xinit:  No such file or directory (errno 2):  unable to connect to X server
/usr/bin/xinit:  No such process (errno 3):  Server error.

_________________



My PC is for sale
Back to top
View user's profile Send private message 
jasmac


Joined: 03 Jun 2009
Posts: 62
Location: Canberra, Australia

PostPosted: Wed 26 May 2010, 18:53    Post subject:  

Hi again,

Thanks Taz, that fix it right up. Installed to flash drive with no problems, configured using the radeon driver and everything is working sweet. I will continue to test and try some other laptops I have.

Thanks

Jason
Back to top
View user's profile Send private message 
Tui

Joined: 27 Sep 2006
Posts: 380
Location: Wellington New Zealand

PostPosted: Wed 26 May 2010, 19:15    Post subject:  

Hi all followers of this new version!
Well I did my d/l of this latest - a full 664Mb, did my checksum
of d/l and compared with published.

Burned my CD-R run as pfix=ram oh! I have got
a Kernal Panic! -- I must be short of mem for this one !

I got 1.3 Gb on board up it to 2Gb, re-run still K/panic! I did
another burn, as thought I have a bad cd-r also close to limit of cd-r 700 Mb - still
the same problem!

One more try! Out with the DVD's and another burn - a bit of
an over kill!

Through it all again still the same problem! - the dreaded
K/Panic!

A lot of lost time, and 3 toasted discs - what's next ?

Anyone got me an answer ?


Cheers Tui
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 46 [688 Posts]   Goto page: 1, 2, 3, ..., 44, 45, 46 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1197s ][ Queries: 13 (0.0168s) ][ GZIP on ]