Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 19:22
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Dosemu don't work on puppy 4.3.1.
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
iw2evk

Joined: 08 Jan 2010
Posts: 78

PostPosted: Thu 20 May 2010, 07:31    Post_subject:  Dosemu don't work on puppy 4.3.1.  

Hi've downloaded the last binaries from :
http://dosemu.sourceforge.net/stable/

USE dosemu-1.4.0-bin.tgz
USE dosemu-freedos-1.0-bin.tgz

NOT dosemu-1.4.0-1.i386.rpm (all-in-one RPM, includes FreeDOS)

After installation i 've tried to start a simple program from dos, but don't start (no error message).
If i start the dosemu box from utilities i receive a message error (like command com interpreter not found)

Someone can help me?

P.s. it's possible install hx extender (HXRT+HXGUI) and himemx and emmx386 instead himem en emm386 in package?

Thanks

Roberto
Back to top
View user's profile Send_private_message 
RetroTechGuy


Joined: 15 Dec 2009
Posts: 2668
Location: USA

PostPosted: Thu 20 May 2010, 09:06    Post_subject: Re: Dosemu don't work on puppy 4.3.1.  

iw2evk wrote:
Hi've downloaded the last binaries from :
http://dosemu.sourceforge.net/stable/

USE dosemu-1.4.0-bin.tgz
USE dosemu-freedos-1.0-bin.tgz

NOT dosemu-1.4.0-1.i386.rpm (all-in-one RPM, includes FreeDOS)

After installation i 've tried to start a simple program from dos, but don't start (no error message).
If i start the dosemu box from utilities i receive a message error (like command com interpreter not found)


That sounds like it's missing "command.com" (or whatever variation of the command interpreter they might have installed)

Quote:
Someone can help me?

P.s. it's possible install hx extender (HXRT+HXGUI) and himemx and emmx386 instead himem en emm386 in package?

Thanks

Roberto


Let's go after the problem from a different angle:

http://packages.debian.org/squeeze/dosemu

Get and install these 2 packages:

http://http.us.debian.org/debian/pool/contrib/d/dosemu/dosemu_1.4.0+svn.1999-1_i386.deb

http://http.us.debian.org/debian/pool/main/e/eglibc/libc6_2.10.2-6_i386.deb

Then test it out (my test indicates that it looks and feels like DOS -- but I didn't install my fortran compiler, to test running programs other than those installed).

And, as always, make a backup of your pupsave before installing new software.
Back to top
View user's profile Send_private_message 
looseSCREWorTWO

Joined: 04 Feb 2010
Posts: 812
Location: Australia, 1999 Toshiba laptop, 512mb RAM, no HDD, 431 Retro & 421 Retro

PostPosted: Thu 20 May 2010, 09:44    Post_subject:  

I use DOSBox without any probs. I use the DOSBox pet provided by mywolfe here:
https://code.google.com/p/mywolfe/downloads/detail?name=dosbox-0.73-i486.pet

and SDL-1.2.13-i486.pet provided by sikpuppy here:
http://www.murga-linux.com/puppy/viewtopic.php?t=5164&start=45

_________________
Steve
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0505s ][ Queries: 12 (0.0064s) ][ GZIP on ]